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Chapter 1:

Welcome to Magento!
Magento Community Edition is a feature-rich eCommerce platform, built on open-
source technology that provides online merchants with unprecedented flexibility and
control over the look, content, and functionality of their eCommerce store. Magento
CE’s intuitive administration interface features powerful marketing, search engine
optimization, and catalog management tools to give merchants the power to create
sites that are tailored to their unique business needs. Designed to be completely
scalable, Magento CE offers companies a stable, secure, customizable eCommerce
solution.

Magento Community Edition
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Resources
Magento provides a wealth of business and technical resources, self-help tools, and
services to help you succeed.

Knowledge Base

Got a question? The Magento Knowledge
Base has an answer. Our Knowledge
Base is your one-stop shop for helpful
articles and how-to instructions, as well
as technical product documentation.

Guides and Tips

Our user guides, eBooks, and articles
provide a wealth of information that is

ready for download.

Wiki

The Magento Wiki is where you can
learn from others, and share what you
know! To help you get started, we’ve
gathered a list of articles that will help
you on your way.

http://www.magentocommerce.com/knowledge-base
http://www.magentocommerce.com/resources/magento-user-guide
http://www.magentocommerce.com/wiki/
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Forums

The Magento forums provide access to a
network of dedicated Magento

enthusiasts who share tips, tricks and
support.

Blog

Check out the Magento blog for the
latest information about new features,
trends, best practices, upcoming events,
and more!

Webinars

Expand your horizons! Register to
attend the upcoming Magento webinar,

or catch up on previous, archived
webinars.

Training & Certification

Magento has training courses for every
role, including marketers, product
managers, designers and developers.
Magento U courses provide practical,
hands-on exercises that help students
learn quickly.

http://www.magentocommerce.com/boards
http://magento.com/blog
http://www.magentocommerce.com/media/webinars
http://magento.com/help/overview
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Partners

Need help to set up or fine-tune your
store? Magento’s certified developers and
consultants are experts in store setup,

design, integration and marketing. Find
a certified expert and jumpstart your

business today!

Expert Consulting Services

Magento’s Expert Consulting Group
(ECG) helps Magento merchants and
Solution Partners maximize their
success. Our experts offer comprehensive
analysis and best practice
recommendations, from architecture
planning through post-deployment.

Join the Conversation!

Facebook

Find out what’s happening and join the
discussion on our Facebook page!

http://magento.com/training/overview
http://www.magentocommerce.com/consulting/
https://www.facebook.com/magento
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Twitter

Follow us on Twitter!

YouTube

Learn while you watch videos
on our YouTube channel!

LinkedIn

Join the users group and
connect with others on LinkedIn!

https://twitter.com/magento
http://www.youtube.com/user/magentocommerce/featured
http://www.linkedin.com/groups?home=&gid=146360&trk=anet_ug_hm
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Chapter 2:

Installing Magento
Magento Community Edition is open source software and can be downloaded for
free. Developers can modify the core code and add features and functionality by
installing extensions from the Magento Connect marketplace.

Because Magento does not provide technical support for this software, businesses
using Magento Community Edition to run their stores might need access to their
own Magento experts to help with the installation and configuration. Answers to
many technical questions can be found on our user forum.

Magento Community Edition is licensed under the Open Software License (OSL)
v3.0, an open source certified license. To learn more, see the License / Trademark
FAQ on our site.

After you have verified that your hosting environment meets Magento’s system
requirements, you can download Magento CE free of charge from the Magento
community site. Although optional, we recommend that you register on our site so
you have access to the forums, wiki, groups, screencasts, and other resources the
community has to offer.

http://www.magentocommerce.com/magento-connect/
http://www.magentocommerce.com/boards/
http://www.magentocommerce.com/license#What open source license do we use for Magento Community Edition?
http://www.magentocommerce.com/license#What open source license do we use for Magento Community Edition?
http://magento.com/resources/system-requirements
http://magento.com/resources/system-requirements
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System Requirements
See our website for a complete list of system requirements.

Base System Requirements

Operating Environment LAMP (Linux, Apache, MySQL, and PHP)

Operating Systems
(Unix only)

Linux x86
Linux x86-64

Web Servers Apache 1.3.x
Apache 2.0.x
Apache 2.2.x

PHP Version 5.2.13

PHP Configuration safe_mode off

memory_limit 512 MB recommended
256 MB minimum

MySQL 4.1.20
InnoDB storage engine

SSL A valid security certificate is required to work over a secure
channel (HTTPS) from the Magento Admin, or when sub-
mitting form data from the storefront. Self-signed SSL cer-
tificates are not supported.

http://magento.com/resources/system-requirements
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Part I: Magento Installation
During the first part of the installation, you will download the scripts and sample data
files needed to install Magento. You will also set up permissions on the server, and
create a new database.

Downloader

Process Overview:
Step 1: Download the Magento CE Downloader Script
Step 2: Download the Sample Data
Step 3: Upload the Downloader Script to Your Server
Step 4: Grant File Access Permissions
Step 5: Set Up the Store Database
Step 6: Upload the Sample Data to Your Server
Step 7: Run the Magento CE Downloader
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Step 1: Download Magento CE Downloader Script

1. Navigate to the Magento Community Edition download page.

2. In the Downloader section, select one of the following formats for the archived
downloader. The archive file name is: magento-downloader-x.x.x.zip (or .tar.gz, or
.tar.bz2). The size of the archive is approximately 46K.

l .zip

l .tar.gz

l .tar.bz2

3. Click the Download button. While the file is downloading, take a moment to look over
the resources on the Magento Community page.

4. Extract the archive to a directory of your choice on your local computer. The name of the
extracted file is: downloader.php

Step 2: Download the Sample Data

Magento provides sample data with examples of products and basic content pages to
help you get started. When you are ready to build your own catalog, you can reinstall
Magento without the sample data. This step is recommended, but is not required.

1. In the Sample Data section, Select your format for the archived sample data.

2. Click the Download button, and Save the file anywhere on your local computer. The file
name is: magento-sample-data-x.x.x.zip (or .tar.gz, or .tar.bz2). The size of the archive is
approximately 10MB.

Sample Data Download

Step 3: Upload the Downloader Script to Your Server

3. Use an FTP or SFTP tool to copy the extracted downloader script to the root www
directory of the server. (The root www directory is usually named public_html.) As an
alternative, you can copy the file to another subdirectory, such as /store.

http://www.magentocommerce.com/download
http://www.magentocommerce.com/download/get-started
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Step 4: Grant File Access Permissions

For the Magento Installer to work correctly, the top-level Magento directory on the
server, and all directories beneath it must have correct permissions. To learn more, see
the Knowledge Base article: Recommended File System Ownership and Privileges.

Step 5: Set Up the Store Database

1. Create a new, empty database using one of the following methods:

l Use phpMyAdmin or a similar tool provided by your hosting company. For
instructions, see the documentation for the specific tool.

l MySQL command line

2. Create a new user with full permissions to the database. Then, write down the following
information:

dbname The database name.

dbuser The name of the database user.

dbpassword The password for the database user.

Step 6: Upload the Sample Data to Your Server

If you want to use the sample data, it must be installed now. If you are ready to add
your own products, skip this step. You can use either of the following methods to install
the sample data:

Method 1:

a. Extract the sample data archive that you downloaded in Step 2, to a directory of
your choice on your local computer. The file name is similar to: magento_sample_
data_for_x.x.x.sql.

The archive contains an SQL script with a dump of the sample data, and a
media/catalog folder with category and product images.

Sample Data Archive

http://www.magentocommerce.com/knowledge-base/entry/install-privs-before


Part I: Magento Installation Chapter 2:  Installing Magento

14 Magento Community Edition: User Guide

b. Use an FTP or SFTP tool to copy themedia folder and its subdirectories from your
local computer to the magento installation directory on the server. Depending on
your server, the path will look something like this:

l /var/www.magento/media

l /var/www/html/magento/media

c. Use an FTP or SFTP tool to copy the magento sample data script to the server. A
good place to put it is in the media/catalog folder.

l /var/www/magento/media/catalog

l /var/www/html/magento/media/catalog

d. Do one of the following:

l Use phpMyAdmin, or a similar tool to run the sample data script and import the
data into the new database.

l On the command line, enter the following:

mysql -u <root user> -p <magent-db-name> < <path-and-filename of

db-script>

You are now ready to install Magento!

Method 2:

If you prefer to install the sample data from the command line, see this Knowledge Base
article, under the heading: Installing Optional Sample Data.

http://www.magentocommerce.com/knowledge-base/entry/ce18-and-ee113-installing
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Step 7: Run the Magento CE Downloader

1. From your browser, navigate to the location of the Magento downloader on your server.
The Magento Downloader welcome page appears.

Welcome

2. To validate your server environment, click the Continue button. If error warnings
appear, correct the errors and click the Check Again button.

Validation

3. When you pass the validation test, do the following:

a. Enter the following Database Connection information:

l Host

l User Name

l User Password
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Database Connection

b. Click the Check InnoDB button to confirm the connection.

c. When you receive confirmation that the credentials are valid, click the Continue
button.

4. On the Magento Connect Manager Deployment page, do the following:

Magento Connect Manager Deployment

a. In the Loader Protocol section, set Magento Connect Channel Protocol to one of
the following:

HTTP (Recommended) HTTP is faster than FTP.

FTP Choose FTP if outgoing connections are not allowed in
your hosting environment.
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Loader Protocol

b. In the Stability section, set Magento Connect Manager Version Stability to
“Stable.”

Stability

c. In the Deployment Type section, select one of the following:

Deployment Type

FTP Connection (Recommended) FTP allows you to upload files to the
server without changing read/write/execute permissions.
After choosing FTP connection, complete the following
with information provided by your FTP server
administrator:

Host Name Enter the host name of the FTP
server.

Credentials Enter the FTP credentials provided by
your FTP server administrator

Installation
Path

Enter the path where Magento CE
will be installed. The installation
path points to the same directory
that contains the downloader.php
file.

Local Filesystem Deploying through the local file system requires the
Apache account permissions to be changed. When the
installation is complete, contact your server
administrator to update the file permissions.
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If the web server user can't write to the magento
directory, you should not proceed. It’s most likely an
ownership issue, rather than a permissions issue.

d. To verify the connection, click the Check FTP button. You will not be able to
continue if any of the deployment parameters are invalid. After the FTP connection
is verified, click the Continue button.

5. On the Welcome to Magento's Installation Wizard Page, do the following:

Magento Installation Wizard

a. Set Magento Connect Channel Protocol to the same protocol you selected in the
previous step. (Options include: HTTP/FTP)

b. Custom permissions determine how read, write, and execute permissions are
applied to the downloaded folders and files. Set Use Custom Permissions to one of
the following:

Yes The Magento CE administrator can execute, write, and read files in
the downloaded folders. In the Folders and Files fields that appear,
specify values in the octal number system to denote the permissions
that the Magento administrator has for folders and files on the server.

No Custom permissions are not specified for downloaded folders and
files. In this case the system default values are used:

0777 Folder permissions to read, write, and execute.

0666 File permissions to read and write.

c. Set Deployment Type to the type specified in the previous step. (Options include
Local Filesystem/FTP)
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d. When you are ready to start the download, click the Start the Download Process
button to begin.

Starting to Download

e. When the "Download completed" message appears, click the Continue to Magento
Installation button.

If you were unable to complete the download process due to a connection error,
try to upload the Full Magento Package from the Community download page.

http://www.magentocommerce.com/download
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Part II: Magento Installation
During the second part of the Magento installation, you will complete the initial
configuration, and create an admin account. The initial installation creates a single
website, one store, and three store views, which can be used for different languages.

Process Overview:
Step 1: License Agreement
Step 2: Localization
Step 3: Configuration
Step 4: Create an Admin Account

Step 1: License Agreement

Read the terms of the Magento Community Edition End User License Agreement. If you
agree to the terms, click the Continue button.

License

Step 2: Localization
Select the default localization settings for your Magento CE installation. The values can
be changed later for specific stores, store views, and websites.
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l Locale

l Time Zone

l Default Currency

Locale Settings

Step 3: Configuration

1. In the Database Connection section, do the following:

a. Set Database Type to “MySQL.”

b. In the Host field, enter the server's fully qualified host name or IP address. If your
database server is on the same host as your web server, enter “localhost.”

c. Refer to the database credentials from Part 1: Step 5, and enter the following:

l Database Name

l User Name

l User Password

d. (Optional) The Table prefix is used when there are multiple instances of Magneto
that share a single database. To learn more, see the Knowledge Base article:
Installing and Verifying Magento Community Edition.

Database Connection

2. In the Web Access Options section, do the following:

http://www.magentocommerce.com/knowledge-base/entry/ce18-and-ee113-installing
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a. Enter the Base URL for the Magento store.

b. In the Admin Path filed, enter the base URL for the store’s Admin Panel. (The
default value is “admin.”)

c. To display charts in the Dashboard, select the Enable Charts checkbox.

d. If you are installing Magento to a development or test environment, and the Web
server is not verifiable, select the Skip Base URL Validation Before the Next Step
checkbox. Otherwise, leave the checkbox unselected.

e. (Recommended) To enable the Apache mod_rewrite module, select the Use Web
Server (Apache) Rewrites checkbox. To learn more, see the Knowledge Base article:
Installing and Configuring Required Prerequisite Software.

f. (Recommended) If your server has a valid security certificate, select the Use Secure
URLs (SSL) checkbox. Then, complete the following:

Secure Base URL Enter the complete base URL for the SSL connection.

Run the Admin
Interface with SSL

Select the checkbox to run the store admin on the secure
channel.

These initial SSL settings can be modified later.

Web Access Options

3. In the Session Storage Options section, set Save Session Data In to one of the following:

Session Storage Options

http://www.magentocommerce.com/knowledge-base/entry/ce18-and-ee113-installing#install-prereq-software
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File System Stores user session data on the file system in the magento-
install-dir/var/session directory. File-based session storage
is the most common configuration.

Database Stores user session data in the database. Choose database
storage if you have a clustered database, or if system access
is slow.

4. When the Configuration settings are complete, click the Continue button.

Step 4: Create an Admin Account

1. In the Personal Information section, enter the following:

l First Name

l Last Name

l Email

Personal Information

2. In the Login Information section, do the following:

a. Enter the Username you of the owner of the Magento store.

b. Enter the Password associated with the Admin account. To confirm, enter it again
in the Confirm Password field.

Login Information

3. (Optional) If you already have one, enter the Encryption Key. Otherwise, Magento will
generate one for you.

The encryption key protects sensitive data such as passwords and personally identifiable
customer information. The encryption key is stored on the server at: /app/etc/local.xml
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Important! When Magento generates your encryption key, write it down and keep it in
a safe place. If you ever move your data to another Magento CE site, you will need the
encryption key to recover the data.

Encryption Key

4. Click the Continue button, and you’re all set!

l To explore your new store, click the Go to Frontend button.

l To explore your store’s admin, click the Go to Backend button.

Reinstalling Magento CE
If you want to repeat the installation on the same server, it is not necessary to download
the files again.

1. On the server, delete the file: app/etc/local.xml

2. Delete any files and directories found in: var/

3. With your browser, navigate to your Magento directory. For example:
http://www.yourDomain.com/magento-directory

The Magento Installation Wizard launches automatically.

Staging Environment
If you plan to develop your store over a period of time, we recommend that you set up a
staging environment where you can test changes before applying them to the live store.

A staging environment is just like any other Magento CE installation, but is not
accessible to the public. You can use a version control tool to keep files synchronized
between the staging environment and the live store.

We highly recommend that you use a staging environment to test extensions and before
updating your live store to a new version of Magento CE.
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Chapter 3:

Your Magento Account
You can find the information related to the products and services you have signed
up to receive, as well as your contact and billing information in the dashboard of
your Magento account. Your Magento account has a separate login from your store,
and can be accessed from either the Magento website or from your store’s Admin.

Your Magento Account

To log in to your Magento account:

1. Navigate to the Magento site: http://www.magento.com

2. In the upper-right corner, click theMy Account link.

3. Enter your First Name, Last Name, Email Address, and select the functions My
Company Primarily performs and My Role.

4. Enter your User Name or Email , and Password. Then, click the Submit button.
Your account dashboard appears.

http://go.magento.com/
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Log In to Your Account

Sharing Your Account
Your Magento account contains information that can be useful to trusted employees and
service providers who help to manage your site. As the primary account holder, you have
authority to grant limited access to your account to other Magento account holders.

Shared Access

26 Magento Community Edition: User Guide
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When your account is shared, all sensitive information—such as your billing history or
credit card information—remains protected. It is not shared at any time with other
users.

All actions taken by users with shared access to your account are your sole
responsibility. Magento Inc. is not responsible for any actions taken by users to whom
you grant shared account access.

To set up a shared account:

1. Before you begin, get the following information from the new user’s Magento account:

l Account ID

l Email address

2. Log in to yourMagento account.

3. In the My Account panel on the left, under Shared Access, click Add New User.

4. In the New User Information section, do the following:

l Enter the Account ID of the new user’s Magento account.

l Enter the Email address that is associated with the new user’s Magento account.

5. In the Shared Information section, do the following:

a. Enter a Sharename to identify your shared account. Because the Sharename
becomes an option in the Switch Accounts list, it should be something that the
other person will recognize as your account.

b. To share your personal contact information, select the checkbox of each item that
you want to make available to the other person:

l Your Email

l Your Phone

6. In the Grant Account Permissions section, select the checkbox of each item that you
want to share.

7. When complete, click the Create Shared Access button.

You are notified when the new role is saved, and the new user record appears in the
Manage Users & Permissions section of the Shared Access page. Magento also sends an
email invitation with instructions for accessing the shared account to the new user.
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Add a New User

To access a shared account:

1. When you receive the invitation to a shared account, the first thing you must do is to
log in to your own Magento account.

Your account dashboard has a new Switch Accounts listbox in the upper-right corner,
with options for “My Account” and the name of the shared account.

2. To gain access to the shared account, set the Switch Accounts listbox to the name of the
shared account.

The shared account displays a welcome message and contact information. The left panel
includes only the items that you have been given permission to use.

Switch Accounts

3. When you are ready to return to your own account, simply set Switch Accounts to “My
Account.”

28 Magento Community Edition: User Guide
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Chapter 4:

Quick Tour
This quick tour follows the customer-decision journey that leads to a purchase on an
eCommerce site powered by Magento Community Edition. Each item is linked to a
topic in this guide, where you can learn more about the subject. You can also follow
along on your computer with the sample data.

Your Storefront
Our storefront example is Madison Island, a fictional fashion website that we created
to highlight some of Magento’s key features and functionality.

To access your storefront:

Using your browser, navigate to your store. The URL is something like this:

http://www.yourdomain.com

Home Page
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Customer Journey

Attract New Customers

Magento Community Edition includes
SEO functionality out of the box.
Improve your search ranking and attract
the most visitors to your site.

Engage Your Customers

Design your site with pre-designed
templates, or create a custom design
with features that invite people to

interact with your store.

Increase AOV

Increase average order value with
promotions and content that encourage
your customers to shop more.
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Moment of Purchase

Give your customers a faster and easier
way to check out. Calculate shipping

and taxes automatically, and integrate
multiple payment methods on a single

page.

Customer Retention

Create and manage newsletters and
promotions to keep your customers
coming back for more.

Loyalty & Advocacy

Encourage customers to write product
reviews, create wishlists, and send email
about products to their friends. This will
strengthen your relationship with your
customers, who in return, will speak
positively of your business to friends

and family.



Customer Journey Chapter 4:  Quick Tour

32 Magento Community Edition: User Guide

Attract New Customers
Magento Community Edition is packed with features that make it easy to create a
“search engine friendly” websites and increase the likelihood of bringing the right
customers to your site.

Search Engine Optimization

Magento offers powerful, native capabilities to streamline Search Engine Optimization
(SEO) practices for content and site exposure that are integrated with the Admin, and
tied directly into the user experience.

Custom URLs

Custom URLs are short, clean, and easy to remember. You can also autogenerate search-
friendly URLs to streamline your purchase path.

Meta Data

Improve your search engine rankings by choosing specific criteria that helps search
engines to find and index your products more easily. Meta data can be entered for
product, category, and content pages.

Sitemap

Link to a sitemap from the footer of your store to give customers an overview of the
catalog structure, with links to all categories and products in the store. You can also
easily integrate your store with Google Sitemap.

Analytics

In addition to monitoring your site from the Admin dashboard, you can integrate third-
party analytics tools such as Google Analytics, for detailed statistics on traffic and sales.
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Engage Your Customers
Magento Community Edition makes it easy to create a customized, engaging site
experience. Encourage your customers to spend more time exploring your site, and give
them the tools to make it easy to find what they want faster.

Content Management System

Magento’s CMS makes it easy to store
pages, or parts of pages, that you can
use in your store. It’s so intuitive that
someone without a technology
background can create and manage site
content.

Design & Theme

Control the visual elements of your store
with a collection of templates and skin

files. You can apply these visual
elements to all pages in your store,

giving your store a cohesive look and
feel.

Multiple Stores, Sites & Views

Control the look and feel of multiple
sites, introduce new market and
languages, and track analytics from a
single Admin.

Multiple Devices

Magento’s powerful features make it
easy to create storefronts optimized for

iPhone, Android, and Mobile Opera
browsers to help you engage consumers
with mobile eCommerce now and into

the future.
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Shopping Tools

Your store includes a set of shopping
tools that create opportunities for your
customers to interact with your store,
connect on social media, and share with
friends.

Sophisticated Search

Filter product by price, manufacturer, or
any other criteria to reduce the time to

purchase.

Increase Average Order Value (AOV)
Magento Community Edition provides a range of tools to help you tailor the shopping
experience, and encourage your customers to put more items in their shopping carts and
spend more money.

Promotions

Magento's catalog and shopping cart
price rules let you create promotions

that kick into gear when a set of
conditions is met.



Chapter 4:  Quick Tour Customer Journey

35Magento Community Edition: User Guide

Coupons

Create limited-time offers and coupons
that customers can scan with their
phone and apply to a purchase.

Product Suggestions

Another way to increase AOV is to offer
suggestions for related products and

opportunities to up-sell and cross-sell at
strategic points along the path to

conversion.

User Permissions & Roles

Restrict access to data in the Admin on
a “need to know” basis. Create multiple
admin roles for read-only or and editing
privileges. Track and review all activity
at a granular level to specific stores and
websites.
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Moment of Purchase
Now that you’ve given your customer an engaging shopping experience, make it easy for
them to complete their purchases. Magento is designed to help you streamline your
checkout process experience while boosting conversion rates.

Order Processing

Magento supports a complete order processing workflow. It's easy to customize order
statuses and track communications between sales reps and customers.

Shipping Labels

Merchants have complete control over package characteristics such as weight and size.
Shipping labels, rate, and barcode information originates directly from the carrier. Labels
can be generated for single or multiple orders.

Multiple Shipping Options

Magento supports a variety of shipping methods so you can give your customers a
choice at checkout. Customers can see a real-time estimate of shipping charges right
from the shopping cart.

Multiple Payment Options

Magento Community Edition supports the payment methods and currencies needed for
global commerce. You can choose the ones you want to offer, and at checkout, your
customers can choose the ones they prefer.

PayPal Merchant Solutions

It's easy to integrate a PayPal Payments account to provide your customers faster, more
secure checkout options.

Assisted Shopping

Assisted shopping makes it easy for customer service reps to create orders for customers.
Customer service reps have access to shopping cart contents, and can move items from a
wishlist to a shopping cart, apply coupon codes, and more.

Security

Whether an order is fulfilled online or over the phone, Magento provides sophisticated
security, including CAPTCHA and SSL encryption, with best-in-breed encryption and
hashing algorithms to protect the security of the system.
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Customer Retention
Magento makes it easy for you to get repeat business and build brand loyalty. Magento
gives you total control and flexibility over creating and revising goodies like rewards
programs, custom coupons and automated emails to keep your customers coming back
again and again.

Custom Coupons

Create coupons codes for social media,
email, or print campaigns. You can
incorporate coupon codes into any

design you like.

Newsletters

Stay in touch with current customers
who’ve opted to receive newsletters. You
can create as many newsletter templates
as you want.
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Loyalty & Advocacy
Give customers a direct connection to your brand by allowing them to create customer
accounts where they can see their purchase history, wishlist, and newsletter
subscriptions. Use product ratings and reviews to give new customers objective product
opinions and promote a sense of community. These features turn customer satisfaction
into one of the most powerful and cost-efficient marketing tools at your disposal.

Dashboard Snapshots

Knowing what’s of interest on your site is crucial to maximize your marketing budget.
Use this information to determine what you should cross- and up-sell to loyal
customers, or which products to put on sale.

Customer Accounts

Opening as account provides customers with a personalized shopping experience that
they can share with their friends. Customers can save their shopping preferences, and
manage their own store billing and shipping information.

Advocacy Tools

Customers who share their wishlists with family and friends make a powerful
endorsement of your brand. Customers create these personalized lists from products they
choose. When shared by email or RSS feed, these simple lists become powerful advocacy
tools.

Reviews & Ratings

Product reviews give your customers a way to engage with your brand while fostering a
sense of community. You can curate your reviews with tools to help you edit and
approve comments for inappropriate content before they go live.
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Success!
Opening your Magento store for business requires the following areas of consideration.
While there are virtually any number of customizations you can make to the storefront
and Admin, you can use each link in this is list as a place to start.

Implementation

If you need help setting up your store,
you can choose from our vast network
of Magento Solutions Partners.

Design

You can design your own home page or
work with an experienced Magento

designer or Solutions Partner to customize
your site.

Product Catalog

Configure products, create categories,
import existing product catalogs, and
leverage APIs or third-party data
management solutions.

http://magento.com/partners/overview
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Payment Methods

Magento supports a wide variety of
payment methods, services, and gateways

that you can offer for your customers’
convenience.

Shipping Methods

Magento shipping methods are easy to
set up and give you the ability to
connect with carriers who can ship
your products all over the world.

Taxes

Manage your taxes with our native tools,
or add third-party extensions from

Magento Connect.

Thanks for your order!

Magento can help you build
relationships with your customers, to
bring them back to your store, again
and again.
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Chapter 5:

Store Admin
Your store Admin is the password-protected back office where you can set up
products, promotions, manage orders, and perform other administrative tasks.

This chapter provides a high-level overview of the management tasks that you can
perform while running your store on a day-to-day basis.

Store Admin
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Admin Login
All of the basic configuration tasks are performed in the Magento Admin Panel, which is
referred to in this guide as your store Admin.

Admin Login

To log in to your store Admin:

1. For a new Magento installation, do the following:

a. On the last page of the Magento Installation Wizard, click the Go to Backend
button.

b. In the address bar of your browser, enter the URL that you specified in the Magento
Installation Wizard, followed by the base URL of your store’s Admin. Most Admin
URLs looks like this:

http://www.mystore.com/admin

You can bookmark the Admin Login page for easy access.

2. Enter the User Name and Password that was specified during the Magento installation.

3. Click the Login button.

Message InBox
Your store has an inbox for the messages received from Magento. The messages are rated
by importance, and might refer to updates, patches, new releases, scheduled
maintenance, upcoming events, and more. Any message that is considered to be of
major importance appears in a pop-up window when you log into your store. You can
manage your message inbox much as you would manage your email. Check it often to
stay up-to-date on the latest information from Magento!
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Incoming Message

To manage incoming messages:

1. When the Incoming Messages box appears, do one of the following:

l Click the Read Details link for more information.

l Click the Close box to remove the popup and continue.

A Latest Message notice also appears to the left, just below the header of your store. As
with the popup box, you can click the Read Details link for more information.

Message Notifications Below Header

2. To read your messages, click Go to messages inbox.

The messages in your inbox are marked by severity listed with the most recent at the
top.

3. After reading a message, you can apply any of the following actions to the message:
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l For more information, click the Read Details link.

l To keep the message, click theMark As Read link.

l To delete the message from your inbox, click the Remove link.

Messages Inbox

To apply an action to multiple messages:

1. On the Admin menu, select System > Notifications.

2. In your message inbox, do one of the following:

l Select the checkbox at the beginning of each message you want to manage.

l Click one of the group selection options above the list to select multiple messages.

3. When the messages that you want to manage are selected, set Actions to one of the
following:

l Mark as Read

l Remove

4. Click the Submit button to complete the process.
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Messages Inbox

Message Importance
Severity Color Description

Critical Red Indicates an important, time-sensitive message.

Major Orange The default message severity level.

Notice Green Indicates that a routine operation has taken place.
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Dashboard
The Dashboard is the first page that appears when you log in to the Admin. It’s a hub of
important information about the health of your eCommerce site, and includes snapshots
of Lifetime Sales, Average Orders, Top Search Terms, Bestsellers, Most Viewed Items,
and more.

Dashboard
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Admin Menu
All of the tools you need to manage the operation and maintenance of your store are
available in the Admin menu.

Dashboard

The Dashboard gives you a quick overview
of the sales and customer activity in your
store. It is usually the first page that
appears when you log in to the Admin.

Sales

The Sales menu is where you can find
everything related to processing an
order, including current and past
orders, invoices, shipments, credit

memos, terms and conditions,
and taxes.

Catalog

The Catalog menu controls everything
related to your product catalog, including
products, categories, attributes, URL
rewrites, search terms and indexing,
product reviews, tags, and Google
Sitemap.
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Mobile

The Mobile menu is where you can
configure the templates, content, and
apps for various mobile devices and

store views.

Customers

The Customers menu is where you can
manage customer accounts, and customer
groups. You can even see which customers
are online at the moment.

Promotions

The Promotions menu is where you set
up catalog and shopping cart price

rules and coupons. Price rules trigger
actions when a set of specific

conditions is met.

Newsletter

The Newsletter menu contains the tools
you need to publish newsletters and
manage your list of subscribers.
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CMS

The CMS menu is where you create
and manage content for your store. In

addition to content pages, you can
create static blocks, “widgets,” and

polls.

Reports

The Reports menu provides a broad
selection of reports that give you insight
into every aspect of your store, including
sales, shopping cart, products, customers,
tags, reviews, and search terms.

System

The System menu includes tools to
configure and maintain every aspect of
your store. In addition, you can install
extensions and manage Web Services

for integration with other applications.
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Admin Tools
The Admin includes many lists of data for products, orders, customers, search terms,
pages, blocks, and so on. Each list has the same set of tools for finding records,
pagination, sorting, filtering, selecting, and applying actions to records.

Global Search

The Global Search box can be used to find any value in the database, including product,
customer, and order records.

Sorting

The header of each column can be used to sort the list in ascending or descending order.

Filters

The filters in the header of each column can be used to limit the list to specific values.
Some filters have additional options that can be selected from a list box, and for others,
you can simply type the value you want to find.

Pagination

The pagination controls are used to view the additional pages of results.

Selection

The Selection controls above the column headers have links to Select All, Unselect All,
Select Visible, and Unselect Visible

Actions

The Action control applies an operation to any record with a checkmark in the first
column.
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Global Record Search
The global search box is located in the Admin header, and can be used to find any record
in the database. The results can include customers, products, orders, or any related
attribute.

Global Record Search

To do a global search:

1. Type the first few letters of what you are looking for into the global search box.

2. In the list of closely matching items, click the one that you want to find.
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List Controls
Many pages in the Admin include a list of records displayed in a grid, with controls at
the top of each column. The controls can be used to sort the list in ascending, or
descending order based on the values in the column. In addition, you can filter the list
based on a value in each column.

Sort Controls

To sort the data:

1. In the upper-left corner, set Choose the Store View to the define the scope of the data to
be retrieved.

2. Click the column name of any header. The arrow indicates the current order as either
ascending or descending.

3. Use the pagination controls to view additional pages in the collection.

To set the pagination controls:

1. Set View to the number of records that you want to view per page.

2. In the Page box, enter the page number you want to view, or click the arrow button to
advance to the next or previous, page.
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Pagination Controls

To filter the data:

1. In the box below the column header, either enter or select the value you want to find.

2. Click the Search button.

Filter Controls
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Actions Control
When working with lists of data, you can use the Actions control to apply an operation
to a single record, or to multiple records. The Actions control lists the operations that
can be applied to the selected records. When working with the Manage Products list, you
can use the Actions control to update the attributes of the group of selected products,
change their status from “Disabled” to “Enabled,” or delete them from the database.

The selection of available actions varies by list, and additional options may appear,
depending on the action selected. For example, when changing the status of a group of
records, a Status box appears next to the Actions control with additional options.

Applying an Action to Selected Records

Selecting Records

The checkbox in the first column identifies each record that is a target for the action. The
search filters can be used to narrow the list to the records you want to target for the
action.

The selection links above the list to the left, can be used to change the checkbox state of
groups of records. The options include:

l Select All / Unselect All

l Select Visible / Unselect Visible

Checkbox States

You can also use the search filter at the top of the column to list any (or all) records, or
only those with a selected or unselected checkbox.. The checkbox search filter settings
include:

Any Lists all records, regardless of checkbox status.
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Yes Lists only records with the checkbox selected.

No Lists only records without the checkbox selected.

When using the Actions control to update attribute settings, you can make as many
changes as necessary, and then update the records in a single step. It’s much more
efficient than changing settings individually for each product record.

To apply an action to selected records:

1. In the list, select the checkbox of each record that is targeted for the action.

2. Set the Actions control to the operation you want to apply.

3. Click the Submit button.

To update attributes:

1. In the list, select the checkbox of each record to be updated.

2. Set the Actions control to “Update Attributes,” and click the Submit button.

The Update Attributes page lists all the available attributes, which are organized by
group in the Product Information panel on the left.

Update Attributes

3. Select the Change checkbox next to each attribute, and make the necessary changes.

4. Click the Save button to update the attributes for the group of selected records.
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Actions by List
List Actions

Sales

Orders Cancel

Hold

Unhold
Print Invoices
Print Packingslips
Print Credit Memos
Print All
Print Shipping Labels

Invoices PDF Invoices

Shipments PDF Packing Slips
Print Shipping Labels

Credit Memos PDF Credit Memos

Search Terms Delete

Catalog

Manage Products Delete
Change Status
Update Attributes

Search Terms Delete

Manage Tags Delete
Change Status

Reviews (All / Pending) Delete
Update Status

Tags (All / Pending) Delete
Change Status

Mobile

Message Queue Delete
Cancel

Customers

Manage Customers Delete
Subscribe to Newsletter
Unsubscribe from Newsletter
Assign a Customer Group
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List Actions

Newsletter

Newsletter Subscribers Unsubscribe
Delete
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Chapter 6:

Multiple Sites, Stores & Views
When Magento Community Edition is installed, a main website, a store, and three
store views are created. You can create additional websites, stores, and store views,
according to your needs. For example, in addition to your main website, you might
have a additional websites with separate domains. Within each website, you can
have multiple stores, and within each store, separate views.

Websites

Suppose you want to sell machine shop equipment online, and your spouse wants to
sell handmade baskets. It is unlikely that you would sell both of these product lines
in a single store. However, in a single Magento installation, you can do both by
setting up separate websites. Each website can have its own domain name. The
websites can be set up to share customer data, or to have entirely separate sets of
customer data.

Stores

For your handmade baskets website, you might want to set up two stores, one
specializing in wicker and one for other materials. You can set up two root categories
(one for wicker items and one for other items) and assign one to each store. Several
stores of one website can have different independent domain names as well, but it
should be configured on the store view level of each store.

Store Views

Your market research indicates that about half of your potential customer base
speaks English, and the other half speaks Spanish. Within each store, you can create
a separate store view for each language. The store views share the same catalog, but
each is presented in its respective language. Customers can switch from one store
view to another using the “language chooser” in the header of the store.

Setting Up Store Hierarchy
Before you begin, carefully plan your store hierarchy in advance because it is referred
to throughout the configuration. Each store can have a separate root category, which
makes it possible to have an entirely different set of navigation for each store.
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To have a separate domain for each website, you must modify the configuration files on
the server. To learn more, see: Tutorial: Multi-Site, Multi-Domain Setup.

Manage Stores

To set up a new website:

1. On the Admin menu, select System > Manage Stores.

2. From Manage Stores, click the Create Website button. Then, do the following:

Website Information

a. Enter the Name of the website. The name is for internal reference, and can refer to
the domain of the site or anything else distinguish it from other sites in the
hierarchy.

b. Enter a Code that will be used on the server to point to the domain. The code must
begin with a lower-case letter, and can include any combination of letters (a-z),
numbers (0-9), and the hyphen (-) character.

c. (Optional) Enter a Sort Order number to determine the sequence in which this site
is listed with other sites. Enter a zero to make this site appear at the top of the list.

3. When complete, click the Save Website button.

To set up a new store:

1. Before you begin, set up the root category that will be used for this store.

2. On the Admin menu, select System > Manage Stores.

3. From Manage Stores, click the Create Store button. Then, do the following:

New Store
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a. Set Website to the site that is the parent of this store.

b. Enter a Name for the store. The name is for internal reference to distinguish it from
other stores in the hierarchy. For example: Private Sales Store.

c. Set Root Category to the root category that will be used for the main navigation of
the store. The root category can be the same as used for other stores, or unique to
this store. For example: Private Sales Root.

4. When complete, click Save Store.

To set up a new store view:

1. On the Admin menu, select System > Manage Stores.

2. From Manage Stores, click the Create Store View button. Then, do the following:

Store View Information

a. Set Store to the parent store of this view.

b. Enter a Name for this store view. The name appears in the “language chooser” in the
header of the store. For example: French.

c. Enter a Code in lowercase characters to identify the view. For example:
privatesales.fr.

d. To activate the view, set Status to “Enabled.”

e. (Optional) Enter a Sort Order number to determine the sequence in which this view
is listed with other views.

3. When complete, click the Save Store View button.

Configuration Scope
If your Magento installation has multiple websites, stores, or views, you can set the
scope of a configuration parameter to apply to a specific part of your installation. The
Current Configuration Scope box in the upper-left corner of the Admin workspace
determines the scope of the current settings. By default, the configuration scope is set to
“Default Config.” For Admin users with restricted access, the list includes only the areas
where the user is granted permission to access.

The configuration scope applies to products categories, attributes, customer
management setting, and so on. The scope of each item appears in brackets after the
field to indicate the range of the setting.
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Current Configuration Scope

If your installation includes multiple websites, stores or views, you should always set
the scope to identify where you want the settings to apply. The possible settings are:
[STORE], [WEBSITE], and [GLOBAL].

Any item with the scope of [STORE] can be set differently for each view. For example,
because the scope of a product name and description is [STORE], the fields can have a
different value for each language. However, some configuration settings—such as postal
code—are [GLOBAL] because the same setting applies throughout the system. The
[WEBSITE] scope also applies to the entire site, including all views.

To set the configuration scope:

Before making a configuration setting that applies only to a specific website, store, or
view, do the following:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, select the page with the configuration settings you want to
change. If necessary, click to expand the section to be configured. Then, do the following:

a. In the upper-left corner of a configuration page, set Current Configuration Scope to
the website, store, or view where the configuration applies.

A checkbox appears after each field, and sometimes additional fields become
available.

b. Clear the Use Default checkbox that is after the field that you want to edit. Then,
enter the new value.

c. Repeat this process for every field that needs to be updated on the page.

3. When complete, click the Save Config button.
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Scope Settings
Scope Description

Store The setting is limited to the store view, which is often used to
display a store in multiple languages.

Website The setting is limited to the website.

Global The setting applies to the entire installation.
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Chapter 7:

Store Information
The basic information for your store includes the store name and address, telephone
number and email address, that appear on email messages, invoices, and other
communications sent to your customers. In this chapter, you will configure the
following information:

l Store Locale

l Countries Options

l State Options

l Shipping Settings

l Store Email Addresses

l Contact Us
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Locale Options
The locale determines the language, country, tax rate, and other settings used
throughout a store. The Locale Options configure the time zone and language of each
store, and identify the days of your work week in the area.

Locale Options

To set the locale of a store:

1. On the Admin menu, select System > Configuration.

2. Click to expand the Locale Options section.

3. Select your Timezone from the list. Then, do the following:

a. Set Locale to the store language.

b. Set First Day of the Week to the day that is considered to be the first day of the
week in your area.

c. In theWeekend Days list, select the days which fall on a weekend in your area. (To
select multiple options, hold down the Ctrl (PC) or Command (Mac) key.)

4. When complete, click the Save Config button.

Field Descriptions
Field Scope Description

Timezone Website Identifies the time zone of the primary market
served by the store. Usually the timezone is the
same as that used in the physical location of
your business.

Locale Store View Identifies the language, currency, and system of
measurement used in the market served.

First Day of Week Store View Identifies the day that is considered to be the
first day of the week in the market served.

Weekend Days Store View Identifies the days that fall on the weekend in
the market served by the store.
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States Options
In many countries, the state, province, or region is a required part of a postal address.
The information is used for shipping and billing information, to calculate tax rates, and
so on. For countries where it is not required, the field can be omitted entirely from the
address, or included as an optional field.

Because standard address formats vary from one country to another, you can also edit
the address template that determines how the information appears on invoices, packing
slips, and shipping labels.

States Options

To set up the state options:

1. On the Admin menu, select System > Configuration.

2. Click to expand the States Options section, and do the following:

3. In the State is required for list, select each country where you want State / Province to
be a required entry. To select multiple options, hold down the Ctrl (PC) or Command
(Mac) key.

4. Set Display not required State to one of the following:

Yes In countries where the state field is not required, the field is included in
the form as an optional entry.

No In countries where the state field is not required, the field is omitted from
the form.

5. When complete, click the Save Config button.

Field Descriptions
Field Scope Description

State is required for Global Identifies the countries where you conduct busi-
ness that do not require a state or province to
be included in a postal address.

Display not required Global For countries where it is not required, determ-
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Field Scope Description

State ines if the State/Province field is included in the
postal address of the customer. Options
include:

Yes Includes the State/Province
field in the customer address,
even if not required by the
country.

No Omits the State/Province field
from the customer address if
not required by the country.

Countries Options
The Countries Options establish the country where your business is located, and the
countries from which you accept payment.

Countries Options

To set the country options for your store:

1. From the Admin menu, select System > Configuration.

2. Click to expand the Countries Options section. Then, do the following:

a. Set Default Country to the country where your business is located.

b. In the Allow Countries list, select each country from which you accept orders. By
default, all countries in the list are selected. To select multiple countries, hold down
the Ctrl (PC) or Command (Mac) key.
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c. In the Postal Code is Optional list, select each country where you conduct business
that does not require a ZIP or postal code to be included as part of the street
address.

d. In the European Union Countries list, select each country in the EU where you
conduct business. By default, all EU countries are selected.

3. When complete, click the Save Config button.

Field Descriptions
Field Scope Description

Default Country Store View Identifies the country where your store is
located.

Allow Countries Store View Identifies each country from which you accept
orders.

Postal Code is Optional
for the following coun-
tries

Global Identifies the countries that do not require a ZIP
or postal code in the shipping address.

European Union Coun-
tries

Global Identifies the countries that are members of the
European Union.

Currency Setup
Magento Community Edition gives you the ability to accept currencies that are used in
more than two hundred countries around the world. In addition to choosing the
currencies that you accept, you can also manage currency rates for the store. If you
accept payment in multiple currencies, make sure to monitor the currency rate settings,
because any fluctuation can affect your profit margin. Currency rates can be set
manually, or imported into the store. Currency symbols are used throughout the store,
and appear in product prices and sales documents such as orders and invoices.

Before you can set currency rates, you must first specify the currencies that you accept,
and which currency is used to display prices in your store. You can customize the
currency symbols as needed, and also set the price display separately for each store or
view.

Currency Options
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To set up currency for your store:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under General, select Currency Setup.

3. Click to expand the Currency Options section, and do the following:

a. Set Base Currency to the primary currency that you use for online transactions.

b. Set Default Display Currency to the currency that you use to display pricing in your
store.

c. In the Allowed Currencies list, select all currencies that you accept as payment in
your store. (To select multiple currencies, hold down the Ctrl key and click each
option.)

4. When complete, click the Save Config button.

Field Descriptions
Field Scope Description

Base Currency Website The primary currency used in store transactions.

Default Display Currency Store View The primary currency used to display prices.

Allowed Currencies Store View The currencies accepted by your store for
payment.
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Shipping Settings
The Shipping Settings establish the point of origin for all shipments made from your
store or warehouse, and also your preference for managing orders that are shipped to
multiple addresses.

To establish the point of origin:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, select Shipping Settings.

3. If applicable, set Current Configuration Scope to the store where the configuration
applies.

4. Click to expand the Origin section.

Shipping Origin

5. Complete the fields for each part of your point-of-origin address. If you need more room
for the street address, use both address lines.

6. When complete, click the Save Config button.

Field Descriptions
Field Scope Description

Country Website The point-of-origin country.

Region/State Website The point-of-origin region or state.

ZIP/Postal Code Website The point-of-origin ZIP or postal code.

City Website The point-of-origin city.

Street Address Website The point-of-origin street address.

Street Address Line 2 Website An additional line for the point-of-origin street
address, if needed.
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To configure shipments to multiple addresses:

1. On the Shipping Settings page, click to expand the Options section. Then, do the
following:

Shipping Options

a. To allow items from a single order to be shipping to multiple addresses, set Allow
Shipping to Multiple Addresses to “Yes.”

b. To limit the quantity of a single item that can be shipping to multiple addresses,
enter the number in theMaximum Qty Allowed for Shipping to Multiple
Addresses field.

2. When complete, click the Save Config button.

Field Descriptions
Field Scope Description

Allow Shipping to Mul-
tiple Addresses

Website Determines if you allow single orders to be ship-
ping to multiple addresses. Options include: Yes
/ No

Maximum Qty Allowed
for Shipping to Multiple
Addresses

Website Sets a limit for the number of units of a product
that can be shipping to multiple addresses.
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Store Email Addresses
You can have up to five different email addresses to represent distinct functions or
departments for each store or view. In addition to the following predefined email
identities, there are two custom identities that you can set up according to your needs.

l General Contact

l Sales Representative

l Customer Support

Each identity and its associated email address can be associated with specific
automated email messages and appear as the sender of email messages that are sent
from your store.

Store Email Addresses

Step 1: Set Up the Email Addresses for Your Domain

Before you can configure email addresses for the store, each must be set up as a valid
email address for your domain. Follow the instructions from your server administrator
or email hosting provider to create the email address you need.

Step 2: Configure the Email Addresses for Your Store

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under General, select Store Email Addresses.
Then, do the following:
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a. Click to expand the General Contact section.

b. If you have multiple stores or views, set the Current Configuration Scope in the
upper-left corner to identify the store or view where the configuration applies. Then,
clear the checkbox after each field so new values can be entered.

General Contact

c. In the Sender Name field, type the name of the person that you to appear as the
sender of all email messages that are associated with the General Contact.

d. In the Sender Email field, type the associated email address.

3. Repeat this process for any other email addresses that you plan to use.

4. When complete, click the Save Config button.

Step 3: Update the Sales Email Configuration as Needed

If you use custom email addresses, make sure to update the configuration of any related
email messages, so the correct identity appears as the sender.

1. In the panel on the left, under Sales, select Sales Email.

2. Click to expand each section, and make sure that the correct store email is selected as
the sender of the message.

3. When complete, click the Save Config button.
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Contact Us
The Contact Us link in the footer of each page is an easy way for customers to keep in
touch with you. The form is enabled by default, and can be configured to send inquiries
to a specific email address and replies from a specific store identity.

Contact Us

To configure the Contact Us form:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under General, click Contacts.

3. Click to expand the Contact Us section, and set Enable Contact Us to “Yes.”

4. Click to expand the Email Options section. Then, do the following:

Email Options

a. In the Send Emails To field, enter the email address where the form information is
to be sent.

b. Set Email Sender to the store identity you want to use for the replies sent.

c. Select the Email Template used to format the data sent from the form.

5. When complete, click the Save Config button.
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Chapter 8:

Industry Compliance
Magento Community Edition offers a range of security and privacy capabilities that
meet legal requirements and industry guidelines for online merchants. Some are
mandated by the payment card industry, and others are required by law, depending
on your location. The topics covered in this chapter include:

l PCI Compliance

l Privacy Policy

l Cookie Law

You will learn about PCI compliance, and the importance of establishing procedures
to protect payment information. You will also learn how to bring your store into
compliance with the Cookie Law, which is a requirement in some countries, and
considered a “best practice” in others. In addition, you will learn how to customize
and maintain a privacy policy for your store.
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PCI Compliance Guidelines
The Payment Card Industry (PCI) has established a set of requirements for businesses
that accept payment by credit card over the Internet. In addition to the need to
maintain a secure hosting environment, there are additional requirements that
merchants must meet to ensure the privacy of cardholder data. Every merchant who
handles customer credit card information is required by the Payment Card Industry to
conduct business within the following guidelines:

PCI Requirement Checklist

Install and maintain a firewall configuration to protect cardholder data.

Do not use vendor-supplied defaults for system passwords and other security
parameters.

Protect stored cardholder data.

Encrypt transmission of cardholder data across open, public networks.

Use and regularly update antivirus software.

Develop and maintain secure systems and applications.

Restrict access to cardholder data by business need to know.

Assign a unique ID to each person with computer access.

Restrict physical access to cardholder data.

Track and monitor all access to network resources and cardholder data.

Regularly test security systems and processes.

Maintain a policy that addresses information security.

As your business grows, you may be required to file a compliance report on an annual
basis. PCI reporting requirements increase in proportion to merchant level, but are
waived for businesses that process fewer than 20,000 credit card transactions per year.
To learn more, visit the PCI Security Standards Council website.

https://www.pcisecuritystandards.org/index.php
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Privacy Policy
Your store includes a sample privacy policy that must be updated with your own
information. Your privacy policy should describe the type of information that your
company collects, and how it is used. It should also list the filenames of cookies that are
placed on the computers of people who visit your store. Any additional cookies that are
associated with third-party extensions and add-ons should be included in the list. For a
complete list of the cookies used by Magento, see Cookie Restriction Mode.

Privacy Policy

To edit your privacy policy:

1. On the Admin menu, select CMS > Pages > Manage Content.

2. Find the privacy policy in the list, and click to open the page.

3. In the panel on the left, click Content.

4. To work in WYSIWYG mode, click the Show/Hide Editor button.

5. Make the necessary changes to the content.

6. When complete, click the Save Page button.
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Cookie Law Compliance
Cookies are small files that are saved to the computer of each visitor to your site, and
used as temporary holding places for information. Information that is saved in cookies is
used to personalize the shopping experience, link visitors to their shopping carts,
measure traffic patterns, and improve the effectiveness of promotions.

To keep pace with legislation in many countries regarding the use of cookies, Magento
offers merchants a choice of methods for obtaining customer consent.

Implied Consent

Using cookies with implied consent is the method that is currently the most widely
adopted in the UK. Implied consent means that visitors to your store have a clear
understanding that cookies are a necessary part of operations, and by using your site,
have indirectly granted permission to use them.

The key to gaining implied consent is to provide enough information for a visitor to
make an informed decision. Many stores display a message at the top of all standard
pages that provides a brief overview of how cookies are used, with a link to the store’s
privacy policy. The privacy policy should describe the type of information that your store
collects, and how it is used.

Expressed Consent

Using cookies with implied consent is the method that is currently the most widely
adopted in the UK. Implied consent means that visitors to your store have a clear
understanding that cookies are a necessary part of operations, and by using your site,
have indirectly granted permission to use them.

Cookie Restriction Mode
Operating your store in “Cookie Restriction Mode” requires that visitors express their
consent before cookies can be saved to their computers. Unless consent is granted, many
features of your store become unavailable. For example, if Google Analytics is available
for your store, it can be invoked only after the visitor has granted permission to use
cookies.

Cookie Restriction Notice In Footer
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When Cookie Restriction Mode is enabled, visitors to your store are notified that cookies
are required for full-featured operations. Depending on your theme, the message might
appear above the header, below the footer, or somewhere else on the page. The message
links to your privacy policy for more information, and encourages visitors to click the
Allow button to grant consent. After consent is granted, the message disappears. The
Cookie Restriction Mode message resides in a CMS static block, and can be edited to suit
your voice and style.

Your privacy policy should include the name of your store and contact information, and
explain the purpose of each cookie that is used by your store. See the end of this topic for
a complete list of the cookies used.

Step 1: Enable Cookie Restriction Mode

1. On the Admin menu, select System > Configuration. Then in the panel on the left,
under General, click Web.

2. Click to expand the Session Cookie Management section, and do the following:

Cookie Session Management

a. Enter the Cookie Lifetime in seconds.

b. If you want to make cookies available to other folders, enter the Cookie Path. To
make the cookies available anywhere in the site, enter a forward slash.

c. To make the cookies available to a subdomain, enter the subdomain name in the
Cookie Domain field. (subdomain.yourdomain.com) To make cookies available to
all subdomains, enter the domain name preceded by a period. (.yourdomain.com)

d. To prevent scripting languages such as JavaScript from gaining access to cookies,
set Use HTTP Only to “Yes.”

e. Set Cookie Restriction Mode to “Yes.”

Step 2: Edit the Cookie Restriction Message

1. On the Admin menu, select CMS > Static Blocks.

2. Find the Cookie Restriction Notice, and click to open the block. Then, do the following:
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Editing the Cookie Restriction Notice

a. Select each Store View where the notice should appear.

b. Set Status to “Enabled.”

c. In the Content box, edit the message as needed.

3. When complete, click the Save Block button.

Step 3: Update Your Privacy Policy

1. On the Admin menu, select CMS > Pages > Manage Content.

2. Find your Privacy Policy in the list, and click to open the page.

3. In the panel on the left, click Content. If necessary, click the Show/Hide Editor button
to work in WYSIWYG mode.

Privacy Policy
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4. Update your privacy policy to describe the information that your company collects, and
how it is used. You can include the information from the tables at the end of this topic.

5. When complete, click the Save Page button.

Field Descriptions
Field Description

Cookie Lifetime Determines when the browser can delete Magento cookies.
The default value is 3600, which means that cookies remain in
the browser for one hour.To ensure that cookies expire at the
end of a browser session, set the lifetime to zero.

Cookie Path Allows you to make Magento cookies available other folders.
If you want to make cookies available anywhere in a site, you
should set this value to a single forward slash.

Cookie Domain Determines if cookies are visible to subdomains. (http://sub-
domain.domain.com) To ensure that your coookies are avail-
abl to all subdomains, enter your domain name with a prefix
of a period. (.domain.com)

USE HTTP Only Makes the cookie available only through HTTP protocol, and
unavailable to JavaScript or other scripting languages.

Magento Standard Cookie
Cookie Name Cookie Description

USER_ALLOWED_SAVE_
COOKIE

Indicates if a customer is allowed to use cookies.

external_no_cache A flag that indicates if caching is disabled.

persistent_shopping_cart The session key.

Stf If product links were sent to friends, stores the timestamps in
the format: $timeStamp1, $timestamp2, ..., $timestampN

pollN A poll ID that indicates if a vote has occurred.

frontend Session ID

guest-view Allows guests to edit their orders.

Google Analytics Cookies

If Google Analytics is enabled and using cookies is allowed by a customer, Magento
saves the following Google Analytics cookies. For more information, see Google’s cookie
usage documentation.

https://developers.google.com/analytics/devguides/collection/analyticsjs/cookie-usage
https://developers.google.com/analytics/devguides/collection/analyticsjs/cookie-usage
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Cookie Description

_utma Distinguishes users and sessions.

_utmb Determines new sessions/visits.

_utmc Determines if the user was in a new session/visit.

_utmz Stores the traffic source or campaign that explains how the
user reached your site.
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Chapter 9:

Navigation by Category
The term, navigation refers to the methods shoppers use to move from page to page
throughout your store. The main menu, or top navigation of your store is actually a
list of category links. The category structure of your catalog is the main way people
find products in your catalog. You will also find categories in the breadcrumb trail
that runs across the top of most pages, and in the “layered navigation” that appears
on the left side of some two- or three-column pages. These are all examples of how
categories can be used to navigate throughout your store.

For a product to be visible in your store, it must be assigned to at least one category.
Each category can have a dedicated landing page with an image, static block, a
description, and list of products. You can also create special designs for category
pages that become active for a specific period of time such as for a holiday season or
promotion.

Categories in Main Menu
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Top Navigation
The main menu of your store displays the selection of categories that are available in
your catalog. You can think of the top navigation as different departments in your store.
A top-level category serves as landing page for all the subcategories below. The position
and presentation of the top navigation might vary by theme, but the way it works is the
same.

Top Navigation

The first level of categories below the root typically appear as options in the main menu.
Below that, you can have as many additional subcategories as needed. The category
structure of your catalog can influence how well your site is indexed by search engines.
The deeper a category, the less likely it is to be thoroughly indexed. As a general rule,
anywhere between one and three levels is considered to be the best. You can set the
maximum number of levels that are available in your top navigation in the system
configuration.

To set the depth of the top navigation:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Category Top Navigation section.

Category Top Navigation

4. In theMaximal Depth field, enter the number of subcategory levels you want to make
available for the top navigation.

5. When complete, click the Save Config button.
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Breadcrumb Trail
A breadcrumb trail is a set of links that shows where you are in relation to other pages in
the store. You can click any link in the breadcrumb trail to return to a previous page.
Here’s an example of a breadcrumb trail from the Magento Demo Store:

HOME/ACCESSORIES/JEWELRY/PEARL STUD EARRINGS

The breadcrumb trail can be configured to appear on CMS content pages, as well as
catalog pages. The format and position of the breadcrumb trail varies by theme, but it is
usually located in the upper-left, just below the header.

Breadcrumb Trail

To add breadcrumbs to CMS pages:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under General, select Web. Then, do the following:

a. Click to expand the Default Pages section.

b. Set Show Breadcrumbs for CMS Pages to “Yes.”

3. When complete, click the Save Config button.

Show Breadcrumbs for CMS Pages
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Layered Navigation
Layered navigation makes it easy to find products based on category, price range, or any
other available attribute. Layered navigation usually appears in the left column of search
results and category pages and sometimes on the home page. The standard layered
navigation includes a “Shop By” list of categories and price range. You can configure the
way layered navigation appears in your store, including the product count and price
range.

Layered Navigation by Category and Price

To set up layered navigation:

1. On the Admin menu, select System Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Layered Navigation section. Then, do the following:

Configure Layered Navigation

a. To display the results after each attribute, set Display Product Count to “Yes.”

b. Set Price Navigation Step Calculation to one of the following:
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l Automatic

l Manual

c. For a manual calculation, enter a number in the Default Price Navigation Step field
to determine how the price ranges are grouped. For example, if you enter 100, the
prices will appear in groups of 100.

Manual Price Navigtion Step

Filterable Attributes
Layered navigation can be used to search for products by category or by attribute. For
example, when a shopper chooses the Apparel/Shoes category from the top navigation,
the initial results include all products in the shoes category. The list can be filtered
further by choosing a specific color or size, or both color and size.

Filterable Attributes In Layered Navigation

Step 1: Set the Attribute Properties

For an attribute to be included in layered navigation, its property settings must be set to
make it filterable.
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1. On the Admin menu, select Catalog > Attributes > Manage Attributes.

2. Click to open the attribute in edit mode, and do the following:

a. Scroll down to the Frontend Properties section, and set Use In Layered Navigation
to one of the following:

l Filterable (with results)

l Filterable (no results)

b. Set Use In Search Results Layered Navigation to “Yes.”

Step 2: Make the Category an Anchor

1. On the Admin menu, select Catalog > Manage Categories.

2. In the Categories panel on the left, click to open the category.

3. On the Display Settings tab, set Is Anchor to “Yes.”

4. Click the Save Category button.

To test the setting, go to your store and select the category in the top navigation. The
selection of filterable attributes for the products in the category appears in the layered
navigation.

Price Navigation
Price navigation can be used to distribute products by price range in layered navigation.
You can also split each range in intervals. There are ways to calculate price navigation:

l Automatic (Equalize Price Ranges)

l Automatic (Equalize Product Counts)

l Manual

With the first two methods, the navigation steps are calculated automatically. The
manual method lets you specify a division limit for price intervals. The following
example shows the difference between price navigation steps of 10 and 100.
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Price Navigation Steps of 10 and 100

Iterative Splitting

Iterative splitting provides the best distribution of products among price ranges. With
iterative splitting, after a customer chooses to view the $0.00-$99 range, the customer
can drill-down through several sub-ranges of prices. Price-range splitting stops when the
number of products reaches the threshold set by the Interval Division Limit.

To configure price layered navigation:

1. On the Admin menu, select System > Configuration. Then in the panel on the left,
under Catalog, select Catalog.

2. In the upper-left corner, set Current Configuration Scope to the store view to be
configured.

3. Click to expand the Layered Navigation section.

4. If you want to display the number of products in parentheses after each filtered item, set
Display Product Count to “Yes.”

5. Set Price Navigation Steps Calculation to one of the following methods:

Method 1: Automatic (Equalize Price Ranges)

Set Price Navigation Steps Calculation to “Automatic (Equalize Price Ranges.)” This
setting uses the existing price layered navigation algorithm, and is similar to the
Automatic option in earlier versions of Magento.

Layered Navigation
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Method 2: Automatic (Equalize Product Counts)

a. Set Price Navigation Steps Calculation to “Automatic (Equalize Price Ranges).”

b. Set Display Price Interval as One Price to “Yes” if you want to display a single price
when multiple products with the same price.

c. In the Interval Division Limit field, enter the threshold for a number of products
within a price range. The range cannot be further split beyond this limit., The
default value is 9.

Automatic (Equalize Product Counts)

Method 3: Manual

a. Set Price Navigaton Steps Calculation to “Manual.”

b. Enter a value to determine the Default Price Navigation Step.

c. Enter theMaximum Number of Price Intervals allowed, up to 100.

Manual

6. When complete, click the Save Config button.

Creating Categories
Every product in your catalog must be assigned to at least one category. Before you add
products to your catalog, you must first establish the basic category structure of your
catalog. The number of subcategory levels that you can have in the top navigation is set
in the system configuration.
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Category Structure

When working in the Admin, the category structure is like an upside-down tree, with the
root at the top. Each section of the tree can be expanded and collapsed. Any disabled or
hidden categories are grayed out.

Category Tree

Step 1: Create a Category

1. On the Admin menu, select Catalog > Manage Categories.

2. Before you begin, set Choose Store View to the store or view. By default, the scope of the
category configuration is set to “All Store Views.”

3. In the category tree, click the category that is to be the parent of the new category. The
parent is the level just above the new category.

If you’re starting from the beginning without any data, there might be only two
categories in the list: “Default Category,” which is the root, and an “Example Category.”
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4. Click the Add Subcategory button.

Step 2: Complete the General Information

1. In the General Information section, do the following:

a. (Required) Type the Name of the category.

b. (Required) To enable the category, set Is Active to “Yes.”

c. You can enter a URL Key for the category, or let the system automatically create one
that is based on the category name.

2. If supported by your theme, you can display a Thumbnail image in the main menu for
each category. Click the Choose File button and select the image to upload.

3. In the Description box, enter a paragraph or two of descriptive text for the category
landing page.

4. To display an Image at the top of the category landing page, click the Choose File
button and select the image to upload.

5. Complete the category meta data:

l Page Title

l Meta Keywords

l Meta Description

6. (Required) To include the category in the main menu, set Include in Navigation Menu
to “Yes.”

7. Click the Save Category button. Then, take note of the following:

l The new category now appears in the tree. If it’s not in the correct position, you can
drag it to another location in the tree.

l In addition to the category name, it has an ID number shown in parentheses, just
after the name at the top of the page.

l A URL Key that is based on the category name can be automatically generated for the
category.

Category URL Key

Step 3: Complete the Display Settings

You can configure the category landing page to display both a static block and product
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list, or one or the other. A static block can provide additional information, including
text, images, and even embedded video.

Display Settings

1. On the Display Settings tab, do the following:

a. Set Display Mode to one of the following:

l Products Only

l Static Block Only

l Static Block and Products

b. If applicable, set CMS Block to the static block that you want to appear on the
category page.

c. If you want this category page to display the “Filter by Attribute” section of layered
navigation, set Is Anchor to “Yes.”

d. Clear the checkbox under Default Product Listing Sort By. Then select one of the
available values to sort the list. By default, all available attributes are listed. The
default values typically include:

l Best Value

l Name

l Price

2. When complete, click the Save Category button.

Modifying Categories
After a category is established, it can be edited, moved to another position in the
category tree, or deleted from the catalog. However, if your catalog is live, you should
consider how the change might impact any existing links to products in the category.
For example, if your product URLs include the category path, and the category name is
changed, any existing links to products in the category will be broken. To avoid this
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problem, you can configure your catalog to automatically create a permanent redirect if
the URL key changes. You can also use the URL Rewrite tool to redirect traffic from an
old URL to a new one.

To move a category:

1. On the Admin menu, select Catalog > Manage Categories.

2. To move a category, simply drag-and-drop it to a new location. Category order changes
are saved automatically.

To delete a category:

1. On the Admin menu, select Catalog > Manage Categories.

2. Click to select the category you want to delete.

A deleted category cannot be restored, so make sure that you have selected the correct
category before proceeding.

3. Click the Delete Category button to save your changes.

Root Categories
The catalog structure is like an upside-down tree, with the root on top. All categories in
your catalog are nested below the root. Because the root category is the highest level of
the catalog, your store can have only one root category active at a time. You can,
however, create additional root categories for alternate catalog structures, different
stores, and views. The root category is not visible to customers in the store, and does not
have a URL key.

Root Categories
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Step 1: Create a New Root Category

1. On the Admin menu, select Catalog > Manage Categories.

2. In the upper-left of the Manage Categories page, click the Add Root Category button.
Then, complete the following required fields:

a. Enter a Name for the root category.

b. Set Is Active to “Yes.”

c. If you want this root category to be in the main menu, set Include in Navigation
Menu to “Yes.”

3. Complete the remaining optional fields as needed:

a. Click the Choose File to upload a Thumbnail Image for the root category.

b. Enter a Description of the root category.

c. Click the Choose File button to upload an Image to the root category.

d. Complete the following meta data:

l Page Title

l Meta Keywords

l Meta Description

4. Click the Display Settings tab. Then, set Is Anchor to “Yes.”

5. When complete, click the Save Category button.

Step 2: Add Subcategories to the New Root

1. From the Categories page, click the General tab.

2. In the category tree on the left, click to select the new root category you created in the
last step.

3. Click the Add Subcategory button.

4. Give the subcategory a Name, and set Is Active to “Yes.”

5. Click the Save Category button.

6. Repeat this process to create as many subcategories as you need.
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Step 3: Apply the New Root Category to Your Store

1. On the Admin menu, select System > Manage Stores.

2. On the Manage Stores page, under Store Name, click theMain Store link.

3. Change Root Category to the new root category.

4. Click the Save Store button.

Hidden Categories
There are many ways to use hidden categories. You might want to create additional
category levels for your own internal purposes, but show only the higher-level categories
to your customers. Or, you might want to link to a category that is not included in the
navigation menu.

To create hidden categories:

1. On the Admin menu, select Catalog > Manage Categories.

2. In the Categories panel on the left, select the category you want to exclude from the
navigation.

3. On the General Information tab, do the following:

a. Set Is Active to “No.”

b. Set Include in Navigation Menu to “No.”

4. On the Display Settings tab, set Is Anchor to “No.”

5. Although the category is hidden, you can still create additional subcategories beneath it,
and make them active. Complete the following settings for each hidden subcategory:

a. On the General Information tab, set Is Active to “Yes.”

b. On the Display Settings tab, set Is Anchor to “Yes.”

As active categories, you can now link to them from other places in your store, but they
will not appear in the navigation menu.

6. When complete, click the Save Category button.
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General Information
On the General Information tab, complete the basic information about the category you
are creating or editing. You can enter keywords to improve the way the category is
indexed by search engines, create a URL key for the category, and activate or deactivate
the category.

General Information

Field Descriptions
Field Description

Name (Required) The category name appears in the navigation, and
also in the URL key of the category page and associated
product pages.

Is Active (Required) To make this category available, select “Yes.”
Options include: Yes / No

URL Key The URL Key is a relative path to the category, and is auto-
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Field Description

matically generated when the category is saved. The URL Key
must be all lower-case characters, with no spaces. As a best
practice, each word is separated by a hyphen. If you edit the
default URL key, a custom redirect is created automatically. A
root category does not have a URL key.

Thumbnail Image If supported by your theme, a thumbnail image can be asso-
ciated with each category and appear as part of the option in
the main menu of the store.

Description The category description, if used, appears below the category
image- and before the product list.

Image The category image, if used, appears at the top of the category
page, before the description and product list.
As an alternative, you can display a CMS static block in place of
the description and image. (See Category Display Settings.)

Page Title The category page title appears in the browser tab and title
bar. As a best practice, the title should be not more than
twelve words in length, and should include a combination of
primary and secondary keywords.

Meta Keywords Keywords are used by some search engines, and not by
others. You can use a keyword search tool to identify high
value keywords that relate to your category. A general rule is
to use no more than thirty keywords, or 180 characters. Avoid
repeats, and empty words such as “a,” “an,” “or” and “that.”

Meta Description Enter a description of the category, using approximately
twenty-five words or 150 characters.

Include in Navigation
Menu

(Required) Determines if the category is included in the main
menu. Options include:

Yes Include this category in the top navigation, select
“Yes.”

No Hides the category, although it is active.Hidden cat-
egories do not appear in the top navigation, but
are included in layered navigation.

Display Settings
The Display Settings determine which content elements appear on a category page and
the order that products are listed. You can enable CMS blocks, set the anchor status of
the category, and manage sorting options from this page.
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Display Settings

Field Descriptions
Field Scope Description

Display Mode Store View Determines the content elements displayed on
the category page. Options include:
Products Only
Static Block Only
Static Block and Products

CMS Block Store View To display a CMS static block at the top of the cat-
egory page, select the name of the block from
the list.

Is Anchor Global When set to “Yes,” includes the “filter by attrib-
ute” section in the layered navigation. Options
include: Yes / No

Available Product Listing
Sort By

Store View (Required) The default values are set to set to
Value, Name, and Price. To customize the
sorting option, clear the Use All Available Attrib-
utes checkbox and select the attributes you
want to use. You can define and add attributes
as needed.

Default Product Listing
Sort By

Store View (Required) To define the default “Sort By” option,
clear the “Use Config Settings” checkbox and
select an attribute.

Layered Navigation Price
Step

By default, Magento displays the price range in
increments of 10, 100, and 1000, depending on
the products in the list. To change the Price Step
range, clear the “Use Config Settings” checkbox.
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Custom Design
The Custom Design tab gives you control over the look and feel of a category and all
assigned product pages, including the content blocks and page layout.

You can customize a category page its assigned products for a promotion or to
differentiate the category from others and increase sales. For example, you might
develop distinctive design for a brand or special line of products.

Custom Design

To create a custom category design:

1. If the parent category of the selected category has already been customized and you want
to use same settings, set Use Parent Category Settings to “Yes.”

2. To apply the custom design to all the products assigned to the category, set Apply to
Products to “Yes.” Otherwise, the customization applies to only the category page.

3. To apply a different theme to the category, select the theme you want to use from the
Custom Theme list.

4. To apply the category design to a specific range of time, click the calendar to select
both the Active From and Active To dates. Otherwise, the design will take effect when
you save the changes to the category.

5. Click the Save Category button to save your changes.

Field Descriptions
Field Scope Description

Use Parent Category Set-
tings

Store View To inherit the design settings from the parent
category set this option to “Yes.” Options
include: Yes / No

Apply to Products Store View To apply the custom settings to all products in
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Field Scope Description

the category, set to “Yes.” Options
include: Yes / No

Custom Theme Store View Select the custom theme you want to apply from
the list of available themes.

Active From Store View If applying a custom theme for a period of time,
enter the beginning date, or select the date from
the calendar.

Active To Store View If applying a custom theme for a period of time,
enter the ending date, or select the date from
the calendar.

Page Layout Store View To apply a different layout to the category page,
select one of the following:

No layout
updates

This option is pre-selected by
default and does not apply
layout changes to the category
page.

Empty This option lets you define your
own page layout.(Requires an
understanding of XML.)

1 column Applies a one-column layout to
the category page.

2 columns
with left bar

Applies a two-column layout
with a left sidebar to the cat-
egory page.

2 columns
with right
bar

Applies a two-column layout
with a right sidebar to the cat-
egory page.

3 columns Applies a three-column layout
to the category page.

Custom Layout Update Store View You can further customize the theme by making
layout updates in XML code.

Category Products
The Category Products tab lists the products that are currently assigned to the category.
From the list, you can easily add and remove products from the category.
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Category Products

To assign products to a category:

1. From the category record, click the Category Products tab. Then, do the following:

a. Use the filters and checkbox control to find the products you want to assign:

l To display all products currently assigned to the category, set the checkbox
control to “Yes.”

l To display all products that are not assigned to the category, set the checkbox
control to “No.”

l To display all products, set the checkbox control to “Any.”

b. Press the Search button.

c. To list all products again, click the Reset Filter button.

2. Select the checkbox of each product you want to assign to the category.

3. When complete, click the Save Category button.
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Chapter 10:

Managing Attributes
Attributes are the building blocks of your product catalog, and describe specific
characteristics of a product. Here are a few ways you can use attributes to enhance
the shopping experience:

l Input controls for product options

l Provide additional information on product pages

l Search parameters

l In product comparison reports

l As layered navigation “Shop By” parameters

l In catalog and shopping cart price rules

Each attribute contains a value that describes a characteristic of a product, such as
“color” or “fabric.” The “color” attribute with the “dropdown” input type might
contain many values, although only a few apply to any given product. Because a
single attribute can be used with multiple products, your store needs to have only
one attribute for color.

You can create as many attributes as you need, and assign the most common value
as the default, to make it easy for your customers to select the option.

The attributes that make up a product are combined into an attribute set, which is
used as template to create new products. The attribute set determines which fields
are included in a product, and how they are grouped in the Product Information
panel. Magento has a default attribute set with a standard selection of product
attributes such as Name, Price, Description, and so on. If you want to keep it
simple, you can use the default attribute set for your entire catalog.
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Attribute Input Types
When viewed from the Admin, attributes are the fields that you complete when you
create a product. The input type that is assigned to an attribute determines the type of
data that can be entered and the format of the field or input control.

From the standpoint of the customer, attributes provide information about the product,
and are the options and data entry fields that must be completed to purchase a product.

Property Description

Text Field A single line input field for text.

Text Area A multiple-line input field for entering paragraphs of text such
as a product description. You can use the WYSIWYG Editor to
format the text with HTML tags, or type the tags directly into
the text.

Date Fields used for entering date values are followed by an icon
that displays either a calendar or list of dates when clicked.
Depending on your system configuration,a date can be typed
directly into the field, or selected from the calendar or list.

Yes/No Displays a drop-down list with pre-defined options of “Yes”
and “No.”

Dropdown Displays a drop-down list of values. Only one item can be
selected at a time. The Dropdown input type is a key com-
ponent of configurable products.

Multiple Select Displays a drop-down list of values. To select more than one
option, hold the Ctrl key down and click each item.

Price This input type is used to create price fields that are in addi-
tion to the predefined attributes, Price, Special Price, Tier Price
and Cost. The currency used is determined by your system
configuration.

Media Image Gives you the ability to associate an image with a product, that
is something other than a product image. For example, you
might include the product logo, care instructions, or an image
of the ingredients from a food label. When you add a media
image attribute to the attribute set of a product, it becomes an
additional image type, along with Base, Small, and Thumbnail.
The media image attribute can be excluded from the thumb-
nail gallery, but is still available to be used.

Fixed Product Tax Lets you define FPT rates based on the requirements of your
locale. To learn more, see: General Tax Settings.
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Creating Attributes
The properties of an attribute determine how it can be used in your catalog and how it
appears throughout your store. In addition to the basic properties, there are additional
properties for drop-down and multiple-select input types, their values, and associated
labels. The title, or label, identifies the attribute in the Admin and your storefront. If
your store is available in multiple languages, you can enter a different translated label
for each language.

Attributes can be created using the Manage Attributes tool, and also from inside a
product record.

Manage Attributes

Step 1: Define the Attribute Properties

1. On the Admin menu, select Catalog > Attributes > Manage Attributes. Then, click the
Add New Attribute button.

2. In the Attribute Properties section, complete the following required (*) properties:

a. Enter a unique Attribute Code to identify the attribute internally. The code should
be all lowercase characters without spaces.

b. In the Apply To list, choose each product type that is associated with the attribute.
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Attribute Properties

3. Complete the remaining Attribute Properties as needed.

a. Set Scope to the indicate where the attribute can be used.

b. Set Catalog Input Type for Store Owner to the type of input control used by the
store administrator during data entry.

c. If you want to prevent duplicate values from being entered in this field, set Unique
Value to “Yes.”

d. To require that a value must be entered in the field before the record can be saved,
set Values Required to “Yes.”

e. To run a validity test of data entered into the field, set Input Validation for Store
Owner to the type of data the attribute should contain.

4. In the Frontend Properties section, complete as many of the settings as needed.

Frontend Properties
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Step 2: Define the Label and Values

1. In the Attribute Information panel on the left, select Manage Label / Options. Then, do
the following:

a. In the Manage Titles section, under Admin, enter a descriptive label to identify the
field during data entry.

b. The next column determines how the label appears in your storefront. You can leave
the box blank to use the Admin label as the default.

c. If your store is available in multiple languages, enter a translated label into each
box, as needed.

2. For drop-down or multiple-select input types, do the following:

a. In the Manage Options section, click the Add Option button.

b. In the new row, under Admin, type the value you want to use in your store's Admin.

c. Enter the value you want your customers to see. (Leave blank to use the Admin
value as the default.)

d. If applicable, enter a translated value for each language supported.

e. Enter a number to determine the Position of this value in relation to other options
in the list.

f. Select Is Default to automatically select this value.

g. Repeat these steps for each value you want to add to the list.

Manage Label / Options for Dropdown Input Type

3. When complete, click the Save Attribute button.

The attribute appears in the Manage Attributes list, sorted in alphabetical order by
Attribute Code. Use the Page controls to view each page of the list.
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Deleting Attributes
If you created sample data while setting up your store, it is possible that you now have
some attributes that aren’t needed for your catalog.

When an attribute is deleted, it is removed from any related products and attribute sets.
System attributes are part of the core functionality of your store and cannot be deleted.

To delete an attribute:

1. On the Admin menu, select Catalog > Attributes > Manage Attributes.

2. In the list, find the attribute and click to open the record.

3. Click the Delete Attribute button.

4. When prompted to confirm, click OK.

Creating an Attribute Set
One of the first steps when creating a product is to choose the attribute set that is used
as a template for the product record. The attribute set determines the fields that are
available during data entry, and the values that appear to the customer.

Manage Attribute Sets

Your store comes with an initial attribute set called “default” which contains a set of
commonly-used attributes. If you would like to add only a small number of attributes,
you can add them to the default attribute set. However, if you sell products that require
specific types of information, such as cameras, it might be better to create a dedicated
attribute set that includes the special attributes (fields) needed to describe the product.

A single attribute can be used by as many different attribute sets as is necessary. For
example, the attribute “color” can be included in an attribute set for clothing, paint, or
for any number of different products.
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To create an attribute set:

1. On the Admin menu, select Catalog > Attributes> Manage Attribute Sets.

2. Click the Add New Set button. Then, do the following:

Edit Set Name

a. Enter a Name for the attribute set.

b. In the Based On field, select another attribute set from which this attribute set is to
inherit attributes. This option enables you to reuse the attributes already defined in
a set to build other attribute sets. The simple option is to leave the Default option
that appears in this field.

3. Click the Save Attribute Set button. The next page displays the following:

l The top left of the page shows the name of the attribute set defined earlier. You have
the option to edit the name because this value is for internal use.

l The center of the page shows a hierarchical tree representing Groups for attributes.

l The right side of the page shows a list of defined attributes that are not assigned to
this attribute set.

4. Select the attribute to be assigned to this Group by dragging them from the Unassigned
Attributes area on the right into the relevant Group in the middle of the page.

5. When the attribute set is complete, click the Save Attribute Set button.

Edit Attribute Set
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System Attributes are marked with a dot and cannot be removed from the Groups list.
However, you can drag them to another Group in the attribute set.

To create a new attribute group:

1. In the Groups section of the attribute set, click the Add New button.

2. Enter a Name for the new group, and click OK.

3. Do either of the following:

l Drag Unassigned Attributes to the new group.

l Drag attributes from any other group to the new group.

The new group becomes a section in the Product Information panel for any product that
is based on this attribute set.

Attribute Quick Reference

Product Type Properties
Property Description

Apply To Identifies the product types that can use the attribute. Visibility
must be set to include the catalog.

Use to Create Con-
figurable Product

Identifies the attribute one that will be used to create a drop-
down list of options for a configurable product.

Data Entry Properties
Property Description

Default Value Displays a common entry as a starting value.

Unique Value Prevents duplicate values from being entered.

Values Required Requires a value to be entered before the record can be
saved.

Input Validation Performs a validation check of the data, based on data type,
or format.

Search and Navigation Properties
Property Description

Use in Quick Search Lets customers use the Search box to find items based on the
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Property Description

Use in Advanced Search Includes the attribute as a field on the Advanced Search form.

Use in Layered Nav-
igation

Includes the attribute in the layered navigation that is dis-
played for category lists.

Use in Search Results
Layered Navigation

Includes the attribute in the layered navigation that is dis-
played for search results lists.

Position Determines the position of the attribute when listed with
others in the layered navigation list.

Use in Product Listing (Depending on theme) Includes the attribute in the product
listing.

Use for Sorting in
Product Listing

(Depending on theme) Includes this attribute as an option in
the Sort By list, which can be used to sort a product list.

Rules and Comparison Properties
Property Description

Comparable on Front-
end

Includes the attribute in the Compare Products report.

Use for Promo Rule
Conditions

Allows the attribute to be used as the basis of a condition that
triggers a promotional Price Rule or Shopping Cart rule.

Presentation Properties
Property Description

Visible on Product View
Page

Includes the attribute on the Additional Information tab of the
product view page.

Allow HTML Tags on
Frontend

Permits text fields and areas to be manually tagged with
HTML.

Enable WYSIWYG Editor Makes the WYSIWYG Editor available for tagging a text field or
text area with HTML.
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Attribute Properties
The Attribute Properties define the individual characteristics that determine how an
attribute can be used in the product catalog.

Attribute Properties

Property Descriptions
Property Description

Attribute Code (Required) A unique identifier for internal use. The Attribute
Code must begin with a letter, but can include a combination
of lowercase letters (a-z) and numbers (0-9).The code must be
less than thirty characters in length and cannot include any
special characters or spaces, although an underscore (_) can
be used to indicate a space.

Scope Limits the use of an attribute to a specific store view or
website. Options include:
Store View
Website
Global

Catalog Input Type for
Store Owner

Determines the data type and input control that is used to
manage the product from the store Admin. Options include:

Text Field A single line input field for text.

Text Area A multiple-line input field that can display
paragraphs of text formatted with HTML.

Date An input field for date values. The date
can be typed directly into the field, or
selected from a list or calendar.

Yes/No A drop-down list with pre-defined
options of “Yes” and “No.”

Dropdown A drop-down list of configurable options,
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Property Description

from which only one can be selected.

Multiple Select Displays a drop-down list of configurable
options. To select more than one option,
hold down the Ctrl key and click each
item.

Price An input type that can be used to create
price fields in addition to the predefined
attributes: Price, Special Price, Tier Price
and Cost.

Media Image An additional image that can be included
in the attribute set of a product.

Fixed Product
Tax

An input type that gives you the ability to
define FPT rates based on the require-
ments of your locale.

Default Value Assigns a starting value to the attribute to help during data
entry. To assign a default value for Multiple Select or Drop-
down input types, see: Creating Attributes.

A default value cannot be set for Multiple Select,
Dropdown, or Fixed Product Tax input types.

Unique Value To prevent duplicate values in a data entry field, set Unique
Value to “Yes.” Options include: Yes / No

Values Required To require that a value to be entered in this field before the
record can be saved, set Values Required to “Yes.” Options
include: Yes / No

Input Validation for Store
Owner

Performs a validation check of the data entered in the field,
based on the following options:
None
Decimal Number
Integer Number
Email
URL
Letters
Letters (a-z, A-Z) or Numbers (0-9)

Apply To (Required) Identifies the product types to which this attribute
applies. Options include:
All Product Types
Selected Product Types
Simple Product
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Property Description

Grouped Product
Configurable Product
Virtual Product
Bundle Product

Use to Create Con-
figurable Product

(Dropdown input type only) Select “Yes” if this attribute will be
used to create a drop-down list for a configurable product.
Options include: Yes / No
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Attribute Frontend Properties
The Frontend Properties determine how an attribute can be used in your store. You can
specify how attributes are used in search, layered navigation, product comparisons, price
rules, and sorting. For text attributes, you can enable the WYSIWYG editor and specify if
HTML tags can be used to format the value.

Frontend Properties

Property Descriptions
Property Description

Use in Quick Search Select “Yes” if you want people to be able to search the catalog
based on the value of this attribute. Options include: Yes / No

Use in Advanced Search Gives shoppers the ability to enter their search criteria
through a form. Options include: Yes / No

Using too many attributes can slow down search.

Comparable on Front-
end

Select “Yes” to include this attribute as a row in the Compare
Products report. Options include: Yes / No

Use In Layered Nav-
igation

(Dropdown, Multiple Select and Price input types only)
Includes the attribute as a filter in the “Shop By” section of
layered navigation. Options include:

No The attribute is not used in layered nav-
igation.

Filterable (with
results)

Lists only products that match the filter
value.
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Property Description

Filterable (no
results)

Lists all attribute values, even those that
do not apply to any product in the list.
Layered navigation appears on a cat-
egory page only if there are filterable
attributes available.

Use In Search Results
Layered Navigation

To include the attribute in the layered navigation for search
results, select “Yes.” Options include: Yes / No

Use for Promo Rule
Conditions

To make the attribute available for use in price rules, select
“Yes.” Options include: Yes / No

Position Determines the position of the attribute in layered navigation
in relation to other filterable attributes.

Enable WYSIWYG (Text Area input type only) To display the editor when entering
or editing the attribute value, select “Yes.” The editor can be
used to format field descriptions with HTML tags. Options
include: Yes / No

Allow HTML Tags on
Frontend

(Text Field and Text Area input types only) To be able to
format the attribute value with HTML tags, select “Yes.”
Options include: Yes / No

Visible on Product View
Page on Front-end

(Simple and virtual products only) To include the attribute on
the Additional Information tab of the product page, select
“Yes.” Options include: Yes / No

Used in Product Listing Depends on the theme. To include the attribute in product
summaries that appear in catalog listings, select “Yes.”

Used for Sorting in
Product Listing

(Depends on theme)
To include this attribute as a “Sort By” option for catalog list-
ings, select “Yes.“ 
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Chapter 11:

Flat Catalog
Magento uses the Entity-Attribute-Value (EAV) model for storing customer, product,
and category data in its database. Although the EAV model enables you to have
completely extensible attributes for those objects, object attributes are stored in
multiple tables rather than one very large table.

Because attributes are stored in many tables—and that includes copies of some of
the same attributes—SQL queries can be long and complex. The flat catalog feature
creates new tables on the fly, where each row contains all necessary data about a
product or category.

In earlier versions of Magento, it was necessary to rebuild the flat catalog every time
you made changes to product attributes or product-category associations. In this
release, the flat catalog is updated for you—either every minute, or according to your
Magento cron job.

Flat catalog options not only enable the flat catalog and flat product indexers but
also enable indexing for catalog and shopping cart price rules. If you have a large
number of SKUs (500,000 or more), Magento can index catalog and shopping cart
price rules quickly if you enable the flat catalog product option.
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Flat Catalog Configuration
It is recommended that you first test flat catalog in a development environment before
enabling it for a live store.

Step 1: Enable Flat Catalog

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Frontend section. Then, do the following:

Use Flat Catalog

a. Set Use Flat Catalog Category to “Yes.”

b. Set Use Flat Catalog Product to “Yes.”

4. When complete, click the Save Config button.

5. When prompted to refresh the indexes, click the Index Management link in the message
at the top of the workspace and follow the instructions to reindex the data.
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Reindex Required

Step 2: Verify the Results

Method 1: Verify the Results for a Single Product

1. Open one browser tab to the store Admin, and log in as an administrator.

2. On a second browser tab, navigate to your store’s home page.

3. On the Admin menu, select Catalog > Manage Products. Then, do the following:

a. Choose a product to modify. Then, click to open the product in edit mode.

b. On the General tab, in the Name field, add the text “_DEMO” to the product name.

4. Click the Save button.

5. In your store, search for the product you edited, and browse to its assigned category.

If necessary, refresh the page to see the result of the change you made. The change
occurs either within the minute or according to your cron job schedule.

Method 2: Verify the Results for Multiple Products

1. On a second browser tab, navigate to your store’s home page.

2. On the Admin menu, select Catalog > Categories > Manage Categories.

3. In the upper-left corner, set Current Configuration Scope to one of the following:

l All Store Views

l A specific store view

4. In the panel on the left, select an existing category. Click the Add Subcategory button,
and do the following:
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a. In the Name field, enter “Test Category.”

b. Set Is Active to “Yes.”

c. Click the Save Category button.

New Subcategory

d. Click the Category Products tab. Then, click the Reset Filter button to display all
products.

e. Select the checkbox of several products to add them to the new category. Then, click
the Save Category button.

Category Products

5. In your store, search for or brows to the category you created.

If necessary, refresh the page to see the result of the change you made. The change
occurs either within the minute or according to your cron job schedule.
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Chapter 12:

Creating Products
Choosing a product type is one of the first things you must do to create a new
product. In this chapter, you will learn how to create a product of each type. To
learn more about all the available options, see Product Information.

If you are just starting out, you can create a few sample products, and experiment
with each type. Before you build your actual catalog, make sure to read Navigation
by Category and Catalog URL Options. This material will give you a good
understanding of the relationship between your store navigation and the categories
in your catalog, and how you can help search engines to bring a steady stream of
shoppers to your store.

Products in Catalog
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Product Types

Simple Product

A simple product is a physical item with
a single SKU. Simple products have a
variety of pricing and of input controls
which makes it possible to sell
variations of the product. Simple
products can be used in association with
grouped, bundle, and configurable
products.

Grouped Product

A grouped product presents multiple,
standalone products as a group. You can

offer variations of a single product, or
group them for a promotion. The

products can be purchased separately, or
as a group.

Configurable Product

A configurable product appears to be a
single product with lists of options for
each variation. However, each option
represents a separate, simple product
with a distinct SKU, which makes it
possible to track inventory for each
variation.
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Virtual Product

Virtual products do not have a physical
presence, and are typically used for such

things as services, warranties, and
subscriptions. Virtual products can be
used in association with grouped and

bundle products.

Bundle Product

A bundle product let customers “build
their own” from an assortment of
options. The bundle could be a gift
basket, computer, or anything else that
can be customized. Each item in the
bundle is a separate, standalone
product.

Downloadable

A digitally downloadable product that
consists of one or more files that are

downloaded. The files can reside on your
server or be provided as URLs to any

other server.
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Simple Product
One of the keys to harnessing the power of product types is learning how and when to
use a simple, standalone product. Simple products can be sold individually, or as part of
a grouped, configurable, or bundle product. A simple product with custom options is
sometimes referred to as a composite product.

Simple Product

The following instructions take you through the process of creating a simple product
with the basic fields. Each required field is marked in the Admin with a red asterisk (*).
After you complete the required settings and save the product, you can add images and
complete the remaining product information as needed.

Process Overview:
Step 1: Choose the Attribute Set
Step 2: Complete the Basic Information
Step 3: Complete the Remaining Product Information

Step 1: Choose the Attribute Set

The first step is to choose the attribute set, which is used as a template for the product
record. The product in this example is based on the Default attribute set, which includes
a standard of set of fields that can be used for most products.

1. On the Admin menu, go to Catalog > Manage Products.

2. In the upper-right corner of the Manage Products page, click the Add Product button.
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3. In the Create Product Settings section, do the following:

a. Accept the “default” Attribute Set, or select another.

b. Set Product Type to “Simple,” and click the Continue button.

Create Product Settings

Step 2: Complete the Basic Information

The basic set of required fields must be completed before the product record can be
saved. The Product Information panel groups related fields by topic and the required
fields are marked with a red asterisk (*).

1. In the Product Information panel, select General. Then, complete the required fields as
follows:

a. Enter the product Name as you want it to appear in all catalog listings.

b. In the Description box, enter the main description that will appear on the Product
Detail page.

c. Enter a Short Description of the product.

d. Assign a unique SKU for the product.

e. Enter theWeight of the product, which is used to calculate shipping.

f. Set Status to “Enabled.”

g. Set Visibility to “Catalog, Search.”
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General

2. In the Product Information panel, select Prices. Then, complete the required fields as
follows:

a. Enter the Price that you will charge for the product.

b. Set Tax Class to the appropriate tax classification for the product.

Prices

3. In the Product Information panel, select Inventory. Then, do the following:
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a. If you do not need to keep track of inventory for the product, set Manage Stock to
“No.”

Depending on the configuration, you might need to clear the Use Config Settings
checkbox.

Inventory with No Stock Management

b. If you want to keep track of inventory, set Manage Stock to “Yes.” Then, do the
following:

l In the Qty field, type the quantity of the item that is currently in stock.

l Set Stock Availability to “In Stock.”

Inventory with Stock Management

4. To be visible in your catalog, the product must be assigned to a category. To assign the
product to a category, do the following:

a. In the Product Information panel, select Categories.

b. In the category tree, click to expand the section where the item belongs.

c. Select the checkbox of each category where you want the product to appear.

5. If your Magento installation has multiple websites, the product must be assigned to
each one where the product is available for sale. (This option appears only if multiple
websites exist in the store hierarchy.) To configure the scope of the product, do the
following:
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a. In the Product Information panel, select Websites.

b. On the Websites tab, select the checkbox of each website where the product is
available for sale.

6. After completing these steps, click the Save and Continue button.

At this point, the product should be visible on the assigned category page of your
catalog. Until the product image is uploaded, a placeholder appears in its place.

Step 3: Complete the Remaining Product Information

Although not required, there is still more product information to complete. At the very
least, you will want to upload product images and complete the meta data. In addition,
you can create additional custom options.

Things to Remember
A simple product can have custom options with a variety of input controls,
which makes it possible to sell many product variations from a single SKU.

Custom options are not tracked as separate inventory items.

A simple product that is included in a configurable, or bundle product type
cannot have custom options.
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Grouped Product
A grouped product is made up of multiple, standalone products that are presented as a
group. You can offer variations of a single product, or group them by season or theme to
create a coordinated set. Each product can be purchased separately, or as part of the
group.

Grouped Product

The following instructions take you through the process of creating a grouped product
with the basic fields. Each required field is marked in the Admin with a red asterisk (*).
After you complete the required settings and save the product, you can add images and
complete the remaining product information, as needed.

Process Overview:
Step 1: Create the Grouped Product
Step 2: Add the Associated Products
Step 3: Configure the Shopping Cart Thumbnails

Step 1: Create the Grouped Product

The first step is to choose the attribute set, which is used as a template for the product
record. The product in this example is based on the Default attribute set, which includes
a standard of set of fields that can be used for most products.
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1. On the Admin menu, select Catalog > Manage Products. Then, click the Add Product
button.

2. In the Create Product Settings section, do the following:

a. Select the Attribute Set you want to use as a template for the product.

b. Set Product Type to “Grouped Product,” and click the Continue button.

Create Product Settings

3. Complete the main configuration settings as you would for a simple product, with the
following exceptions:

l A grouped product does not have price options because the price of each item in the
group originates from the associated product.

l On the Inventory tab, you can set quantity increments and stock availability for the
group as a whole, but the inventory of individual items is managed by the individual
associated products.

4. Click the Save and Continue button.

Step 2: Add the Associated Products

1. In the Product Information panel on the left, select Associated Products. Then, do the
following:

Associated Products

a. To display the complete unfiltered list, click the Reset Filter button.

b. If you need help finding the products you want, use the filter controls at the top of a
column.
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c. Select the checkbox of each product that you want to include.

d. To list only the products you have selected, set the filter control at the top of the
checkbox column to “Yes.” Then, click the Search button.

2. Click the Save button to save your changes.

Step 3: Configure the Shopping Cart Thumbnails

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, select Checkout.

3. Click to expand the Shopping Cart section. Then, set Grouped Product Image to one of
the following:

l Product Thumbnail Itself

l Parent Product Thumbnail

Shopping Cart Thumbnails

4. Click the Save Config button to save the setting.

Things to Remember
A grouped product is essentially a collection of simple associated products.

Simple and virtual products associated with a grouped product cannot have
custom options.

Each item purchased appears individually in the shopping cart, rather than as
part of the group.

The thumbnail image in the shopping cart can be set to display the image from
the grouped product record, or from the associated product.
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Configurable Product
A configurable product looks like a single product with drop-down lists of options for
each variation. Each option is actually a separate simple product with a unique SKU,
which makes it possible to track inventory for each product variation. You could achieve
a similar effect by using a simple product with custom options, but without the ability
to track inventory for each variation. Products with multiple options are sometimes
referred to as composite products.

Although a configurable product uses more SKUs, and may initially take a little longer
to set up, it can save you time in the long run. If you plan to grow your business, the
configurable product type might be a better choice for a product with multiple options.

Configurable Product

The following instructions take you through the process of creating a configurable
product with the basic fields. Each required field is marked in the Admin with a red
asterisk (*). After you complete the required settings and save the product, you can add
images and complete the remaining product information, as needed.

Process Overview:
Step 1: Create Attributes for Drop-down Options
Step 2: Create the Attribute Set
Step 3: Create the Configurable Product
Step 4: Add the Associated Products
Step 5: Make Any Necessary Price Adjustments
Step 6: Configure the Shopping Cart Thumbnails
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Step 1: Create Attributes for Drop-Down Options

Create an attribute for each drop-down list of options that you want to include in the
configurable product. If the attribute already exists and has the correct properties, you
can add it to the attribute set in the next step. To learn more, see: Creating Attributes.

Required Attribute Properties
Property Setting

Scope Global

Catalog Input Type for
Store Owner

Dropdown

Apply to Configurable Product or All Product Types

Use to Create Con-
figurable Product

Yes

Step 2: Create the Attribute Set

1. On the Admin menu, select Catalog > Attributes > Manage Attribute Sets. Then, click
the Add New Set button.

2. Assign a Name to the attribute set.

3. In the Based On list, select an existing attribute set, such as “Default,” to use as a
template. Then, click the Save Attribute Set button.

4. Starting from the list of Unassigned Attributes, drag and drop each attribute you want
to include in the product to the center column. You can arrange them in any order.

5. To group the attributes in their own section of the Product Information panel, do the
following:

a. In the Groups section, click the Add New button.

If prompted by your browser, select “Temporarily Allow Scripted Windows” to
continue. Then, click the Add New button again.

b. When prompted, enter a Name for the new group. Then, click the OK button.

The new group appears at the bottom of the Groups column.

c. Drag and drop each attribute that you created for the drop-down options to group
where you want them to appear.
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Attribute Set

6. Click the Save Attribute Set button.

7. When prompted to update your cache, click the link in the message and refresh the
invalid cache.

Step 3: Create the Configurable Product

1. On the Admin menu, select Catalog > Manage Products. Then, click the Add Product
button.

2. In the Create Product Settings section, do the following:

a. Select the Attribute Set that you created for the product.

b. Set Product Type to “Configurable Product,” and click the Continue button.

Create Product Settings

3. In the Select Configurable Attributes section, select the checkbox of each attribute that
you want to include in the product. Then, click the Continue button.

Select Attributes
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4. Complete the Product Information as you would for a simple product, with the
exception of the following fields:

l On the Prices tab, the Price is a required field, but is used as a default price. The
price of each individual associated product can be adjusted accordingly.

l On the Inventory tab, Manage Stock is set to “No” by default, because inventory is
managed by each associated product.

5. When complete, click the Save and Continue Edit button.

Step 4: Add the Associated Products

Process Overview:
Method 1: Quick Simple Product Creation
Method 2: Create Empty
Method 3: Copy from Configurable

1. In the panel on the left, select the last option, Associated Products.

2. Then, use one of the following methods to add the associated products.

Method 1: Quick Simple Product Creation

This method automatically creates the associated products and optionally, assigns a
Name and SKU to each one.

1. In the Quick Simple Product Creation section, the Name and SKU are set to
Autogenerate, which makes it easy to see which products belong to the configurable
product,. However, if you want to change the default value, you can clear the checkbox
and enter a different value.

2. For each associated product that you want to create, do the follwing:

a. Enter theWeight.

b. Set Status to “Enabled.”

c. To prevent the associated products from being listed individually in the catalog, set
Visibility to “Not Visible Individually.”

3. To complete the fields for the drop-down lists, do the following:

a. For each of the configurable attributes that you set up, select the values that apply
to the first product.

b. Enter the Qty, and set Stock Availability to “In Stock.”
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c. Click the Quick Create button to create the associated product record.

Quick Simple Product Creation

4. To create additional associated products, do the following:

a. Select the value for each configurable attribute.

b. If there is an extra charge for the selection, enter the adjustment in the Price field.

c. Click the Quick Create button.

Repeat this step to create as many associated product as you need. As each associated
products is created, it appears in the list at the bottom of the page.

List of Associated Products

Method 2: Create Simple Associated Product

This method opens a blank Product Information form, which you can complete for each
associated product.

1. In the Create Simple Associated Product section, click the Create Empty button. A pop-
up window with a blank Product Information form appears.

2. Complete the required fields as you would for any simple product.

3. Click the Save button to add the associated product.

Method 3: Copy from Configurable

This method opens a Product Information form that contains the values already entered
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for the configurable product. The only fields that need to be completed are the Name,
SKU, and values for each drop-down attribute.

1. In the Create Simple Associated Product section, click the Copy From Configurable
button. A pop-up window with the basic Product Information from the configurable
product appears.

2. Complete the following required fields:

l SKU

l Weight

3. Complete the fields with values for each drop-down list.

4. Click the Save button to add the associated product to the configurable product record.

Step 5: Make Any Necessary Price Adjustments

Use the Super Products Attributes Configuration section to make price adjustments to a
specific associated product. The adjustment can be entered as a fixed value or
percentage, and is made in relation to the price of the configurable product.

Super Products Attributes Configuration

Step 6: Configure the Shopping Cart Thumbnails

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Checkout.

3. Click to expand the Shopping Cart section. Then, set Configurable Product Image to
one of the following:

l Product Thumbnail Itself

l Parent Product Thumbnail
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Shopping Cart Thumbnails

4. Click the Save Config button to save the setting.

Things to Remember

A configurable product allows the shopper to select options from drop-down
lists. Each option is actually a separate, simple product.

The drop-down list values are based on attributes that must be set up in
advance with required settings. The attribute Scope must be set to “Global,”
and Use to Create Configurable Product must be “True.” The drop-down
attributes must be included in an attribute set, which is then used as a
template for the configurable product.

The simple products associated with a configurable product cannot include
custom variants or options, and must be based on the same attribute set that
is used to create the configurable product. The associated products can be
generated automatically from inside with configurable product record.

The thumbnail image in the shopping cart can be set to display the image from
the configurable product record, or from the associated product.
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Virtual Product
Although virtual products are not physical in nature, they do represent something that
can be sold, such as a membership, service, warranty, or subscription. Virtual products
can be sold individually, or included as part of the following product types:

l Grouped Product

l Bundle Product

The process of creating a virtual product and a simple product is nearly the same.
However, because a virtual product is not shipped, there is no Weight field or option to
include a gift card.

Virtual Product

The following instructions take you through the process of creating a virtual product
with the basic fields. Each required field is marked in the Admin panel with a red
asterisk (*). After you complete the required settings and save the product, you can
complete the remaining product information as needed.

Process Overview:
Step 1: Choose the Attribute Set
Step 2: Complete the Required Fields
Step 3: Complete the Remaining Product Information
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Step 1: Choose the Attribute Set

1. On the Admin menu, select Catalog > Manage Products.

2. In the upper-right corner of the Manage Products page, click the Add Product button.

3. In the Create Product Settings section, do the following:

a. Accept the “default” Attribute Set, or select another.

b. Set Product Type to “Virtual Product,” and click the Continue button.

Create Product Settings

Step 2: Complete the Required Fields

Complete the required fields as you would for a simple product. The only difference is
that a virtual product has no weight. All required fields are marked with a red asterisk
(*).

1. On the General tab, complete the required fields as follows:

a. Type the product Name as you want it to appear in all catalog listings.

b. In the Description box, enter the main description that will appear on the product
view page.

c. Enter a Short Description of the product.

d. Assign a unique SKU to the product.

e. Set Status to “Enabled.”

f. Set Tax Class to the appropriate setting for your area.

g. Set Visibility to “Catalog, Search.”

2. On the Prices tab, enter the Price you intend to charge for the product or service.

3. If you’re not going to manage your inventory, you can skip this section. Otherwise,
complete the required fields on the Inventory tab as follows:

a. Under Manage Stock, clear the Use Config Settings checkbox. Then, set Manage
Stock to “Yes.”

b. In the Qty field, enter the quantity of the item currently in stock.

c. Set Stock Availability to “In Stock.”
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4. If applicable, on theWebsite tab, select the checkbox for the website where the product
or service will be available for sale.

5. On the Categories tab, assign the product to the appropriate categories, as follows:

a. In the Product Category tree, click to expand the section where the item belongs.

b. Select the checkbox to assign the product to each category where you want the
product to be listed in the catalog.

6. When the required fields are complete, click the Save and Continue button.

Step 3: Complete the Remaining Product Information

You have now completed the required fields. The next step is to complete the rest of the
product information as needed for this product. The meta information and product
images are a good place to start.

Things to Remember

Virtual products can be used for anything that is not physical in nature, such
as services, subscriptions, and warranties.

Virtual products are much like simple products, but without the Weight and
Allow Gift Message fields.

Shipping Options appear during checkout only if there is also a physical
product in the cart.
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Bundle Product
A bundle is a “build your own,” customizable product. Each item in a bundle can be
based on one of the following product types:

l Simple Product

l Virtual Product

Bundle Product

The following instructions take you through the process of creating a bundle product
with the basic fields. Each required field is marked with a red asterisk (*). After you
complete the required settings and save the product, you can complete the remaining
Product Information as needed.

Process Overview:
Step 1: Create the Bundle Product
Step 2: Complete the Product Information
Step 3: Add Bundle Items

Step 1: Create the Bundle Product

1. On the Admin menu, select Catalog > Manage Products. Then, click the Add Product
button.

2. In the Create Product Settings section, select the Attribute Set for the product.
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3. In the Create Product Settings section, do the following:

a. Accept the “default” Attribute Set, or select another.

b. Set Product Type to “Bundle Product.” Then, click the Continue button.

Create Product Settings

Step 2: Complete the Product Information

1. Complete the Product Information as you would for a simple product, with the
exception of the following:

a. On the General tab, set both the SKU and Weight fields to one of the following:

l Dynamic

l Fixed

If using a Fixed value, enter the actual value in the field to the right.

Dynamic SKU and Weight

b. On the Prices tab, set Price to one of the following:

l Dynamic

l Fixed

If using a Fixed value, enter the actual value in the field to the right.

Dynamic Price

c. Then, set Price View to one of the following:
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l As Low as

l Price Range

2. Click the Save and Continue Edit button.

Step 3: Add Bundle Items

1. In the Product Information panel on the left, select the last option, Bundle Items.

2. Then in the Shipment section, set Ship Bundle Items to one of the following:

l Together

l Separately

Shipment

3. In the Bundle Items section, click the Add New Option button.

4. In the Default Title box, enter a label for the bundle item, as you want it to appear on
the Customize Product page. Then, do the following:

Bundle Items

a. Set Input Type to one of the following:

l Drop-down

l Radio Buttons

l Checkbox

l Multiple Select

b. Set Is Required as needed.

c. In the Position field, enter the order that you want this item listed in relation to
other items included in the bundle.

5. Click the Add Selection button. Then, do the following:
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Select Products

a. Click the Reset Filter button to display the unfiltered list of products.

b. Select the checkbox of each product that you want to include in this item.

c. In the Qty to Add column, enter the quantity of each item to be included.

6. Click the Add Selected Product(s) to Option button. When the items appear in the
Bundle Items list, do the following:

a. Set User Defined Qty to one of the following:

Yes Displays an input box so the customer can change the quantity.

No Prevents the customer from changing the default quantity.

b. Enter a number in the Position column of each item to determine its place in
relation to other items.

c. To make an item the default selection, select the Default option of the item to be
pre-selected in the form.

Bundle Items

7. Repeat steps 3-7 for each bundle item you want to include.

8. When complete, click the Save button to save the bundle product.
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Field Descriptions
Field Description

SKU Determines if each item is assigned a variable, dynamic SKU,
or if a fixed SKU is used for the bundle. Options include:
Fixed / Dynamic.

Weight Specifies the weight is calculated based on the items selected,
or is a fixed weight for the entire bundle. Options include:
Fixed / Dynamic.

Price View Determines if the product price is shown as a range, from the
least expensive to the most expensive (Price Range), or with
the least expensive shown (As Low As). Options include: Price
Range / As Low As.

Ship Bundle Items Specifies if individual items can be shipped separately.

Things to Remember
A bundle is a “Build Your Own” product.

Bundle items can be simple or virtual products without custom options.

The Price View can be set to a price range or “As Low as.”

SKU and Weight can be either “Fixed” or “Dynamic.”

The Quantity can be set to a pre-set or user-defined value.

Items can be shipped together or separately.
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Downloadable Product
A downloadable product can be anything that you can deliver as a file, such as an
eBook, music, video, software application, or an update. You can offer an album for sale,
and sell each song individually. You can also use a downloadable product to deliver an
electronic version of your product catalog.

Because the actual download doesn’t become available until after the purchase, you can
provide samples, such as an excerpt from a book or a clip from an audio file, that the
customer can try from the product page.

Download with Sample

Downloadable products can be configured to require that the customer log in to an
account to receive the link, or can be sent by email and shared with others. The status of
the order before the download becomes available, default values, and other delivery
options are set in the configuration.

The files for download can be either uploaded to your server, or linked to on a different
server on the Internet.

Downloadable product file names can include letters and numbers. You can to use
either a dash or underscore character to represent a space between words. Any invalid
characters in the file name are replaced with an underscore.
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The following instructions take you through the process of creating a downloadable
product with the basic fields. Each required field is marked in the Admin with a red
asterisk (*). After you complete the required settings and save the product, you can add
images and complete the remaining product information as needed.

Process Overview:
Step 1: Choose the Attribute Set
Step 2: Complete the Basic Product Information
Step 3: Complete the Download Information
Step 4: Complete the Remaining Product Information

Step 1: Choose the Attribute Set

The first step is to choose the attribute set, which is used as a template for the product
record. The product in this example is based on the Default attribute set, which includes
a standard of set of fields that can be used for most products.

1. On the Admin menu, go to Catalog > Manage Products.

2. In the upper-right corner of the Manage Products page, click the Add Product button.

3. In the Create Product Settings section, do the following:

a. Attribute Setis currently set to “Default.” You can leave it as it is, or select another.

b. Set Product Type to “Downloadable Product,” and click the Continue button.

Create Product Settings

Step 2: Complete the Basic Product Information

The basic set of required fields must be completed before the product record can be
saved. The Product Information panel groups related fields by topic and the required
fields are marked with a red asterisk (*).

1. In the Product Information panel, select General. Then, complete the required fields as
follows:

a. Enter the product Name as you want it to appear in all catalog listings.

b. In the Description box, enter the main description that will appear on the Product
Detail page.
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c. Enter a Short Description of the product.

d. Assign a unique SKU for the product.

e. Set Status to “Enabled.”

f. Set Visibility to “Catalog, Search.”

2. In the Product Information panel, select Prices. Then, complete the required fields as
follows:

a. Enter the Price that you will charge for the product.

The price entered here becomes the base price of the download and is listed in the
catalog before the customers selects items for download. Any additional price that is
associated with an individual download is added to the base price.

b. Set Tax Class to the appropriate tax classification for the product.

3. In the Product Information panel, select Inventory. Then, do the following:

a. If you do not need to keep track of inventory for the product, set Manage Stock to
“No.”

b. If you do need to keep track of inventory, set Manage Stock to “Yes.” Then, do the
following:

l Set Manage Stock to “Yes.”

l In the Qty field, type the quantity of the item that is currently in stock.

l Set Stock Availability to “In Stock.”

4. In the Product Information panel, select Categories. Then, do the following:

a. In the category tree, click to expand the section where the item belongs.

b. Select the checkbox of each additional category where you want the product to
appear.

5. To make the product available on multiple websites, it must be assigned to each one.
(This option appears only if you have multiple websites.) To configure the scope of the
product, do the following:

a. In the Product Information panel, select Websites.

b. Select the checkbox of each website where the product will be available for sale.

6. After completing these steps, click the Save and Continue Edit button.
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Step 3: Complete the Download Information

1. In the Product Information panel, select Downloadable Information.

2. In the Links section, do the following:

a. Enter a Title for the list of downloadable products.

b. Set Links can be purchased separately to one of the following:

l If you want to offer multiple download links, such as to sell individual songs on
an album, select “Yes.”

l To offer a single download of this item, select “No.”

3. Click the Add New Row button, and do the following:

a. Enter the Title and Price of the download.

b. To limit the number of downloads a customer can make, enter the number in the
Max number of downloads field. To allow unlimited downloads, select the
Unlimited checkbox.

c. Set Sharable to your preference.

l To require that customers log in to their accounts to access the download link,
select “No.”

l To send the link by email, which the customer can then share with others, select
“Yes.”

4. Under Sample, use one of the following methods to deliver a sample of the
downloadable product.

l Select the File option. Then, click the Browse button, and select the sample file

to upload to the server.

l Select the URL option. Then, paste the full URL of the sample file.

5. Under File, use one of the following methods to deliver the actual downloadable product.

l Select the File option. Then, click the Browse button, and select the file to

upload.

l Select the URL option. Then, paste the full URL of the file that is available for
download.

6. In the Sort Order field, enter a number to indicate the sequence that this download will
be listed with other downloads on the product page.

7. To add another download, click the Add New Row button, and repeat the process.
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Links

8. When complete, if uploading files to the server, click the Upload Files button.

9. Click the Save and Continue Edit button.

Step 4: Complete the Samples Information

1. Click to expand the Samples section.

2. Enter a Title for the section of samples on the product page.

3. Click the Add New Row button. Then, do one of the following:

l Select the File option. Then, click the Browse button, and select the sample file

to upload.

l Select the URL option. Then, paste the full URL of the sample file.

Add New Sample

4. To add a new row, click the Add New Row button, and repeat the process.

5. When complete, click the Save button.

6. When prompted to refresh the index and cache, click the links in the message at the top
of the workspace, and follow the instructions.

At this point, the product should be visible on the assigned category page of your
catalog. Until a product image is uploaded, a placeholder appears in its place.
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Step 5: Complete the Remaining Product Information

Although not required, there is other product information to complete. At the very least,
you will want to upload product images and complete the meta data.

Things to Remember

Downloadable products can be uploaded to the server, or linked to from another

server on the Internet.

You can determine the number of times a customer can download a product.

Customers purchasing downloadable products can be required to login before
going through checkout.

The delivery of a downloadable product can be made when the order is either in
either a “Pending” or “Invoiced” state.
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Downloadable Product Configuration
The configuration settings determine guest checkout, default values, and delivery
options for downloadable products.

To configure downloadable products:

1. On the Admin menu, select System > Configure.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Downloadable Product Option section.

4. Configure the options as described in the following field descriptions.

5. When complete, click the Save Config button.

Downloadable Product Options

Field Descriptions
Field Scope Description

Order Item Status to
Enable Downloads

Website Determines the status that an order must have
before downloads become available. Options
include: Pending / Invoiced

Default Maximum
Number of Downloads

Website Determines the default number of downloads
available to a customer. Options include: Yes /
No

Shareable Website Determines if customers must log in to their
accounts to access the download link. Options
include:

Yes Allows the link to be sent by
email, which can then be shared
with others.

No Requires customers to log in to
their accounts to access the
download link.
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Field Scope Description

Default Sample Title Store View The default title for all sample files.

Default Link Title Store View The default link for all downloadable titles.

Opens Links in New
Window

Website Determines if the download link opens in a new
browser window. Options include: Yes / No

Use Content Disposition Store View Determins how the the link to the downloadable
content is delivered, as anemail attachment, or
as an inline link in a browser window. Options
include:

Attachment The download link is delivered
as an email attachment.

Inline The download link is delivered
as an inline link on a web page.

Disable Guest Checkout
if Cart Contains Down-
loadable Items

Website Determines if guests who are purchasing down-
loadable products must log in to an account to
complete the checkout process. Options
Include:

Yes If the cart contains down-
loadable products, the guest
will have to either register for
an account, or login to an
existin account to complete the
purchase.

No The download link is delivered
as an inline link in the body of
the email message.

Guest checkout is only available for dowload
products if Sharable is set to "Yes."
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Chapter 13:

Product Information
The Product Information panel provides access to the full range of settings that
make up a product record. The information in this section can be used for reference
when creating a product of any type.

The selection of Product Information tabs, and the organization of the fields on each
page is determined by the attribute set that was used to create the product.

Product Information
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General
Use the General tab to enter information about the product. In addition to providing
basic information about the product, this section determines the product's visibility in
the catalog and search.

The selection, order, and grouping of the fields is determined by the attribute set that
was used to create the product. As a result, the product attributes might differ from
what is shown in the example.

Product Information: General

Field Descriptions
Field Scope Description

Name Store View (Required) The name of the product you want to
appear in catalog. The name is also used to
auto-generate the URL Key.

Description Store View (Required) The main product description that
appears on the product page.
The text should be plain ASCII text. HTML tags
can be used to format the description if per-
mitted by the attribute properties.
Do not paste text directly from a word pro-
cessor, because the text might include print
control codes that will not render correctly. To
strip out any control codes, save the file as a .txt
file before copying and pasting te text into the
product description.
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Field Scope Description

Short Description Store View (Required) Depending on the theme, the Short
Description might appear on catalog pages.
Because of its length, it is often used for RSS
feeds.

SKU Global (Required) The Stock Keeping Unit is a unique
identifier for each individual product or service
provided.

Weight Global (Required) The weight of the product is a
decimal value used for shipping calculations,
and refers to the standard measurement system
used by shipping carriers in your locale. In the
United States, weight is measured in pounds
and ounces, whereas countries on the metric
system measure weight in grams and kilograms.

Set Product as New from
Date

Website Sets the beginning date for the range of time the
product is featured in the “New Product” block
on the Home page. The date can be typed dir-
ectly into the box, or selected from the calendar.

Set Product as New to
Date

Website Sets the ending date for the range of time the
product is featured in the “New Product” block
on the Home page.

Status Website (Required) The Status indicates when the
product is ready to be offered for sale in your
store. Options include: Enabled / Disabled.

URL Key Store View The URL Key determines the online address of
the product. It is added to the base URL of the
store, and appears in the address bar of a
browser.
The URL Key should be all lowercase characters,
with hyphens instead of spaces. Magento ini-
tially creates a default, “search engine friendly”
URL, based on the product name.
Do not type the suffix .html in the URL Key,
because use of the suffix is controlled by your
store configuration. To learn more, see , SEO
URL Options.

Visibility Store View (Required) Determines the level of visibility the
product has throughout the store. Options
include:

Not Visible Indi-
vidually

The product may be asso-
ciated with a one-to-many
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Field Scope Description

product, but is not listed in
the catalog.

Catalog The product appears in
the catalog listing, but is
not included in Search
results.

Search The product appears in
search results, but is not
listed in the catalog.

Catalog, Search The product is listed in the
catalog and search results.

Country of Manufacture Website Select the manufacturer of the product. To add
new options to the list, see Manage
Label / Options.

Button Descriptions
Field Description

Create New Attribute Gives you the ability to create a new attribute while working in
product edit mode. Although you can save the new attribute,
it is not automatically included in the attribute set that is asso-
ciated with the current product.
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Meta Information
Meta data is your first level of contact with potential customers who are searching for a
product. Your title and description are selling tools that will either help to motivate a
visitor to click your link or not. It is wise to use a descriptive title and a description that
includes relevant words that a potential customer might search.

The information is read by search engines that index your site. Although Google no
longer places a value on meta keywords, other search engines continue to use the
information. It’s a good practice to incorporate high-value keywords in your product
titles and related content.

Product Information: Meta Information

Field Descriptions
Field Description

Meta Title The title appears in the title bar and tab of your browser, and
is also used as the title on a search engine results page (SERP).

Meta Keywords Enter relevant keywords for the product. Consider using
keywords that customers may use to find the product.

Meta Description Write a few sentences to describe the product. Though not
visible to the customer, some search engines include the meta
description on the search results page.
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Recurring Profile
Recurring Profiles are most often used for subscriptions or products with installment
payment plans. When such a product is purchased from your store, the customer is
redirected to a third-party payment system. The customer enters into a recurring
payment agreement to authorize the payment system to charge the customer account
according to the recurring profile settings.

When a customer purchases a product with recurring payments, the profile parameters
specified from Magento are transferred to the payment system. Magento supports
recurring profiles for items paid with PayPal Express Checkout.

For example, to set up a product with monthly subscription payments, the following
parameters are specified in the recurring profile of the product. The customer is charged
by the payment system once a month, for a year.

Billing Settings

Billing Period Unit: Month

Billing Frequency: 1

Maximum Billing Cycles: 12

You can also set up a trial period where the customer pays a special, introductory price
for a period of time. Wen the trial ends, the customer is charged the regular amount.

Creating a recurring profile for a product does not create additional sales orders.

In the third-party payment system, a recurring profile is an accounting record that
captures payments on a regular basis and according to the payment schedule defined in
the recurring profile. A recurring profile submits the information about the frequency of a
payment being initiated to the payment system.

The Recurring Profile tab appears by default for simple and virtual products. However
you can configure it to become available for other product types by changing the Apply
To property of the recurring_profile attribute. To learn more about recurring profiles, see:
Working with Recurring Profiles in the knowledge base.

To set up a recurring profile:

1. On the Admin menu, select Catalog > Manage Products. Find the product in the list,
and click to open it in edit mode.

2. In the panel on the left, select Recurring Profile.

3. Set Enable Recurring Profile to “Yes.” The section expands to include additional
options.

http://www.magentocommerce.com/knowledge-base/entry/working-with-recurring-profiles/
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Recurring Profile

4. In the Schedule section, do the following:

Schedule

a. To let the customer determine the starting date for the payments, set Customer Can
Define Start Date to “Yes.”

b. In the Schedule Description field, enter a brief description of the recurring payment.
The description is used as the name of the recurring payment on the Review
Information page.

c. In theMaximum Payment Failures filed, enter the number of times payment can
fail before the recurring profile is suspended.

d. To automatically initiate a payment transactoin at the end of the next billing cycle,
set Auto Bill on Next Cycle to “Yes.”

5. In the Billing section, do the following:

Billing

a. Set Billing Period Unit to the period of time that defines the billing cycle.

b. Set Billing Frequency to how often a payment transaction is initiated during the
billing cycle.

c. In theMaximum Billing Cycles field, enter the maximum number of payments
allowed for the recurring profile. If left blank, the the customer will continue to be
charged until the recurring profile is canceled.

6. In the Trial Period section, do the following:
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Trial Period

a. Set Trial Billing Period Unit to the period of time that defines the billing cycle
during the trial period.

b. Set Trial Billing Period Frequency to how often a payment transaction is initiated
during the trial billing cycle.

c. In the Trial Billing Period Cycles field, enter the maximum number of payments
allowed during the trial period.

d. In the Trial Billing Amount field, enter the product price during the trial period.

The trial billing period parameters are optional, but if specified, make sure that all
fields are complete. Otherwise, the payment system will not authorize the payment.

7. In the Initial Fees section, do the following:

Initial Fees

a. In the Initial Fees field, enter the amount that the customer is charged at the time
of purchase. The initial fee is paid only once during the life of a subscription.

b. If you want to cancel the recurring if the initial payment fails, set Allow Initial Fee
Failure to “Yes.” If set to “No,” the initial fee is added to the customer’s outstanding
amount and is charged by the payment system as soon as the customer account has
a sufficient amount.

8. When complete, click the Save button.

Field Descriptions
Field Scope Description

Schedule Global

Customer Can Define Determines if the customer can set the starting
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Field Scope Description

Start Date date for the payments. Options include:

Yes Displays the Recurring Profile Start
Date as an option on the product page.

No The customer cannot set the start date.

Schedule Description A brief description of the recurring payment.
The description appears as the name of the
recurring payment on the review information
page of the payment system. If left empty, the
name of the selected product appears as the
name of the recurring profile.

Maximum Payment Fail-
ures

Determines the number of failed scheduled pay-
ments before the recurring profile is auto-
matically be suspended.

Auto Bill on Next Cycle Determines if the payment system automatically
initiates a payment transaction after the regular
billing cycle.
In the event of a number of payment failures
and the customer has an outstanding amount,
the customer is charged in the next billing cycle.
Options: Yes / No

Billing Global

Billing Period Unit Determines the period of time included in a sub-
scription billing cycle, and how frequently a
payment transaction is initiated. Options
include:
Day
Week
Two Weeks
Month
Year

Billing Frequency Determines how often within the billing period a
payment transaction is initiated for the recurring
profile.

Maximum Billing Cycles Limits the number of payments that can be
made during a billing cycle. If you do not specify
the maximum of billing cycles, the recurring
profile remains permanently active and the cus-
tomer is charged by the payment system until
the recurring profile is suspended or canceled.

Trial Period Global
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Field Scope Description

Trial Billing Period Unit Determines the period of time included in a trial
subscription billing cycle, and how frequently a
payment transaction is initiated. Options
include:
Day
Week
Two Weeks
Month
Year

Trial Billing Frequency Determines how often during the billing period
a payment transaction is initiated for the recur-
ring profile.

Maximum Trial Billing
Cycles

Limits the number of recurring payments that
can be made during a trial billing cycle.

Trial Billing Amount The price of the product during the trial period.

Initial Fees Global

Initial Fee The amount the customer is charged at the time
of purchase. The initial fee is paid only once
during the life of a subscription.

Allow Initial Fee Failure Determines if the payment profile is suspended
if the initial fee payment fails. In case the field is
set to No, Options include:

Yes The payment profile is suspended if
the initial fee fails.

No The initial fee is added to the cus-
tomer’s outstanding amount and is
charged by the payment system as
soon as the customer account has the
sufficient amount.
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Design
The Design page gives you the ability to apply a different theme to the product page,
and make updates to the XML code that controls the page layout.

Product Information: Design

Field Descriptions
Field Description

Custom Theme To apply a custom theme, select the one you want from the
list of available themes.

Active From If applying a custom theme for a period of time, enter the
beginning date, or select the date from the Calendar.

Active To If applying a custom theme for a period of time, enter the
ending date, or select the date from the Calendar.

Custom Layout Update You can further customize the theme with XML coding.

Page Layout To apply a different layout to the product page, select one of
the following:

No layout updates This option is preselected by default
and does not apply layout changes.

Empty This option lets you define your own
layout, such as a 4-column page.
Requires an understanding of XML.

1 column Applies the 1-column layout.

2 columns with left
bar

Applies the 2 column layout.

2 columns with
right bar

Applies the 2-columns with right bar
layout.
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Field Description

3 columns Applies the 3 column layout.

Display product options
in

Options include: Product Info Column / Block after Info
Column

Gift Options
Gift Options determine if customers have the option to add a gift message and to gift
wrap the product during checkout. To configure gift options for the store, see: Gift
Options Configuration.

To set up gift options for a product:

1. On the Admin menu, select Catalog > Manage Products. Then, click to open the
product in edit mode.

2. In the panel on the left, select Gift Options. Then, do the following:

Gift Options

a. The Allow Gift Message reflects the default configuration. To override the setting,
clear the Use Config Settings checkbox. Then, change the value as needed.

b. To charge for gift wrapping, enter the amount in the Price for Gift Wrapping field,
as a decimal, without the currency symbol.

3. When complete, click the Save button.
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Websites
If your Magento installation has multiple websites, stores, or views, you can set the
scope of a configuration setting, product, category, or attribute to apply to a specific
website, store, or store view. To learn more, see: Multiple Sites, Stores & Views.

Product Information: Websites

To assign a product to a store view:

1. In the Product Information panel on the left, select Websites.

2. Select the checkbox for each store view where the product is offered for sale.

3. When complete, click the Save button.
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Categories
Every product in your catalog must be assigned to at least one category. Before you can
add products to your catalog, you must first establish its basic category structure. A
product cannot be saved until after it has been assigned to at least one category.

Product Categories

To set up the product categories:

1. In the Product Information panel on the left, select Categories.

2. In the category tree, select the checkbox of each category to which you want to associate
the product. Click the plus [+] icon to show any available subcategories.

A single product can be assigned to more than one category.

3. When complete, click the Save button.



Chapter 13:  Product Information Related Products

175Magento Community Edition: User Guide

Related Products
Related products are meant to be purchased in addition to the item the customer is
viewing. Simply click the checkbox of a product to place it in the shopping cart. The
placement of the Related Products block varies according to theme and page layout. In
the example below, it appears at the bottom of the Product View page. With a 2 column
layout, the Related Product block often appears in the right column.

Related Products

To set up related products:

1. In the Product Information panel on the left, click Related Products.

2. Click the Reset Filter button in the upper-right to list all the available products, or use
the search filters at the top of each column to find specific products.

3. In the list, select the checkbox in the first column of any product you want to feature as
a related product.

Select Related Products

4. When complete, click the Save button.
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Up-sells
Up-sell products are items that your customer might prefer instead of the product
currently viewed. An item offered as an up-sell might be of a higher quality, more
popular, or have better profit margin. Up-sell products appear on the product page,
under a heading such as, “You may also be interested in the following product(s).”

Up-Sell on Product Page

To select up-sell products:

1. In the Product Information panel, select Up-sells.

2. Click the Reset Filter button in the upper-right to list all the available products, or use
the search filters at the top of each column to find specific products.

3. In the list, select the checkbox in the first column of any product you want to feature as
an up-sell.

4. When complete, click the Save button.
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Cross-sells
Cross-sell products are similar to impulse purchases positioned next to the cash register
in the checkout line of a grocery store. Products offered as a cross-sell appear on the
shopping cart page, just before the customer begins the checkout process.

Cross-sell Offered During Checkout

To set up cross-sell products:

1. In the Product Information panel on the left, click Cross-sells.

2. Click the Reset Filter button in the upper-right to list all the available products, or use
the search filters at the top of each column to find specific products.

3. In the list, select the checkbox in the first column of any product you want to feature as
a cross-sell.

Cross-Sell Product
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4. When complete, click the Save button.

Custom Options
Custom options are an easy way to offer a selection of product variations that do not
rely on attributes. The limitations are that you cannot track inventory based on any
variation, and that a product with custom options cannot be used with a configurable,
grouped, or bundle product. Custom options are a good solution if your inventory needs
are simple.

Custom Options on Product Page

To create custom options:

1. On the Admin menu, select Catalog > Manage Products.

2. In the list, open the product record in edit mode.

3. In the panel on the left, select Custom Options.

4. In the upper-right corner, click the Add New Option button. Then, do the following:
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Custom Options

a. In the Title field, enter a name for the property.

b. Set the Input Type you want to use for data entry.

c. Set Is Required to “Yes” if the option must be selected before the product can be
purchased.

d. In the Sort Order field, enter a number to indicate the order of this item in the list
of options. Enter the number 1 to display this option first.

5. Click the Add New Row button. Then, complete the following:

Add New Row

a. In the Title field, enter a name for this option.

b. In the Price field, enter any markup or markdown from the base product price that
applies to this option.

c. Set Price Type to one of the following:

Fixed The price of the variation differs from the price of the base
product by a fixed monetary amount, such as $1.

Percentage The price of the variation differs from the price of the base
product by a percentage, such as 10%.

d. Enter a SKU to identify the option. The option SKU is added as a suffix to the SKU
of the product record.
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e. In the Sort Order field, enter a number to indicate the order of this item in the list
of options. Enter the number 1 to display this option first.

6. When complete, click the Save button.
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Chapter 14:

Inventory
Inventory settings can be made for the catalog as a whole, and fine tuned for each
individual product. In addition to controlling stock levels, the inventory settings
determine how backorders and returned items on credit memos are managed.

Inventory Configuration
The Product Stock Items configuration determines the default product inventory
settings. The configuration applies to individual products, rather than to the
contents of the cart as a whole.

To configure the default inventory settings:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Inventory.

3. Click to expand the Product Stock Options section.

4. Enter the default settings for each item, as described in the following field
descriptions.

5. When complete, click the Save Config button.

Product Stock Options
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Field Descriptions
Field Scope Description

Manage Stock Global Determines if you use full inventory control to
manage the items in your catalog. Options
include:

Yes Activates full inventory control to keep
track of the number of items currently
in stock.

No Does not keep track of the number of
items currently in stock.

Backorders Global Determines how your store manages back-
orders. A backorder does not change the pro-
cessing status of the order. Funds are still
authorized or captured immediately when the
order is placed, regardless of whether the
product is in stock. When the product becomes
available, it will be shipped. Options include:

No Back-
orders

Does not accept backorders
when product is out of stock

Allow Qty
Below 0

Accepts backorders when the
quantity falls below zero.

Allow Qty
Below 0 and
Notify Cus-
tomer

Accepts backorders when the
quantity falls below zero, but
notifies customers that orders
can still be placed.

Maximum Qty Allowed in
Shopping Cart

Global Determines the maximum number of a product
that can be purchased in a single order. By
default, the maximum quantity is set to 10,000.

Qty for Item's Status to
Become Out of Stock

Global Determines the stock level at which a product is
considered to be out of stock.

Minimum Qty Allowed in
Shopping Cart

Global Determines the minimum amount of an item
that is available for purchase according to cus-
tomer group. By default, the minimum quantity
is set to 1.
Click the Add Minimum Qty button to enter a dif-
ferent value for a specific customer group.

Notify for Quantity Below Global Determines the stock level at which notification
is sent that the inventory has fallen below the
threshold.

Enable Qty Increments Global Determines if items can be sold in quantity incre-
ments. Options include: Yes / No
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Field Scope Description

Qty Increments Global Establishes the number of products that make
up a quantity increment.

Automatically Return
Credit Memo Item to
Stock

Global Determines if items included on credit memos
are automatically returned to inventory. Options
include: Yes / No

Managing Stock
Each product in your catalog has both a short and long version of the Inventory options,
depending on whether you need to manage inventory for the product. The long form
appears only when Manage Stock is set to “Yes.” The initial values reflect the default
Product Stock Option configuration.

Product Information: Inventory (Short Form)

To complete the inventory settings:

1. In the Product Information panel, select Inventory. To complete the required settings,
do the following:

a. Clear the checkbox below theManage Stock field. Then, set Manage Stock to “Yes.”

b. In the Qty field, type the number of units you currently have in stock.

c. Set Stock Availability to “In Stock.”

2. Complete the remaining settings as needed, as described in the following field
descriptions.

3. When complete, click the Save button.
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Product Information: Inventory (Long Form)

Field Descriptions
Field Description

Manage Stock Determines if you use full inventory control to manage the
items in your catalog. Options include:

Yes Activates full inventory control to keep track of the
number of items currently in stock. (To change the
setting, clear the Use Config Settings checkbox and
select “Yes.”)

No Does not keep track of the number of items cur-
rently in stock. (This is the default setting.)

Qty (Required) The quantity of the item in stock.

Qty For Item’s Status to
become Out of Stock

Determines the stock level at which a product is considered to
be out of stock.

Minimum Qty Allowed in
Shopping Cart

Determines the minimum amount of this item that is available
for purchase. By default, the minimum quantity is set to 1.

Maximum Qty Allowed in
Shopping Cart

Determines the maximum number of this item that can be
purchased in a single order. By default, the maximum quant-
ity is set to 10,000.

Qty Uses Decimals Determines if customers can use a decimal value rather than a
whole number when entering the quantity ordered. Options
include:

Yes Permits values to be entered as decimals,
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Field Description

rather than whole numbers, which is suit-
able for products sold by weight, volume
or length.

No Quantity values must be entered as
whole numbers.

Can be divided into Mul-
tiple Boxes for Shipping

Determines if parts of the product can shipped separately.
Options include: Yes / No

Backorders Determines how your store manages backorders. A back-
order does not change the processing status of the order.
Funds are still authorized or captured immediately when the
order is placed, regardless of whether the product is in stock.
When the product becomes available, it will be shipped.
Options include:

No Backorders Does not accept backorders when
product is out of stock

Allow Qty Below
0

Accepts backorders when the quantity
falls below zero.

Allow Qty Below
0 and Notify Cus-
tomer

Accepts backorders when the quantity
falls below zero, but notifies customers
that orders can still be placed.

Notify for Quantity Below Determines the stock level at which notification is sent that the
inventory has fallen below the threshold.

Enable Qty Increments Determines if the product can be sold in quantity increments.
Options include: Yes / No

Qty Increments Establishes the number of products that make up a quantity
increment.

Stock Availability Determines the current availability of the product. Options
include:

In Stock Makes the product available for pur-
chase.

Out of Stock Unless Backorders are activated, pre-
vents the product from being available
for purchase and removes the listing
from the catalog.
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Stock Availability
You can define an inventory level that becomes the threshold to determine when an item
needs to be reordered. The out of stock threshold can be set to any number greater than
zero.

Another way you can use the stock availability threshold is to manage products that are
in high demand. If you want to capture new customers, rather than sell to high-quantity
buyers, you can set a maximum quantity to prevent a single buyer from taking out your
entire inventory.

Your catalog can be configured to display the availability of each item as “In Stock” or
“Out of Stock” on the product page. The configuration setting applies to the catalog as a
whole, and the message changes according to the stock status of the product. There are
several display variations possible, including how “out of stock” products are managed
in the catalog and search results lists.

“In Stock” Message on Product Page

Step 1: Configure the Inventory Stock Options

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Catalog, select Inventory.

3. Click to expand the Stock Options section. Then, do the following:
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Stock Options

a. To configure how “out of stock” products are handled in the category and search
results lists, set Display Out of Stock Products to one of the following:

Yes Includes “out of stock” products on catalog pages.

No Omits “out of stock” products from catalog pages.

b. To configure the stock availability message on the product page, set Display
products availability in stock in the frontend to one of the following:

Yes Displays an availability message indicating the product stock status.

No Does not display an availability message.

4. Click the Save Config button to save the setting.

Step 2: Set the Product to Manage Stock

1. On the Admin menu, select Catalog > Manage Products.

2. In the list, click to open the product. Then in the Product Information panel on the left,
select Inventory.

3. If necessary, clear the Use Config Settings checkbox, and set Manage Stock to “Yes.”
Then, complete the inventory settings as needed.

4. Make sure that Stock Availability is set to “In Stock.”

5. Click the Save button to save the product settings.

Step 3: Set the "Out of Stock" Threshold

1. On the Inventory tab, set the Qty for Item’s Status to Become Out of Stock to a value
above zero.

2. To set the quantity of the product that is allowed in the cart, set the following fields to
the appropriate values for your product, store, and strategy:

l Minimum Quantity Allowed in Shopping Cart

l Maximum Quantity Allowed in Shopping Cart
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3. To be notified when stock drops below the threshold, clear the Use Config Settings
checkbox. Then, set Notify for Quantity Below to a number to establish the threshold.
The default the value is 1.

If you need time to restock your inventory, you can use this value to indicate when it is
time to replenish.

Stock Availability Message Scenarios
You can use a combination of configuration settings to control stock availability
messages on product pages and in listings of products on catalog pages.

Product Page Messages
There are several variations of messaging available for the product page, depending on
the combination of Manage Stock and Stock Availability settings.

Grouped Product with Both Messages

Example 1: Show Availability Message

Scenario 1: This combination of settings causes the availability message to appear on
the product page, according to the stock availability of each product.

Stock Options

Display product availability in stock in the frontend: Yes
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Product Inventory Message

Manage Stock Yes

Stock Availability In Stock
Out of Stock

“Availability: In Stock”
“Availability: Out of Stock”

Scenario 2: When stock is not managed for a product, this combination of settings can
be used to display the availability message on the product page.

Stock Options

Display product availability in stock in the frontend Yes

Product Inventory Message

Manage Stock No “Availability: In Stock”

Example 2: Hide Availability Message

Scenario 1: This combination of configuration and product settings prevents the
availability message from appearing on the product page.

Stock Options

Display product availability in stock in the frontend No

Product Inventory Message

Manage Stock Yes

Stock Availability In Stock
Out of Stock

None
None

Scenario 2: When stock is not managed for a product, this combination of configuration
and product settings prevents the availability message from appearing on the product
page.

Stock Options

Display product availability in stock in the frontend No

Product Inventory Message

Manage Stock No None

Catalog Page Messages
The following display options are possible for the category and search results lists,
depending on product availability, configuration settings, and theme.
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Example 1: Show Product with “Out of Stock Message”

This combination of configuration settings includes out of stock products in the category
and search results lists, and displays an “out of stock” message.

Stock Options Message

Display Out of Stock Products
Display product availability in stock in the frontend

Yes
Yes “Out of stock”

Display Out of Stock Products Yes

Display product availability in stock in the frontend No None

Example 2: Show Product without “Out of Stock Message”

This combination of configuration settings includes out of stock products in the category
and search results lists, but does not display a message.

Stock Options Message

Display Out of Stock Products
Display product availability in stock in the frontend

Yes
No None

Example 3: Hide Product Until Back in Stock

This configuration setting omits out of stock products entirely from the category and
search results lists, until they are back in stock.

Stock Options Message

Display Out of Stock Products No None

Out of Stock Threshold
You can define an inventory level that becomes the threshold to determine when an item
needs to be reordered. The out of stock threshold is set to a number above zero.

To set the out of stock threshold:

1. In the Product Information panel, select Inventory.

2. Set the Qty for Item’s Status to Become Out of Stock to a value above zero.

To change the quantity allowed in cart:

This option is helpful for products in high demand. If you want to capture a larger
number of new customers rather than selling high volumes to high-quantity buyers, you
can set a maximum quantity to prevent a high-quantity buyer from taking out your
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entire inventory.

1. In the Product Information panel, select Inventory.

2. Change theMinimum and Maximum Quantity Allowed in Shopping Cart fields to
appropriate values for your product, store, and strategy.

To be notified when stock drops below a certain threshold:

1. In the Product Information panel, select Inventory.

2. Clear the Use Config Settings checkbox, and set Notify for Quantity Below to indicate
the level when you want to be notified. By default, the value is set to 1.

Product Alert Configuration
You can enable your customers to subscribe to two types of customer alerts by email:
price change alerts and in-stock alerts. For each alert type, choose whether to enable
users to subscribe to it, and select the email template to use. Also, select a sender
display name, which applies to both alert types.

Product Alerts

The price change alert creates a Sign up for price alert link on every product page.
Customers can click the link to subscribe to alerts related to the product. Whenever the
price changes, or the product goes on special, the customer receives an email alert.

The in-stock alert creates a link called “Sign up to get notified when this product is back
in stock” for every product that is out of stock. Customers can click the link to subscribe
to the alert. When the product is back in stock, customers receive email notification that
the product is available.

Products that have alerts have a Product Alerts tab in the Product Information panel
that lists the customers who have subscribed to either alert.

Product Alerts Run Settings
These settings enable you to select how often Magento checks for changes that require
alerts to be sent. Additionally, you can select the recipient, sender, and template for
emails that are sent if the sending of alerts fails.
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Product Alert Run Settings

Field Descriptions
Field Description

Frequency Choose how often product alerts are sent out: Daily, Weekly,
or Monthly.

Start Time Choose what time of day the product alert process starts. This
time should be after any price or inventory updates are per-
formed.

Error Email Recipient Identify the email address of the person (normally a store
administrator) who should receive an email notification when
there is an error in the product alert process.

Error Email Sender Select the role that the email will be “from.”

Error Email Template Select the email template to use for product alert error noti-
fications. .

Managing Stock for Configurable Products
By default, Manage Stock is turned off for a configurable product, because the inventory
is managed through each associated product. However, at times it may be necessary to
apply inventory settings to a configurable product as a whole, such as to set quantity
increments and change the stock availability.

To enable quantity increments:

1. On the Inventory tab of the configurable product, clear the Use Config Settings
checkbox, and set Manage Stock to “Yes.” The Enable Qty Increments field appears.

2. To sell the product in quantity increments, do the following:

a. Below the Enable Qty Increments field, clear the Use Config Settings checkbox.
Then, set Enable Qty Increments to “Yes.”

b. In the Qty Increments field, enter the number of products that you want to sell
together as a single batch.
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To set product as “Out of Stock:”

1. On the Inventory tab of the configurable product, clear the Use Config Settings
checkbox, and set Manage Stock to “Yes.” The Stock Availability field appears.

2. To temporarily remove the product from sale, set Stock Availability to “Out of Stock.”

3. When you are ready to offer the product for sale, set Stock Availability to “In Stock.”
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Chapter 15:

Product Images
Using images of consistent quality, size, and proportion gives your product catalog a
professional look with commercial appeal. If you have a large catalog with several
images per product, you can easily have hundreds, if not thousands of product
images to manage. Before you get started, it’s a good idea to establish a naming
convention for your image files, and organize them so you can find the originals if
you ever need them.

The Images tab in the Product Information panel is used to upload and manage
individual images for the current product. You can upload multiple images for each
product, with different images for each website or store view. However, if you have a
large quantity of images to manage, it is more efficient to import, rather than upload
each one individually. To learn more, see: Importing Product Images.

Product Images

Thumbnail Gallery
The thumbnail gallery on the product page can be used to display multiple images
of the product. Although the position of the gallery varies by theme, it is usually just
below the main image on the product page. Click each image to browse through the
thumbnail gallery.
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Thumbnail Gallery Popup

Light Boxes and Sliders
Some stores use third-party light boxes or sliders to replace the default product image
display. You will find a variety of light box and slider extensions available in Magento
Connect.

Image Zoom
Magento displays a magnified portion of the image on mouseover, provided that you
have uploaded a larger image that can be used to zoom in for a closer look. When zoom
is activated, you can click the main image and move the cursor around to magnify
different parts of the image. The magnified selection appears to the right of the image.
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Image Zoom

Image Size and Type
As a best practice, you should standardize the size of your images so they appear at the
highest possible resolution. A single product image can be displayed in several different
sizes throughout your catalog. In addition to the main image on the product page, there
are smaller images and thumbnails.

The following image types determine how images are used in your catalog. If you have
only one product image, you can use the same image for each type. If you do not assign
an image to each type, a placeholder image will mark the place in the catalog.

Image Type
Image Type Description

Thumbnail Thumbnail images appear in the thumbnail gallery, shopping
cart, and in some blocks such as Related Items. Example size:
50 x 50 pixels

Small Image The small image is used for the product images in listings on
category and search results pages, and to display the product
images needed for sections such as for Up-sells, Cross-sells,
and the New Products List. Example size:
470 x 470 pixels

Base Image The base image is the main image on the product detail page.
Image zoom is activated if you upload an image that is larger
image than the image container. Example Size:
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Image Type Description

470 x 470 pixels (without Zoom)
1100 x 1100 pixels (with Zoom)

Media Image (Optional) A media image you the ability to associate addi-
tional images with a product, that are other than a product
image. For example, you might include the product logo, care
instructions, or an image of the ingredients from a food label.
If you add a media image attribute to the attribute set of a
product, it is listed as an additional image type, along with
Base, Small, and Thumbnail. You can set it to "Exclude" so it
doesn't appear in the gallery.

Adding Product Images
The Images tab is used to upload and manage images for a single product. You can
upload multiple images for the product, and maintain different images for each website
or store view. However, if you have many images to manage, you might prefer to import
them, rather than upload product images individually.

Adding Product Images

To add product images:

1. If the images are to be used for only a specific store view, set Choose Store View in the
upper-left corner to identify the view where the images will be used.

2. In the panel on the left, click Images.

3. Click the Browse Files button, and select the product images files you want to upload to
your store.

4. Click the Upload Files button to upload the selected images to your store. Then, for each
image, do the following:
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a. Enter a descriptive Label for the image. This text appears on mouseover and can
improve indexing by search engines.

b. If using multiple images, enter a numeric value in the Sort Order field to determine
the sequence in which they appear in the thumbnail gallery.

c. To prevent an image from being included in the thumbnail gallery, click the Exclude
checkbox. For example, if the product has only one image, there’s no reason to
include it in the gallery.

d. To delete any image, select the Remove checkbox.

5. When complete, click the Save and Continue Edit button.

To add images to the gallery:

Follow the same process for adding a new product image. For best results, gallery image
files should be the same size and proportion as the main product image.

Field Descriptions
Field Description

Image On mouseover, a thumbnail of each uploaded image
appears.

Label The label is the descriptive “Alt” text that appears on
mouseover. Including a label for each image improves index-
ing by search engines, and accessibility for people who use
screen readers.

Sort Order Determines the order in which images are displayed in the
gallery.

Thumbnail The Thumbnail image is used in the shopping cart and in
some blocks, such as Related Items.

Small Image The Small Image is used in product listings on the category
and search results pages, and to display product images in
additional sections such as Up-sells, Cross-sells, and the New
Products List.

Base Image The Base Image is the main image on the product page, and is
also used to produce the magnified area displayed during
image zoom.

Media Image (Optional) The Media Image appears only if an attribute of the
Media Image type is included in the attribute set.

Exclude Select the Exclude checkbox to prevent the image from being
listed in the thumbnail gallery.
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Field Description

Remove Select the Remove checkbox to delete the image. Selected
images are deleted when the product record is saved.

Placeholders
Magento uses a temporary image as a placeholder until permanent product images are
available. The initial placeholder image is the Magento logo, which you can replace with
placeholder images of your own design.

Product Placeholder

To upload placeholder images:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Catalog, select Catalog.

3. Click to expand the Product Image Placeholders section. Then, do the following:

a. For each image type, click the Browse button to upload the placeholder image you
want to use for the Base Image, Small Image, and Thumbnail images. If you like,
you can use the same image for each type.

b. When complete, click the Save Config button.

Product Image Placeholder Configuration
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Watermarks
If you have gone to the expense of creating your own original product images, there is
not much you can do to prevent unscrupulous competitors from stealing them with the
click of a mouse. However, you can place a watermark on each image to identify it as
your property and make it a less attractive target. A watermark file can be either a .jpg
(jpeg), .gif, or .png image.

To place watermarks on product images:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under General, select Design.

3. Click to expand the Product Image Watermarks section. Then, complete the following
steps for the Base, Small, and Thumbnail images:

a. Enter theWatermark Default Size, in pixels. For example: 200 x 300

b. Enter theWatermark Opacity, as a percentage. For example: .40

c. Click the Browse button and select the Watermark image file to upload.

d. Set Watermark Position to your preference.

4. When complete, click the Save Config button.

Field Descriptions
Field Description

Base Image Watermark
Default Size

The default size of the watermark for the Base Image. (For
example, 470 x 470)

Base Image Watermark
Opacity, Percent

The percentage of opacity applied to the watermark for the
Base Image.

Base Image Watermark The file with the watermark image to be uploaded for the
Base Image. (The image file can be .jpg (jpeg), .gif, and .png.)

Base Image Watermark
Position

The position of the watermark for the Base Image. Options
include:
Stretch

Tile

Top/Left

Top/Right

Bottom/Left
Bottom/Right
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Field Description

Small Image (Repeat the above for the Small Image.)

Thumbnail Image (Repeat the above for the Thumbnail Image.)

Shopping Cart Thumbnails
The thumbnail images in the shopping cart give customers a quick overview of the items
they are about to purchase. However, for products with multiple options, the standard
product image may not match the actual item being purchased. If the customer
purchased a pair of red shoes, ideally, the thumbnail in the shopping cart should show
the product in the same color.

The thumbnail image for both grouped and configurable products can be set to display
the image from either the “parent” product record or associated product. The setting
applies to all grouped or configurable products in the current store view.

To configure shopping cart thumbnails:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, select Checkout.

3. Click to expand the Shopping Cart section, do the following:

Shopping Cart Configuration

a. Set Grouped Product Image to one of the following:

l Product Thumbnail Itself

l Parent Product Thumbnail

b. Set Configurable Product Image to one of the following:

l Product Thumbnail Itself

l Parent Product Thumbnail

4. When complete, click the Save Config button.
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Chapter 16:

Product Pricing
The Prices tab is used to establish the pricing structure of the product. Options
include special and tier pricing, and manufacturer’s suggested retail price.

Product Information - Prices

Field Descriptions
Field Scope Description

Price Global The retail price of the product.

Group Price Global Sets up promotional prices for specific cus-
tomer groups within the selected website.

Special Price Website To offer a Special Price, enter a discounted
price and complete the date range fields to
establish when the promotion goes into
effect.
When available, the retail price is crossed out
and the special price appears below in a large,
bold font.

Special Price From Date Website Sets the beginning date for the range of time
the Special Price is offered.

Special Price To Date Website Sets the ending date for the range of time the
Special Price is offered.
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Field Scope Description

Tier Price Website Tier pricing is used to offer a quantity dis-
count. The discount can be applied to specific
customer groups within the selected website.

Apply MAP Website When applied, hides the actual product price
from the customer. Options include:
Yes / No / Use Config

Display Actual Price Website Determines when the customer can see the
actual product price. Options include:

In Cart Displays the actual
product price in the
shopping cart.

Before Order Con-
firmation

Displays the actual
product price only at
the end of the check-
out process, just
before the order is
confirmed.

On Gesture Displays the actual
product price

Use Config Displays the actual
price according to the
configuration setting.

Manufacturer’s Sugges-
ted Retail Price

Global The retail price as suggested by the man-
ufacturer (MSRP).

Tax Class The tax class associated with the product.
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Special Price
To offer a Special Price, enter a discounted price and complete the date range fields to
establish when the promotion goes into effect. On both the catalog list and product
pages, the regular price is crossed out, and the Special Price appears in bold red.

Special Pricing

To display a special price:

1. In the Product Information panel on the left, select Prices.

2. Enter the amount of the Special Price.

3. Complete the Special Price From Date and Special Price To Date to define the period of
time that the special price is in effect. You can pick the dates from the Calendar to

the right of each field.

4. Click the Save button to save your changes.

5. When prompted to update the cache and indexes, follow the instructions at the top of
the page.
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Tier Price
Tier pricing lets you offer a quantity discount from oth the catalog list and product
detail pages. The discount can be applied to a specific store view or customer group.

Tier Price “As Low as”

l On the catalog page, the product price includes the words, “As Low As,” followed by
the lowest tier price.

l On the product page, the calculated quantity discount has the message:

Buy 2 for $__._ each and save _%

The prices in the storefront take precedence from the highest to the lowest quantity.
Therefore, if you have a tier for the quantity 5 and one for the quantity 10 and a
customer adds 5, 6, 7, 8 or 9 items to the shopping cart, then the customer gets the
discounted price that you specified for the quantity 5 tier. As soon as the customer adds
the 10th item, the discounted price specified for the quantity 10 tier supersedes the
quantity 5 tier and that discounted price (of 10) applies instead.
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Tier Price on Product Page

To display a tier price:

1. In the Product Information panel on the left, select Prices.

2. In the Tier Price section, click the Add Tier button. Then, do the following:

Tier Pricing

a. Select theWebsite to which the tier pricing applies.

b. Select the Customer Group for whom the tier pricing is available.
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To apply a tier to multiple groups, but not all groups, create multiple tiers, each
with the same Qty and Price information and select a different customer group for
each.

c. In the Qty field, enter the quantity that must be ordered to receive the discount.

d. In the Price field, enter the adjusted price of the item.

3. When complete, click the Save button.

4. When you are prompted to update the cache and indexes, follow the instructions in the
message at the top of the workspace.

Minimum Advertised Price (MAP)
Merchants are sometimes prohibited from displaying a price that is lower than the
manufacturer’s suggested retail price (MSRP). Magento’s Minimum Advertised Price
(MAP) gives you the ability to remain in compliance with the manufacturer’s
requirements while offering your customers a better price. Because requirements differ
from one manufacturer to another, you can configure your store to prevent the display of
your actual price on pages where it is not allowed to appear according to the terms of
the manufacturer.

“Click for Price” Gesture with Popup
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MAP can be configured at both the global and product levels. There are a variety of
configuration options that you can use to remain in compliance with the terms of your
agreement with the manufacturer, while still offering your customers a better price. Your
store’s MAP settings can be applied to all products in your catalog or configured for only
specific products.

If a product added to the shopping cart has MSRP specified, the price will not be
crossed-out in the mini shopping cart or in the shopping cart.

For products that allow configuration on the frontend, and whose prices depend on a
selected option, (either custom options or simple products with their own SKUs and
stock management), the following logic is implemented:

l MAP is applied to the main price; prices of the options, bundle items, and associated
products (which add or subtract from the main price) are displayed normally.

l If a product does not have a main price, and its price is derived from the associated
products’ prices (such as in a grouped product), the MAP settings of the associated
products are applied. Note that the MAP feature is not supported for bundled
products with dynamic pricing.

Regarding other price settings, the MAP application logic is the following:

l If tier pricing is set, the tier price is displayed according to the Display Actual Price
setting.

l If a special price is set, it is considered to be the actual price for MAP.

In the order management and customer management tools, as well as in the reports
sections of the Admin, only the actual price appears.

Global Configuration
On the global level, you can enable/disable the functionality, apply it to all products,
define how the actual price is displayed, and edit the text of the MAP related messages
and information tips that appear in the store. When MAP is enabled globally, product-
level MAP settings become available. For a product you can choose to apply MAP,
specify the MSRP, and define how the actual price is displayed. Product-level MAP
settings override the global MAP settings.
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Minimum Advertised Price Configuration

To configure MAP globally:

1. On the Admin menu, select System > Configuration.

2. If applicable, in the upper-right corner, set Current Configuration Scope to the website
where the configuration applies.

3. In the panel on the left, under Sales, select Sales. Then, click to expand theMinimum
Advertised Price section, and do the following:

4. To activate MAP, set Enable MAP to “Yes.”

a. Set Apply MAP (Default Value) to one of the following:

l To apply MAP to certain products, select “No.”

l To apply MAP by default to all products and hide all prices throughout the site,
select “Yes.”

b. To determine when and where you want your actual price to be visible to the
customer, set Display Actual Price to one of the following:

l In Cart

l Before Order Confirmation

l On Gesture (on click)

5. When complete, click the Save Config button.
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To configure MAP for a specific product:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, click to expand theMinimum
Advertised Price section. Then, do the following:

a. Set Enable MAP to “Yes.”

b. Set Apply MAP (Default Value) to “No.”

c. Complete the remaining settings as needed. Then, click the Save Config button.

3. Select Catalog > Manage Products, and open the product record.

4. In the Product Information panel on the left, selectPrices. Then, do the following:

a. Enter your Price that is lower than the manufacturer’s minimum advertised price.

b. Set Apply MAP to “Yes.”

c. Set Display Actual Price according to your preference.

d. Enter theManufacturer’s Suggested Retail Price.

5. When complete, click the Save button.

Minimum Advertised Price Configuration

Using MAP with Product Types
Product Type Description

Simple, Virtual The actual price is not shown on the catalog and product
pages; it is displayed according to the Display Actual Price
setting. The custom options prices are displayed normally.
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Product Type Description

Grouped Prices of the associated simple products are not shown on
the catalog and product pages; they are displayed according
to their Display Actual Price setting.

Configurable The actual price is not shown on the catalog and product
pages; it is displayed according to the Display Actual Price
setting. The prices of the options are displayed normally.

Bundle with fixed price The actual price is not shown in the catalog; it is displayed
according to the Display Actual Price setting. The prices of the
bundle items are displayed normally.

Downloadable The actual price is not shown on the catalog and product
pages; it is displayed according to the Display Actual Price
setting. The prices of the links are displayed normally.

Using MAP with Price Settings
Price Setting Description

Tier Price If tier pricing is set, the tier pricing message is not displayed in
the catalog. On the product page a notification is displayed
that indicates that the price can be lower when ordering more
than a certain quantity, but the discount is displayed in per-
centages only. For associated products of a grouped product,
the discounts are not displayed on the product page.
The tier price is shown according to the Display Actual Price
setting.

Special Price If the Special price is specified, the special price is displayed
according to the Display Actual Price setting.

Field Descriptions
Field Description

Enable MAP Activates Minimum Advertised Price for your store.
Options include: Yes / No

Apply MAP Applies MAP by default to all products in the store. Options
include:

Yes Initially hides all prices in the store, and
displays them according to the Display
Actual Price setting.

No Does not apply MAP to all products, by
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Field Description

default. If MAP is enabled, it can still be
applied to products individually.

Display Actual Price Determines where the actual price of a product is visible to the
customer.Options include:

In Cart Displays the actual product price in the
shopping cart.

Before Order
Confirmation

Displays the actual product price at the
end of the checkout process, just before
the order is confirmed.

On Gesture Displays the actual product price in a
popup when the customer clicks the
“Click for price” or “What’s this?” link.

Default Popup Text
Message

The popup text message that appears when the customer
selects the “Click for price” link from a category list or product
view page.

Default “What’s This” Text
Message

The pop-up text message that appears when the customer
clicks the “What’s this?” link from the product view page.

Manufacturer's Sugges-
ted Retail Price

The retail price as suggested by the manufacturer (MSRP).

Product Group Price
Product Group Price enables you to set promotional prices for different customer groups
at the product level. Group price can be used with the following product types:

l Simple

l Configurable

l Virtual

l Bundle

l Downloadable

For bundle products, the group price is specified as a discount percentage. If bundle
items have their own group prices set for the same customer group, then the discount
specified for the whole bundle product applies to the group prices.

For the Grouped product types, the Group Price functionality is not applied, even if
these product types are selected in the Apply To field of the group_price attribute. In
this case, the Group Price field does not appear on the Prices page in Product
Information.
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Important! When a group price is set for a product, then the catalog price rules for the
corresponding customer groups are applied to the group price, not to the regular price.

To set a group price for a product:

1. On the Admin menu, select Catalog > Manage Products. Then in the list, click to open
the product in edit mode.

2. In the panel on the left, click Prices. Then, do the following:

a. In the Group Price field, click the Add Group Price button.

b. Select the target Customer Group and enter the product Price for the group. The
Website column defines the scope of the Group Price field.

3. When complete, click the Save button.

Group Price

Group Price Examples
The following table illustrates how the minimum promotional price logic is
implemented. The table provides several examples, but it is not an exhaustive list of
possible combinations.

Admin Price Settings Price Displayed in Storefront

Price = $4
Special Price = $5
Tier Price = $3

For customers from the tier price group(s):
$ 4
As low as: $3
For customers from other groups: $4

Price = $5
Special Price = $3
Tier Price = $4

For all customers:
Regular Price: $5
Special Price: $3
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Admin Price Settings Price Displayed in Storefront

Price = $5
Special Price = $3
Tier Price = $4
Price after a catalog price rule applied = $2

For customers from the catalog price rule
group:
Regular Price: $5
Special Price: $2
For customers from other groups:
Regular Price: $5
Special Price: $3

Price = $5
Special Price = $4
Group Price = $3

For customers from the price group:
Regular Price: $5
Special Price: $3
For customers from other groups:
Regular Price: $5
Special Price: $4

Group Price Attribute
The list of product types for which group price can be specified is defined in the group_
price attribute properties. The product types that can be used with the attribute are
configured in the the Apply To property.

Group Price Attribute Properties

Regular price The value of the price system product attribute, which by default,

corresponds to the Price specified on the Prices tab in Product

Information.

Promotional price A product price that is defined by any of the following
system product attributes: special_price, group_price, or
tier_price; or the resulting price after a catalog price rule is
applied.



Product Group Price Chapter 16:  Product Pricing

216 Magento Community Edition: User Guide

The display of group prices in the store follows the general logic used for Magento
pricing. If, in addition to the regular price, a product has promotional price(s), the
lowest price appears in the storefront. If a product custom option has price set as a
percentage, then the lowest promotional price is used as base for the calculation. The
same logic applies when the associated products (the options) of a configurable product
have prices set as a percentage.
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Chapter 17:

Storefront Search Tools
Research shows that people who use search are more likely to make a purchase than
those who rely on navigation alone. In fact, according to some studies, people who
use search are nearly twice as likely to make a purchase.

Magento Community Edition has a powerful search engine that you can use as is, or
enhance to make even more effective. In this chapter, we will examine the search
tools that are available to your customers while shopping in your store.

l Quick Search

l Advanced Search

l Search Results

In addition, Magento’s layered navigation gives your customers the ability to filter
product options by price, manufacturer, or any other criteria to reduce the time it
takes to make a purchase.



Quick Search Chapter 17:  Storefront Search Tools

220 Magento Community Edition: User Guide

Quick Search
The Quick Search box in the upper-right corner helps visitors find products in your
catalog. The search text can be the full or partial product name, or any other word or
phrase that describes the product.

To do a quick search:

1. Type the first few letters of what you are looking for into the search box.

2. Press either the Enter key or the button to the right of the search box to retrieve a list of
matching products from the catalog.

Quick Search
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Advanced Search
Advanced Search lets shoppers search through your catalog by entering values into a
form. Because the form contains multiple fields, a single search can include several
parameters. The result of the search is a list of the products that match the search
criteria. A link to Advanced Search is in the footer of your store.

Advanced Search

Each field in the form corresponds to an attribute from your product catalog. You can
determine which fields to include by setting the attribute frontend properties to “Include
in Advanced Search.”

As a best practice, you should include only the fields that your customers are most likely
to use to find a product, because too many can slow down the search.

To use advanced search:

1. In the footer of the store, click the Advanced Search link.

2. In the Search Settings form, enter any value you want to match in as many fields as
necessary. You can find records based on a full or partial match.

3. Click the Search button at the bottom to display the results.
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Search Settings

4. If you don’t see what you are looking for in the search results, click Modify your search
and try another combination of values.

Search Results
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Search Results
The Search Results include all products that match the search parameters entered
through the Quick Search box or the Advanced Search form. Any page in the catalog that
lists products has essentially the same controls. The only difference is that one is the
result of a search query, and the other the result of navigation.

The results can be displayed in either a grid or list format, and the records can be sorted
by any number of parameters. Page controls can be used to sort the list, change the
format, and to advance from one page to the next. Depending on the page layout, the
left column of the page may also include layered navigation under the “Shop By”
heading, with the products listed by category and attribute.

Search Results with Page Controls
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Page Controls
Control Description

View As Displays the list in either a Grid or List format.

Sort By Changes the sort order of the list.

Show Per Page Determines how many products appear per page.

Pagination Links Navigation links to other pages.

To configure the page settings:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Frontend section. Then, adjust the settings according to your
preference.

4. When complete, click the Save Config button.

Catalog Frontend Search Configuration
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Field Descriptions
Field Scope Description

List Mode Store View Determines the format of the search results list.
Options include:

Grid Only Formats the list as a grid
of rows and
columns.Each product
appears in a single cell
of the grid.

List Only Formats the list with
each product on a sep-
arate row.

Grid (default / List) By default, products
appear in Grid view, but
can be toggled to List
view.

List (default / Grid) By default, products
appear in List View, but
can be toggled to Grid
view.

Products per Page on
Grid Allowed Values

Store View Determines the number of products displayed
in Grid View. To provide a selection of options,
enter multiple values separated by commas.

Products per Page on
Grid Default Value

Store View Determines the number of products displayed
per page by default, in Grid View.

Products per Page on
List Allowed Values

Store View Determines the number of products displayed
in List View. To provide a selection of options,
enter multiple values separated by commas.

Products per Page on
List Default Value

Store View Determines the number of products displayed
per page by default, in List View.

Allow All Products per
Page

Store View If set to “Yes,” includes the “ALL” option in the
“Show per Page” control.

Product Listing Sort by Store View Determines the sort order of the search results
list. The selection of options is determined by
the Display Settings of the category and the avail-
able attributes that are set to be “Used for
Sorting in Product Listing.” The default is set to
“Use All Available Attributes,” and typically
includes:
Best Value
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Field Scope Description

Name
Price

Use Flat Catalog Category Global Enables the flat category structure. Options
include: Yes / No

Use Flat Catalog Product Global Enables the flat product structure. Options
include: Yes / No

Allow Dynamic Media
URLs in Products and Cat-
egories

Store View Allows dynamic media URLs, rather than static
URLs.

Popular Search Terms
The Search Terms link in the footer of your store displays the search terms that have
been used by visitors to your store, and ranks them by popularity. Search terms appear
in a “tag cloud” format, where the size of the text indicates the popularity of the term.

By default, Popular Search Terms is enabled as a search engine optimization tool, but
has no direct connection to the catalog search process. Because the Search Terms page is
indexed by search engines, any terms included on the page will help improve your
search engine ranking and the visibility of your store.

Popular Search Terms
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To configure Popular Search Terms:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Catalog, select Catalog. Then, do the
following:

a. Click to expand the Search Engine Optimizations section.

b. Set Popular Search Terms to “Enable.”

3. When complete, click the Save Config button.

Search Engine Optimizations

Catalog Search Configuration
By adjusting the Catalog Search configuration, you can control the behavior of the
search operations and determine the size of valid query text, and the display of search
recommendations.

To configure catalog search:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Catalog, select Catalog. Then, click to
expand the Catalog Search section.

Catalog Search

3. To limit the length and word count of search query text, do the following:



Catalog Search Configuration Chapter 17:  Storefront Search Tools

228 Magento Community Edition: User Guide

a. Set Minimal Query Length to the minimum number of characters that can be
submitted in a query.

b. Set Maximum Query Length to the maximum number of characters that can be
submitted in a query.

c. Set Maximum Query Words Count to the maximum number of words that can be
submitted in a query.

4. Set Search Type to one of the following:

5. To limit the number of records that can be used with layered navigation, enter the
maximum number allowed in the Apply Layered Navigation if Search Results are Less
Than field. To allow any number of records, enter 0.

6. When complete, click the Save Config button.

Field Descriptions
Field Scope Description

Minimal Query Length Store View The minimum number of characters allowed in
a catalog search.

Maximum Query Length Store View The maximum number of characters allowed in
a catalog search.

Maximum Query Words
Count

Store View The maximum number of words allowed in a
query.

Search Type Store View Determines the type of search operation per-
formed by the MySql engine. Options include:

Like Performs a search based on
individual keywords.

Fulltext Performs a search based on
the full text of each attribute
and ranks each by relevence.

Combine
(Like and
Fulltext)

This combination of Like and
Fulltext matches by keyword,
but takes into consideration its
relevence.

Apply Layered Nav-
igation if Search Results
are Less Than

Store View Sets the maximum number of search results
that are displayed as a list. Any results over the
number are shown as layered navigation. To
apply layered navigation to all search results,
enter 0.

Using layered navigation for all search
results can impact performance.
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Chapter 18:

Managing Search Terms
You can learn what your customers are looking for by examining the search terms
they use to find products in your store. If enough people are looking for a product
that you don’t carry, perhaps it’s time to add it to your catalog. Meanwhile, rather
than have them leave them empty handed, why not redirect them to another
product in your catalog? Here are a few ways you can leverage your customers’
search terms:

Landing Page

The landing page for a search term can be a content page, a category page, a product
detail page, or even a page on a different site.

Synonyms

One way to improve the effectiveness of catalog search is to include different terms
that people may use to describe the same item. You don’t want to lose a sale just
because someone is looking for a “sofa,” and your product is listed as a “couch.” You
can capture a broader range of search terms by entering the words, “sofa”
“davenport,” and “loveseat” as synonyms for “couch,” and direct them to the same
landing page.

Misspelled Words

Use search terms to capture common misspellings and redirect them to the
appropriate page. For example, if you sell wrought iron patio furniture, you know
that many people misspell the term as “rod iron,” or even “rot iron.” You can enter
each misspelled word as a search term, and make them synonyms for “wrought
iron.” Even though the word is misspelled, the search will be directed to the page for
“wrought iron.”

Adding Search Terms
As you learn new words that people use to search for products in your catalog, you
can add them to your search terms list to direct people to the closely matching
products in your catalog.
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Search Terms

To add a new search term:

1. On the Admin menu, select Catalog > Search Terms.

2. Click the Add New Search Term button. Then, do the following:

a. In the General Information section, in the Search Query box, type the word or
phrase that you want to add as a new search term.

General Information

b. Select the Store where the search term will be used. If your store is available in
multiple languages, select the applicable store view.

c. If this term is a synonym for another search term, enter the other term in the
Synonym For field. Any search for the synonym will be automatically redirected to
the page for the other term.

d. To redirect the search results to another page in your store, or to another website,
type the full URL of the target page in the Redirect URL field.

e. If you want this term to be available for use as a suggestion whenever a search
returns no results, set Display in Suggested Terms to “Yes.”

3. When complete, click the Save Search button.
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To edit a search term:

1. On the Admin menu, select Catalog > Search Terms.

2. Click the row of any record to open the search term in edit mode.

3. Make the necessary changes.

4. When complete, click the Save Search button.

To delete a search term:

1. In the list, select the checkbox of the term to be deleted.

2. In the upper-right corner of the list, set the Actions control to “Delete.”

3. When complete, click the Submit button.
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Chapter 19:

SEO Best Practices
Search engine optimization is the practice of fine-tuning the content and
presentation of a site to improve the way the pages are indexed by search engines.
Magento Community Edition includes a number of features that support your
ongoing effort to improve the indexing of your site, such as:

l Meta Information

l Sitemap

l Catalog URL Options

l Dynamic Media URLs

l Canonical Meta Tag

l URL Rewrites
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Meta Information
Your store is loaded with places where you can enter keyword-rich meta data to improve
the way search engines index your site. While setting up your store, you might have
entered preliminary meta data, with the intention of finishing it later. Over time, you
can fine-tune the meta data to target the buying patterns and preferences of your
customers.

Meta Title

The meta title appears in the title bar
and tab of your browser, and search
results listings. The meta title should be
unique to the page, and less than 70
characters in length.

Meta Keywords

Although some search engines ignore
meta keywords, others continue to use
them. The current best practice is to

incorporate high-value keywords in the
meta title and meta description.

Meta Description

Meta descriptions provide a brief
overview of the page for search results
listings. Ideally, a meta description
should be between 150-160 characters in
length, although the field will accept up
to 255 characters.
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Sitemap
The default Magento sitemap has links to every product and category in your store, and
can help improve the way your products are indexed by some search engines. Like a
table of contents, the sitemap also gives visitors a quick overview of the organization of
your catalog. To switch between the category and product lists, click the link on the
right. By default, the footer of your store includes a link to the sitemap.

Sitemap

The sitemap can be formatted as a nested, tree-like structure, or as a simple list. The
number of lines included per page, and the use of indentation is set in your system
configuration.

Because the Magento sitemap does not include CMS pages, it is not a complete index to
the content on your site. In addition to the default sitemap, it is recommended that you
also generate a Google sitemap that can be used for reference when your site is indexed
by Google.

To set up the sitemap:

1. On the Admin menu, select System > Configuration. Then in the panel on the left,
under Catalog, select Catalog.

2. Click to expand the Sitemap section. Then, set the following options according to your
preference:

l Use Tree Like Category Sitemap

l Minimum Lines per Page
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Sitemap Configuration

3. Scroll down the page and click to expand the Search Engine Optimizations section.
Then, set Autogenerated Site Map to “Enable.”

4. When complete, click the Save Config button.

Catalog URL Options
Although you might not give it much thought at the beginning, the URLs you assign to
products and categories play a major role in determining how well your site is indexed
by search engines.

Before you start building your catalog is an ideal time to consider the available options.
Magento creates both dynamic and static URLs. In addition, there are several
configuration options that determine the format of URLs used for items in your catalog.

Dynamic URL
A dynamic URL is created “on the fly,” and might include a query string with variables
for the product ID, sort order, and the page where the request was made. When a
customer searches for a product in your store, the resulting URL might look something
like this:

http://mystore.com/catalogsearch/result/?q=tee+shirt

Dynamic URL

Static URL
A static URL is a fixed address for a specific page. A static URL can be displayed in a
search-engine friendly format, or one that references products and categories by ID.
Search-engine friendly URLs include words that people might use to look for a product,
and are created by enabling Web Server Rewrites.

http://mystore.com/accessories/eyewear.html

http://mystore.com/catalog/product/view/id/409/s/chelsea-tee-

409/category/16/

Static URL
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To configure search-engine friendly URLs:

1. On the Admin menu, select System > Configure. Then in the panel on the left under
General, select Web.

2. Click to expand the Search Engine Optimization section.

3. Set Use Web Server Rewrites to “Yes.”

4. When complete, click the Save Config button.

URL Key
The URL key is the part of of a static URL that describes the product or category. When
you create a product or category, an initial URL key is automatically generated based on
the name. The URL key should consist of lowercase characters with hyphens to separate
words. A well-designed, “search engine friendly” URL key might include the product
name and key words to improve the way it is indexed by search engines. The URL key
can be configured to create an automatic redirect if the URL key is changed.

Store Code
The store code can be included in the URL. However, it might cause problems if third-
party services, such as PayPal, are configured to work with a URL that does not include
the code. By default, the store code is not included in URLs.

To configure the store code for URLs:

1. On the Admin menu, select System > Configure. Then in the panel on the left under
General, select Web.

2. Click to expand the URL Options section.

3. Set Add Store Code to your preference.

4. When complete, click the Save Config button.

URL Options
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HTML Suffix
Your catalog can be configured to either include or exclude the .html suffix as part of
category and product URLs. There are various reasons why people might choose to use
or to omit the suffix. Some believe that the suffix no longer serves any useful purpose,
and that pages without a suffix are indexed more effectively by search engines. However,
your company might have a standardized format for URLs, that requires a suffix.

The most important thing to understand is that the suffix is controlled by your system
configuration. Never type the suffix directly into the URL key of a category or product.
(Doing so will result in a double suffix at the end of the URL.)

Whether you decide to use the suffix or not, be consistent and use the same setting for
all your product and category pages. Here are examples of a category URL with, and
without, the suffix.

http://mystore.com/accessories/eyewear.html

http://mystore.com/accessories/eyewear/retro-chic-eyeglasses

URL Suffix Examples

Category Path
You can configure the URL to either include or exclude the category path. By default, the
category path is included in all category and product pages. The following examples
show the same product URL with, and without, the category path.

http://mystore.com/accessories/eyewear/retro-chic-eyeglasses

http://mystore.com/retro-chic-eyeglasses

Category Path Examples

To prevent search engines from indexing multiple URLs that lead to the same content,
you can exclude the category path from the URL. Another method is to use a canonical
meta tag to let search engines know which URLs to index and which to ignore.

To configure catalog URLs:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Search Engine Optimizations section. Then, do the following:

a. Set Product URL Suffix to “html” or “htm.” Do not include a period before the suffix.

b. Set Category URL Suffix to “html” or “htm.” Do not include a period before the
suffix.
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c. Set the category path to your preference. To omit the category path from product
URLs, set Use Categories Path for Product URLs to “No.”

4. When complete, click the Save Config button.

5. After the setting is saved, you will be prompted to refresh the cache. Click the Cache
Management link in the message at the top of the workspace. Then, follow the
instructions to refresh the cache.

Search Engine Optimizations

Field Descriptions 
Field Scope Description

Autogenerated Site Map Store View Determines if the Magento site map is imple-
mented in the store. When enabled, a link to the
site map appears in the footer. Options include:
Enable / Disable.

Popular Search Terms Store View Determines if Popular Search Terms is imple-
mented in the store. Options include: Enable /
Disable.

Product URL Suffix Store View Determines if a suffix, such as html or htm, is
applied to product URLs. If used, do not include
a period before the suffix, because it is applied
automatically.

Category URL Suffix Store View Determines if a suffix, such as html or htm, is
applied to category URLs. If used, do not include
a period before the suffix, because it is applied
automatically.

Use Categories Path for
Product URLs

Store View Determines if category paths are included in
product URLs. Doing so can cause multiple URLs
that lead to the same page. To learn more, see:
Canonical Meta Tag.

Create Permanent Redir- Store View Determines if a permanent redirect is created
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Field Scope Description

ect for URLs if URL Key
Changed

Page Title Separator Store View Identifies the character that separates the cat-
egory name and subcategory in the page title
that appears in the browser.

Use Canonical Link Meta
Tag for Categories

Store View If there are multiple URLs that point to the same
category page, uses a canonical meta tag to
identify the category URL that search engines
should index. Options include: Yes / No.

Use Canonical Link Meta
Tag for Products

Store View If there are multiple URLs that point to the same
product page, uses a canonical meta tag to
identify the product URL that search engines
should index. Options include: Yes / No.

Dynamic Media URLs
A dynamic media URL is a relative reference to an image or other media asset. When
enabled, dynamic media URLs can be used to link directly to assets on your server, or
even on a CDN. As with all markup tags, the code is enclosed in double curly braces. The
format of a dynamic media URL looks like this:

{{media url="path/to/image.jpg"}}

Dynamic Media URL

If you prefer to use a static URL, you can change the configuration setting. If dynamic
media URLs are included in your catalog, but later the setting is disabled, each reference
in your catalog will appear as a broken link. However, the links can be restored by again
enabling dynamic media URLs. Using dynamic media URLs can enhance your catalog,
but can also impact the performance of catalog search.
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Allow Dynamic Media URLs in Products and Categories

To configure dynamic media URLs:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Catalog, select Catalog.

3. Click to expand the Frontend section. Then, set Allow Dynamic Media URLs in
Products and Categories to either “Yes” or “No.”

4. Click the Save Config button to save the setting.
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To use static URLs by default for media files:

By default, images inserted into the catalog from media storage have relative, dynamic
URLs. If you prefer to use a static URL, you can change the configuration setting.

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under General, select Content Management.

3. In the WYSIWYG Options section, set Use Static URLs for Media Content in WYSIWYG
for Catalog to “Yes.”

4. Click the Save Config button to save the setting.

Enable WYSIWYG Editor

Canonical Meta Tag
Some search engines penalize websites that have multiple URLs that point to the same
content. The canonical meta tag tells search engines which page to index when multiple
URLs have identical or very similar content. Using the canonical meta tag can improve
your site ranking and aggregate pageviews.

For example, if your catalog is configured to include the category path in product URLs,
your store will generate multiple URLs that point to the same product page.

http://mystore.com/furniture/living-room/microfiber-sofa-sleeper

http://mystore.com/microfiber-sofa-sleeper

The canonical meta tag is placed in the <head> block of a product or category page. It
provides a link to your preferred URL, so search engines will give it greater weight.

When canonical meta tags for categories are enabled, the category page of your store
includes a canonical URL to the full category URL:

http://mystore.com/furniture/living-room/microfiber-sofa-sleeper

when canonical meta tags for products are enabled, the product page includes a
canonical URL to the domain-name/product-url-key because product URL keys are
globally unique.

http://mystore.com/microfiber-sofa-sleeper
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If you also include the category path in product URLs, the canonical URL remains
domain-name/product-url-key. However, the product can also be accessed using its full
URL, which includes the category. For example, if the product URL key is microfiber-
sofa-sleeper and is assigned to the Furniture > Living-Room category, the product can
be accessed using either URL.

You can avoid being penalized by search engines by omitting the category from the URL,
or by using the canonical meta tag to direct search engines to index either by product or
category. As a best practice, it is recommended that you enable canonial meta tags for
both categories and products.

To enable the canonical meta tag:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, select Catalog.

3. Click to expand the Search Engine Optimizations section.

4. If want search engines to index only pages that have a full category path, do the
following:

a. Set Use Canonical Link Meta Tag for Categories to “Yes.”

b. Set Use Canonical Link Meta Tag for Products to “No.”

5. If you want search engines to index only product pages, do the following:

a. Set Use Canonical Link Meta Tag for Products to “Yes.”

b. Set Use Canonical Link Meta Tag for Categories to “No.”

6. When complete, click the Save Config button.
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Chapter 20:

Managing URL Rewrites
The URL Rewrite tool lets you change any URL that is associated with a product,
category, or CMS page. When the rewrite goes into effect, any links that point to the
previous URL are redirected to the new address.

The terms rewrite and redirect are often used interchangeably, but refer to slightly
different processes. A URL rewrite changes the way a URL appears in the browser. A
URL redirect, on the other hand, updates the URL that is stored on the server. A
URL redirect can be either temporary or permanent. Your store uses URL rewrites
and redirects to make it easy for you to create search engine friendly URLs and to
preserve existing links.

Create Permanent Redirect for Old URL

Automatic Product Redirects
Your store can be configured to automatically generate a permanent redirect
whenever the URL key of a product changes. In the product record, the checkbox
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below the URL key indicates if permanent redirects are enabled for your catalog. If your
store is already configured to automatically redirect catalog URLs, making a redirect is
as easy as updating the URL key.

To set up automatic redirects:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Search Engine Optimizations section. Then, set Create Permanent
Redirect for URLs if URL Key Changed to “Yes.”

Create Permanent Redirect

4. When complete, click the Save Config button.

To automatically redirect catalog URLs:

1. On the Admin menu, select Catalog > Manage Products.

2. Find the product in the list, and click to open the record.

3. In the URL Key field, do the following:

a. Make sure that the Create Permanent Redirect for old URL checkbox is selected. If
not, complete the instructions to enable automatic redirects.

b. Update the URL Key as needed, using all lowercase characters and hyphens instead
of spaces.

4. When complete, click the Save button.

5. When prompted to refresh the cache and index, click the links in the messages that
appear at the top of the workspace. Follow the instructions.

The permanent redirect is now in effect for the product and any associated category
URLs.
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6. To view the redirect records, select Catalog > URL Rewrite Management. The most
recent permanent redirects are at the top of the list.

Creating URL Rewrites
The URL Rewrite tool can be used to create product and category rewrites, and custom
rewrites for any page in your store. When the rewrite goes into effect, any existing links
that point to the previous URL are seamlessly redirected to the new address.

You can use rewrites to create additional URLs for items, as a temporary seasonal
change, or as a permanent change. Rewrites can be created for any valid path, including
CMS content pages. Internally, the system references products and category by ID. No
matter how often the URL changes, the ID remains the same. Here are some examples of
how you might use URL rewrites:

Original URL
http://www.example.com/peripherals/ergonomic-keyboard.html

Additional Product URL
http://www.example.com/best-keyboard.html

Additional Category URL
http://www.example.com/all-on-sale.html

http://www.example.com/save-now/spring-sale
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URL Rewrite Management

The following instructions show how to use the URL Rewrite tool to create three different
kinds of redirects:

l Product Rewrite

l Category Rewrite

l Custom Rewrite

Creating a Product Rewrite

Step 1: Request a Product Rewrite

1. On the Admin menu, select Catalog > URL Rewrite Management.

2. In the upper-right corner, click the Add URL Rewrite button.

3. Set Create URL Rewrite to “For product.”

Create URL Rewrite for Product

4. In the list, find the product that you want to redirect, and click the record.

5. Scroll down to the bottom of the Select Category tree, and click the Skip Category
Selection button.

6. In the URL Rewrite Information section, do the following:
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URL Rewrite Information

a. If you have multiple stores, set Store to the specific view where the rewrite applies.

b. In the Request Path field, enter the URL key of the page to be redirected.

c. Set Redirect to one of the following:

l Temporary (302)

l Permanent (301)

d. For your own reference, enter a brief description of the rewrite.

7. When complete, click the Save button.

Your new product rewrite now appears at the top of the list.

New Product Rewrite

Step 2: Refresh the Index

1. On the Admin menu, select System > Index Management.

2. Select the Catalog URL Rewrites checkbox.

3. Set the Actions control to “Reindex Data,” and click the Submit button.
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Refresh Catalog URL Rewrite Index

Step 3: Test the Rewrite

Test the rewrite from your store, to make sure that it works correctly.

Creating a Category Rewrite

Step 1: Request a Category Rewrite

1. On the Admin menu, select Catalog > URL Rewrite Management.

2. In the upper-right corner, click the Add URL Rewrite button.

3. By default, Create URL Rewrite is set to “For category.” In the category tree, click to
select the category to be redirected.

Select Category

4. In the URL Rewrite section, do the following:

a. If you have multiple stores, select the Store where the rewrite applies.

b. In the Request Path field, enter the URL key of the category to be redirected.
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c. Set Redirectto one of the following:

l Temporary (302)

l Permanent (301)

d. For your own reference, enter a brief description of the rewrite.

5. When complete, click the Save button.

Category URL Rewrite Information

Your new category rewrite now appears at the top of the list of rewrites.

New Category Rewrite

6. Test the rewrite from your store, to make sure that it works correctly.

Step 2: Refresh the Index

1. On the Admin menu, select System > Index Management.

2. Select the Catalog URL Rewrites checkbox.

3. Set the Actions control to “Reindex Data,” and click the Submit button.
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Refresh Catalog URL Rewrite Index

Step 3: Test the Rewrite

Test the rewrite from your store, to make sure that it works correctly.

Creating a Custom Rewrite

Step 1: Take Note of the Request Path and Target Path

Before you begin, write down the URL keys of the page to be redirected (Request Path),
and the target page where it will be redirected (Target Path).

Step 2: Request a Custom Rewrite

1. On the Admin menu, select Catalog > URL Rewrite Management.

2. In the upper-right corner, click the Add URL Rewrite button.

3. Set Create URL Rewrite to “Custom.”

Custom URL Rewrite

4. In the URL Rewrite Information section, do the following:

a. If you have multiple stores, select the Store where the rewrite applies.

b. In the ID Path field, enter the relative path of the destination page.

l To redirect to another CMS page in your store, enter the relative path to the page,
without a leading forward slash.

l To redirect to a page on a different site, enter the fully qualified URL of the new
destination.

new-page URL key of target page.
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somewhere/new-page Relative path to target page, without leading forward
slash.

http://magento.com Fully qualified URL of target page on external website.

c. In the Request Path field, enter the relative path of the page to be redirected.

d. In the Target Path field, enter the valid URL of an existing page that will be the new
destination. This refers to the same page as the ID Path.

e. Set Redirect to one of the following:

l Temporary (302)

l Permanent (301)

f. For your own reference, enter a brief Description of the rewrite.

In the following illustration, the CMS page “about-magento-demo-store” is
temporarily redirected to the target, “my-page.”

Custom URL Rewrite Information

5. When complete, click the Save button.

Your new rewrite now appears at the top of the list.

New Custom Rewrite
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Step 3: Refresh the Index

1. On the Admin menu, select System > Index Management.

2. Select the Catalog URL Rewrites checkbox.

3. Set the Actions control to “Reindex Data,” and click the Submit button.

Refresh Catalog URL Rewrite Index

Step 4: Test the Rewrite

Test the rewrite from your store, to make sure that it works correctly.

Field Descriptions
Field Description

Create URL Rewrite Indicates the type of rewrite to be made. The type cannot be
changed after the rewrite is created. Options include:
For Category
For Product
Custom

ID Path The ID of the target page. The ID Path and Target Path refer to
the same page.

Request Path The URL of the page that is to be redirected. Depending on
your configuration, the Request Path might include the .html
suffix and category. For example:
brandname
brand/brandname
catalog/category/view/id/56
private-sale-shoes/prima-pump.html
brand/brandname.html
A Request Path must be unique, and must not have been
used previously. If you have made several attempts to redirect
the same page, delete any unsuccessful redirects and refresh
the cache.
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Field Description

Target Path The URL that points to the destination page. The Target Path
can be a different CMS page, or the result of a search.
To avoid getting a 404 "Page Not Found" error, the path must
exactly match what the system expects to find. The following
examples are valid target paths:
brandname
brand/brandname
catalog/category/view/id/52
catalogsearch/advanced/result/?brand=brandname
http://magentocommerce.com

Redirect Indicates whether the rewrite is temporary or permanent.
Options include:

No

Temporary (302) Indicates to search engines that the
rewrite is for a limited duration. Search
engines do not preserve page rank
information for temporary rewrites.

Permanent
(301)

Indicates to search engines that the
rewrite is permanent. Search engines gen-
erally preserve page rank informaton for
permanent rewrites.

Description Describes the purpose of the rewrite. This field is for reference
and is not visible to customers.
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Chapter 21:

Promotions
In this chapter, you will learn how to set up product relationships, and use price
rules to trigger discounts based on a variety of conditions. Here are a few ways you
can use price rules to offer incentives to your customers:

l Send your best customers a coupon for a discount on a specific product

l Offer free shipping for purchases over a certain amount

l Schedule a promotion for a period of time

With price rules, you can set up your promotions in advance, so they spring into
action whenever the required conditions are met.
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Product Relationships
An easy way to promote products throughout your catalog is to establish relationships
between products. The options available are: Up-sell products, Related products, and
Cross-sell products.

Related Products

Related products are meant to be
purchased in addition to the item the
customer is viewing. They compliment,
enhance, or add optional features to the
product.

Up-sells

Up-sell products are items that are
similar, but are perhaps of a higher-

quality, more popular, or have a better
profit margin than the item the

customer is considering.

Cross-sells

Cross-sell products are offered on the
shopping cart page as last-minute
purchases before the checkout process
begins.
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Catalog Price Rules
Catalog price rules can be used to selectively put products on sale under certain
conditions. Catalog price rules do not use coupon codes, because they are triggered
before a product is placed into the shopping cart.

Catalog Rules

Process Overview:
Step 1: Add a New Rule
Step 2: Define the Conditions
Step 3: Define the Actions
Step 4: Apply the Rule

Step 1: Add a New Rule

1. On the Admin menu, select Promotions > Catalog Price Rules.

2. In the upper-right corner, click the Add New Rule button.

The options in the panel on the left include Rule Information, Conditions, and Actions.
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Rule Information

3. On the Rule Information page, do the following:

a. Complete the Rule Name and Description fields. These fields are for your internal
reference only.

b. Set Status to “Active.”

c. Select theWebsites where the rule will be available.

d. Select the Customer Groups to which this rule applies.

To select multiple options, hold down the Ctrl key (PC) or Command key (Mac), and
click each option.

e. Set From Date and To Date to define the range of dates when the rule will be in
effect. If you leave the dates blank, the rule is enabled as soon as the price rule is
saved.

f. Enter a number to establish the Priority of this rule in relation to other rules.

Step 2: Define the Conditions

Most of the available conditions are based upon existing attribute values. If you want to
apply the rule to all products, leave the conditions blank.

1. In the panel on the left, select Conditions. The first rule begins:

Condition - Line 1
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The statement has two underlined links, which when clicked, display the options for
that part of the statement. If you save the condition without making additional
selections, the rule will apply to all products.

l Click the ALL link, and select “ALL” or “ANY.”

l Click the TRUE link and select “TRUE” or “FALSE.”

l Leave the condition unchanged to apply the rule to all products.

You can create different conditions by changing the combination of these values.

If ALL of these conditions are TRUE:

2. Click the Add button at the beginning of the next line.

a. In the list under Product Attribute, select the attribute that you want to use as the
basis of the condition. For this example, the selected condition is “Attribute Set.”

Condition Line 2, Part 1

For an attribute to appear in the list, it must be configured to be used in promo rule
conditions. To learn more, see: Attribute Frontend Properties.

The selected condition appears in the statement, followed by two more underlined
links. The statement now says:

If ALL of these conditions are TRUE:

Attribute Set is …

b. Click the is link, and select the comparison operator that is needed to describe the
condition to be met. In this example, the options are “IS” or “IS NOT.”

c. Then, click the ... “more” link, and choose the attribute set upon which the condition
is based.
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Condition Line 2, Part 3

The selected item appears in the statement to complete the condition.

If ALL of these conditions are TRUE:

Attribute Set is Eyewear

3. To add another line to the statement, click the Add button, and choose one of the
following:

l Conditions Combination

l Product Attribute

Then, repeat the process until the condition is complete.

If at any time you want to delete part of the statement, click the Delete button at the
end of the line.

Step 3: Define the Actions

1. In the panel on the left, select Actions.

Actions

2. In the Update Prices Using the Following Conditions section, set Apply to one of the
following options:
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By Percentage of the
Original Price

Discounts item by subtracting a percentage from the
original price. For example:

Enter 10 in Discount Amount for an updated price that is
10% less than the original price.

By Fixed Amount Discounts item by subtracting a fixed amount from original
price. For example:

Enter 10 in Discount Amount for an updated price that is
$10 less than the original price.

To Percentage of the
Original Price

Discounts item by defining the final price based on
percentage. For example:

Enter 10 in Discount Amount for an updated price that is
10% of the original price.

To Fixed Amount Sets the price to a fixed amount.

Then, do one of the following:

l Enter the Discount Amount.

l To apply the discount amount to associated products, set Enable Discount to
Subproducts to “Yes.” Then, enter the Discount Amount to apply.

3. If you want to stop the processing of other rules after this rule has been applied, set Stop
Further Rules Processing to “Yes.” This safeguard prevents customers from receiving
multiple discounts for the same product.

4. Click the Save and Continue Edit button to save your changes.

Step 4: Apply the Rule

As new rules are added, the prices and the priorities are recalculated accordingly.

To apply a new rule immediately, do one of the following:

l Click the Save and Apply button.

l From the Catalog Price Rules list, click the Apply Rules button.

When you create a new price rule, it might take an hour or so for it to become available.
Allow enough time for it to get into the system. Then, test the rule to make sure that it
works correctly. Unless otherwise specified, price rules are automatically processed with
other system rules each night.
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Price Rule with Multiple SKUs
A single price rule can be applied to multiple SKUs, which makes it possible to create a
variety of promotions based on a product, brand, or category. In the following
illustration, multiple products are selected for a catalog price rule.

Selecting Multiple SKUs for a Price Rule Condition

To apply a price rule to multiple SKUs:

1. On the Admin menu, select Promotions > Catalog Price Rules.

2. Do one of the following:

l Follow the instructions to create a catalog price rule.

l In the list, click to open the catalog price rule that you want to change.

3. In the panel on the left, select Conditions. Then, do the following:

a. In the first line, set the first parameter to “ANY.”

If ANY of these conditions are TRUE

b. If the price rule doesn't have a line for SKU, Click the Add button at the
beginning of the next line. Then, in the list under Product Attribute, select SKU.
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Choose the Condition

c. Click the … “more” link to display more options. Then, click the Chooser button
to display the list of available products.

SKU IS

d. In the list, select the checkbox of each product that you want to include. Then, click
the Select button to add the SKUs to the condition.

Multiple SKUs Added to Condition

4. Complete the rule, including any Actions to be taken when the conditions are met.

5. To apply the rule, click the Save Rule button.

When you create a new price rule, it might take an hour or so for it to become available.
Allow enough time for it to get into the system. Then, test the rule to make sure that it
works correctly. Unless otherwise specified, price rules are automatically processed with
other system rules each night.

Shopping Cart Price Rules
Shopping cart price rules create discounts for orders at the checkout level, based on a set
of conditions. The discount can be applied automatically when the conditions are met,
or be applied when the customer enters a valid coupon code. When applied, the discount
appears on the shopping cart page under the subtotal.

Once established, the price rule can be used as needed for a season or promotion by
changing its status and date range.
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Apply Coupon in Shopping Cart

Process Overview:
Step 1: Add a New Rule
Step 2: Define the Conditions
Step 3: Define the Actions
Step 4: Complete the Labels
Step 6: Apply the Rule

Step 1: Add a New Rule

1. On the Admin menu, select Promotions > Shopping Cart Price Rules. Then, click the
Add New Rule button.

Shopping Cart Price Rules

The options in the panel on the left include Rule Information, Conditions, Actions, and
Labels.
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Shopping Cart Price Rule General Information

2. Under General Information, complete the Rule Name and Description. These fields are
for internal reference only.

3. If you want the rule to go into effect immediately, set Status to “Active.”

4. To establish the scope of the rule, do the following:

a. Select theWebsites where the promotion is to be available.

b. Select the Customer Groups to which the promotion applies.

l To make the promotion available only to registered customers, do not select the
“NOT LOGGED IN” option.

To select multiple options, hold down the Ctrl key (PC) or Command key (Mac), and
click each option.

5. To associate a coupon with the price rule, set Coupon to “Specific Coupon.” Then, do the
following:

a. Enter a numeric Coupon Code that the customer must enter to receive the discount.

b. To set a limit on the number of times the coupon can be used, complete the
following:
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Uses per Coupon Determines how many times the coupon code can be
used. If there is no limit, leave the field blank.

Uses per Customer Determines how many times the coupon code can be
used by the same registered customer who belongs to
any of the selected customer groups. The setting does
not apply to guest shoppers who are members of the
NOT LOGGED IN customer group, or to customers who
shop without logging in to their accounts. If there is no
limit, leave the field blank.

6. To define the “good through” date range for the promotion, do the following:

a. Click the Calendar button next to the From Date field, and choose the first date.
The promotion will start at the beginning of that day.

b. Click the Calendar button next to the To Date field, and choose the last date.
The promotion will stop at the end of that day.

7. Enter a number to determine the Priority of this price rule in relation to the Action
settings of other price rules that might be active at the same time. (Number 1 has the
highest priority.)

8. To apply the rule to published listings in RSS feeds, set Public In RSS Feed to “Yes.”

Step 2: Define the Conditions

In this step, the conditions are described that must be met for an order to qualify for the
promotion. The rule goes into action whenever the set of conditions is met.

1. In the panel on the left, select Conditions. The first rule appears by default, and states:

If ALL of these conditions are TRUE:

The statement has two underlined links which when clicked, display the selection of
options for that part of the statement. You can create different conditions by changing
the combination of these values. Do any of the following:

l Click the ALL link, and select “ALL” or “ANY.”

l Click the TRUE link and select “TRUE” or “FALSE.”

l Leave the condition unchanged to apply the rule to all products.

Condition - Line 1
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2. Click the Add button at the beginning of the next line. Then, choose one of the
following options from the list to describe the condition that you want to set for the rule.

l Product attribute combination

l Products subselection

l Conditions combination

l Cart Attribute

Condition - Line 2, Part 1

Example 1: To create a regional price rule, select one of the following cart attributes:

l Shipping Postcode

l Shipping Region

l Shipping State/Province

l Shipping Country

Example 2: To base the condition on shopping cart totals, select one of the following
cart attributes:

l Subtotal

l Total Items Quantity

l Total Weight

When you make a selection, the basic structure of the statement appears in the box with
additional links to mark where you can select information. Each underlined word is a
building block that describes a different aspect of the condition.

3. In the list under Product Attribute, select the attribute upon which the condition is
based. For this example, the selected condition is “Attribute Set.”

Condition - Line 2, Part 1
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For an attribute to appear in the list, its Use for Promo Rules Conditions property must
be set to “Yes.”

The condition appears in the statement, followed by two more underlined links. The
statement now says:

Condition - Line 2, Part 2

If ALL of these conditions are TRUE:

If an item is FOUND in the cart with ALL of these conditions true

Attribute Set is …

4. Click the is link, and select the comparison operator that is needed to describe the
condition to be met. In this example, the options are “IS” and “IS NOT.”

5. Click the ... “more” link, and choose the attribute set upon which the condition is based.
The selected item appears in the statement to complete the condition.

Completed Condition

If ALL of these conditions are TRUE:

Attribute Set is Electronics

6. To add more conditions, click the Add button and again, choose one of the following:

l Conditions Combination

l Product Attribute

Then, repeat the process until the condition is complete.

If at any time you want to delete part of the statement, click the Delete button at the
end of the line.

Step 3: Define the Actions

The shopping cart price rule actions describe how prices are updated when the
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conditions of the rule are met.

Shopping Cart Price Rule Actions

1. In the panel on the left, select Actions.

2. Set Apply to one of the following discount options:

Percent of product price
discount

Discounts item by subtracting a percentage from the
original price. The discount applies to each qualifying item
in the cart. For example:

Enter 10 in Discount Amount for an updated price that is
10% less than the original price.

Fixed amount discount Discounts item by subtracting a fixed amount from original
price. The discount applies to each qualifying item in the
cart. For example:

Enter 10 in Discount Amount for an updated price that is
$10 less than the original price.

Fixed amount discount
for whole cart

Discounts the entire cart by subtracting a percentage from
the cart total. For example:

Enter 10 in Discount Amount to subtract 10% from the cart
total.

Buy X get Y free Defines a quantity that the customer must purchase to
receive a quantity for free. (The Discount Amount is Y.)

3. Enter the Discount Amount as a number, without symbols. For example, depending on
the discount option selected, the number 10 might indicate a percentage, a fixed
amount, or a quantity of items.

4. In theMaximum Qty Discount is Applied To field, enter the largest number of the same
product that can qualify for the discount.
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5. To determine how free shipping is applied, set Free Shipping to one of the following:

No Free shipping is not available for the promotion.

For matching items only Free shipping is available only for specific items in the cart
that match the rule.

For shipment with
matching items

Free shipping is available for the entire cart when a coupon
that is based on the rule is used.

6. Set Stop Further Rules Processing to “Yes” to stop processing other rules as soon as this
one is applied. This safeguard prevents customers from receiving multiple discounts for
the same purchase.

7. To define an additional action that applies to specific items in the cart, only when a
specific set of conditions is met, click the Add button. Then, choose an item from the
following sections in the list:

l Cart item attribute

l Price in cart

l Quantity in cart

l Row total in cart

l Product attribute (from all available in your catalog)

Add as many levels as you need to describe the conditions to be met.

8. When complete, click the Save Rule button.

Step 4: Complete the Labels

The label appears on the order below the subtotal to identify the discount. You can enter
a default label for all store views, or enter a different label for each view.

1. In the panel on the left, select Labels.

2. In the Default Label section, enter the text for the Default Rule Label for All Store
Views.

Default Label

3. In the Store View Specific Labels section, enter the label text for each store view. For
example, if each store view is in a different language, enter the label translation for each
view.
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Store View Specific Labels

Step 5: Apply the Rule

1. When complete, click the Save Rule button.

2. When you create a new price rule, it might take an hour or so for it to become available.
Allow enough time for it to get into the system. Then, test the rule to make sure that it
works correctly. Unless otherwise specified, price rules are automatically processed with
other system rules each night. As new rules are added, Magento recalculates the prices
and the priorities accordingly.

Field Descriptions
Field Description

Rule Information
Rule Name (Required) The name of the rule is for internal reference.

Description A description of the rule should include the purpose of the
rule, and explain how it is used.

Status (Required) Determines if the rule is currently active in the
store. Options include: Active / Inactive

Websites (Required) Identifies the websites where the rule can be used.

Customer Groups (Required) Identifies the customer groups to which the rule
applies.

Coupon (Required) Indicates if a coupon is associated with the rule.
Options include:

No Coupon There is no coupon associated with the
rule.

Specific Coupon A specific coupon is associated with the
rule.
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Field Description

Coupon Code When prompted,
enter the Coupon
Code that the cus-
tomer must enter to
take advantage of the
promotion.

Use Auto Gen-
eration

Select the checkbox to
automatically generate
multiple coupon
codes which can be
used with the pro-
motion.

Uses per Coupon The number of times the coupon code can be used.

Uses per Customer Determines how many times the coupon code can be used by
the same registered customer who belongs to any of the selec-
ted customer groups. The setting does not apply to guest
shoppers who are members of the NOT LOGGED IN cus-
tomer group, or to customers who shop without logging in to
their accounts. If there is no limit, leave the field blank.

From Date The first date in the “good through” time period when the
coupon can be used.

To Date The last date in the “good through” time period when the
coupon can be used.

Priority A number that indicates the priority of this rule in relation to
others. The highest priority is number 1.

Public in RSS Feed Determines if the promotion is included in your store’s public
RSS feed. Options include: Yes / No.

Actions

Apply Determines the type of calculation that is applied to the pur-
chase. Options include:
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Field Description

Percent of
product price
discount

Discounts item by subtracting a per-
centage from the original price.
For example: Enter 10 in Discount
Amount for an updated price that is 10%
less than the original price.

Fixed amount
discount

Discounts item by subtracting a fixed
amount from original price.
For example: Enter 10 in Discount
Amount for an updated price that is $10
less than the original price.

Fixed amount
discount for
whole cart

Discounts the entire cart by subtracting a
percentage from the cart total.
For example: Enter 10 in Discount
Amount to subtract 10% from the cart
total.

Buy X Get Y Free
(discount
amount is Y)

Defines a quantity that the customer
must purchase to receive a quantity for
free. (The Discount Amount is Y.)

Discount Amount (Required) The amount of discount that is offered.

Maximum Qty Discount
is Applied To

Sets the maximum number of products that the discount can
be applied to in the same purchase.

Discount Qty Step (Buy X) Sets the number of products represented by “X” in a “Buy X
Get Y Free” promotion.

Apply to Shipping
Amount

Determines if the discount can be applied to the cost of ship-
ping. Options include: Yes / No.

Free Shipping Determines if free shipping is included in the promotion, and
if so, for which items. Options include:

No Free shipping is not available when a
coupon that is based on the rule is used.

For matching
items only

Free shipping is available only for specific
items in the cart that match the rule.

For shipment
with matching
items

Free shipping is available for the entire
cart when a coupon that is based on the
rule is used.

Stop Further Rules Pro-
cessing

Determines if additional rules can be applied to this purchase.
To prevent multiple discounts from being applied to the same
purchase, select “Yes.” Options include: Yes / No

Default Label
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Field Description

Default Rule Label for All
Store Views

Enter a default label to identify the discount that can be used
for all store views.

Store View Specific
Labels

If applicable, enter a different label to identify the discount for
each store view.

Coupon Codes
Coupons codes can be associated with shopping cart price rules to apply a discount
when a set of conditions is met. For example, a coupon code can be created for a specific
customer group, or for anyone who makes a purchase over a certain amount.

In-store Coupon for Mobile Users

Here are a few ways that you can use coupons in your store:

l Email coupons to customers

l Produce printed coupons

l Create in-store coupons for mobile users

Coupon codes can be sent by email, or included in newsletters, catalogs, and
advertisements. You can even create in-store coupons with a quick response code that
shoppers can scan with their smart phones. The QR code links to a page on your site
with more information about the promotion.

To apply the coupon to a purchase, the customer enters the coupon code during
checkout from the shopping cart page of your site, or possibly at the cash register of your
“brick and mortar” store.
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Enter Coupon Code in Shopping Cart

To set up a coupon code:

1. Follow the instructions to create a shopping cart price rule.

2. On the General Information page, do the following:

a. Set Coupon to “Specific Coupon.”

b. Do one of the following:

l Enter a numeric Coupon Code to be used with the promotion.

l Select the Use Auto Generation checkbox.

c. To limit the number of times the coupon can be used, complete the following:

l Uses per Coupon

l Uses per Customer

If you leave these fields blank, there will be no limit on the number of times the
coupon can be used.

d. To make the coupon valid for a limited period of time, complete the From Date and
To Date fields. To select the date, click the Calendar button next to each field.

If you leave the date range empty, the rule will never expire.
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Price Rule Coupon Code Settings

3. Follow the standard instructions to complete the shopping cart price rule.

Auto-Generating Coupon Codes

Batches of discount coupon codes can be formatted and generated automatically.

To configure auto-generated codes:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under Customers, select Promotions. Then, click to expand the
Auto Generated Specific Coupon Codes section.

Auto Generated Specific Coupon Codes

3. To create a specific format for your codes, enter the following:

l Code Length

l Code Format

l Code Prefix

l Code Suffix

l Dash Every X Characters

4. When complete, click the Save Config button.

These settings can be overridden from the Shopping Cart Price Rule page.
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Field Descriptions
Field Scope Description

Code Length Global Defines the length of the coupon code, exclud-
ing the prefix, suffix and separators.

Code Format Global Defines the coupon code format. Options
include:

Alphanumeric Any combination of letters
and numbers.

Alphabetical Letters only.

Numeric Numbers only.

Code Prefix Global A value that is appended to the beginning of all
coupon codes. If you do not want to use a
prefix, leave the field blank.

Code Suffix Global A value that is appended to the end of all codes.
If you do not want to use a suffix, leave the field
blank.

Dash Every X Characters Global An interval where a dash (-) can be inserted into
all coupon codes. If you do not want to use a
dash, leave the field blank.

Coupon codes that differ by only a dash are
considered to be different codes.

Exporting Auto-Generated Coupon Codes

To generate and export a batch of coupon codes:

1. On the Admin menu, select Promotions > Shopping Cart Price Rules.

2. Select an existing rule, or create a new one.

3. Set Coupon to “Specific Coupon.” Then, do the following:

a. Select the Use Auto Generation checkbox.

b. Complete the other rule settings as needed.

4. Click the Save and Continue Editing button.

5. In the panel on the left, select Manage Coupon Codes. Then, do the following:
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a. In the Coupon Qty field, enter the number of codes to be generated.

b. Adjust the code format settings, as needed.

c. Click the Generate button.

The generated coupon codes appear below. The list shows how many times each coupon
code has been used.

Generated Coupon Codes

To delete coupon codes:

1. In the list, select the checkbox of each code that you want to delete.

2. Set the Actions control to “Delete.”

3. Click the Submit button. When prompted, click OK to confirm.

To export coupon codes:

1. In the list of generated codes, use the filter controls at the top of each column to display
the codes that you want to export.

2. Set Export to to the file format that you want to use for the data file.

3. Click the Export button.

Tracking Coupon Usage

In addition to the information in the list, you can also run a detailed report about the
coupon usage for each website, store, or view.
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To generate a coupon report:

1. On the Admin menu, select Reports > Sales > Coupons.

2. In the upper-right corner, set Show Report For to define the scope of the report.

3. Set Shopping Cart Price Rule to “Specified.” Then, select the rules that you want to
include in the report.

4. When complete, click the Show Report button.

Coupon Usage Report

Free Shipping Promotion
Free shipping can be offered as a promotion, either with, or without a coupon. A free
shipping coupon, or voucher, can also be applied to customer pick-up orders, so the
order can be invoiced and “shipped” to complete the workflow.

Some shipping carrier configurations give you the ability of offer free shipping based on a
minimum order. To expand upon this basic capability, you can use shopping cart price
rules to create complex conditions based on multiple product attributes, cart contents,
and customer groups.

Process Overview:
Step 1: Enable Free Shipping
Step 2: Create the Shopping Cart Price Rule
Step 3: Test the Rule
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Step 1: Enable Free Shipping

1. Enable the Free Shipping method in the configuration of your store.

2. Complete the free shipping settings for any carrier service that you want to use for free
shipping.

Step 2: Create the Shopping Cart Price Rule

1. On the Admin menu, select Promotions > Shopping Cart Price Rules.

2. Follow the steps below to set up the free shipping promotion that you want to offer.

3. When complete, click the Save Rule button.

When you create a new price rule, it might take an hour or so for it to become available.
Allow enough time for it to get into the system. Then, test the rule to make sure that it
works correctly. Unless otherwise specified, price rules are automatically processed with
other system rules each night.

Free Shipping for Any Order

1. Complete the General Information settings as follows:

a. Enter a Rule Name for internal reference.

b. Set Status to “Active.”

c. Set Website to “Main Website.” (Click to make sure the entry is selected.)

d. Select the Customer Groups to which the rule applies.

e. Do one of the following:

l To offer a free shipping promotion without a coupon, accept the default, “No
Coupon” setting.

l To use a coupon with the price rule, set Coupon to “Specific Coupon.” If
necessary, complete the instructions to set up a coupon.

2. In the panel on the left, select Actions. Then, do the following:

a. Set Apply to “Percent of product price discount.”

b. Set Apply to Shipping Amount to “Yes.”

c. Set Free Shipping to “For shipment with matching items.”
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Price Rule Action

3. In the panel on the left, select Labels. Then, do one of the following:

l Enter a Default Rule Label for All Store Views. This label is visible to the customer.

l If your store is available in multiple stores, enter a label for each view, as needed.

4. When complete, click the Save Rule button.

Free Shipping for Orders Over $Amount

1. Complete the General Information settings as follows:

a. Enter a Rule Name for internal reference.

b. Set Status to “Active.”

c. Set Website to “Main Website.” (Click to make sure the entry is selected.)

d. Select the Customer Groups to which the rule applies.

e. Do one of the following:

l To offer a free shipping promotion without a coupon, accept the default, “No
Coupon” setting.

l To use a coupon with the price rule, set Coupon to “Specific Coupon.” If
necessary, follow the instructions to set up a coupon.

2. In the panel on the left, select Conditions.

3. Click the Add button to insert a condition. Then, do the following:

a. In the list under Cart Attribute, click Subtotal.

b. Click the underlined is link, and select “equals or greater than.”

c. Click the … “more” link, and enter a threshold value for the Subtotal, such as 100, to
complete the condition.

4. In the panel on the left, select Actions. Then, do the following:
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a. Set Apply to “Percent of product price discount.”

b. Set Apply to Shipping Amount to “Yes.”

c. Set Free Shipping to “For shipment with matching items.”

5. In the panel on the left, select Labels. Then, do one of the following:

l Enter a Default Rule Label for All Store Views. The label is visible to the customer
during checkout.

l If your store is available in multiple views, enter a label for each view, as needed.

When complete, click the Save Rule button.

Step 3: Test the Rule

When you create a new price rule, it might take an hour or so for it to become available.
Allow enough time for it to get into the system. Then, test the rule to make sure that it
works correctly. Unless otherwise specified, price rules are automatically processed with
other system rules each night.

Buy X Get Y Free
This example shows how to set up a shopping cart price rule for a “Buy X, Get Y Free”
promotion. The format of the discount is as follows:

Buy X quantity of product, get Y quantity for free.

Process Overview:
Step 1: Create a Shopping Cart Price Rule
Step 2: Define the Conditions
Step 3: Define the Actions
Step 4: Complete the Label
Step 5: Apply the Rule

Step 1: Create a Shopping Cart Price Rule

Complete Step 1 of the shopping cart price rule instructions to create a shopping cart
rule with the general information.

Step 2: Define the Conditions

Complete Step 2 of the shopping cart instructions to define the conditions for the price
rule. The conditions can be triggered by purchasing a specific product, making a



Chapter 21:  Promotions Shopping Cart Price Rules

287Magento Community Edition: User Guide

purchase of a certain amount, or any other scenario.

Step 3: Define the Actions

1. In the panel on the left, select Actions. Then, do the following:

a. Set Apply to “Buy X get Y free (discount amount is Y).”

b. Set Discount Amount to 1. This is the quantity the customer will receive for free.

c. In the Discount Qty Step (Buy X) field, enter the quantity that the customer must
purchase to qualify for the discount.

Buy X Get Y Free

2. Click the Save and Continue Edit button. Then, complete the rest of the rule as needed.

Step 4: Complete the Label

Complete Step 4 of the shopping cart price rule instructions to enter the label that
appears during checkout.

Step 5: Apply the Rule

When complete, click the Save Rule button.

When you create a new price rule, it might take an hour or so for it to become available.
Allow enough time for it to get into the system. Then, test the rule to make sure that it
works correctly. Unless otherwise specified, price rules are automatically processed with
other system rules each night.

Discount with Minimum Purchase
Shopping cart price rules can be used to offer a percentage discount based on a
minimum purchase. In the following example, a 25% discount is applied to all
purchases over $200.00 in a specific category. The format of the discount is as follows:

X% off all Y (category) over $Z dollars
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Process Overview:
Step 1: Create a Shopping Cart Rule
Step 2: Define the Conditions
Step 3: Define the Actions

Step 1: Create a Shopping Cart Rule

Follow the basic instructions to create a shopping cart rule.

Step 2: Define the Conditions

1. In the panel on the left, select Conditions.

2. Click the Add button at the beginning of the next line, and select Product Attribute
Combination.

Product Attribute Combination

3. Click the Add button at the beginning of the next line.

If an Item is FOUND

4. In the list under Product Attribute, click Category.
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Choose Condition to Add

a. Click the … “more” link to display additional options.

Category IS

b. Click the Chooser button to display the available categories. Then in the
category tree, select the checkbox of each category that you want to include.

Category Tree

c. Click the Select button at the end of the line to add the categories to the
condition.
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Category Condition

5. Click the Add button at the beginning of the next line, and do the following:

a. In the list under Product Attribute, select Price.

a. Click the first underlined parameter, IS. Then in the list, select “equals or greater
than.”

Price Equals or Greater Than

b. Click the ... “more” link to display the price field. Then, enter the amount that the
price must be to meet the condition. For example, enter 200.00.

Enter the Price to Complete the Condition

6. Click the Save and Continue Edit button.

Step 3: Define the Actions

1. In the panel on the left, select Actions. Then, do the following:

Actions
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a. Set Apply to “Percent of product price discount.”

b. Enter the Discount Amount. For example, enter 25 for a twenty-five percent
discount.

c. If you want to prevent the purchase from qualifying for additional promotions, set
Stop Further Rules Processing to “Yes.”

2. Click the Save and Continue Edit button. Then, complete the rule as needed.
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Chapter 22:

Shopping Tools
Your store includes a set of shopping tools that create opportunities for your
customers to interact with your store, and to share the experience with friends.

Wishlist

The Wishlist block displays the items
from the customer’s wishlist.

Compare Products

The Compare Products block lets your
customers quickly compare the

features of one product with another.

Product Reviews

Product reviews help build a sense of
community, and are considered to be
more credible than any advertising
money can buy.
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Tags

Tags help customers organize and
remember the products that they have
seen, offer quick navigation, and help

search engines index your store.

Polls

The Poll block displays a series of polls
or surveys that you can use to learn
more about your customers.

Email a Friend

The Email a Friend link makes it easy
for your customers to share links to

products with their friends.

Wishlists
A wishlist is a list of products that registered customers can share with friends or
transfer to their shopping carts at a later date. When wishlists are enabled, the Add to
Wishlist link appears on the category and product pages of your store.

l Wishlists can be set to public or private

l Items can be transferred between the wishlist and shopping cart

l Wishlists can be shared with friends
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Add to Wishlist Links on Category Page

Depending on the theme, the Add to Wishlist might be a text link or a graphic image.
Wishlists increase customer loyalty and bring new people to your store.

Shared wishlists are sent from a store email address, but the body of the message
contains a personalized note from the customer. You can customize the email template
that is used for the notification message when wishlists are shared, and choose the store
contact that appears as the sender.

Each wishlist can be maintained in the customer’s account dashboard, where it can be
updated, and used to add products to the shopping cart. When a product with multiple
options is added to a wishlist, any options that have been selected by the customer are
included in the wishlist item description. For example, if the customer adds the same
pair of shoes, but in three different colors, each pair appears as a separate wishlist item.
On the other hand, if the customer adds the same product to the wishlist multiple
times, the product appears in the wishlist only once, but with an updated quantity that
reflects the number of times the product was added. Customers can update their
wishlists from their account dashboard. Merchants can also update a customer’s wishlist
from the Admin.

Wishlist Configuration
The configuration enables wishlists, and determines the email template and sender of
email messages that are sent when a wishlist is shared.
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To configure the wishlist:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Customers, select Wishlist.

3. Click to expand the General Options section, and verify that Enabled is set to “Yes.”

General Options

4. Click to expand the Share Options section. Then, do the following:

Share Options

a. Set Email Template to the template to be used for the notification that is sent when
a customer shares a wishlist.

b. Set Email Sender to the store contact that appears as the sender of the notification.

5. Click to expand theMy Wishlist Link section. Then, set Display Wishlist Summary to
one of the following:

l Display number of items in wishlist

l Display item quantities

My Wishlist Link

6. When complete, click Save Config.

Compare Products
The Compare Products block usually appears in the far right column, or sidebar of the
category page, and can be used to generate a detailed, side-by-side comparison of two or
more products. You can customize the report to include additional attributes or remove
ones that you don’t want to include. Depending on the theme, the Add to Compare link
can be represented by an icon or a link.
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Compare Products

To compare products:

1. From your storefront, find the products that you want to compare, and click the Add to
Compare link for each.

2. In the Compare Products block in the right sidebar, click the Compare button. The
Compare Products report opens in a new window.

3. To print the report, click Print This Page.

4. To clear the Compare Products list, click the Clear All link.
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Compare Products Report
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Recently Viewed/Compared Products
The Recently Viewed and Recently Compared blocks usually appear in the right sidebar
of a catalog page. The number of products listed in each block can be configured for each
website, store, or view.

Recently Viewed

To configure Recently Viewed/Compared Products:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Recently Viewed/Compared Products section. Then, do the
following:

Recently Viewed/Compared Products



Product Reviews Chapter 22:  Shopping Tools

300 Magento Community Edition: User Guide

a. Set Show for Current to the website, store, or view where you want the
configuration to apply.

b. In the Default Recently Viewed Products Count field, enter the number of recently
viewed products you want to include.

c. In the Default Recently Compared Products Count, enter the number of recently
compared products you want to include.

4. When complete, click the Save Config button.

Product Reviews
Product reviews help to build a sense of community, and are considered more credible
than any advertising money can buy. In fact, some search engines give sites with
product reviews a higher ranking than those without. For those who find your site by
searching for a specific product, a product review is essentially the landing page of your
store. Product reviews help people find your store, keep them engaged, and often lead to
sales.

Add Your Review

Writing Product Reviews
Customers can write reviews for any product in your catalog. Reviews can be written
from the product page by clicking the “Add Your Review” link. For products that haven't
been reviewed, the link says, “Be the first to review this product.”
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The number of stars indicates the satisfaction rating. Visitors can click the link to read
the reviews and write their own. As an incentive, customers can receive reward points for
submitting a review.

Write a Product Review

Moderating Reviews
When a review is submitted, it is sent to the Admin for moderation. When approved, the
review is published in your store.

To edit and approve customer reviews:

1. On the Admin menu, select Catalog > Reviews and Ratings > Customer Reviews >
Pending Reviews.

Reviews

2. In the list, click a pending review to view the details, and edit if necessary.
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3. To approve a pending review, change the Status from “Pending” to “Approved.” To reject
a review, select “Not Approved.”

4. When complete, click the Save Review button.

Custom Ratings
By default, customer can rate the quality, price, and value of a product. In addition, you
can add your own custom ratings that relate to your products and customers. The
average rating for each product appears in catalog lists and on the product page.

Manage Ratings

To create your own ratings:

1. On the Admin menu, select Catalog > Reviews and Ratings > Manage Ratings.

2. In the upper-right corner, click the Add New Rating button.

3. In the Rating Title section, enter the Default Value for the new rating. Then, enter the
translation for each language supported by your store.

Rating Title
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4. In the Rating Visibility section, set Visibility In to the store view where the rating will be
used. (Hold down the Ctrl key to select multiple options.)

5. In the Sort Order field, enter a number to determine the sequence that this rating
appears in the list of ratings.

Rating Visibility

6. When complete, click the Save Rating button.

Tags
Tags are one-word descriptors that are used as keywords for your catalog. Tags can be
assigned to products by registered customers who are logged in, and also by guests. Tags
help customers organize and remember the products that they have seen, offer quick
navigation, and help search engines index your store.

Popular Tags

Tags are formatted as a tag cloud, and typically appear in the Popular tags block in the
right sidebar of catalog pages. The size of the text indicates the popularity of the tag.
Each product page has an “Tag this Product” section at the bottom of the page, where
shoppers can enter their own tags. As an incentive, customers can earn reward points for
adding tags to a product.

The tags that customers have given a product are listed on the Customers Tagged
Product tab of the product record. The detail includes the tag, the customer name, and
email address.
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To add a tag from the store:

1. From any product page, scroll down to the Tag this Product section at the bottom of
the page.

Tag this Product

2. In the Add a Tag text box, type the tag you want to associate with the product.

l To enter multiple tags, separate each with a blank space.

l To enter a phrase, enclose the text in single quotes.

3. Click the Add Tags button.

The tag will be submitted for review and published on the site when approved.

Products Tagged by Administrators
There’s no reason to wait for customers to tag products. The store administrator can
apply new tags to products, and reuse existing tags.

Products Tagged by Administrators

To add a new tag:

1. On the Admin menu, select Catalog >Tags > All Tags.

2. In the upper-right corner, click the Add New Tag button. Then, do the following:

a. Enter the Tag Name.

b. Set Status to “Approved.”

c. In the Base Popularity field, enter a numeric value to assign a weight to the tag.
The number assigns a base value to the tag and increases its size in the tag cloud.

3. When complete, click the Save Tag button.
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To apply an existing tag to specific products:

1. In the Manage Tags list, click to open the tag.

2. Click to expand the Products Tagged by Administrators section. Then, do the
following:

a. Click the Reset Filter button to display all product records.

b. Select the checkbox of each product that you want to tag.

3. When complete, click the Save Tag button.

The products now appear in the list of Products Tagged by Administrators.

Moderating Tags
After a customer submits a product tag, an administrator must approve the tag before it
becomes visible in the store. After a tag has been approved, it can be used for other
products without further approval.

Changing the Status of Pending Tags

To approve multiple tags:

1. On the Admin menu, select Catalog >Tags > Pending Tags. Then in the list, click to
open a pending tag.

2. In the list, select the checkbox of each tag that you want to approve.

3. Set the Actions control to “Change Status.” Then, set the Status control to “Approved.”

4. When complete, click the Submit button.
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To manage a single tag:

1. On the Admin menu, select Catalog >Tags > Pending Tags. Then in the list, click to
open a pending tag.

Editing a Tag

2. If necessary, you can edit the text as needed. Then, do one of the following:

l To approve and publish the pending tag, set Status to “Approved.”

l To reject the tag, set Status to “Disapproved.”

3. When complete, click the Save Tag button.

Tag Activity

The remaining sections give you a snapshot of the tag activity, including which
customers have used the tag, and products tagged by the store administrator and
customers.

Customers Submitted this Tag

You can jump to a specific customer or product by clicking its row in the list.

Products Tagged by Customers

Polls
Polls make it easy to learn about your customers’ opinions and preferences. The poll
occupies a small amount of space and is usually placed in the right sidebar of a catalog
page. Poll results appear immediately after a response is submitted. If you create
multiple polls, a new poll appears each time the page is refreshed.
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Original Poll and Results

To create a poll:

1. On the Admin menu, select CMS > Polls.

2. In the upper-right corner of the Poll Manager, click the Add New Poll button.

3. In the Poll Information section, do the following:

Poll Information

a. Enter the Poll Question.

b. By default, Status is set to “Open.” If you later want to remove the poll from your
store, set Status to “Closed.”

c. Set Visible In to the store view where you want the poll to appear.

4. In the panel on the left, select Poll Answers. Then, for each answer, do the following:

a. Click the Add New Answer button. Then, do the following:

Assigned Answers

a. In the Answer Title field, enter the answer as you want it to appear in the poll.

b. To weight an answer, enter a number in the Votes Count field. The number will
increment each time a customer chooses the answer.

5. Click the Save Poll button to save your poll.
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To prevent multiple voting:

You can protect the poll results by preventing people from voting multiple times from
the same computer.

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under General, select Web.

3. Click to expand the Polls section, and set Disallow Voting in a Poll Multiple Times
from Same IP Address to “Yes.”

Disallow Voting Multiple Times

4. When complete, click the Save Config button.

Editing a Poll
After a poll has been created, click the row in the Poll Manager

To edit a poll:

1. From the Poll Manager list, click to open the poll in edit mode. Then, make the
necessary changes.

l To close the poll so that it no longer appears in the store, set Status to “Closed.”

l To see the vote count for each answer, click Poll Answers in the panel on the left.

2. When complete, click the Save Poll button.

Poll Answer Count
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Email a Friend
The Email a Friend link makes it easy for your customers to share links to products with
their friends. In the Magento demo store, the Email a Friend link appears as an envelope
icon.

The automated message that is sent from your store is referred to as transactional email.
The message template can be customized for your voice and brand. To prevent
spamming, customers can send only five messages per hour.

Email a Friend

To send email to a friend:

1. On a catalog page, click the Email a Friend link. When prompted, either log into your
customer account or register to open an account.

2. Complete theMessage and enter the recipient Name and Email Address.

To send the message to more than one person, click the Add Another Recipient link and
complete the information for each person.

3. When ready to send the message, click the Send Email button.
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Email to a Friend Form

Gift Options
At checkout, customers are presented with the available gift options during the Shipping
Method step of the process. If the customer chooses to add gift options, two groups of
checkboxes appear: Gift Options for Entire Order and Gift Options for Individual Items. .

Gift Options During Checkout

Gift Options Configuration
The Gift Options configuration determines if customers have the option to add a gift
message for the complete order, and for individual items. The gift options must be
configured first for the website, and can then be overridden at the product level.
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To enable gift options:

1. On the Admin menu, select System > Configuration. Then in the panel on the left,
under Sales, select Sales.

2. Click to expand the Gift Options section. Then, set the following options according to
your preference:

l Allow Gift Messages on Order Level

l Allow Gift Messages for Order Items

Gift Options Configuration

3. When complete, click the Save Config button.

Field Descriptions
Field Scope Description

Allow Gift Messages on
Order Level

Website Specify whether a gift message can be added for
the entire order.

Allow Gift Messages on
Order Items

Website Specify whether a gift message can be added for
an individual order item.
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Chapter 23:

Newsletters
Publishing a regular newsletter is considered to be one of the most powerful and
affordable marketing tools available. Magento Community Editiongives store
administrators the ability to publish and distribute newsletters to customers who
have registered to receive them, plus all the tools necessary to:

• Promote your newsletter

• Build and manage your list of subscribers

• Develop content

• Maintain an archive of back issues

• Drive traffic to your store
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Newsletter Configuration
The first step in creating newsletters is to configure the newsletter settings for your site.
You can require customers to confirm the registration by clicking a confirmation link
sent by email. This technique is called double opt-in, because customers must confirm
twice that they want to receive a newsletter. This method reduces the number of
customers that might otherwise consider your newsletter as spam.

To configure newsletter settings on your site:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Customers, select Newsletter.

3. Click to expand the Subscription section. Then, do the following:

a. Confirm the email templates and senders of the following email messages sent to
subscribers:

l Success email

l Confirmation email

l Unsubscription email

b. To require people to double-opt in to confirm their subscription, set Need to
Confirm to “Yes.”

c. To allow people who do not have an account with your store to subscribe to the
newsletter, set Allow Guest Subscriptions to “Yes.”

d. When complete, click the Save Config button.

Subscription Options
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Newsletter Templates
Before sending a newsletter, create a newsletter template. You can create and save as
many of these as required for any situation, from an annual holiday newsletter to a
weekly product update.

Newsletter Template

To create a newsletter template:

1. On the Admin menu, select Newsletter > Newsletter Templates. The page lists the
available newsletter templates. You can edit an existing template or create a new one.

2. To add a new template, click the Add New Template button. Then, do the following:

a. In the Template Name field, specify a unique and indicative name for this template.
This value is not visible for customers.

b. In the Template Subject field, specify the subject of the email to be sent to your
customers.

c. In the Sender Name and Sender Email fields, specify the name and email of the
sender of the email to be sent to your customers.

d. In the Template Content field, use the WYSIWYG editor to compose the body of the
email. Note that this field is pre-filled with tags showing an unsubscribe link in the
email. We recommend that you do not remove this link so that all emails that are
sent enable your customers to unsubscribe from the newsletter.

e. Click Preview Template, to display the content with the formatting as it will be
viewed by your subscribers.

3. When complete, click the Save Template button.

After you have saved a template, a Save As button appears when you edit this template.
You can use the Save As button, so you can make changes and save it as a new
template, without affecting the original. This can save you time because you will not
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need to re-enter all the template information in order to create a new template. If you
already have an existing template that is similar to the new template, simply edit the
fields that you require, and then use the Save As button to create a new template.

Newsletter Queue
A newsletter that has many recipients must be sent in stages. The process of sending the
newsletter is managed by a queue. After you start the queue, Magento sends the emails
in packs.

To ensure delivery of your newsletters, it is recommended that you integrate your
Magento installation with a third-party newsletter provider. These services are “white
listed” by email service providers. Look for newsletter providers in Magento Connect.

To send your newsletter using a queue:

1. On the Admin menu, select Newsletter > Newsletter Templates.

2. Set the Actions control to the relevant template. Then, select Queue Newsletter.

3. In the Queue Date Start field, specify when the newsletter will start being sent.

4. In the Subscribers From field, select one or more store views whose customers this
newsletter will be sent to.

5. Review the template and parameters and then click the Save Newsletter button to
schedule sending the newsletter.
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Chapter 24:

Sales Channels
Publishing your catalog through multiple channels is an effective way to widen your
distribution without much effort. You can start by syndicating your content with
RSS feeds, and then expand by sending your catalog data to shopping aggregators.

Social Marketing
There are many social marketing extensions that can be added to your store. To
learn more, see: Magento Connect.

Social Marketing Extensions

Facebook Open Graph
The Facebook Open Graph 2.0 extension is a tool developers can use to add custom
social networking buttons to your store. The extension uses the new Facebook Open
Graph 2.0 protocol.

http://www.magentocommerce.com/magento-connect/marketing/social-marketing.html
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Facebook Open Graph

When the Facebook Open Graph 2.0 extension is successfully installed and all
configuration is complete, the Facebook buttons appear on each product page in the
store, along with the Facebook blocks that provide information about other Facebook
users and friends who have clicked the social buttons. The information provided in the
blocks depends on the customer who is logged in to Facebook and whether friends have
performed actions with your app, such as clicked a social button.

Process Overview
Step 1: Download and install the extension
Step 2: Create an application on the Facebook Developer site
Step 3: Configure Magento

Step 1: Download and Install the Extension

The Facebook Open Graph 2.0 extension is free of charge and can be downloaded from
Magento Connect. Copy the Extension Key to the clipboard.

To install the extension:

1. On the Admin menu, select System > Magento Connect > Magento Connect Manager.

2. When prompted, enter your Admin credentials, and click the Log In button.

3. Paste the Extension Key, and click the Install button.

Step 2: Create Application on Facebook Developer Site

The current implementation of the Facebook Open Graph 2.0 extension requires an
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application to be created manually on the Facebook Developers site.

1. Navigate to: https://developers.facebook.com/

2. In the main menu, click Apps.

3. Click Create New Application and perform all of the steps of the app creation wizard.

The App Namespace value that you entered will be used in the Magento configuration.

4. In the left column, select Settings > Basic. Under the “Select how your app integrates
with Facebook” heading, select Website. Then in the Site URL field, enter your store
address.

Important! Your website and store should have one domain name.

a. For Action Types in the Advanced settings in the Graph API URL field enter own,
want or other action you want to be associated with a social networking button on
your product pages. This title is for internal use.

You cannot set the “dislike” action as it is not supported by Facebook Open Graph
2.0.

b. The Object Type you create should have the following Object Properties:

l URL (page URL)

l Title (product title)

l Image (image URL)

l Description (product description)

l Price

By default, a new Object Type has only the first four properties. To add the Price
property, use the Add Another Property button on the Object Type page.

Step 3: Configure Magento

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Social, select Facebook.

If the extension is installed, the Social tab appears in the Configuration panel.

3. Set Current Configuration Scope to your website.

4. In the Facebook Config section, do the following:

https://developers.facebook.com/
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a. To display Facebook buttons in the store, set Enable Facebook on Frontend to
“Yes.”

b. Enter the App Namespace value of your application. You can find it in the Basic
Settings section of your app on the Facebook Developers site.

c. Specify the App ID and App Secret values of your application. You can find them in
the Basic Settings section of your app on the Facebook Developers site.

d. Enter the Open Graph Type value of your Object Type. To find it on the Facebook
Developers site, open the settings of your application, navigate to Open Graph >
Dashboard, click your object type, and expand the Advanced settings.

On the page header, the system will display the Apps > %Your Facebook
Application Name% > Open Graph > Object Type: %Object name%.

e. To add and configure a social networking button, click Add Action Button and
complete the setup for each button. The action settings can be different for each
store view.

Action In the Action column, specify the internal button action
title, for example, own or want. This value should
correspond to the value you have specified in the Graph
API URL field on the Facebook Developers site. The
Graph API URL field is available in the Advanced section
of the Action Type settings.

Button Title In the Button Title column, specify the name of the
social networking button as you want it to appear in the
frontend.

Enable Friend Box In the Enable FriendBox column decide if you want to
display in the frontend the related Facebook block, which
contains the count and the pictures of friends.

Count Friend Box In the Count in FriendBox column, set the maximum
number of friends that can be displayed in the related
Facebook block. By default, it is set to 3. If you set zero
value (0) or leave the field empty, then the default value
is applied.

5. When complete, click Save Config button.

The social network buttons you have created and the corresponding Facebook blocks now
appear on the product pages of your store.
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Setting Up RSS Feeds
RSS (Really Simple Syndication) is an XML-based data format that is used to distribute
information online. Your customers can subscribe to your RSS feeds and be notified of
new products and promotions. RSS Feeds can also be used to publish your product
information to shopping aggregation sites, and can also be included in newsletters.

When RSS feeds are enabled, any additions to products, specials, categories,
and coupons in your store are automatically sent to the subscribers of each
feed. A link to all the RSS feeds that you publish is in the footer of your

store.

The software that is used to read an RSS feed is called a feed reader, and allows people
to subscribe to headlines, blogs, podcasts, and much more. Google Reader is one of the
many feed readers which are available online for free.

To set up RSS feeds for your store:

1. From the Admin menu, select System > Configuration.

2. In the upper-right corner, set Current Configuration Scope to the store view where you
want the feeds to be available.

3. In the panel on the left, under Catalog, select RSS Feeds.

RSS Feed Configuration

4. In the Rss Config section, set Enable RSS to “Enable.” Then, in each section below, set
the feeds that you want to activate to “Enable.”

a. In the Wishlist section, set Enable RSS to “Enable.”

b. In the Catalog section, set any, or all, of the following feeds to “Enable.”
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l New Products

l Special Products

l Coupons/Discounts

l Tags Products

l Top Level Category

l Top Level Category

c. In the Order section, set Customer Order Status Notification to “Enable.”

5. When complete, click the Save Config button.

Types of RSS Feeds
RSS Feed Description

Wishlist When enabled, an RSS feed link will be available on top of cus-
tomer wishlist pages. Additionally, the wishlist sharing page
will also include a checkbox that lets you add a link to wishlist
RSS feeds on shared wishlists.

New Products The new products RSS feed tracks new products added to the
store catalog and will syndicate them.

Special Products The special products RSS feed will syndicate products with
special pricing.

Coupons / Discounts Any special coupons or discounts generated in your store will
be added to this RSS feed.

Tags Products The tags products RSS feed manages and syndicates newly
added product tags.

Top Level Category This RSS feed tracks new top level categories, or root level cat-
egories, in your catalog.

Customer Order Status Allows customers to track their order status with an RSS feed.
When enabled, an RSS feed link will appear on the order.
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Chapter 25:

Mobile Apps
XML Connect is a module that enables you to create and manage Magento mobile
apps. It also enables the apps to load content and communicate with a Magento
Community Edition instance on the server after being installed on a mobile phone or
other mobile device. You can easily create mobile applications for your stores from
the Magento Admin Panel.

Mobile Devices

To enable the XML Connect module:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Advanced, select Advanced.

3. In the list, confirm that Mage_XmlConnect is set to “Yes.”

Creating a Mobile App
According to the Magento Mobile logic, a mobile app is strictly bound to a certain
store and certain mobile device type. The workflow for creating and activating a
mobile app is as follows:
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Process Overview:
Step 1: Create a New Mobile App
Step 2:Design the App and Add Content
Step 3: Complete the Configuration
Step 4: Subscribe to a Plan
Step 5: Submit Your App to Magento

Step 1: Create a New Mobile App

1. On the Admin menu, select Mobile > Manage Apps.

2. In the upper-right corner, click the Add App button.

3. Set Device Type to one of the following:

l iPad

l iPhone

l Android

Then, click the Continue button.

Select the Device Type

4. On the General tab, complete the following fields:

Mobile App Information

App Name Specify the name of the app. It is an internal name and it is
not displayed to app users.
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Store View Select the store view where the app will be used.

Catalog Only App Decide whether your app shows only the catalog or provides
options to buy products or add them to the wishlist.

a. In theMailbox title field, enter the title for your mailbox for the More Info tab of the
app.

5. To save the new app, click the Save or Save and Continue Edit button in upper-right
corner of the page.

Step 2: Design the App and Add Content

1. In the panel on the left, select Design, and do the following:

Design
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a. In the Images section, you can specify your logo, banners, and background image.
Up to five rotating banners can be used. For each banner, you can choose the action
to be performed when it is clicked. To set an action for a banner, click the link next
to the Action label.

Images

b. You can choose to redirect customers to product page, CMS page, or category page.
For product and category pages, you will need to type the name of the product or
category. A CMS page can be selected from a list.

c. After you add the images, click either the Save or Save and Continue Edit button in
the upper-right corner.

d. In the Color Themes section, specify the colors you want to use.
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Color Themes

e. In the Tabs section, set up the selection of tabs that you want to use for navigation.
You can use the arrows below to change the tab order.

Tabs

2. In the panel on the left, select Content to add CMS pages to your app. To add a new
page, click the Add Page button. Then, do the following:

Content
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a. In the Label field, specify the label for the app page. The label is visible for
application users.

b. Set Get Content from CMS Page to the CMS page you want to use.

Step 3: Complete the Configuration

1. In the panel on the left, select Payment Methods. Then, select following payment
methods that you want to use.

Payment Methods

Enable Standard
Checkout

If you select “Yes,” all payment methods that are
supported by Magento Community Edition are available.

Activate PayPal MECL In this field you can activate the PayPal mobile
embedded payment method. You can choose to use
MECL (Mobile Express Checkout Library) alongside
standard checkout, or use it as your only checkout
method for Magento mobile. PayPal MECL requires a
PayPal business account.

2. (iPhone only) In the panel on the left, select Analytics. You can enable Flurry Analytics
after subscribing to a Magento support plan and submitting your application to
Magento. You will be able to see the statistics from your store Admin and at
www.flurry.com. The following fields are available:

Analytics
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Enable Flurry
Analytics

If you select Yes, the Flurry API Code field appears.

Flurry API Code Specify your Flurry API code. You can request it from
Magento, after submitting your application.

Flurry Analytics Site Contains the link to www.flurry.com, where you can
view the statistics after it is enabled.

Flurry Analytics is currently available only for iPhone apps.

3. In the panel on the left, select Submission History to view the records about your app
submissions. You need to resubmit the application if you make changes in any
submission settings. It refers to the settings on the Submit App page, which opens on
Save and Submit App button click.

Submission History

4. In the panel on the left, select Cache Management to set the cache lifetime of the app.
To disable the cache, leave the Cache Lifetime field empty.

Cache Management

5. In the panel on the left, select Social Networking to use API to link your app with your
accounts on Twitter, Facebook, or LinkedIn.
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Social Networking

6. In the panel on the left, select Push Notification to manage the Urban Airship push
notification service. Then, do the following:

Push Notification

You can find more about the AirMail by Urban Airship at
http://urbanairship.com/products/airmail/.

a. Read and accept the Urban Airship Terms of Service.

b. Set Enable AirMail Message Push notification to “Yes.”

c. Enter the following Urban Airship account credentials:
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l Application Key

l Application Secret

l Application Master Secret

You can request them by sending email to magentomobile@magento.com after
submitting your application to Magento.

d. In theMailbox title field, enter the title for your mailbox for the More Info tab.

7. To save the new app, click the Save or Save and Continue Edit button in upper-right
corner.

Step 4: Subscribe to a Plan

To order a subscription for a Magento support plan, visit the Mobile page on the
Magento website. When you purchase a subscription, you will receive the activation key
for your application.

Step 5: Submit Your App to Magento

1. From the Admin, select Mobile > Manage Apps. Then, select the app you want to
submit.

2. In the upper-right corner, click the Save and Submit App button.

3. On the Submit App page, under Key, enter the Activation Key that you received from
Magento.

4. Complete the information in the Submission Fields section, which appears in the app
store. The following fields are available:

a. In the Title field, specify the name of your application. It is shown to the customers,
so we recommend choosing a 10-12 character recognizable title.

b. In the Description field, specify the description of your store. It appears in the App
Store.

c. In the Contact Email field, specify the email address to contact for this application
and submission issues.

d. The Price field is currently unavailable for editing, as only free applications are
currently allowed in Magento.

e. In the Country field select the countries where the application will be available.

f. In the Copyright field enter your copyright text. It appears in the information
section of your application.

http://www.magentocommerce.com/product/mobile
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g. In the Keywords fields, enter a comma-separated list of keywords for your
application. The field may contain 100 characters maximum. These keywords are
matched to users' searches in the application stores.

5. Under Icons, do the following:

a. In the Large iTunes Icon field (or Large Android Market Logo for Android
applications), browse for the image that will appear as a large icon of your image in
the applications store. You do not need to gradient or soften edges; this is done
automatically by Apple. Required size: 512px by 512px.

b. In the Loader Splash Screen field, browse for the image that will appear first on the
screen, while your application is loading. Required size: 320px by 460px. For iPhone
applications you can specify a separate image for iPhone retina screens in the
Loader Splash Screen (iPhone 4 retina) field. Required size: 640px by 920px.

c. In the Custom App Icon field, browse for the image that will be used as your
application icon, after the user installation of your application. Recommended size:
57px by 57px at 72 dpi.

l For iPhone applications you can specify a separate image for iPhone retina
screens in the Custom App Icon (iPhone 4 retina) field. Required size: 114px by
114px.

d. In the Copyright Page Logo field, browse for your logo image, which is displayed on
the copyright page of your application. Recommended size: 100px by 100px.

l For iPhone applications you can specify a separate image for iPhone retina
screens in the Copyright Page Logo (iPhone 4 retina) field. Required size: 114px
by 114px.

6. In the upper-right corner, click the Submit App button.

After you submit your app, you can contact the Magento team, for example by email at
magentomobile@magento.com, to request Urban Airship and/or Flurry credentials, and
any other information you need. Placing your application in the app store takes from
several hours to several days.

Managing AirMail
From the Magento Admin, you can create and send AirMail push notification messages,
also called push notifications, and AirMail messages to your mobile application users.
Push notifications, which are plain text messages, appear to the user when the app is
launched. AirMail messages are rich-media, and can include HTML, images, video, and
audio.

In Magento, message sending is implemented using the cron job scheduler. By default, it
checks for new messages to be sent every five minutes.
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To send a push notification or AirMail message:

1. Create a template for the message.

2. Add the message to the queue.

You select the message type when adding the message to the queue. When you send the
AirMail message, the push notification is sent as well. For example, you can make it
something like “You've got a new message from YourStore store.” The push notification
appears when the user opens your application. The AirMail message is stored in the
AirMail application inbox.

Creating a Message Template

To create a new message template:

1. On the Admin menu, select Mobile > Message Templates.

2. In the upper-right corner, click the Add New Template button. Then, complete the
fields, as described below.

3. When complete, click the Save button.

Template

Field Description

Application Select the application for which the message template is inten-
ded.

Template Name Specify the template name, maximum 255 characters.

Push Title Specify the text of the push notification messages that will be
sent using this template, maximum 140 characters. When you
send the AirMail message, the push notification is sent as well.
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Field Description

Message Title Specify the title for the AirMail messages, sent using this tem-
plate, maximum 140 characters.

Template Content In this field you can create the content of your AirMail
message. To add the content you can use the WYSIWIG editor,
or hide the editor and write the HTML code in the text
window. You can hide and show the editor using the
Show/Hide Editor button.
You can insert variables with the store contact information
and widgets to your template.
To insert a variable, click the corresponding icon in the editor,
or click the Insert Variable button if the editor is hidden. Then
in the list, click the variable you want to insert.
To insert a widget, click the corresponding icon in the editor,
or click the Insert Widget button if the editor is hidden. The
Insert Widget pop-up window opens, where you need to take
several steps to set the widget. When you are finished, click
the Insert Widget button in the upper-right corner of the
window.

Message Queue Management

While adding the message to the queue, you have the option of specifying what type of
message you will send, a push notification or an AirMail message.

To add messages to the sending queue:

1. On the Admin menu, select Mobile > Message Templates.

2. Select the message template that you want to use. Then, in the Action column, select
“Queue Message” and complete the following:

Queue Message

Message Type In the Message Type drop-down menu under Message
Settings, select the type of the message you want to send. It
can be Push message or AirMail message.
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For Android applications, only push notifications are
available.

Start Date In the Start Date field, specify the start date and time for
sending the message. You can type it manually or select
from the calendar by clicking the calendar button. If you
leave Start Date empty, the message will be sent
immediately after you finish configuration and click Queue
Message.

3. Under Template, specify the following:

Push Title In the Push Title field, you can edit the text of the push
notification message, maximum 140 characters. If you
intend to send a push notification, and have selected Push
message in the Message Type drop-down menu, proceed to
the step 4.

Message Title In the Message Title field, you can edit the title of the
AirMail message, maximum 255 characters.

Template Content In the Template Content field, you can make changes in
your message template. For more information about editing
the template, see the last step of the procedure in “Creating
a Message Template.”

4. In the upper-right corner, click the Queue Message button to add the message to the
queue. You are redirected to the AirMail Messages Queue page, the message is added to
list with In Queue status.

l To cancel the message transmission, select the message and in the Actions column,
select “Cancel.” Canceled messages are not deleted and can be previewed.

l To delete the message from the queue, select the message and in the Actions column,
select “Delete.”
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Chapter 26:

Google Tools
Your store includes a number of tools to help optimize your content, analyze your
traffic, and connect your catalog to shopping aggregators. In this chapter, you will
learn how to use the following Google tools:

l Google Merchant Center

l Google Sitemap

l Google Analytics

Google Merchant Center
Google Merchant Center helps you manage Google’s shopping tools and services
from a single dashboard. In addition to the following services, you can also link
Google Analytics to your Merchant Center account.

Google Shopping

Google Shopping is a commercial service that helps shoppers find products on
Google, compare products, and connect with merchants.

Product Listing Ads

Your product listings can include rich information, such as product image, price,
and merchant name. Whenever a user enters a search query on Google.com that is
relevant to an item you are trying to sell, Google will automatically show the most
relevant products along with the associated image, price, and product name.

http://www.google.com/shopping
https://www.google.com/ads/innovations/productlistingads.html
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Google Merchant Center Login

Process Overview:
Step 1: Open a Google Merchant Account
Step 2: Verify Your Website URL
Step 3: Claim Your Website URL

Step 1: Open a Google Merchant Account

1. Visit the Google Merchant Center, and do one of the following:

l If you have a Google account, enter your Email address and password, and click the
Sign In button.

l Click the Sign Up button, and follow the instructions to create an account.

Google Merchant Center Dashboard
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2. In the panel on the left, click to expand Settings, and select General.

3. Enter your Store name and Description.

4. Enter the full Website URL for your store. Depending on your domain, the URL might be
formatted as one of the following:

l http://mystore.com

l http://www.mystore.com

At this time, your Website URL is unclaimed and unverified.

Website URL Unverified - Unclaimed

5. Complete the remaining General settings information, and Save Changes.

Step 2: Verify Your Website URL

In this step, you will use Google Webmaster Tools to verify that you have the right to
upload product listings from your store.

1. On a new browser tab, go to Google Webmaster Tools. Then, do the following:

a. Click the Add a Site button. When prompted, enter the URL of your store, and click
Continue.

b. When prompted to verify that you are the owner of the site, click the Alternate
methods tab.

c. Select the HTML tag method, and press Ctrl + C to copy the meta tag code to the
clipboard.

http://www.google.com/webmasters/tools/
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HTML Meta Tag Code

1. Return to your store's Admin, and select System > Configuration.

2. In the panel on the left, under General, select Design. Then, do the following:

a. Click to expand the HTML Head section.

b. Scroll down to theMiscellaneous Scripts box and press Ctrl + V to paste the
verification code from the clipboard.

c. When complete, click the Save Config button.
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Paste Google Site Verification Code

3. Return to Google Webmaster Tools, and click the Verify button. When prompted, click
Continue. Your site is now verified.

Google Webmaster Tools - Site Verified

Step 3: Claim Your Website URL

In this final step, you will establish the connection between your site and your Google
Merchant account.

http://www.google.com/webmasters/tools/
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1. Return to the Google Merchant Center. The General Settings now show that your site is
verified, but not claimed.

Google Merchant Center- Claim this URL

2. Click the Claim this URL link. Your Website URL is now both verified and claimed.

Website URL Verified and Claimed

What next? Now that your site is verified, you can submit a sitemap to Google. You can
also set up a Google Analytics account, and link it to your Merchant Center Dashboard.

Google Sitemap
Google Sitemap improves the way your store is indexed by their search engine, and is
specifically designed to find pages which might otherwise be overlooked. As with the
standard Magento sitemap, Google Sitemap is an index of all the pages on your site.
However, unlike the Magento sitemap, the Google Sitemap is not visible to customers.
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Process Overview:
Step 1: Remove any “robots.txt” Restrictions
Step 2: Generate the Sitemap
Step 3: Submit Your Sitemap to Google
Step 4: Restore Previous “robots.txt” Restrictions

Step 1: Remove any "robots.txt" Restrictions

When first setting up your Google Sitemap, you must provide full access for Google to
index your site. If you have a robots.txt file, make sure that it includes the following
instruction:

User-agent:*

Disallow:

After your sitemap has been successfully submitted to Google, you can restore any
instructions to exclude certain locations of your site. If you have not yet set up a
robots.txt file, you can do so after you finish the sitemap.

Step 2: Generate the Sitemap

1. On the Admin menu, select Catalog > Google Sitemap.

2. In the upper-right corner, click the Add Sitemapbutton. Then, do the following:

a. In the Filename field, enter: “sitemap.xml”

b. Enter the path to a writable location on your server for the sitemap.

l To put the sitemap in a folder, enter the path to the folder:
/sitemaps

l To put the sitemap at the base path of your store, enter a forward slash: /

c. Set Store View to the view where the sitemap will be used.

Configure Google Sitemap

3. Click the Save & Generate button to create the sitemap.

The sitemap appears in the list, with a link to sitemap.xml file. From here, you can do
the following:
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l To view the sitemap, click the hyperlink in the Link for Google column. This is the
link that you will later submit to Google.

l To update the sitemap, click the Generate link.

Step 3: Submit Your Sitemap to Google

1. Go to Google Webmaster Tools and do one of the following:

l Log in to your existing account.

l Create a new account, and log in.

2. Click the Add a Site button.

Add a Site

3. When prompted to enter your store address, enter the full URL of your store, such as:
http://www.mystore.com

Click the Continue button.

4. To verify that you are the owner of the site, click the Alternate Methods tab. Then,
choose one of the following methods:

l Add a DNS record to your domain’s configuration

l Add a meta tag to your site’s home page

To verify your site with a meta tag, do the following:

a. Open two tabs on your browser; one for Google Webmaster Central, and the other
that is logged in to the Admin of your store.

b. Follow the instructions on Webmaster Central to copy the full text of the Google site
verification meta tag.
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c. On the Admin menu, select System > Configuration. In the Configuration panel on
the left, under General, click Design.

d. In the HTML Head section, scroll down to Miscellaneous Scripts and paste the site
verification meta tag. Then, click the Save Config button.

e. Return to Google Webmaster Central, and click Verify.

Google Site Verification

5. After your site is verified and appears in your Google dashboard, do the following:

a. Click the name of your store. Then, click the Sitemaps button.

b. In the upper-right corner, click the Add/Test Sitemap button.

6. Return to your store Admin, and copy the path to your Google sitemap. If necessary, log
back in and do the following:

a. Go to Catalog > Google Sitemap.

b. In the Link for Google column, right-click the link to your sitemap. Then on the
context menu, click Copy Shortcut.

c. Open a text editor and paste the link. Then, copy the part of the link that comes
after the “dot com.” It looks like this:

/media/s4d71280645299/sitemaps/sitemap.xml

7. Return to Google Webmaster Tools and paste the text into the box to complete the
address of your sitemap. Then, click the Submit Sitemap button.
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Submit Google Sitemap

8. Make sure that the link to your sitemap is working correctly, and that your Google
dashboard shows the number of pages indexed.

Step 4: Restore Previous "robots.txt" Restrictions

If you changed your robots.txt file to make it fully accessible, you can now restore the
previous instructions to disallow access to certain areas of your site.

Google Analytics
Google Analytics is a free service provided by Google to help website owners find out
more about the traffic on their website and about conversions. Magento supports the
following Google Analytics options:

Page View Tracking Shows the origin of visitors to your store, and the pages
visited.

Ecommerce Tracking Shows which visitors to your store make purchases, and
what they buy.

Step 1: Set Up a Google Merchant Account

The first step is to establish a Google merchant account, and then verify and claim your
website URL. For detailed instructions, see: Google Merchant Center.

When you sign up for an account, a report appears that shows your new Google
Analytics account number in the following format: UA-XXXXXXX-1. Write this number
down, because it is required to complete the configuration for your store.
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Step 2: Turn On Ecommerce Tracking

1. Sign in to your Google Analytics account.

2. On the main menu, select Admin.

The options in the Administration section are organized into three columns under
Account, Property, and View. If you have multiple accounts or stores, make sure that the
Account button is set to the correct account, and that the Property button is set to the
correct store.

Google Analytics Admin

3. In the View column, select the View Settings option.

4. In the panel on the left, select Ecommerce Settings. Then, do the following:

a. Click the Status switch to turn on Ecommerce Tracking. Then, click the Next step
button.

b. Click the Submit button to save the setting. When the Success message appears at
the top of the page, you are done.

http://www.google.com/analytics/
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Ecommerce Tracking On

Step 3: Complete the Magento Configuration

1. On the Admin menu, select System > Configuration. Then in the panel on the left,
under Sales, select Google API.

2. Click to expand the Google Analytics section, and do the following:

Google Analytics

3. Set Enable to “Yes.”

4. In the Account Number field, enter the Google Analytics account number, or tracking
code that you wrote down when you signed up for the service.

5. To anonymize part of your visitors’ IP address before it is sent to Google, set Enable IP
Anonymization to “Yes.”

According to Google, anonymizing IP addresses can reduce the accuracy of geographic
data in the Analytics report.

6. When complete, click the Save Config button.
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Google Shopping
Google Shopping gives you the ability to upload product feeds from your catalog so your
products can be easily found through Google Search. Any Simple product from your
catalog can be uploaded to Google Shopping. The product attributes that are mapped to
Google are used as search parameters by customers looking for products. After mapping
the product attributes to sync with Google Content attributes, you can create a simple
upload from your store to Google Shopping.

Magento Connect has a number of extensions that you can install to establish
integration with Google Shopping. Some extensions are free, and others are available for
purchase from developers. In addition to Google Shopping, there are many extensions
available to integrate your store with shopping sites.

Visit Magento Connect and read the descriptions and reviews, to help you decide which
solution is the best for your store. Then, follow the instructions to install the extension.

Google Content API for
Shopping

Magento’s Google Content API for
Shopping extension allows developers to
migrate their eCommerce stores into the
new Google API to ensure that they
come up in Google searches.

Google Shopping Feed

“The #1 Google Shopping extension for
Magento. Used by thousands of sites

globally, recommended by Google reps.”

http://www.magentocommerce.com/magento-connect/integrations/shopping-site-integration.html?id=12850&s=8&pl=2&te=0&q=&t=0&p=1
http://www.magentocommerce.com/magento-connect/google-content-api-for-shopping.html
http://www.magentocommerce.com/magento-connect/google-content-api-for-shopping.html
http://www.magentocommerce.com/magento-connect/google-shopping-feed.html
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Chapter 27:

Mastering Magento CMS
The old adage, “content is king” is more true now than ever before. The term, content
marketing refers to the art of promoting your products or services by providing
valuable information to your customers at no charge. The quality of your content
helps distinguish your store from others, increases your visibility to search engines,
and provides support to your customers. This soft-sell approach is often more
effective than advertising, builds credibility and trust, and can turn your store into a
destination.

Your content should reflect the branding of your store, and be delivered with your
distinctive visual presentation and voice to convey your message. Use pictures to tell
a story. Educate, inspire, and entertain. With quality content, sometimes less is
more.

Magento Community Edition includes a powerful content management system
(CMS) that you can use to create rich content for your store. In this chapter, you will
learn how to create new content, and incorporate existing content to create a
compelling experience that will bring your customers back to your store for more.

CMS Menu

Pages

Create pages with text, images, blocks,
variables, and widgets, that can be
inforporated into the navigation of
your store, and linked to other pages.
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Static Blocks

The CMS makes it easy to create
blocks of content without writing any
code. Blocks can contain text, images,
and even video, and can be assigned

to any part of the page layout.

Widgets

Use the Widget tool to display
dynamic data and add blocks, links,
and interactive elements most
anywhere in your store.

Polls

Create polls to learn about your
customers’ opinions and preferences.

They're fun to take and see the results!
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Content Pages
All content can be viewed in terms of its shelf life, just as any product in a store. Did
you know that the shelf life of social media content is less than twenty-four hours?
The potential shelf life of the content you create can help you decide where to invest
your resources.

Content with a long shelf life is sometimes referred to as evergreen content.
Examples of evergreen content include customer success stories, "how to"
instructions, and Frequently Asked Questions (FAQ.) Other content is perishable by
nature, such as events, industry news, and press releases.

Core Content
The Magento demo store has examples of core content pages that can help you get
started. Take a look at the following pages in your store, to make sure that they
convey your message and brand.

Home

The demo “Home” page includes a
banner, an image carousel, several
static blocks with links, and a list of
new products.
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About Us

The “About Us” page is linked from the
footer of your store. You can include
images, video, links to press releases

and announcements. The sample page
has an image on the right, and one of
a decorative sort to indicate the end of

the page.

Customer Service

The “Customer Service” page is
another node in the page hierarchy.
The two headers on the page have
content that only becomes visible
when the header is clicked.

Privacy Policy

Your store’s “Privacy Policy” page
should be updated with your own

information. As a best practice, your
privacy policy should explain to your

customers the type of information that
your company collects and how it is

used.

Page Not Found

The “404 Page Not Found” page is
named for the response code that is
returned when a page cannot be
found. URL redirects reduce the
number of times that this page
appears. However, for those times
when it is necessary, you might as
well take advantage of the opportunity
to offer some links to products that
the customer might find interesting.
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Enable Cookies

The “Enable Cookies” page appears
when visitors to your site do not have
cookies enabled in their browsers. The
page provides step-by-step, illustrated
instructions to enable cookies for the

most popular browsers.

Service Unavailable

The “503 Service Unavailable" page is
named for the response code that is
returned when the server is
unavailable.

Creating a Page
The process of adding a new content page to your store is essentially the same for any
type of page you might want to create. You can include text, images, blocks of content,
variables, and widgets.

Don’t forget that most content pages are designed to be read by search engines first, and
by people second. Keep the needs of each of these two very different audiences in mind
when choosing the page title and URL, composing the meta data, and writing the
content.

Process Overview:
Step 1: Add a New Page
Step 2: Select the Page Layout
Step 3: Complete the Content
Step 4: Complete the Meta Data
Step 5: Publish the Page
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Step 1: Add a New Page

1. On the Admin menu, select CMS > Pages > Manage Content.

2. Click the Add New Page button.

3. In the Page Information section, do the following:

Page Information

a. Enter a Title for the new page.

b. Enter a URL Key for the page that is based on the Title. It should be all lowercase
characters, with hyphens instead of spaces.

The URL Key is added to the base URL for your store, to create the online address
for the page.

c. In the Store View list, select each view where this page will be available.

d. Set Status to “Disabled.” (This will be changed when the page is ready to publish.)

4. With the required fields complete, click the Save and Continue Edit button.

Step 2: Select the Page Layout

1. In the Page Information panel on the left, select Design.

2. In the Page Layout section, set Layout to one of the following:

l 1 column

l 2 columns with left bar

l 2 columns with right bar

l 3 columns
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Page Layout

Step 3: Complete the Content

1. In the Page Information panel on the left, select Content.

2. In the Content Heading box, type the text you want to appear as the main heading at
the top of the page.

Complete the remaining content, as you want it to appear in the main content column,
according to the page layout selected. The content can include text, images, variables,
and widgets with dynamic data.

3. Click the Show / Hide Editor button to display the WYSIWYG editor. You can format
the text with the toolbar buttons.

WYSIWYG Editor

4. Click the Show / Hide Editor button again to return to the HTML mode. You can work
in either mode that you prefer.
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HTML Mode

5. Click the Save and Continue Edit button.

Step 4: Complete the Meta Data

1. In the panel on the left, select Meta Data.

2. Complete the Keywords and Description for the page. This information is used by
search engines to index the page.

Step 5: Publish the Page

1. In the panel on the left, select Page Information.

2. Set Status to “Published.”

3. Click the Save Page button.

When the page is complete, it can be added to the navigation of your store, linked to
other pages, or added as a link in the footer.

Using the Editor
The WYSIWYG editor gives you the ability to enter and format while working in a “What
You See Is What You Get” view of the content. If you prefer to work directly with the
underlying HTML code, you can easily change modes. The editor can be used to create
content for pages, blocks, and product descriptions. When working in the product
catalog, the editor is accessed by clicking the WYSIWYG Editor button.

For a complete list of toolbar buttons, see the Editor Toolbar in the appendix of this
guide.

Editor Toolbar
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Inserting a Link
The easiest way to insert a link is to use the Link button in the editor toolbar. It doesn’t
require any knowledge of HTML and the result is the same.

To insert a link:

1. Highlight the text where you want to create the link. Then, in the editor toolbar, click
the Link button.

Link Button

2. In the Link URL field, enter one of the following:

l The URL Key of a page in your store.

l The full URL of an external page to be linked.

3. Set Target to one of the following:

l Open link in the same window

l Open in a new window

4. In the Title field, enter the tooltip text that appears when someone hovers over the link.

5. Click the Insert button to create the link.
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Inserting Images
From the editor, you can insert an online image that resides on another server, or
display an image that has been uploaded to your store’s Media Storage library.

Method 1: Insert an Image from Media Storage

1. If necessary, click the Show / Hide Editor button to display the code.

2. Position the cursor where you want the code to be inserted. Then, click the Insert Image
button.

3. Select the image that you want to use, and click the Insert File button.

Media Storage

4. To view the image in WYSIWYG mode, click the Show / Hide Editor button.

Method 2: Insert an Image from Another Server

Use this method to insert an image that is available online, but resides on another
server. You must have the full URL of the image to complete the process.

1. Click the Show / Hide Editor button to work in WYSIWYG mode.

2. Position your cursor where you want the image to appear.

3. On the Editor toolbar, click the Insert Image button.
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Insert Image Button

4. Then, do the following:

a. In the Image URL field, paste the full Web address to the image.

b. In the Image Description field, write a brief description of the image.

c. In the Title field, write a relevant title for the image.

5. Click the Insert button to complete the process.

Adding a Widget
The Widget tool can be used to add a variety of content elements to the page, including
links to any content page or node, product, or category. Links can be positioned on the
page by block reference or incorporated directly into CMS content and email templates.
You can create links to the following four types of content:

l CMS Pages

l Catalog Categories

l Catalog Products

Links can be displayed as a block, or used inline and incorporated into existing text. By
default, a link inherits its style from the location (block reference) according to the style
sheet (styles.css) of the theme.

To add a widget to a page:

1. Open the CMS page to be edited. Then, in the panel on the left, select Content.

2. Position the cursor in the HTML code where you want to place the link.

3. Click the Insert Widget button. Then, do the following:

a. When prompted, select theWidget Type. In this example, we insert a link to a
product.

b. You can leave the Anchor Custom Text field empty to use the product name.

c. Enter a Anchor Custom Title for best SEO practice. (The title isn't visible on the
page.)

d. Set Template to one of the following:
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l To incorporate the link into text, select “Product Link Inline Template.”

l To place the link on a separate line, select “Product Link Block Template.”

4. Click the Select Product button, and do the following:

a. In the tree, navigate to the category you want.

b. In the list, click the product that you want to include in the link.

Select the Product

c. Click the Insert Widget button to place the link on the page. The link markup tag is
enclosed in double curly braces.

Widget Link Code

5. Click the Show / Hide Editor button to see the link in WYSIWYG mode.
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Now you can continue editing the page, and incorporate the links into the rest of the
content.

Widget Links on CMS Page
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Static Blocks
A block is a modular unit of content that can be positioned most anywhere on the
page. CMS Static blocks are used to create modular chunks of content that can be
incorporated into other blocks and pages.

CMS Static Blocks

Magento Community Edition’s content management system (CMS) makes it easy to
create blocks of content without writing any code. Blocks can contain text, images,
and even video, and can be assigned to any part of the page layout.

Positioning Blocks

Blocks can also be defined and positioned by entering XML code in the Layout
Update box on the target page. Custom CMS blocks can also be referenced and
positioned without writing any code by using the Widget tool.
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Creating a Static Block
Custom, static blocks of content can be added to any page, group of pages, or even to
another block. The carousel image slider on the home page of the demo store is
generated by code that is placed in a static block. The three smaller blocks below are also
static blocks that link to other pages. Although they look like graphic images, they are
actually defined using HTML and CSS.

Static Blocks on Home Page

To create a block:

1. On the Admin menu, select CMS > Static Blocks.

2. In the upper-right corner, click the Add New Block button. Then, do the following:

a. Assign a descriptive Block Title.

b. Assign a unique Identifier to the block. Use all lowercase characters, with
underscores instead of spaces. The identifier is used for internal reference.

c. Select the Store View(s) where this content block will be visible.

d. Set Status to “Enabled” to make the block visible in the store.

e. Complete the Content for the block. You can use the Editor to format text, create
links and tables, add images, video, and audio.

3. When complete, click the Save Block button.
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General Information

Positioning Blocks
The code that controls the page layout and placement of blocks is written in XML. You
may have noticed references to XML Page Layout Updates throughout the Admin of your
store. Every product, category, and piece of content—whether it’s a page, block, banner,
or app—has a section where you can update the XML code that controls the positioning
of the item.

Block References
The selection of available block references that is available varies by page type, and
whether the customer is logged in, or is visiting the as a guest.

Widgets make it easy to position a block at a specific place on the page, and even for a
specific product or category. You can select each option from a list, rather than trying to
remember all of the possible combinations.

Category and CMS Pages
Block Reference Position

Breadcrumbs The navigation aid at the top of many pages that shows your
current location as a link. Any additional content placed in the
Breadcrumbs reference floats to the right of the bread-
crumbs, if displayed.

Left Column Content is added to the left column.

Main Content Area Content is added to the main content area.

My Cart Extra Actions Content appears below the Cart Subtotal in the My Cart
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Block Reference Position

popup located within the top link.

Navigation Bar Content appears below the main navigation bar.

Page Bottom Content appears at the bottom of the page.

Page Footer Content appears above the footer of the page.

Page Header Content appears below the header of the page.

Page Top Content appears at the top of the page.

Right Column Content appears in the right column.

Store Language Content appears in the upper-left corner of the header.

Product Page
Block Reference Position

Alert URLs Content appears below the title of the product on the product
detail page.

Bottom Block Options
Wrapper

If custom options are added, content appears below the Add
to Cart button.

Breadcrumbs Content appears to the right of breadcrumbs—the navigation
aid that provides links as a path—that’s showcased below the
navigation bar.

Info Column Options
Wrapper

If a custom options are added, content appears to the right.
The same location applies to configurable options.

Left Column Content appears below the left column blocks.

Main Content Area Content appears below the main content area.

My Cart Extra Actions Content appears below the Cart Subtotal in the My Cart
popup located within the top link.

Navigation Bar Content appears below the main navigation bar.

Page Bottom Content appears at the bottom of the page.

Page Footer Content appears above the footer of the page.

Page Header Content appears below the header of the page.

Page Top Content appears at the top of the page.

PayPal Express Checkout If the PayPal payment method is enabled, content appears
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Block Reference Position

(Payflow Edition) Short-
cut Wrapper

below the PayPal buy button.

PayPal Express Checkout
Shortcut Wrapper

If the PayPal payment method is enabled, content appears
below the PayPal buy button.

Product Tags List Content appears below the products tag bar.

Product View Extra Hint Content appears below the main top price of the product.

Right Column Content appears below the right column blocks.

Store Language Content appears to the right of the language chooser.

Tags List Before Content appears above the Add Your Tags field.
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Chapter 30:

Widgets
A widget is a snippet of code that makes it possible to display a wide range of
content and place it at specific block references in your store. Many widgets display
real-time, dynamic data and create opportunities for your customers to interact with
your store. The Widget tool makes it easy to place existing content such as blocks,
banners, and interactive elements most anywhere in your store.

In addition, the widget code that you generate can be easily incorporated into other
content directly from the editor. Here are a few ways you can use widgets:

l Create landing pages for marketing campaigns

l Dynamically update information such as recently viewed items

l Display promotional images at specific locations in your store

l Add interactive elements and action blocks, such as external review systems,
video chats, voting, and subscription forms

l Provide navigation elements such as tag clouds, rotating banners, and catalog
image sliders

l Create dynamic elements that can be easily configured and embedded with
content

Widget Types
CMS Page Link

Displays a link to a selected page. Allows you to specify custom text and title. When
the link is complete, it can be used in content pages and blocks.

CMS Static Block

Displays a block of content at a specific location on a page.

Catalog Category Link

Displays a link to a selected catalog category. Allows you to specify custom text and
a title. Two templates are available: inline and block. When the link is complete, it
can be used in content pages and blocks.
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Catalog New Products List

Displays a block of products which have been designated as new, for the duration of
time specified in the product record.

Catalog Product Link

Displays a link to a selected catalog product. Allows you to specify custom text and a
title. Two templates are available: inline and block. When the link is complete, it can be
used in content pages and blocks.

Orders and Returns

The Orders and Returns widget gives customers the ability to submit their own requests
for return merchandise authorization.

Recently Compared Products

Displays the built-in block of recently compared products. You can specify the number of
products included, and format them as a list or product grid.

Recently Viewed Products

Displays the built-in block of recently viewed products. You can specify the number of
products included, and format them as a list or product grid.

Mini Shopping Cart

If the store has a responsive theme, the Mini Shopping Cart widget can be used to
display additional information, such as a banner or contact information, in the mini
shopping cart.

Creating a Widget
The process of creating a widget is nearly the same for each type. You can follow the first
part of the instructions, which is the same for all types, and then complete the last part
that is specific to the type of widget you want to create.

Process Overview:
Step 1: Choose the Widget Type
Step 2: Specify Where It Goes
Step 3: Complete the Widget Options
Step 4: Check It Out!
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Step 1: Choose the Widget Type

1. On the Admin menu, select CMS > Widgets.

2. Click the Add New Widget Instance button. Then, do the following;

a. In the Settings section, select the Type of widget you want to create.

b. Select the Design Package/Theme that will be used with the widget.

3. Click the Continue button.

Widget Settings

4. In the Frontend Properties section, do the following:

Frontend Properties

a. In theWidget Instance Title field, enter a descriptive title for the widget. This title
is for internal use only, and won’t be visible to your customers.

b. Set Assign to Store Views to “All Store Views,” or to the view where the widget to be
available. To select more than one, hold the Ctrl key down, and select each option.

c. Enter a number in the Sort Order field to determine the order of the block when
listed with others in the column. The top position is zero.

Step 2: Specify Where It Goes

1. In the Layout Updates section, click the Add Layout Update button.

2. Set Display On to the type of category or product page where you want the widget to
appear.
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3. In the Block Reference list, select the block or section of your page layout where you
want the widget to appear.

Layout Updates

If the widget is a link, set Template to one of the following:

Block Template Formats the content so it can be placed as standalone unit
on the page.

Inline Template Formats the content so it can be placed inside other
content. For example, a link that goes inside a paragraph of
text.

4. Click Save and Continue Edit to save your changes and continue editing.

Step 3: Complete the Widget Options

The options for each type vary slightly, but the process is essentially the same. The
following instuctions show how to place a CMS Static Block.

1. In the panel on the left, select Widget Options.

2. Click the Select Block button.

3. In the list, click to select the block you want to place.

Select Block

4. When complete, click the Save button.

The widget appears in the Manage Widget Instances list.
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5. When prompted, follow the instructions at the top of the workspace to update the cache,
as needed.

Step 4: Check It Out!

Return to your storefront to verify that the block is in the correct location. To move the
block to a different location, you can reopen the widget and try a different page or block
reference.

CMS Static Block Widget
The CMS Static Block widget gives you the ability to place an existing CMS block most
anywhere in your store.

Step 1: Choose the Widget Type

1. On the Admin menu, select CMS > Widgets.

2. Click the Add New Widget Instance button.

3. In the Settings section, set Type to “CMS Static Block.” Then, click the Continue button.

4. In the Frontend Properties section, do the following:

a. In theWidget Instance Title field, enter a descriptive title for the widget. This title
is for internal use only, and is not visible to your customers.

b. Enter a number in the Sort Order field to determine the order of the block when
listed with others in the column. The top position is zero.

c. Set Assign to Store Views to “All Store Views,” or to the view where the app will be
available. To select more than one, hold the Ctrl key down, and select each option.

Step 2: Complete the Layout Updates

1. In the Layout Updates section,set Display On to the category, product, or page where
you want the block to appear.

2. To complete the Layout Updates, do the following:

a. Select the Page where you want the block to appear.

b. Select the Block Reference to identify the place on the page where the block will
appear

c. Accept the default setting for Template, which is set to "CMS Static Block Default
Template."

d. Click Save and Continue Edit.
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Step 3: Place the Block

1. In the panel on the left, select Widget Options.

2. Click the Select Block button.

Then in the list, click to select the block you want to place.

3. When complete, click the Save button.

The app appears in the Manage Widget Instances list.

4. When prompted, follow the instructions at the top of the workspace to update the index
and page cache.

5. Return to your storefront to verify that the block is in the correct location. To move the
block to a different location, you can reopen the widget and try a different page or block
reference.

New Products List
The list of new products is an example of dynamic content, and consists of live data that
is pulled from your product catalog. By default, the “New Products” list includes the first
eight of the most recently added products. However, it can also be configured to include
only products within a specified date range.

New Products List on Home Page

Process Overview:
Step 1: Set the Date Range for Each Product
Step 2: Create a Working Copy of the Widget
Step 3: Select the Location for the List
Step 4: Configure the List
Step 5: Preview Your Work
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Step 1: Set the Date Range for Each Product

To make a product appear in the list by date range, the dates must be specified in the
product record. The product then appears in the New Products list during the date range
specified.

1. On the Admin menu, select Catalog > Manage Products.

2. Find the product you want to feature, and open the record. Then, do the following:

a. In the Set Product as New From Date field, click the calendar button and select the
first date that you want the product to be featured.

b. In the Set Product as New To Date field, click the calendar button and select the
last date that you want the product to be featured.

"Set Product As New " Date Range

3. When complete, click the Save button.

4. When you are prompted to reindex and refresh the page cache, click the links at the top
of the workspace, and follow the instructions.

The product will now appear in the New Products list during this date range. Repeat
this step for each product that you want to feature.

Step 2: Create a Working Copy of the Widget

The code that determines the content of the list and its placement in your store is
generated by the Widget tool. To create your own working copy of the New Products list,
simply save a copy of the existing widget. Your working copy is a new “instance” of the
widget, and any changes you make will not affect the original.
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1. On the Admin menu, select CMS > Widgets.

2. In the upper-right corner, click the Add New Widget Instance button.

3. In the Settings section, do the following:

a. Set Type to “Catalog New Products List.”

b. Select the Design Package/Theme that is used by the store.

4. Then, click the Continue button.

Widget Type

5. In the Frontend Properties section, complete the following fields:

Widget Instance Title Enter a descriptive title for your widget. This title is visible
only from the Admin.

Assign to Store Views Select the store views where the widget will be visible. You
can select a specific store view, or "All Store Views."

Sort Order (Optional) Enter a number to determine the order this items
appears with others in the same part of the page. (0 = first,
1 = second, 3= third, and so on.)

Widget Frontend Properties

Step 3: Select the Location for the List

1. In the Layout Updates section, click the Add Layout Update button. Then, do the
following:

a. Set Display On to “Specified Page.”

b. Set Page to “CMS Home Page.”

c. Set Block Reference to “Main Content Area.”
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d. Set Template to one of the following:

l New Product Lists Templates

l New Products Grid Template

Layout Updates

2. Click the Save and Continue Edit button to save your changes.

Step 4: Configure the List

1. In the panel on the left, select Widget Options. Then, do the following:

2. Set Display Products to one of the following:

All Products Lists products in sequence, starting with those most
recently added.

New Products Lists only the products which are identified as “New.” A
product is considered to be new during the date range
specified in the “Set Product As New From” date and “Set
Product As New To” date. fields of the product. The list will
be blank if the date range expires and no additional
products have been set as "New."

3. Complete the remaining information as follows:

a. To provide navigation control for lists with multiple pages, set Display Page
Control to “Yes.” Then, in the Number of Products per Page field, enter the
number of products you want to appear on each page.

b. Set Number of Products to Display to the number of new products you want to
include in the list. The default setting is 10.

c. In the Cache Lifetime (Seconds) field, select how often you want to refresh the list
of new products. By default, the cache is set to 86400 seconds, or 24 hours.
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Widget Options

4. When complete, click the Save button.

5. When prompted to refresh the cache, click the link in the message at the top of the
workspace, and follow the instructions.

Step 5: Preview Your Work

1. On the Admin menu, select CMS > Pages > Manage Content.

2. Find the published page in the list, where you placed the New Products list. Then, in the
Action column, click the Preview link.

Mini Shopping Cart Widget
You can use a widget to show relevant information to your customers when the mini
shopping cart is displayed in your store. For example, you might want to display a
promotional message, or you could provide a phone number or other contact
information.

You can use the mini shopping cart widget only with responsive web design themes.

Widget in Mini Shopping Cart
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Step 1: Choose the Widget Type

1. On the Admin menu, select CMS > Widgets.

2. Click the Add New Widget Instance button.

3. In the Settings section, do the following:

a. Set Type to “CMS Static Block.”

b. Set Design Package/Theme to any responsive web design (RWD) theme. You must
select a responsive package/theme to use the mini cart widget.

c. Click the Continue button.

Widget Settings

4. In the Frontend Properties section, do the following:

a. In theWidget Instance Title field, enter a descriptive title for the widget. This title
is for internal use only, and is not visible to your customers.

b. Enter a number in the Sort Order field to determine the order of the block when
listed with others in the column. The top position is zero.

c. Set Assign to Store Views to “All Store Views,” or to the view where the block will be
available. To select more than one, hold the Ctrl key down and select each option.

Frontend Properties
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Step 2: Complete the Layout Updates

1. In the Layout Updates section, set Display On to the category, product, or page where
you want the block to appear.

2. To complete the Layout Updates, do the following:

a. Select the Page where you want the block to appear.

b. Set Block Reference to “Mini-cart promotion block.”

c. Accept the default setting for Template, which is set to “CMS Static Block Default
Template.”

d. Click Save and Continue Edit.

Step 3: Place the Block

1. In the panel on the left, select Widget Options.

2. Click the Select Block button. Then in the list, click to select the block you want to
place.

3. When complete, click the Save button.

The block appears in the Manage Widget Instances list.

4. When prompted, follow the instructions at the top of the workspace to update the index
and page cache.

5. Return to your storefront to verify that the block is in the correct location.
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Chapter 31:

Variables
Variables are reusable pieces of information that can be created once and used in
multiple places, such as email templates, blocks, and content pages. Your Magento
store includes a large number of predefined attributes, and also gives you the ability
to create your own custom variables.

Predefined Variables
Predefined variables are easy to add to content pages, blocks, and email templates.

To add a variable to a page:

1. On the Admin menu, select CMS > Pages > Manage Content. Then, click to open the
page.

2. In the Page Information panel on the left, select Content. Then from the editor, do
one of the following:

l Click the Insert Variable button.

l If you prefer to work with the code, click the Show / Hide Editor button.

3. Position the insertion point in the text where you want the variable to appear. Then,
click the Insert Variable button.

4. In the list of available store contact variables, click the one you want to use.
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Insert Variable

5. When complete, click the Save button.

To add a variable to a block:

1. On the Admin menu, select CMS > Static Block. Then, click to and open the block.

2. From the editor, do one of the following:

l Click the Insert Variable button.

l If you prefer to work with the code, click the Show / Hide Editor button.

3. Position the insertion point in the text where you want the variable to appear. Then,
click the Insert Variable button.

4. In the list of available variables,click to select the one you want to use.

5. When complete, click the Save Block button.

To add a variable to an email template:

1. On the Admin menu, select System > Transactional Emails.

2. Do one of the following:

l Click to edit a predefined template.

l Click the Add New Template button to create a new one.

3. In the Template Content box, position the insertion point where you want the variable
to appear. Then, click the Insert Variable button.

4. In the list of available variables, click to select the one you want to use.
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5. When complete, click the Save Template button.

Predefined Variables
Store Contact Variables

Store Contact Information
Base Unsecure URL
Base Secure URL
General Contact Name
General Contact Email
Sales Representative Contact Name
Sale Representative Contact Email
Custom 1 Contact Name
Custom 1 Contact Email
Custom 2 Contact Name
Custom 2 Contact Email
Store Name
Store Contact Telephone
Store Contact Address

Custom Variables
If you know a little basic HTML, you can create custom variables and incorporate them
into pages, blocks, banners, and email templates. When a variable is inserted into
HTML, it is formatted as a markup-tag, and enclosed in double curly braces.

{{CustomVar code= "store_hours"}}

To create a custom variable:

1. On the Admin menu, select System > Custom Variable.

2. Click the Add New Variable button.

3. Enter an identifier in the Variable Code field. Use all lowercase characters, without
spaces.

4. Enter a Variable Name, which is used for internal reference. Then, do one of the
following:

l In the Variable HTML Value text field, enter any content you want to include, using
basic HTML tags. This option allows you to format the value.

l In the Variable Plain Value field, enter the variable value as plain text.
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New Custom Variable

5. When complete, click the Save button.
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Chapter 32:

Layout Updates
Before you begin working with custom layout updates, it is important to understand
how the pages of your store are constructed, and the difference between the terms
layout and layout update. The term layout refers to the visual and structural
composition of the page. However, the term layout update refers to a specific set of
XML instructions that determines how the page is constructed.

The XML layout of your Magento Community Edition store is a hierarchical tree of
blocks. Some elements appear on every page, and others appear only on specific
pages. You can see how blocks are referenced by examining the layout update code
for your home page. To do so, simply open your CMS home page in edit mode, and
select the Design tab to view the Page Layout section. Depending on the theme, it
might contain instructions to remove blocks, unset blocks, and add blocks by
referencing specific areas of the page layout.

In many cases, the same result can be achieved with a widget. To place a block of
content with a widget, you must identify the page, and location on the page, where
you want the block to appear. You can use a widget to place a block on any generic
page of your store, including the home page and all CMS pages. However, to place a
block in the sidebar of a specific CMS page, you must make a layout update.
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Placing a Block with a Layout Update
Blocks can be placed in the left or right column of a specific page by making a layout
update to the XML code. With a few simple changes to the code, you can position the
block in either column, and control its position in relation to other blocks.

As you work with the underlying code, you will encounter slightly different terminology.
For example, the term callout is sometimes used to refer to a block that is defined as a
layout update with XML code. The term sidebar refers to the left or right columns of the
page layout. For our general discussion, we use the terms block and column. However,
when entering layout update code, make sure to follow the syntax exactly as shown in
the example.

To place a block in a side column:

1. On the Admin menu, select CMS > Pages > Manage Content.

2. Click to open the CMS page. Then, in the panel on the left, select Design.

3. In the Layout Update XML box, enter the code for the right or left sidebar, as shown in
example. Then, do the following:

a. Change the reference name to identify either the “right” or “left” column.

b. Change the block_id to the identifier of the block to be placed.

<reference name="right">

<block type="cms/block" name="right.permanent.callout">

<action method="setBlockId"><block_id>your-block-id</block_

id></action>

</block>

</reference>

Code for CMS Block in Side Column

4. When complete, click the Save Page button.
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Controlling Block Order
To control the order of blocks in an XML layout update, include a “before” or “after”
positioning property in the code. To place a block—either before, or after a specific
block—replace the hyphen with the block identifier, as shown in the following examples:

before="-" Places the block at the top of the sidebar, before other blocks.

after="-" Places the block at the bottom of the sidebar, after other blocks.

<block type="cms/block" before="-" name="left.permanent.callout">

<block type="cms/block" before="some-other-block"

name="left.permanent.callout">

<block type="cms/block" after="-" name="left.permanent.callout">

<block type="cms/block" after="some-other-block"

name="left.permanent.callout">

Code to Position CMS Blocks
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Standard Block Layout
In the following diagram, the block names that can be used to refer to a block in the
layout are black, and the block types, or block class paths, are blue.

Standard Block Layout
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Block Descriptions

Block Type Description

page/html There can be only one block of this type per page. The block
name is "root," and, it is one of the few root blocks in the lay-
out.You can also create your own block and name it "root,"
which is the standard name for blocks of this type.

page/html_head There can be only one block of this type per page. The block
name is "head," and it is a child of the root block. This block
must not be removed from layout.

page/html_notices There can be only one block of this type per page. The block
name is "global_notices," and it is a child of the root block. If
this block is removed from the layout, the global notices will
not appear on the page.

page/html_header There can be only one block of that type per page. The block
name is "header," and it is a child of the root block. This block
corresponds to the visual header at the top of the page, and
contains several standard blocks. This block must not be
removed.

page/html_wrapper Although included in the default layout, this block is deprec-
ated, and only is included to ensure backward compatibility.
Do not use blocks of this type.

page/html_

breadcrumbs

There can be only one block of this type per page. The name
of this block is "breadcrumbs," and it is a child of the header
block. This block displays breadcrumbs for the current page.

page/html_footer There can be only one block of this type per page. The block
name is "footer," and it is a child of the root block. The footer
block corresponds to the visual footer at the bottom of the
page, and contains several standard blocks. This block must
not be removed.

page/template_links There are two blocks of this type in the standard layout. The
"top.links" block is a child of the header block, and cor-
responds to the top navigation menu. The "footer_links" block
is a child of the footer block, and corresponds to the bottom
navigation menu. It is possible to manipulate the template
links, as shown in the examples.

page/switch There are two blocks of this type in a standard layout. The
"store_language" block is a child of the header block, and cor-
responds to the top language switcher. The "store_switcher"
block is a child of the footer block, and corresponds to the
bottom store switcher.
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Block Type Description

core/messages There are two blocks of this type in a standard layout. The
"global_messages" block displays global messages. The "mes-
sages" block is used to display all other messages. If you
remove these blocks, the customer won't be able to see any
messages.

core/text_list This type of block is widely used throughout Magento, and is
used as a placeholder for rendering children blocks.

core/profiler There is only one instance of this type of block per page. It is
used for the internal Magento profiler, and should not be
used for other purposes.

Layout Update Syntax
Custom layout updates can be applied to product category pages, product pages, and
CMS page to achieve a variety of results, such as:

l Create new block (<block>)

l Update existing content (<reference>)

l Assign actions to blocks (<action>)

l Remove blocks (<remove>)

Any change made to the layout is applied when the associated entity—which can be
either a product, category, or CMS page—becomes active in the frontend of the store.

Custom layout update instructions consist of well-formed XML tags, without the <?xml
...> declaration and root tag. As with normal XML, every tag must either be empty or
properly closed, as shown in the following examples:

<tag attribute="value" />

<tag attribute="value"> ... </tag>

<block>

Creates a new block within the current context. Layout block nesting defines the ordering
of block initialization location of the blocks on the page.

Name Value

type * block class path

An identifier of the block class path that corresponds to the
class of the block. See the list of the available block types
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Name Value

below.

name * block name identifier

A name that can be used to address the block in which this
attribute is assigned. If you create a new block with the name
that is the same as one of the existing blocks, your newly
created block substitutes the previously existing block. See
the list of names of existing blocks below.

before block name | '-'

Is used to position the block before a block with the name
specified in the value. If "-" value used the block is positioned
before all other sibling blocks.

after block name | '-'

Is used to position the block after a block with the name spe-
cified in the value. If "-" value used the block is positioned
after all other sibling blocks.

template template filename

A template filename used for the specific block type. As you
have no way to see the list of template files, use whatever tem-
plate value is demanded for every block type listed below.

as Block alias

An alias name by which a template calls the block in which
this attribute is assigned. Sometimes it's necessary to specify
the alias for a specific block type.

<reference>

Changes the context for all included instructions to a previously defined block. An
empty <reference> tag if of no use, because it affects only the instructions which are
children.

Name Value

name * block name

A name of a block to reference.
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<action>

Is used to access block API, in other words, call block's public methods. It is used to set
up the execution of a certain method of the block during the block generation. Action
child tags are translated into block method arguments. The list of all available methods
depends on the block implementation (e.g. public method of the block class).

Name Value

method * Block method name

A name of the public method of the block class this instruction is
located in that is called during the block generation.

<remove>

Removes an existing block from the layout.

Name Value

name * Block name

The name of the block to be removed.

<extend>

This instruction performs final modifications to blocks which are already part of the
layout. Every attribute in the <block> instruction—except for the block name—is subject
for change. In addition,the special attribute parent can be used to change the parent of
the block. Simply put the name of the new parent block into the <extend> instruction,
and the parent of the block that is referenced will be changed in the layout.

Name Value

name * Block name

The name of any block to be extended.

* Any other
Any other attribute specific for the <block> instruction.

parent Block name

The name of the block that should become a new parent for
the referenced block.

* Indicates a required value
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Layout Update Examples
The following blocks types can be manipulated with custom layout instructions. Each
action must be specified using the full syntax of the instruction. In the following
examples, a simplified notation is used to refer to each action,.which corresponds to the
full syntax of the instruction.

?

<!-- Action can be specified inside either a <block>

or <reference> instruction. -->

<action method="someActionName">

<arg1>Value 1</arg1>

<arg2>Value 2</arg2>

<!-- -->

<argN>Value N</argN>

</action>

<!-- -->

Full Syntax

?

someActionName($arg1, $arg2, ..., $argN)

 Simplified Syntax

page/template_links
Action Description

addLink($label, $url, $title, $prepare

Adds another link to the end of the list of
existing links. Just specify the $label (link
caption), $url (link URL) and $title (link
tooltip), and you'll see a new link in the cor-
responding place. The $prepare parameter
must be "true" if you want the URL to be
prepared, or converted to the full URL from
the shortened URL. For example, the
newpage becomes BASE_URL/newpage if
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Action Description

prepared.

removeLinkByUrl($url) Removes a link from the block by its URL.
Note that the URL must be properly spe-
cified and exactly match corresponding
URL of the link you want to remove.

cms/block
Action Description

setBlockId($blockId) Specifies the ID of a CMS block, so its
content can be fetched and displayed when
the page is rendered.

?

<!--...-->

<reference name="content">

<block type="cms/block" name="additional.info" as="additionalInfo">

<action method="setBlockId"><id>additional_info</id></action>

</block>

</reference>

<!-- -->

Example

core/text

A core/text block can be used to enter freeform text directly into the template.

Action Description

addText($textContent) Specifies text to be rendered as the block's
content. After the text is specified, the
layout update instructions must continue
to be a valid XML statement. If you use
HTML tags as part of the text, it is recom-
mended to use:
<![CDATA[...]]>
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?

<!--...-->

<reference name="content">

<block type="core/text" name="test.block">

<action method="addText">

<txt><![CDATA[<h2>ATTENTION!</h2><p>Check your options

carefully before you submit.</p>]]></txt>

</action>

</block>

</reference>

<!-- -->

Example

page/html_welcome

This block can be used to duplicate the “Welcome, <USERNAME>!” message that
appears in the header block. When the user is not logged in, the welcome message
specified in the configuration appears. See: System > Configuration > General > Design
> Header.

XML Load Sequence
For developers, it is important to understand that blocks and layout updates must be
loaded in the correct order, in keeping with the rules of precedence and load sequence
which determine how the page is rendered. Magento supports the following page layout
scenarios:

Default Layout
The default layout consists of the visual elements that are visible from every page of the
store. Whether it is a menu item, or a shopping cart block, each item has a handle in the
default section of the layout definition.

Changes to Specific Pages
The second case allows you to create a different layout for a specific page. The
XML layout for specific pages is constructed in the same sequence that Magento loads
modules, and is determined by the system configuration.
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In addition to the instructions in the layout update files which are specific to each
module, you can make a custom layout update that applies to a special case in the
backend, and is merged each time the special case occurs.
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Chapter 33:

Markup Tags
A markup tag is a snippet of code that contains a relative reference to an object in
your store, such as a page, block, or image. Markup tags can be incorporated into
the HTML content of CMS pages, blocks, images, and email templates.

Markup tags are enclosed in double, curly braces, and can be generated by the
Widget tool, or typed directly into HTML content. For example, rather than hard-
coding the full path to a page, you can use a markup tag to represent the store URL.
The markup tags featured in the following examples include:

Store URL

The Store URL markup tag represents the base URL of your website, and is used as a
substitute for the first part of a full URL, including the domain name. There are two
versions of this markup tag: One that goes directly to your store, and the other with
a forward slash at the end that is used when a path is added.

{{store url='apparel/shoes/womens'}}

Store URL

Media URL

The Media URL markup tag represents the location and filename of an image that is
stored on a content delivery network (CDN), and can be used to place an image on a
page, block, banner, or email template.

{{media url='shoe-sale.jpg'}}

Media URL

Block ID

The Block ID markup tag is one of the easiest to use, and lets you place a block
directly on a CMS page, and even place a block inside another block. You can use
this technique if you want to use the same image with text for different promotions,
or languages. The Block ID markup tag references a block by its identifier.

{{block id='block-id'}}

Block ID
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Template Tag

A template tag references a PHTML template file, and can be used to display the block
on a CMS page or static block.

The code in the following example can be added to a page or block to display the
Contact Us form.

{{block type="core/template" name="contactForm"

template="contacts/form.phtml"}}

“Contact Us” Template Tag

The code in the next example can be added to a page or block to display the a list of
products in a specific category, by category ID.

{{block type="catalog/product_list" category_id="22"

template="catalog/product/list.phtml"}}

“Category Product List” Template Tag

Widget Code

The Widget tool can be used to display lists of products, or to insert complex links, such
as one that goes to a specific product page, based on product ID. The code that is
generated includes the block reference, location of the code module, and corresponding
PHTML template. After the code is generated, you can copy and paste it from one place
to another.

The code in the following example can be added to a page or block to display the list of
new products.

{{widget type="catalog/product_widget_new"

display_type="new_products" products_count="10"

template="catalog/product/widget/new/content/new_grid.phtml"}}

“New Products Grid” Code

The code in the next example can be added to a page or block to display a link to a
specific product, by product ID.

{{widget type="catalog/product_widget_link" anchor_text="My Product

Link"

title="My Product Link"template="catalog/product/widget/link/link_

block.phtml" id_path="product/31"}}

“Link to Product” Code
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Using Markup Tags in Links
You can use markup tags with HTML anchor tags, and link directly to any page in your
store. The link can be incorporated into CMS content, such as a page, static block,
banner, or email template. You can also use this technique to link an image to a specific
page.

Process Overview:
Step 1: Identify the Destination URL
Step 2: Add the Markup to the URL
Step 3: Complete the Anchor Tag

Step 1: Identify the Destination URL

If possible, navigate to the page that you want to link to, and copy the full URL from the
address bar of your browser. The part of the URL that you need comes after the “dot com
forward slash.” Otherwise, copy the URL Key from the CMS page that you want to use as
the link destination.

http://mystore.com/apparel/shoes/womens

http://mystore.com/apparel/shoes/womens.html

Full URL to Category Page

http://mystore.com/apparel/shoes/womens/nine-west-pump

http://mystore.com/apparel/shoes/womens/nine-west-pump.html

Full URL to Product Page

http://mystore.com/about-us

Full URL to CMS Page

Step 2: Add the Markup to the URL

The Store URL tag represents the base URL of your website, and is used as a substitute
for the “http address” part of the store URL, including the domain name and “dot com.”
There are two versions of the tag, which you can use, depending on the results you want
to achieve.

Markup Tag Description

store direct_url Links directly to a page.
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Markup Tag Description

store url Places a forward slash at the end, so additional references can
be appended as a path.

In the following examples, the URL Key is enclosed in single quotes, and the entire
markup tag is enclosed in double curly braces. When used with an anchor tag, the
markup tag is placed inside the double quotes of the anchor. To avoid confusion, you
can alternate using single-and double quotes for each nested set of quotes.

1. If you are starting with a full URL, delete the “http address” part of the URL, up through
and including the “dot.com forward slash.” In its place, type the Store URL markup tag,
up through the opening single quote.

http://mystore.com/apparel/shoes/womens

{{store url='apparel/shoes/womens'}}

Store URL Markup Tag

Otherwise, type the first part of the Store URL markup tag, and paste the URL key or
path that you copied earlier.

{{store url='

{{store url='apparel/shoes/womens'}}

Store URL Markup Tag with URL Key

2. To complete the markup tag, type the closing double quotes and double braces.

Step 3: Complete the Anchor Tag

1. Wrap the completed markup tag inside an anchor tag, using the markup tag instead of
the target URL. Then, add the link text, and closing anchor tag.

<a href="{{markup tag goes here}}">Link Text</a>

Markup in Anchor Tag

2. Paste the completed anchor tag into the code of any CMS page, block, banner, or email
template, where you want the link to appear.

<a href="{{store url='apparel/shoes'}}">Shoe Sale</a>

Complete Link with Markup
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Chapter 34:

Your Store Design
Magento provides a variety of easy-to-use design options that you can use to apply
your own customized look-and-feel to your store. To learn more advanced
techniques, such as how to use themes, skins, layouts, and blocks, see the Magento
Design Guide.

Magento is an object-oriented environment with pages that are assembled from
separate components. For some, this approach requires a slightly different way of
thinking, because there isn’t a single HTML page that corresponds to any given
page. After you understand the basics, you’ll appreciate working in such a flexible
and fluid environment!

Your Store Logo
The size of the logo in the header is determined by your theme. If your theme has a
sample logo, you can right-click and download the logo to make sure the
replacement logo is the same size.

Logo In Header

The logo image path points to its location on the server. What is actually a long
path is entered as a short path that is relative to the theme. For example:

Actual path: skin/frontend/base/default/images/logo.gif

Relative path: images/logo.gif

The header image filename is hard-coded into some of the theme files. Therefore, if
you change the file name of the logo file, you will also have to make some simple
updates to some source files. For non-programmers, the easiest approach is to use
the default filename, “logo.gif,” and write over the existing file.

http://www.magentocommerce.com/design_guide
http://www.magentocommerce.com/design_guide
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To change the logo:

1. On the server, copy your new logo file to the images folder of your theme. For example:
skin/frontend/base/default/images/logo.gif

2. On the Admin menu, select System > Configuration. Then in the panel on the left,
under General, select Design.

3. If you have multiple stores or views, set the Current Configuration Scope in the upper-
left corner to the store or view where the configuration applies. Then, clear the checkbox
after each field so new values can be entered.

4. Click to expand the Header section. Then, do the following:

a. If the path or filename has changed, enter it in the Logo Image Src field.

Logo Image Path

b. In the Logo Image Alt field, enter the alt text for the image. If the configuration is
for a different language view, enter the alt text in the appropriate language.

5. When complete, click the Save Config button.

Changing the Welcome Message
The "Welcome" message in the upper-left corner expands to include the name of
customers who are logged in. You can change the text for each store or store view.

Welcome Message

To change the welcome message:

1. On the Admin menu, select System > Configuration. Then in the panel on the left,
under General, select Design.

2. If you have multiple stores or views, set the Current Configuration Scope in the upper-
left corner to the store or view where the configuration applies. Then, clear the checkbox
after each field so new values can be entered.

3. Click to expand the Header section.

4. In the Welcome text box, enter the text that you want to appear in the header,
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Welcome Text

5. When complete, click the Save Config button.

6. When prompted to update the Page Cache, click the Cache Management link at the top
of the workspace. Then, follow the instructions to refresh the cache.

Store Demo Notice
If you are using a store as a demo, or if it is online but still “under construction,” you
can display a store demo notice at the top of the page. When you are ready to “go live”
with the store, simply remove the message.

To set the store demo notice:

1. On the Admin menu, select System > Configuration. Then in the panel on the left,
under General, select Design.

2. Click to expand the HTML Head section.

3. Scroll down and set the Display Store Demo Notice to your preference.

4. When complete, click the Save Config button.

Store Demo Notice
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Chapter 35:

Page Layout
The layout of each page in your store consists of distinct sections, or containers, that
define the header, footer, and content areas of the page. Depending on the layout,
each page might have one, two, three columns, or more. You can think of the layout
as the “floor plan” of the page.

Content blocks float to fill the available space, according to the section of the page
layout where they are assigned to appear. You will discover that if you change the
layout from a three-column to a two-column layout, the content of the main area
expands to fill the available space, and any blocks that are associated with the
unused side bar seem to disappear. However, if you restore the three-column layout,
the blocks reappear. This fluid approach, or liquid layout, makes it possible to
change the page layout without having to rework the content. If you are used to
working with individual HTML pages, you will discover that this modular, “building
block” approach requires a different way of thinking.

Page Layout Variations

1 Column

The “1 Column” layout can be used to
create a dramatic home page with a
large image or focal point. It’s also a
good choice for a landing page, or any
other page that has a combination of
text, images, and video.
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2 Columns with Left Bar

The “2 Columns with Left Bar” layout
is often used for pages with navigation
on the left, such as a catalog or search
results pages with layered navigation.
It is also an excellent choice for home
pages that need additional navigation
or blocks of supporting content on the

left.

2 Columns with Right Bar

With a “2 Columns with Right Bar”
layout, the main content area is large
enough for an eye-catching image or
banner. This layout is also often used
for Product pages that have blocks of
supporting content on the right.
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3 Columns

The “3 Column” layout has a center
column that is wide enough for the
main text of the page, with room on
each side for additional navigation
and blocks of supporting content.

Empty

The “Empty” layout can be used to
define custom page layouts. To learn
more, see the Magento Design Guide.

Page Layout Examples
The column dimensions are determined by style sheet of the theme. Some themes apply
a fixed pixel width to the page layout, while others use percentages to make the page
respond to the width of the window or device.

Most desktop themes have a fixed width for the main column, and all activity takes
place within this enclosed area. Depending on your screen resolution, there is empty
space on each side of the main column.

1 Column Layout
The content area of a “1 Column” layout spans the full-width of the main column. This
layout is often used for a home page with a large banner or slider, or pages that require
no navigation, such as a login page, splash page, video, or full-page advertisement.

http://www.magentocommerce.com/design_guide
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1 Column Layout

2 Columns with Left Bar
The content area of this layout is divided into two columns. The main content column
floats to the right, and the side bar floats to the left.

2 Columns Left Bar

2 Columns with Right Bar
This layout is a mirror image of the other two-column layout. This time, the side bar
floats to the right, and the main content column floats to the left.
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2 Columns Right Bar

3 Columns
A 3-column layout has a main content area with two side columns. The left side bar and
main content column are wrapped together, and float as a unit to the left. The other side
bar floats to the right.
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3 Columns

Uploading a Favicon
Favicon is short for “favorite icon,” and refers to the little icon on the tab of each browser
page. Depending on the browser, the favicon also appears in address bar, just before the
URL.

Favicons are generally 16 x 16 pixels or 32 x 32 pixels in size. Although Magento accepts
.ico, .png, .jpg, .jpeg, .apng, and .svg file types, not all browsers support these formats.
The most widely-supported file format to use for a favicon is .ico. There are many free
tools available online that you can use to generate an .ico image or convert an exiting
image to the .ico format.

Favicon in Address Bar

Process Overview:
Step 1: Create a Favicon
Step 2: Upload the Favicon to Your Store
Step 3: Refresh the Cache
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Step 1: Create a Favicon

1. Create a 16x16 or 32x32 graphic image of your logo, using the image editor of your
choice.

2. (Optional) Use one of the available online tools to convert the file to the .ico format.
Then, save the file to your computer.

Step 2: Upload the Favicon to Your Store

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under General, select Design. Then, click to expand the HTML
Head section.

3. To upload a favicon, click the Choose File button. Then, select the favicon file that you
prepared.

Uploading a Favicon

4. To delete the current favicon, select the Delete Image checkbox.

5. When complete, click the Save Config button.

Step 3: Refresh the Cache

1. As soon as the favicon is uploaded, you are prompted to refresh the cache. Click the
Cache Management link in the message at the top of the workspace.

2. In the list, select the Page Cache checkbox that is marked “Invalidated.”

3. In the upper-right corner, set Actions to “Refresh” and click the Submit button.

4. To view the new favicon, return to your storefront and press F5 to refresh the browser.
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Chapter 36:

Page Configuration
The page configuration settings correspond to the different sections of the page. The
settings include:

l HTML Head

l Header

l Footer

HTML Head
The settings in the HTML Head section correspond to the <head> tag of an
HTML page and can be configured for each store view. In addition to meta data for
the page title, description, and keywords, the section includes a link to the favicon,
and miscellaneous scripts. Instructions for search engine robots and the display of
the store demo notice are also configured in this section.

To configure the HTML Head:

1. On the Admin menu, select System > Configuration. Then in the panel on the left,
under General, select Design.

2. If you have multiple stores or views, set the Current Configuration Scope in the
upper-left corner to the store or view where the configuration applies. Then, clear the
checkbox after each field so new values can be entered.

3. Update the fields as needed.

4. When complete, click the Save Config button.
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HTML Head

Field Descriptions

Favicon Icon Uploads the small graphic image that appears in the address
bar and tab of the browser.

Default Title The title that appears at the title bar of each page when
viewed in a browser. The default title is used for all pages,
unless another title is specified for individual pages.

Title Prefix A prefix can be added before the title to create a two- or
three-part title. A vertical bar or colon can be used as a sep-
arator at the end of the prefix to differentiate it from the text
of the main title.

Title Suffix A suffix can be added after the title to crete a two-or three part
title. A vertical bar or colon can be used as a separator at the
end of the prefix to differentiate it from the text of the main
title.

Default Description The description provides a summary of your site for search
engine listings and should not be more than 160 characters in
length.

Default Keywords A series of keywords that describe your store, each separated
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by a comma.

Default Robots Instructions that tell search engines how to index your site.
Options include:
INDEX, FOLLOW
NOINDEX, FOLLOW
INDEX, NOFOLLOW
NOINDEX, NOFOLLOW

Miscellaneous Scripts An input box that where you can upload miscellaneous
scripts to the server. For example, any third-party JavaScript
that must be placed before the <body> tag, can be entered
here.

Display Demo Store
Notice

Controls the display of the demo store notice at the top of the
page. Options include: Yes / No

Header
The Header section identifies the path to the logo file, and specifies the logo alt text and
welcome message.

Header

To configure the Header:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under General, select Design.

3. Click to expand the Header section. Then, make any changes necessary.

4. When complete, click the Save Config button.
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Page Footer
The Page Footer configuration section is where you can update the copyright statement
that appears at the bottom of the page, and enter miscellaneous scripts.

Footer Configuration

Field Description

Copyright The copyright statement that appears at the bottom of each
page. To include the copyright symbol, use the
HTML character entity: &copy;

Miscellaneous HTML An input box where you can upload miscellaneous scripts to
the server. For example, third-party JavaScript— such as an
analytics tracking code—that must be placed after the <body>
tag, can be entered here.
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Chapter 37:

Your Store’s Theme
A theme is a collection of files that determines the visual presentation of your store.
You might think of a theme as the “window dressing” of your store. When you first
install Magento, the design elements of the store are based on the “Default” Theme.
In addition to the initial default theme that comes with your Magento installation,
there is a wide variety of themes that are available “off the shelf” on Magento
Connect.

Magento themes include layout files, template files, translation files, and skins. A
skin is a collection of supporting CSS, images, and JavaScript files that together,
create the visual presentation and interactions that your customers experience when
they visit your store. Themes and skins can be modified and customized by a
developer or designer who has knowledge of Magento theme design and access to
your server. To learn more, see the Designer’s Guide to Magento.

Responsive Web Design
Responsive design is an approach to web page creation that flows the page layout to
fit the visitor’s screen size and orientation, and changes the layout accordingly. The
Magento default responsive theme features stylesheets that support flexibility for
layouts and images, and helps provide a pleasing experience for site visitors using
mobile devices. By comparison, non-responsive sites or sites not optimized for
smaller screens or mobile devices are often slow or difficult to read, and offer a
clunky mobile eCommerce experience.

Benefits of using the Magento default responsive theme include:

l You can get a tablet and smart phone friendly responsive site in about half the
time as before, speeding time to market and freeing up resources for other
projects.

l Your responsive site makes you better able to participate in the fast growing
mobile commerce space, and gives you the ability to create a website that is more
easily adapted to new opportunities and less expensive to maintain. A responsive
site also offers potential search engine optimization (SEO) benefits from using
Google’s preferred approach to mobile-optimizing sites.

http://www.magentocommerce.com/design_guide
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l You no longer need to develop separate content per device. The default theme is easy
to customize for simple sites, and provides a powerful starting point for developing
themes for more complex sites.

To learn more about creating custom responsive themes, see the Responsive Theme
Developer's Guide.

Using the Default Theme
The default Magento Community Edition theme uses Responsive Web Design (RWD)
principles.

Responsive web design enables you to use a single theme to present your storefront to
your customers regardless of which device they use to access it. The theme is built using
modern technologies and incorporate best practices for mobile sites and experiences.

Responsive Theme on Tablet and Smartphone

To view the default theme:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under General, select Design.

3. Click to expand the Package section. The new responsive theme is enabled by default.
The default package name is “rwd.”

Default RWD Theme Package
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Click to expand the Themes section. The Default theme name is “default” (although the field
appears blank).

Default RWD Theme

4. When complete, click the Save Config button.

Exceptions
Responsive design is not currently implemented for the following:

l Multiple address checkout

l Popular search terms page

l Popular search terms cloud

l Site map

l My Account—Billing Agreements

l My Account—Recurring Profiles

l Gift registry

l Multiple wishlists

l Add to cart by SKU

l Email templates

l Tags

l Polls

l Captcha

Technical Information
The responsive theme uses the following modern technologies:

Sass/Compass

A CSS pre-compiler that provides organizable, reusable CSS.

jQuery

jQuery is used for all custom JavaScript in the responsive theme. jQuery operates in
noConflict() mode so it doesn't conflict with Magento's existing JavaScript library.

http://compass-style.org/
http://jquery.com/
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JavaScript Libraries

Additional JavaScript libraries discussed in more detail in the Responsive Theme
Developer’s Guide.

Code Location
The new responsive theme code is contained in the following directories (relative to your
Magento installation directory):

app/design/frontend/rwd

skin/frontend/rwd
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Installing a New Theme
When you first install Magento, the design elements of the store are based on the
“Default” Theme. You can modify the theme, add themes created by others, or create new
ones. To learn more, see the Designer’s Guide to Magento.

Magento Connect contains hundreds of extensions, which are add-ons to Magento that
can extend the functionality or enhance the appearance of your store. The following
example shows how to add a mobile theme from Magento Connect.

Magento Connect

To install a new theme:

1. Go to Magento Connect.

2. In the upper-right corner, click to extend the All Platforms list, and choose Enterprise

3. You can browse through the available themes based on price or popularity, or do a
keyword search. For more information, click the thumbnail of any theme.

4. To get the registration key, you must be a registered Magento Community Edition owner
and be logged into your account. Then, click the Install Now button to get the license
key.

http://www.magentocommerce.com/design_guide
http://www.magentocommerce.com/magento-connect/
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Install Now

5. To complete the process, follow the instructions to install an extension from Magento
Connect.

To activate the theme for your store:

1. On the Admin menu, select System > Configuration. In the panel on the left, under
General, select Design.

2. Click to expand the Themes section. Then, do the following:

Themes

3. In the Default field, enter the name of the theme. The name of the Magento demo store
theme is “mds.”

4. If you want to use an alternate them for different browsers or devices, do the following:

a. Click the Add Exception button.

The Add Exception button is used to use a different theme for specific browsers. For
example, a theme that is optimized for mobile can be used whenever a mobile device
is detected.
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Add Exception

a. In theMatched Expression field, enter the name of the browser or device that
triggers the use of the alternate theme. If there are multiple browsers, separate the
name of each with a vertical bar. For example, because the mobile theme can be
used with multiple devices, you can enter them all in the Match Expression field, as
follows:

Android|Blackberry|Googlebot-Mobile|iPhone|iPod|mobi|Palm|Opera

Mini|Windows Mobile

b. In the Value field, enter the name of the theme. In this example, the value is
“Mobile.”

5. Click the Save Config button on the top right of the page.

6. Test the new theme from your store. If you installed an exception for different browsers,
view the store with each browser or device.

If the new theme uses a different page layout than your current home page, you might
need to change its page layout setting to match the theme.
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Chapter 38:

Customer Accounts
The header of every page in your store extends an invitation for shoppers to “Log in
or register” for an account with your store. You have the option to require that
customers register before making a purchase, or to allow them to make purchases as
guests.

Customers who open an account with your store enjoy a range of benefits, including:

Faster Checkout

Registered customers move through checkout faster because much of the information
is already in their accounts.

Ability to Self-Serve

Registered customers can update their information, check the status of orders, and
even reorder from their account dashboard.

Account Dashboard
Customers can access their account dashboard by clicking the “My Account” link in
the header of the store. They can use their account dashboard to view and modify
their information, including past and current addresses, billing and shipping
preferences, newsletter subscriptions, wishlist, and more.
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Account Dashboard

Account Information

Customers can update their account information and change their password, as needed.

Address Book

The customer address book includes the default billing and shipping address, and
additional address entries.

My Orders

Displays a list of all customer orders, with a link to each. Any order can be reordered by
simply clicking the Reorder link.

Billing Agreements

Displays a list of any customer billing agreements.

Recurring Profiles

Displays a list of any products that are purchased on a recurring basis, as a
subscription.

My Product Reviews

Displays a list of all product reviews submitted by the customer, with a link to each.

My Wishlist

Displays the customer's wishist. Products from the wishlist can be added to the cart.

My Applications

This section is a placeholder for API applications that link the customer account to other
applications or extensions.
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Newsletter Subscriptions

Lists all available newsletters,. Those to which the customer is currently subscribed have
a checkmark .

My Downloadable Products

Lists all downloadable products the customer has purchased, with a link to each.
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Chapter 39:

Customer Groups
The customer group determines which discounts are given to a customer, as defined
by price rules, and the tax class that is associated with the group. The default
customer groups include:

l General

l Not Logged In

l Wholesale

To create a customer group:

1. On the Admin menu, select Customers > Customer Groups.

Customer Groups

2. To create a new group, click the Add New Customer Group button. Then, do the
following:

a. Enter a unique Group Name to identify the group from the Admin. The name
must be less than 32 characters.

b. Select the Tax Class that applies to the group.

Group Information

3. When complete, click the Save Customer Group button.
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To edit a customer group:

1. On the Admin menu, select Customers > Customer Groups.

2. In the list, click to open the record.

3. Make the necessary changes.

4. When complete, click the Save Customer Group button.
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Chapter 40:

Managing Orders
In this chapter, we will explore what happens after a customers places an order, and
the time the order is delivered. You will learn how to offer shopping cart assistance,
fulfill orders, print invoices, collect payment, process credit memos, manage returns,
and more.

Sales Order

When an order is created, either from the storefront or in the Admin, a sales order is
created as a temporary record of the transaction. Sales orders can be seen from the
Admin by selecting the Orders option from the Sales menu. Payment has not yet
been processed and the order can still be canceled.

Invoice

An invoice is a record of the receipt of payment for an order. Creating an invoice
converts the temporary sales order into a permanent record of an Order, which can
no longer be canceled. Multiple invoices can be created for a single order, each
containing as much or as few of the purchased products that you specify. Depending
on the payment action, payment can be automatically captured when the invoice is
generated.

Shipment

A shipment is a record of the products in an order that have been shipped. As with
invoices, multiple shipments can be associated with a single order, until all of the
products in the order are shipped.

Credit Memo

A credit memo is a record of a refund. A product cannot be refunded until it has
been paid (which means that it has been invoiced). This means that you are not able
to create a credit memo before an invoice has been created. The credit memo serves
as a record of a refund, but it is not a record of the actual return of funds to the
customer.



Order Process Overview Chapter 40:  Managing Orders

Order Process Overview
Order Submitted

During checkout, the customer reviews the order, agrees to the Terms and Conditions,
and clicks the Place Order button. Customers receive a confirmation of their orders, with
a link to their customer account.

Order “Pending"

Before payment is processed the status of a sales order is “Pending.” At this point, the
order can still be canceled.

Payment Received

Depending on the payment method, you, may be notified when the transaction is
authorized and in some cases, processed. The status of the invoice is now “Processing.”

Order Invoiced

Sometimes an order is invoiced before payment is received. In this example, the invoice
is generated and submitted after the credit card payment has been authorized and
processed. After the invoice is generated and submitted, a copy is sent by email to the
customer.

Order “Processing”

When the customer logs into his account to check on the order, the status is still
"Processing."

Order Shipped

The shipment is submitted, and packing slips printed. You ship the package, and the
customer is notified by email. Congratulations! You’re in business.

442 Magento Community Edition: User Guide



443Magento Community Edition: User Guide

Chapter 41:

Assisted Shopping
Customers sometimes need assistance to complete a purchase. Some customers like
to shop online, but would rather the order by phone. While you’re on the phone, the
customer might decides to take advantage of a coupon. To complete the sale, you
must know how to edit the contents of the shopping cart, apply the discount from
the coupon, and complete the order from the Admin—all while the customer is on
the phone. No problem!

You can offer immediate shopping cart assistance to any customer who has
registered for an account with your store. The Manage Shopping Cart tool gives you
the ability to edit the contents of the customer’s shopping cart in real time, from the
Admin of your store. Here are a few of the services you can offer:

l Create a new order

l Create a customer account

l Update the contents of the customer’s cart

l Apply a coupon code

l Transfer items from a wishlist

l Add gift wrap

Customer Service reps can see the contents of a customer’s shopping cart while the
customer is on the phone, and the changes can be seen by the customer immediately
after the page is refreshed.
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Online Customers
You can see who’s online in your store at any given time, and examine the contents of
the customer’s shopping cart, past purchases, and recent activity.

Online Customers

To see who's online:

1. On the Admin menu, select Customers > Online Customers.

2. In the list, click the customer record to view the customer information.

3. To see what's currently in the customer's shopping cart, click to expand the Shopping
Cart section.

Customer's Shopping Cart
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Create an Order
For registered customers who need assistance, you can create an entire order directly
from the Admin. The Create New Order form includes all the information that is needed
to complete the normal checkout process, with activity summaries from the customer’s
account dashboard.

For existing customers, new orders can be created both from the Manage Customer page
and from the Sales Order page.The Sales Order page can also be used to open accounts
for new customers.

Create Order

Step 1: Initiate the Order

Method 1: Create New Order from Existing Account

1. On the Admin menu, select Customers > Manage Customers.

2. Find the customer in the list and click to open the record.

3. Click the Create Order button.
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New Order Detail

4. To complete the order, do the following:

a. To add products from the Current Activities section, find the product in the list and
select the Add to Order checkbox. Then, click the Update Changes button.

New Order Detail

b. To add products from the catalog, click the Add Products link. Then, select the
checkbox of each product to be added to the cart, and the Qty to be purchased.

Add Products
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l If the product has multiple options, click the Configure button. Complete the
options as needed, and click the OK button. Then, click the Add Selected
Product(s) to Order link to update the cart.

Configure

c. To override the price of an item, select the Custom Price checkbox. Then, enter the
new price in the box below. Click the Update Items and Qty’s button to update the
cart totals.

Custom Price

d. Complete the following sections, as needed for the order:

l Apply Coupon Codes

l Payment Method

l Shipping Method

e. In the Order Comments section, enter any comments that you want to accompany
the order. To include the comments in the email notification that is sent to the
customer, click the Order Comments button.

Order Comments and Email Confirmation
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f. The Email Order Confirmation checkbox is selected by default. If you don’t want to
send an email confirmation to the customer, clear the checkbox.

4. When complete, click the Submit Order button.

Method 2: Create New Order from Sales

1. On the Admin menu, select Sales > Orders.

2. Click the Create New Order button.

Create New Order

3. Do one of the following:

l For registered customers, find the customer in the list and click to open the record.

l For unregistered customers, click the Create New Customer button.

4. Complete the order information as you would if going through the checkout process .For
a new customer account, complete the following sections:

l Account Information

l Billing Address

l Shipping Address

Step 2: Add Products to the Order

Products can be added to the order by selecting each item from the catalog, or by
transferring the information from a previous order, the customer’s wishlist, recently
viewed products, or other activities.

1. To add products to the order, do the following:

a. Click to the Add Products button.

b. Click the Reset Filter button to list all products. Then, use the filter controls as
needed to find the products to be added. Then, click the Search button.
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c. Select the checkbox of each product to be added to the cart and if applicable, enter
the Qty to be purchased.

If the product has multiple options, click the Configure link. Complete the options
as needed and click the OK button.

2. Click the Add Selected Product(s) to Shopping Cart button to update the cart. The
current content of the cart appear in the Items Ordered section.

3. To override the price of an item, select the Custom Price checkbox. Then, enter the new
price in the box below. Click the Update Items and Qty’s button to update the cart
totals.

4. Complete the following sections, as applicable to the order:

l Apply Coupon Codes

l Payment Method

l Shipping Method

5. When complete, click the Submit Order button.

Update an Order
After a customer has placed an order, it is sometimes necessary to edit the order, place it
on hold, or cancel the order entirely.

When you make changes to an order, the original order is canceled and a new order is
generated. You can, however, make changes to the billing or shipping address without
generating a new order.

To edit an order:

1. On the Admin menu, select Sales > Orders.

2. Select the pending order that you want to edit.

3. Click the Edit button at the top of the screen. When prompted to confirm, click OK to
continue.
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Edit Order

4. Make the necessary changes to the order.

5. When complete, do one of the following:

l Click Save to save changes made to the billing or shipping address.

l Click Submit Order to save changes made to line items, and reprocess the order.

To place an order on hold:

If the customer’s preferred method of payment is not available, or if the item is
temporarily out of stock, you can put the order on hold.

1. On the Admin menu, select Sales > Orders.

2. In the list, find the pending order that you want to place on hold. Then, click to open
the order.

3. Click Hold to place the order on hold.

Hold Order

To return the order to an active state, repeat the process and click Unhold.

To cancel an order:

Canceling an order removes it from the list of pending orders.
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1. On the Admin menu, select Sales > Orders.

2. Find the pending order that you want to cancel, and click to open the order.

3. In the upper-right corner, click the Cancel button to remove this order.

Cancel Order

4. The status of the order is now “Canceled.”

Canceled Order

Create a Customer Account
Customers usually create their own accounts from your store. However, you can also
create customer accounts directly from the Admin, which is useful when customers order
by phone.

Add New Customer
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To create a new customer account:

1. On the Admin menu, select Customers > Manage Customers.

2. Click the Add New button.

3. In the Associate to Website list, select one of the following:

l Admin

l Main Website

You can associate a customer with the Admin website to require that orders are placed
only from the store Admin. Customers associated with the Admin website cannot log in
to their accounts from the store.

4. Assign the customer to a Customer Group.

5. Complete the remaining customer information.

Customer Information

6. In the Password Management section, do one of the following

l Manually assign a password.

l Select the Send auto-generated password checkbox. The new password is generated
after the customer information is saved.

7. When complete, click the Save Customer button.
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To add a new address to a customer account:

1. On the Admin menu, select Customers > Manage Customers. Then, click to open the
customer record.

2. In the panel on the left, select Addresses. Then, do the following:

a. To add a new address, click the Add New Address and complete the information.

b. To assign a Default Address check either the Default Billing Address or Default
Shipping Address as needed.

Customer Addresses

3. When complete, click the Save Customer button.

Field Descriptions
Field Description

Account Information

Associate to Website Identifies the website associated with the customer account.

Group Identifies the customer group to which the customer belongs.
Select the checkbox to disable automatic group change based
on VAT.

Prefix If used, the prefix that is associated with the customers name.
For example: Mr, Mrs. or Dr.

First Name The customer's first name.

Middle Name / Initial The customer's middle name or middle initial.

Last Name The customer's last name.

Suffix If used, the suffix that is associated with the customer's name.
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Field Description

For example: Jr.,Sr., or III.

Email The customer's email address.

Date of Birth The customer's date of birth.

Tax / VAT Number The customer's Tax or Value Added Tax number, if applicable.

Gender Identifies the customer's gender as Male or Female.

Send Welcome Email Select the checkbox if you want the system to send the cus-
tomer a welcome email message.

Send From If you have multiple stores, select the store from which the
welcome message will be sent.

Update a Customer Account
The panel on the left of the Customer Information page includes information about
customer activity, such as when the customer last logged in and out, addresses, order
statistics, recent orders, shopping cart contents, product reviews, newsletter
subscriptions, and so on.

Customer Account

To view customer information:

1. On the Admin menu, select Customers > Manage Customers.

The Manage Customers page lists all customers who have opened an account with your
store or were added by the administrator .

2. Click to open a customer record.

3. In the panel on the left, select the type of information you need to edit. Then, make the
necessary changes.

4. When complete, click the Save Customer button.
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Persistent Shopping Cart
A persistent shopping cart keeps track of unpurchased items which are left in the cart,
and saves the information for the customer’s next visit. Customers who are
“remembered” can have the contents of their shopping carts restored the next time they
visit your store.

Using a persistent shopping cart can help reduce the number of abandoned shopping
carts and increase sales. It is important to understand that the persistent shopping cart
does not expose sensitive account information at any time. While the persistent
shopping cart is use, both registered customers and guest shoppers are required to either
log in to an existing account, or create a new account before going through checkout. For
guest shoppers, a persistent shopping cart is the only way to retrieve information from a
previous session.

Types of Cookies
To use the persistent shopping cart, the customer’s browser must be set to allow cookies.
During operation, the following cookies are used:

Session Cookie
A short-term session cookie exists for the duration of a single
visit to your site, and expires when the customer leaves, or
after a set period of time.

Persistent Cookie
A long-term persistent cookie continues in existence after the
end of the session, and saves a record of the customers’
shopping contents for future reference.

A persistent shopping cart is controlled by a combination of factors, which can include
whether or not the customer wants to be “remembered,” the lifetime of the cookies, and
the point at which the persistent cookie is cleared. The system retains a record of the
shopping cart contents, even if the customer later uses different devices to shop in your
store. For example, a customer can add an item to the shopping cart from a laptop, edit
the cart contents from a desktop computer, add more items from a mobile device, and
complete the checkout process from a tablet.

There is a separate independent persistent cookie for each browser. If the customer uses
multiple browsers while visiting your store during a single, persistent session, any
changes made in one browser will be reflected in any other browser when the page is
refreshed. While the persistent shopping cart is enabled, your store creates and
maintains a separate persistent cookie for each browser that is used by a customer to log
in or create an account.
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When a persistent cookie is applied, a Not %Jane Smith%? link appears in the page
header, to give the customer the ability to terminate the persistent session and start
working as a guest, or log in as a different customer.

If Persist Shopping Cart is set to “Yes,” the following situation is possible:

l Customer A in the persistent session adds products to the cart, and goes away to
make a cup of coffee.

l Customer B takes his place, and does not click the Not %Customer A% link. The B is
actually working with the A’s shopping cart. If he or she goes to checkout and logs in
as Customer B, the shopping cart content of the A (modified by B or not) is added to
the B’s shopping cart.

l After B submits the order, the ordered products are removed from the A’s shopping
cart.

Cookie Scenarios
Remember Me

The “Remember Me” checkbox on the Login page lets customers choose to save the
contents of their shopping carts.

Yes: If “Remember Me” is selected, a persistent
cookie is created, and the contents of the shopping
cart is saved for the customer’s next logged-in
session.

No: If “Remember Me” is not selected or cleared, a
persistent cookie is not created, and the shopping
cart information is not saved for the next customer’s
logged-in session.

Continue Persistence After Logout (No)

When Clear Persistence on Log Out is set to “No,” the following scenarios apply:

When the customer logs in, the persistent cookie is
invoked, in addition to the session cookie which is
already in use.

When the customer logs out, the session cookie is
deleted, but the persistent cookie remains in effect.
The next time the customer logs in, the cart items
will be restored, or added to any new items which
have been placed in the cart.
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If the customer does not log out, but the session
cookie expires, the persistent cookie remains in
effect.

When the customer logs in, the persistent cookie is
invoked, in addition to the session cookie which is
already in use.

Clear Persistence on Logout (Yes)

When Clear Persistence on Log Out is set to “Yes,” the following scenarios apply:

When the customer logs in, the persistent cookie is
invoked, in addition to the session cookie which is
already in use.

When the customer logs out, both cookies are
deleted.

If the customer does not log out, but the session
cookie expires, the persistent cookie remains in
effect.

Cookie Workflow
When Persistent Shopping Cart is enabled, the general workflow of applying the
persistent cookie depends on the values of the Enable Remember Me and Clear
Persistence on Log Out settings in the Admin , and the store customer decision to select
or clear the Remember Me checkbox when logging in or registering. The following
variants are possible:

Settings Effect

Enable Remember Me = “No”
Clear Persistence on Log Out = any value

The Remember me checkbox is not avail-
able on the login and registration page. The
persistent cookie is not used.

Enable Remember Me = “Yes”
Clear Persistence on Log Out = any value
Remember Me (not selected)

The session cookie is applied as usual; the
persistent cookie is not used.

Enable Remember Me = “Yes”
Clear Persistence on Log Out = “Yes”

When a customer logs in, both cookies are
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Settings Effect

Remember Me = “Yes” applied. When a customer logs out, both
cookies are deleted. If a customer does not
log in, but the session cookie expires, the
persistent cookie is still used. Apart from
logging out, the persistent cookie is deleted
when its lifetime runs out or when the cus-
tomer clicks the Not %Jane Smith% link.

Enable Remember Me = “Yes”
Clear Persistence on Log Out = “No”
Remember Me = “Yes”

When a customer logs in, both cookies are
applied. When a customer logs out, the
session cookie is deleted, the persistent
session continues. The persistent cookie is
deleted when its lifetime runs out or when
the customer clicks the Not %Jane Smith%
link.

To set up a persistent shopping cart:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Customers, select Persistent Shopping Cart. Then, click
to expand the General Options section.

3. To enable the persistent shopping cart and to display additional configuration options,
set Enable Persistence to “Yes.”

Persistent Shopping Cart

4. Do the following:

a. Set Persistence Lifetime (seconds) to the length of time that you want the
persistent cookie to last. The default value 31,536,000 seconds is equal to one year,
and is the maximum time allowed.

b. Set Enable “Remember Me” to one of the following:

Yes Displays the “Remember Me” checkbox on the Login page of your
store, so customers can choose to save their shopping cart
information.

No Persistence can still be enabled, but customers are not given the
option to choose if they want to save their information.
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c. To preselect the “Remember Me” checkbox, set Remember Me Default Value to
“Yes.”

d. Set Clear Persistence on Log Out to one of the following:

Yes The shopping cart is cleared when a registered customer logs out.

No The shopping cart is saved when a registered customer logs out.

If the session cookie expires while the customer is still logged in, the persistent
cookie remains in use.

e. Set Persist Shopping Cart to one of the following:

Yes If the session cookie expires, the persistent cookie is preserved. If a
guest shopper later logs in or creates a new account, the shopping
cart is restored.

No The shopping cart is not preserved for guests after the session cookie
expires.

5. When complete, click the Save Config button.

Field Descriptions
Field Scope Description

Enable Persistence Website Determines if the persistence is enabled.

Persistence Lifetime (seconds) Website Defines the lifetime of the persistent
cookie in seconds. Maximum allowed
value is 3153600000 seconds (100 years).

Enable “Remember Me” Website Defines whether the Remember Me
checkbox appears on the login and regis-
tration pages of the store. Options
include:

Yes Displays the Remember
Me checkbox.

No Does not display the
Remember Me checkbox,
and the persistent cookie
is used only for customers
who already have it.

“Remember Me” Default Value Website Defines the default state for the Remem-
ber Me checkbox.

Clear Persistence on Log Out Website Defines whether the persistent cookie is
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Field Scope Description

deleted when a store customer logs out.
No matter how Clear Persistence on Log
Out is configured, if a customer does not
log out, but the session cookie expires,
the persistent cookie is still used.

Persist Shopping Cart Website Defines whether using the persistent
cookie gives access to the shopping cart
data of the correspondent account.
Options include:

Yes The shopping cart con-
tents are saved after the
session ends.

No The shopping cart con-
tents are not saved after
the session ends.

Terms and Conditions
When Terms and Conditions is enabled, customers must select a checkbox to verify that
they agree to the terms and conditions of the sale. The Terms and Conditions message
and checkbox appear during Order Review between the Totals section and the Place
Order button. The transaction cannot be finalized until the customer selects the
checkbox to agree to the terms and conditions of the sale.

Terms and Conditions at Checkout
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Step 1: Enable Terms and Conditions

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Checkout. Then, click to expand the
Checkout Options section.

3. Make sure that Enable Onepage Checkout is set to “Yes.” Otherwise, the Terms and
Conditions checkbox will not appear during checkout.

4. To display the terms and conditions checkbox during checkout, set Enable Terms and
Conditions to “Yes.”

5. When complete, click the Save Config button.

Checkout Options

Step 2: Add Your Terms and Conditions

1. On the Admin menu, select Sales > Terms and conditions.

2. In the upper-right corner, click the Add New Condition button.

3. In the Terms and Conditions Information section, complete the following:

Terms and Conditions Information
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a. Enter the Condition Name. The name is for internal reference only.

b. Set Status to “Enabled.”

c. Set Show Content as to one of the following:

Text Displays the terms and conditions content as unformatted text.

HTML Displays the terms and conditions content as HTML, which can
be tagged and formatted.

4. Identify the Store View where the Terms and Conditions will appear.

5. Enter the Checkbox Text that you want to appear as a label with the checkbox. For
example, you could use “I understand and accept these terms and conditions of the
sale.”

6. In the Content field, either type or paste enter the full text of the terms and conditions
of the sale.

7. (Optional) Enter the Content Height (css) , in pixels, to determine the height of the text
box in which the terms and conditions statement appears during checkout. For example,
if you want the text box to be one inch high, enter 96, which is the equivalent value in
pixels.

8. When complete, click the Save Condition button.
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Chapter 42:

Order Fulfillment
When the order is placed, a sales order is created as a temporary record of the
transaction. In the Orders list, sales orders are shown with a status of "Pending,"
and can be canceled at any time until the payment is processed. After payment
confirmed, the order can be invoiced and shipped.

Place Order
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Order Workflow
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Order Status
All orders have an order status that is associated with a stage in the order processing
workflow. You can see the status of an order by clicking the control at the top of the
Status column.

Order Status

Your store has a set of predefined order status and order state settings. The state
describes the position of an order in the workflow.

Order Status Order State

Canceled
Canceled Ogone
Closed
Complete
Declined Ogone
Suspected Fraud
On Hold
Payment Review
PayPal Canceled Reversal
PayPal Reversed
Pending
Pending Ogone
Pending Payment
Pending PayPal
Processed Ogone Payment
Processing
Processing Ogone Payment
Waiting Authorization

New
Pending Payment
Processing
Complete
Closed
Canceled
On Hold
Payment Review
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Custom Order Status
In addition to the preset order status values, you can create custom order status values
of your own, assign order statuses to order states, and set a default order status for order
states. For example, you might need a custom order status for orders, such as
“packaging” or “backordered,” or for a status that is specific to your needs. You can
create a descriptive name for the custom status, and then assign it to the associated
order state in the order processing workflow.

Currently only default custom order status values are applied in the order management
workflow. The custom status values that are not set as default are available only in the
comments section in the order view in the Admin .

Order Statuses

To create a custom order status:

1. On the Admin menu, select System > Order Statuses.

2. In the upper-right corner, click the Create New Status button.

3. In the Order Status Information section, do the following:

a. Enter a Status Code. This value is for internal use only. The first character must be
a letter (a-z), and the rest can be any combination of letters and numbers (0-9). You
can use the underscore character instead of a space.

b. Enter a Status Label to identify the status setting in both the Admin and store.

Order Status Information
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4. In the Store View Specific Labels section, enter any labels that you need for different
store views and languages.

5. When complete, click the Save Status button.

The new order status now appears in the Order Statuses list.

To assign an order status to a state:

1. Front the Order Statuses list, click the Assign Status to State button.

2. In the Assignment Information section, do the following:

a. Select the Order Status that you want to assign. They are listed by status label.

b. Select the Order State that represents where the order status belongs in the
workflow.

c. To make this status the default for the order state, select the Use Order Status as
Default checkbox.

Assign Status to State

3. When complete, click the Save Status Assignment button.

To edit an existing order status:

1. On the Order Statuses page, click to open the status record in edit mode.

2. Update the status labels as needed.

3. When complete, click the Save Status button.

To remove an order status from an assigned state:

1. On the Order Statuses page, find the order status record that you want to unassign.

2. In the Action column on the far right of the row, click the Unassign link.

A message appears at the top of the workspace that the order status has been
unassigned. Although the order status label still appears in the list, it is no longer
assigned to a state. Order statuses cannot be deleted.
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Invoice an Order
An invoice is a record of the receipt of payment for an order. Creating an invoice for an
order converts the temporary sales order into a permanent record of the order, which
cannot be canceled. Multiple invoices can be created for a single order, each containing
as much or as few of the purchased products that you specify.

The invoice for a single order, or for a batch of orders, can be generated from the Admin.
However, some payment methods generate the invoice automatically when payment is
authorized and captured. The payment method determines which invoicing options can
be used for the order.

For orders with online payment methods where you have chosen “Authorize and
Capture,” this button does not appear. A new invoice page looks very similar to a
completed order page, with some additional fields that can be edited.

Invoice Order

To invoice an order:

1. On the Admin menu, select Sales > Orders.

2. In the list, find the “Pending” order, and click to open the record.

3. If the items are ready to ship, you can create a packing slip for the shipment with the
invoice. To create a packing slip, do the following:

a. In the Shipping Information section, select the Create Shipment checkbox.

b. To include a tracking number, click the Add Tracking Number button and enter the
Carrier, Title, and Number.
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Shipping Information

4. To make a partial invoice scroll down to the Items to Invoice section, and enter the Qty
to Invoice for each item.

5. Under the Invoice History menu, in the Invoice Comments section, complete the
comments as needed. Then, in the Invoice Totals section, select the Append Comments
checkbox to add the comments to the invoice.

Every activity related to the order is noted in the Comments section.

6. Select the Email Copy of Invoice checkbox to send a copy of the invoice to your
customer.

7. Click the Submit Invoice button to process the invoice and capture the sale.

If your store requires that you ship before invoicing, click the Ship button, complete the
shipping information and submit your shipment. When that is complete, finish the
invoicing steps.
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Invoice

Payment Actions
Payment Action Description

Capture Online Upon invoice submission, the system captures the payment
from the third-party payment gateway. You have the ability to
create a credit memo and void the invoice.

Capture Offline Upon invoice submission, the system does not capture the
payment. It is assumed that the payment is captured directly
through the gateway, and you no longer have the option to
capture this payment through Magento. You have the ability
to create a credit memo, but you do not have the option to
void the invoice. (Even though the order used an online
payment, the invoice is essentially an offline invoice.)

Not Capture When the invoice is submitted, the system does not capture
the payment. It is assumed that you will capture the payment
through Magento at a later date. There is a Capture button in
the completed invoice. Before capturing, you are able to
cancel the invoice. After capturing you are able to create a
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Payment Action Description

credit memo and void the invoice.

Do not select Not Capture unless you are certain that you
are going to capture the payment through Magento at a
later date. You will not be able to create a credit memo
until the payment has been captured using the Capture
button.

Print Invoices
You can print an invoice for a single order, or for multiple invoices as a batch, or group.
However, before an invoice can be printed, the invoice must first be generated for the
order.

To view or print the PDF, you must have a PDF reader. You can download Adobe
Reader at no charge.

To print invoices:

1. On the Admin menu, select Sales > Invoices.

2. In the Invoices list, select the checkbox of each invoice that you want to print.

3. Set the Actions control to “Print Invoices.”

Print Invoices

4. Click the Submit button to generate the PDF and display the document in a new
window.

5. After the file has been downloaded and saved to your computer, you can open and print
the document with Adobe Reader.

http://www.adobe.com/products/reader.html
http://www.adobe.com/products/reader.html
http://www.adobe.com/products/reader.html
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Ship an Order
An order that has been paid, but is awaiting shipment has the “Processing” status.

To ship an order:

1. On the Admin menu, select Sales > Orders.

2. In the Orders list, click to open the order to be shipped.

3. In the upper-right corner, click the Ship button.

Ship an Order

4. If you need to update the billing or shipping address, click the Edit link in the upper-
right corner of the section. Make the necessary changes, and click the Save Order
Address button.

5. To have the carrier generate a shipping label, select the Create Shipping Label checkbox.

6. To add a tracking number, scroll down to the Shipping Information section, and click
the Add Tracking Number button. Then, do one of the following:

l Select the Carrier. and enter the tracking Number.

l Set Carrier to “Custom Value.” Enter a Title for the custom carrier, and enter the
tracking Number.

Shipping Information

7. To make a partial shipment, scroll down to the Items to Ship section, and enter the Qty
to Ship for each item.

8. To notify customers by email of the shipment, do the following:

a. Enter any comments you would like to include in the Shipment Comments box.
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b. To include the comments in the notification email that is sent to the customer,
select the Append Comments checkbox.

c. To send a copy of the shipment email to yourself, select the Email Copy of
Shipment checkbox. The status of an invoice email appears next to the invoice
number of the completed invoice as either sent or not sent.

9. When complete, click the Submit Shipment button. The status of the order changes from
“Processing” to “Complete.”

View Shipment Detail
The shipment record contains a detailed history of the fulfillment process associated
with the order. Partial shipments can be made until the order is fulfilled.

To view the shipment detail:

1. On the Admin menu, select Sales > Shipments.

2. Find the shipment in the list, and click to open the record.

3. If you want to add a comment to the order, scroll down to the Comments History
section, and enter the comment in the box.

l To send the comment to the customer by email, select the Notify Customer by Email
checkbox.

l To post the comment in the customer’s account, select the Visible on Frontend
checkbox.

4. Click the Submit Comment button.

Packing Slips
A packing slip is a sales document that accompanies shipments sent from your store,
and lists each item included in the package. You can print a packing slip for a single
order, or print multiple packing slips as a batch, or group. However, before a packing
slip can be printed, it must first be created for the order.

To view or print the PDF, you must have a PDF reader. You can download Adobe
Reader at no charge.

http://www.adobe.com/products/reader.html
http://www.adobe.com/products/reader.html
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To print packing slips:

1. On the Admin menu, select Sales > Shipments.

Method 1: Print Single Packing Slip from Shipment

a. In the Shipments list, open the record that needs a packing slip.

b. In the upper-right corner of the shipment page, click the Print button. Look for the
download indicator in the lower-left corner of your browser window.

Packing Slip

Method 2: Print Multiple Packing Slips

a. In the Shipments list, select the checkbox of each shipment record that needs a
packing slip.

b. In the upper-right corner, set the Actions control to “PDFpackingslips” and click the
Submit button.

Printing Multiple Packing Slips

2. Do one of the following:
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l To save the document, click the Save button. Then, follow the prompts to save the
file to your computer.When the download is complete, open the PDF in Adobe
Reader, and print the document.

l To view the document in Adobe Reader, click the Open button. From here, you can
either print the packing slip or save it to your computer.

Shipping Labels
You can easily create shipping labels for new and existing orders from the Admin of your
store. To create shipping labels, you must first set up your shipping carrier account to
support labels. Then, follow the prompts to enter a description of the package and its
contents. Magento contacts the shipping carrier, creates an order in the carrier’s system,
and receives a shipping label and tracking number for the shipment.

An individual order is created for each package shipped. A single shipment with
multiple packages receives multiple shipping labels.

Process Overview:
Step 1: Contact Your Shipping Carriers
Step 2: Update the Configuration for Each Carrier
Step 3: Create Shipping Labels
Step 4: Print Shipping Labels

Step 1: Contact Your Shipping Carriers

Before you begin, make sure that your shipping accounts are set up to process labels.
Some carriers might charge an additional fee to add shipping labels to your account.

1. Contact each carrier that you use to activate shipping labels for your store.

2. Follow the instructions provided by each carrier to add shipping label support to your
account.

FedEx Contact FedEx Web Services regarding their label evaluation process.

USPS Contact uspstechsupport@esecurecare.net to request that API Signature
Confirmation V3 be enabled for your live USPS API Access account.

UPS Contact UPS to confirm your account type supports shipping labels. To
generate shipping labels, you must use the UPS XML option.

DHL Contact the DHL Resource Center to learn more about their services or
send an inquiry through their Contact Center.

http://www.fedex.com/us/web-services/index.html
mailto:uspstechsupport@esecurecare.net
http://www.ups.com/?Site=Corporate&cookie=us_en_home&setCookie=yes
http://www.dhl-usa.com/en/contact_center.html
http://www.dhl-usa.com/en/contact_center.html
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Step 2: Update the Configuration for Each Carrier

1. Make sure that your Store Information is complete.

2. Follow the instructions below for each carrier account that has been activated for label
printing.

UPS

United Parcel Service ships both domestically and internationally. However, shipping
labels can be generated only for shipments that originate within the United States.

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, select Shipping Methods.

3. Click to expand the UPS section. Then, verify that your UPS Shipper Number is correct.
Your Shipper Number appears only when United Parcel Service XML is enabled.

4. When complete, click the Save Config button.

USPS

The United States Postal Service ships both domestically and internationally.

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, select Shipping Methods.

3. Click to expand the USPS section. Then, do the following:

a. Verify that the Secure Gateway URL is entered. The correct URL should be entered
automatically.

b. Enter the Password provided to you by USPS.

c. Set Size to “Large.” Then, enter the following dimensions:

l Length

l Width

l Height

l Girth

4. When complete, click the Save Config button.

FedEx

FedEx ships domestically and internationally. Stores located outside the United States
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can create FedEx labels for international shipments only.

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under sales, select Shipping Methods.

3. Click to expand the FedEx section. Then, make sure that the following FedEx credentials
are correct:

l Meter Number

l Key

l Password

4. When complete, click the Save Config button.

DHL

DHL provides international shipping services.

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under sales, select Shipping Methods.

3. Click to expand the DHL section. Then, do the following:

a. Verify that the Gateway URL is entered. The correct URL should be entered
automatically.

b. Make sure that the following credentials are complete:

l Access ID

l Password

l Account Number

4. When complete, click the Save Config button.

Step 3: Create Shipping Labels

Process Overview:
Method 1: Create Label for New Shipment
Method 2: Create Label for Existing Shipment
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Method 1: Create Label for New Shipment

1. On the Admin menu, select Sales > Orders.

2. Find the order in the list, and click to open the record. The status of the order must be
either “Pending” or “Processing.”

3. In the upper-right corner, click the Ship button. Then, confirm the shipping information
according to carrier requirements.

4. In the lower-right corner, select the Create Shipping Label checkbox. Click the Submit
Shipment button, and do the following:

a. To add products from the order to the package, click the Add Products button. The
Quantity column shows the maximum number of products that are available for the
package.

b. Select the check box of each product to be added to the package and enter the
Quantity of each. Then, click the Add Selected Product(s) to Package button.

l To add a new package, click the Add Package button.

l To delete a package, click the Delete Package button.

If you use a package type other than the default, or require a signature, the cost of
shipping might differ from what you have charged the customer. Any difference in
the cost of shipping is not reflected in your store.

5. When complete, click OK.

l If you need to cancel an order, click the Cancel button. A shipping label will not be
created, and the Create Shipping Label checkbox is cleared.

6. Magento now connects to the shipping carrier system, submits the order, and receives a
shipping label and tracking number for each package.

l If the label is successfully created, the shipment is submitted, the tracking number
appears in the form, and the label is ready to print.

l If the carrier cannot create the label due to the problems with connection, or for any
other reason, the shipment is not processed.

Method 2: Create Label for Existing Shipment

1. On the Admin menu, select Sales > Orders.

2. Find the order in the list and click to open the Shipping form. Then, do the following:
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a. In the Shipping and Tracking Information section, click the Create Shipping Label
button.

b. Distribute the ordered product(s) to the appropriate package(s), and click OK.

c. To review the package information, click the Show Packages button.

Magento connects to the shipping carrier system, submits an order, and receives a
shipping label and a tracking number.

l If a shipping label for this shipment already exists in the system, it is replaced
with a new one. However, existing tracking numbers are not replaced. Any new
tracking number is added to the existing one.

Step 4: Print Shipping Labels

Shipping labels are generated in PDF format, and can be printed from the Admin panel.
Each label includes the order number and package number.

Process Overview:
Method 1: Print Label from Shipment Form
Method 2: Print Labels for Multiple Orders

Method 1: Print Label from Shipment Form

1. On the Admin menu, do one of the following:

l Select Sales > Orders. Find the order in the list, and click to open the record. In the
Order View panel on the left, select Shipments. Then, click to open the shipment
record.

l Select Sales > Shipments. Find the order in the list, and click to open the record.

2. To download the PDF file, go to the Shipping and Tracking section of the form and click
the Print Shipping Label button. Depending on your browser settings, the shipping
labels can be viewed and printed directly from the PDF file.

The Print Shipping Label button appears only after the carrier has generated labels for
the shipment. If the button is missing, click the Create Shipping Label button. The
button will appear after Magento receives the label from the carrier.
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Method 2: Print Labels for Multiple Orders

1. On the Admin menu, do one of the following:

l Select Sales > Orders.

l Select Sales > Shipments.

2. In the list, select the checkbox of each order that has shipping labels to be printed.

3. In the upper-right corner, set the Actions control to "Print Shipping Labels."

4. Click the Submit button.

A complete set of shipping labels is printed for each shipment that is related to the
selected orders.

Required Carrier Configuration Settings
Field Description

Type Package types differ by carrier and method. The default
package type for each carrier is initially selected.
USPS does not require the package type for domestic ship-
ments.

Customs Value (International shipments only) The declared value or sales
price of the contents of an international shipment.

Total Weight The total weight of all products added to the package is cal-
culated automatically. The value can also be changed manu-
ally, and entered as pounds or kilograms.

Length, Width, Height (Optional) The package dimensions are used for custom pack-
ages only. You can specify the measurements units as inches
or centimeters.

Signature Confirmation Indicates if a signature is required to confirm receipt of the
package. Although the options vary by carrier and shipping
method, possible values include:

Not Required No confirmation of delivery is sent to the
store by the shipping carrier.

No Signature A delivery confirmation without the sig-
nature of the recipient is sent to the store
by the shipping carrier.

Signature
Required

The shipping carrier obtains the sig-
nature of the recipient and provides the
store with a printed copy.
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Field Description

Direct (FedEx Only) FedEx obtains a signature
from someone at the delivery address. If
no one is available to sign for the
package, the carrier tries to deliver the
package at another time.

Indirect (FedEx Residential Deliveries Only) FedEx
obtains the signature of someone, pos-
sibly a neighbor or building manager, at
the delivery address. The recipient can
leave a signed FedEx door tag to author-
ize the package to be left without anyone
present to sign for it.

Contents (USPS Only) Select one of the following
descriptions of the package:
Gift

Documents
Commercial Sample
Returned Goods
Merchandise
Other

Explanation (USPS Only) A detailed description of the
package contents.

Adult Required The shipping carrier obtains the sig-
nature of an adult recipient and provides
the store with a printed copy.
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PDF Printouts
The Order ID can be included in the sales documents that accompany an order. Follow
the instructions below to include the Order ID in the header of invoices, packing slips,
and credit memos.

To configure PDF printouts:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, select PDF Print-outs.

3. Click to expand each section.

4. To include the order ID in the header of each document, Set Display Order ID in
Headerto “Yes.”

5. When complete, click the Save Config button.

PDF Print-outs

Customer Address Formats
The store administrator can modify address templates to control the format of the
following customer billing and shipping addresses:

l Customer’s billing and shipping addresses in the customer’s address

l Shipping and billing addresses from customer’s address book (available during the
shopping cart checkout)

l Addresses in invoices, shipments, and refunds (printed in PDF files)
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Address Templates

To change the order of address fields:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Customers, select Customer Configuration.

The section includes a separate set of formatting instructions for each of the following:

l Text

l Text One Line

l HTML

l PDF

l JavaScript Template

3. Edit each template as needed, using the examples below for reference.

4. When complete, click the Save Config button.
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Examples

{{depend address attribute code}} a space, a character, or UI label

{{/depend}};

{{if address attribute code}}{{var address attribute code}} a space, a

character, or UI label

{{/if}}

For Text, Text One Line, HTML and PDF Address Templates

#{address attribute code} or User Interface label #{address attribute

code}

For JavaScript Address Template

Template Types
Template Description

Text The template is used for all addresses that are printed.

Text One Line This template defines the order of address entities in the cus-
tomer’s shopping cart address book list. Progress during
checkout.

HTML This template defines the order of address fields located
under the Customer Addresses area in the Admin panel (Cus-
tomers > Manage Customers) and those located on the Add
New Address page when a customer creates a new billing or
shipping address on his or her account page.

PDF The template defines the display of billing and shipping
addresses in the printed invoices, shipments, and credit
memos.

JavaScript Template In the templates, you will see the following code blocks:

depend For processing inner elements.

if An attribute is defined.

var The code attribute is printed.
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Chapter 43:

Store Credit and Refunds
Store credit is an amount to be restored to a customer account. Store credit can be
used by customers to pay for purchases, and by administrators as cash refunds. Gift
card balances can be credited to the customer’s account, instead of using the gift
card code for future purchases.

After an order has been paid for and invoiced, all of the order, or a portion of it, can
be refunded by issuing a credit memo. A credit memo differs from a refund because
the amount of the credit is restored to the customer’s account where it can be
applied to future purchases, rather than returned to the customer as cash. In some
cases, a refund can be given at the same time that a credit memo is issued, just as
payment can be made at the time of invoicing. The amount of store credit in a
customer’s account can be managed from Admin.
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Product Return Workflow

Product Return Workflow
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Create a Credit Memo
A credit memo is a document that lists the amount that is owed to the customer. The
amount can be applied toward a purchase, or refunded to the customer. You can print a
credit memo for a single order, or for multiple orders as a batch, or group. Before a credit
memo can be printed, it must first be generated for the order.

Credit Memo

To create a credit memo:

1. On the Admin menu, select Sales > Orders.

2. Find the order in the list, click to open the order.

3. In the upper right corner, click the Credit Memo button. (The button appears only if an
invoice has been generated for the order.)

The New Credit Memo page looks similar to the completed order page, with an Items to
Refund section that lists each item from the invoice.
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New Credit Memo

If an online payment method was used, you will not be able to edit these fields.

4. Do one of the following:

l If the product is to be returned to inventory, check the Return to Stock checkbox.

l If the product will not be returned to inventory, leave the checkbox blank.

The Return to Stock checkbox appears only if you have set the inventory Stock
Options to “Decrease Stock When Order Is Placed.”

Return to Stock

5. Complete the following:

a. In the Qty to Refund box, type the number of items to be returned and press the
Enter key to record the change. The Update Qty’s button appears.

b. Set the Qty to Refund of any items not to be refunded to 0.

c. Click the Update Qty’s button to recalculate the total. (The amount to be credited
cannot exceed the maximum quantity that is available for refund.)
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Update Quantities

6. In the Refund Totals section, do the following, as applicable:

a. In the Refund Shipping field, enter the amount that is to be refunded from the
shipping fee. This field initially displays the total shipping amount from the order
that is available for refund. It is equal to the full shipping amount from the order,
less any shipping amount that has already been refunded. Like the quantity, the
amount can be reduced, but not increased.

b. In the Adjustment Refund field, enter a value to be added to the total amount
refunded as an additional refund that does not apply to any particular part of the
order (shipping, items, or tax). The amount entered cannot raise the total refund
higher than the paid amount.

c. In the Adjustment Fee field, enter a value to be subtracted from the total amount
refunded. This amount is not subtracted from a specific section of the order such as
shipping, items, or tax.

Update Quantities

d. If the purchase was made using store credit, select the Refund to Store Credit
checkbox, to credit the amount back to the customer’s account balance.

e. To add a comment, type the text in the Credit Memo Comments box.

f. To send an email notification to the customer, select the Email Copy of Credit
Memo checkbox.

g. If you want to include the comments you have entered, check the Append
Comments checkbox.

The status of a credit memo notification appears in the completed credit memo next
to the credit memo number.
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Refund Totals

7. To complete the process and generate the credit memo, select one of the following refund
option buttons, depending on the payment type:

l Refund Offline

l Refund Online

8. To add a comment to the completed credit memo, scroll down to the Comments History
section, and enter the comment in the box.

l To send the comment to the customer by email, select the Notify Customer by Email
checkbox.

l To post the comment in the customer’s account, select the Visible on Frontend
checkbox.

Below the credit memo is a complete list of all activity related to the order.

9. Click the Submit Comment button.

Credit Memo Submit Comment
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Print a Credit Memo
To print or view the completed credit memo, you must have a PDF reader installed on
your computer. You can download Adobe Reader at no charge.

Credit Memos

To print a credit memo:

1. On the Admin menu, select Sales > Credit Memos.

Selected Credit Memo with Action

2. Use one of the following methods to print the credit memo:

Method 1: Open the Credit Memo

1. In the list, click to open the credit memo.

2. Click the Print button to print the PDF document.

Method 2: Use the Action Control

1. In the list, select the checkbox of each credit memo that you want to print.

2. Set the Actions control to “PDF Credit Memos,” and click the Submit button.

3. When prompted, do one of the following:

l To save the document, click Save. Then, follow the prompts to save the file to your
computer.When the download is complete, open the PDF in Adobe Reader, and print
the document.

http://www.adobe.com/products/reader.html
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l To view the document, click Open. The printed-ready PDF credit memo opens in
Adobe Reader. From here, you can either print the credit memo or save it to your
hard disk.

PDF Credit Memo
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Chapter 44:

Basic Payment Methods
Magento Community Editionsupports a wide variety of payment methods, services,
and gateways that you can offer for your customers’ convenience. In addition to the
payment methods in this guide, other solutions can be downloaded from Magento
Connect. This chapter explains how to enable and configure the following basic
payment methods:

l Bank Transfer Payment

l Cash On Delivery

l Check / Money Order

l Purchase Order

l Zero Subtotal Checkout

l Saved Credit Card

Test Credit Card Numbers

Visa 4111111111111111

MasterCard 5555555555554444

American Express 378282246310005

Expiration Date Any future date

CVV/CVC 123 or 000
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Definitions
Term Definition

Payment Method A way for the customer to pay for the merchandise in your
store. Payment methods can be internal or external.
The Payment Methods section of the System Configuration
includes all basic payment methods and gateways.

Payment Gateway A third-party service provider that processes transactions for
external payment methods.

Merchant Location
Setting the merchant location is the first step to configure any payment method.

To set the merchant location country:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods.

3. In the upper-right corner, set Current Configuration Scope to either your website or
leave it set to “Default Config.”

4. In the Merchant Location section, set Merchant Country to your country.

Merchant Location

5. When complete, click the Save Config button.

Bank Transfer Payment
Magento Community Edition lets you accept payments transferred directly from
customers’ bank accounts to your merchant bank account.
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Bank Transfer Payment

To set up bank transfer payments:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods. Click to expand the Bank
Transfer Payment section. Then, do the following:

a. To activate this payment method, set Enabled to “Yes.”

b. Enter a Title to identify this payment method during checkout.

c. Set New Order Status to “Pending” until payment is authorized.

d. Set Payment from Applicable Countries to one of the following:

All Allowed Countries Customers from all countries specified in your store
configuration can use this payment method.

Specific Countries After choosing this option, the Payment from Specific
Countries list appears. Select each country in the list
where customers can make purchases from your store.

e. Enter the Instructions your customers must follow to set up a bank transfer.
Depending on the country where your bank is located and your bank’s requirements,
you might need to include the following information:

l Bank account name

l Bank account number

l Bank routing code
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l Bank name

l Bank address

f. Set Minimum Order Total and Maximum Order Total to the amounts required to
qualify to use this payment method.

An order qualifies if the total falls between, or exactly matches, the minimum or
maximum total values.

3. Enter a Sort Order number to determine the position of Bank Transfer in the list of
payment methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

4. When finished, click the Save Config button.

Cash On Delivery
Magento Community Edition allows you to accept COD payments from your customers.
With a cash on delivery payment, the customer pays at the time of delivery. The
customer pays the order amount to the shipping carrier, who sends a check to you.
Shipping carriers typically charge an extra fee for COD service. You can account for this
fee in your shipping and handling charges.

Cash On Delivery Payments
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To set up cash on delivery payments:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods. Click to expand the Cash
on Delivery Payments section. Then, do the following:

a. To activate this payment method, set Enabled to “Yes.”

b. Enter a Title to identify this payment method during checkout.

c. Set New Order Status to “Pending” until receipt of payment is confirmed.

d. Set Payment from Applicable Countries to one of the following:

All Allowed Countries Customers from all countries specified in your store
configuration can use this payment method.

Specific Countries Select each country in the list where customers can make
purchases from your store.

e. Enter Instructions for making a Cash On Delivery payment.

f. Set Minimum Order Total and Maximum Order Total to the order amounts which
are required to qualify for this payment method.

An order qualifies if the total is between, or matches, the minimum or maximum
order total.

g. Enter a Sort Order number to determine the sequence in which Cash On Delivery is
listed with other payment methods during checkout. (0 = first, 1 = second, 2 =
third, and so on.)

3. When complete, click the Save Config button.

Check / Money Order
Magento Community Edition allows you to accept payments by either check or money
order. The Check / Money Order payment method is enabled for your story by default.
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Check / Money Order

To set up payment by check or money order:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods. Click to expand Check /
Money Order, and do the following:

a. To activate this payment method, set Enabled to “Yes.”

b. Enter a Title to identify this payment method during checkout.

c. Set New Order Status to "Pending” until receipt of payment is confirmed.

d. Set Payment from Applicable Countries to one of the following:

All Allowed Countries Customers from all countries specified in your store
configuration can use this payment method.

Specific Countries After choosing this option, the Payment from Specific
Countries list appears. Select each country in the list
where customers can make purchases from your store.

e. In theMake Check Payable To field, enter the name of the party to whom the check
must be payable.

f. In the Send Check To field, enter the street address where the checks are mailed.

g. Set Minimum Order Total and Maximum Order Total to the order amounts
required to qualify for this payment method.
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An order qualifies if the total falls between, or exactly matches, the minimum or
maximum total values.

h. Enter a Sort Order number to determine the position of Check / Money Order in the
list of payment methods that is shown during checkout. (0 = first, 1 = second, 2 =
third, and so on.)

3. When finished, click the Save Config button.

Purchase Order
A purchase order (PO) allows commercial customers to pay for purchases with prior
authorization by referencing the PO number. During checkout, the customer is prompted
to enter the purchase order number as the method of payment.

Customers who are representatives of other companies can use the Purchase Order
payment method to buy products and assign a corresponding purchase order number
generated in their accounting system to the sales order generated in Magento.

For example, your customer represents the company that sells computers and needs to
buy some monitors from your store. In their accounting system, the customer creates a
purchase order that is assigned a unique PO number. The customer places an order in
your store using the Purchase Order payment method and references the PO number
from their accounting system. All order-related documents, including the order
confirmation email, invoice, shipment, and credit memo, will have the PO number on
them. The company accounting department can now reference the PO number entered
on the Magento sales order so that they can track the order.

When the customer receives your invoice, they process the payment in their accounts
payable system. You should always establish the credit worthiness of a customer before
accepting payment by purchase order.

Purchase Order
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To set up payment by purchase order:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods. Click to expand the
Purchase Order section. Then, do the following:

a. To activate this payment method, set Enabled to “Yes.”

b. Enter a Title to identify this payment method during checkout.

c. Set New Order Status to “Pending” until payment is authorized.

d. Set Payment from Applicable Countries to one of the following:

All Allowed Countries Customers from all countries specified in your store
configuration can use this payment method.

Specific Countries After choosing this option, the Payment from Specific
Countries list appears. Select each country in the list
where customers can make purchases from your store.

e. Set Minimum Order Total and Maximum Order Total to the amounts required to
qualify for this payment method.

An order qualifies if the total falls between, or exactly matches, the minimum or
maximum total values.

f. Enter a Sort Order number to determine the position of Purchase Order in the list of
payment methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

3. When finished, click the Save Config button.

Zero Subtotal Checkout
Zero Subtotal Checkout is only available for orders created from the Admin, and can be
used for orders with a subtotal of zero. This situation might occur when a discount
covers the entire price of the purchase, and there is no additional charge for shipping. To
save time, these orders can be set to invoice automatically.

Unlike other payment methods for which you can set order amount filters, this method
contains an intrinsic order amount filter, so that the method appears only when the
subtotal equals zero.

Zero Subtotal Checkout can be used in cases such as:

l The product that the customer adds to the shopping cart is of the Downloadable or
the Virtual product type and its price equals zero.

l The price of a simple product is zero and the Free Shipping method is available.
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l A coupon code that covers the full price of products and shipping is applied in the
shopping cart.

l A gift card is applied to the shopping cart and it fully covers the order amount
including shipping. During the checkout of an order covered by a gift card, the
customer will still have to select the "No Information Required" payment method in
the Payment Information section of the Checkout page.

The payment method is available if taxes are configured so that they are applied to the
products in the shopping cart after the discount is applied.

To set up Zero Subtotal Checkout:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods. Click to expand the Zero
Subtotal Checkout section. Then, do the following:

Zero Subtotal Checkout

a. Enter a Title to identify this payment method during checkout.

b. Set Enabled to “Yes” to activate this payment method.

c. Set New Order Status to “Pending” until payment is authorized.

Pending The order is waiting for authorization.

Processing Payment has been authorized, and the transaction is
being processed.

d. Set Automatically Invoice All Items to “Yes” if you want to automatically invoice all
items with a zero balance.

e. Set Payment from Applicable Countries to one of the following:

All Allowed Countries Customers from all countries specified in your store
configuration can use this payment method
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Specific Countries After choosing this option, the Payment from Specific
Countries list appears. Select each country in the list
where customers can make purchases from your store.

f. Enter a Sort Order number to determine the position of Zero Subtotal Checkout in
the list of payment methods during checkout. (0 = first, 1 = second, 2 = third, and
so on.)

3. When finished, click the Save Config button.

Saved Credit Cards
This option enables you to take credit cards and to process them offline. This method is
useful when you have a card terminal in a “brick and mortar” store or have access to a
virtual terminal.

Important! Saving customer card data is discouraged unless absolutely necessary.
Even though the data is encrypted it still poses a security risk to hold this information.
The Saved Credit Cards payment method is not PCI compliant.

When using the Credit Cards payment method, it is highly recommended to configure
an SSL certificate for your store.

Saved CC
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To set up the Saved Credit Cards:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under Sales, select Payment Methods.

3. In the upper-right corner, set Current Configuration Scope to the applicable website or
store view for the configuration.

4. Click to expand the Saved CC section.

5. Complete each field in this section, using the following field descriptions for reference.

6. When complete, click the Save Config button.

Field Descriptions
Field Scope Description

Enabled Website Determines if payment by a saved credit card is
available to customers. Options include: Yes /
No.

Title Store View The name of this payment method that appears
to the customer during checkout.

New Order Status Website Determines the initial status of orders paid by a
saved credit card. Option: Pending

Credit Card Types Website Determines the credit cards that can be used
with this method. Select each card in the list that
you support with this method.

Request Card Security
Code

Website Determines whether the payment method
requires the customer to enter the security code
on the back of the card. If your credit card ter-
minal requires the security code, set this option
to “Yes.”

3D Secure Card Val-
idation

Website Determines if credit card validation is carried out
using the 3D Secure Credit Card Validation
system. You must subscribe to 3D Secure and
have it configured for your Magento installation.

Payment from Applicable
Countries

Website Select the range of countries from which you
accept payment by saved credit card. Options
include: All Allowed Countries / Specific Coun-
tries.

Payment from Specific
Countries

Website To accept payment by saved credit card from
only specific countries, select each supported
country in the list.

Minimum Order Total Website Determines the minimum order total of orders
that can be paid by saved credit card.
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Field Scope Description

Maximum Order Total Website Determines the maximum order total of orders
that can be paid by saved credit card.

Sort Order Website A number that determines the sequence in
which this payment method is listed with others
during checkout.
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Chapter 45:

PayPal Payment Solutions
PayPal is a global leader in online payments and a fast and secure way for your
customers to pay online. With PayPal and Magento Community Edition, you can
accept payments from all major debit and credit cards, and PayPal account holders.
Since customers don’t even need a PayPal account to pay with PayPal, both you and
your customers can get extra convenience without extra effort.

The PayPal payment methods that are available in Magento, and the method names,
are different depending on merchant location. For country-specific PayPal methods,
see the list at the end of this chapter. The two PayPal payment methods that can be
used all over the world are Express Checkout and PayPal Payments Standard.

PayPal payment methods are mutually exclusive, with the exception of PayPal
Express Checkout. You cannot have more than one method enabled at a time.
PayPal Express Checkout can be used with other PayPal payment methods except
PayPal Payments Standard. PayPal Payments Standard cannot be enabled
simultaneously with any other method, including Express Checkout.

PayPal Express Checkout
With PayPal Express Checkout enabled, customers can
click the “Checkout with PayPal” button to make a
secure payment from the PayPal site. You can use
Express Checkout as a standalone solution, or in
combination with one of the other solutions.

Getting Started with PayPal Express Checkout

Setting Up PayPal Express Checkout

All-In-One Solutions
PayPal offers a variety of PCI-compliant solutions to meet the needs of your growing
business.

http://www.magentocommerce.com/knowledge-base/entry/getting-started-with-paypal-express-checkout-for-magento-community
http://www.magentocommerce.com/knowledge-base/entry/setting-up-paypal-express-checkout-for-magento-community
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PayPal Payments Advanced

(Includes Express Checkout) PayPal Payments Advanced offers your customers a secure
checkout experience without leaving your site. Flexible templates and a low monthly fee
make this an ideal choice for merchants who want to create a more customized checkout
experience.

PayPal Payments Pro

PayPal Payments Pro brings you all the benefits of a merchant account and payment
gateway in one, plus the ability to create your own, fully customized checkout
experience.

l PayPal Payments Pro Hosted Solution (Includes Express Checkout)

l PayPal Payments Pro Payflow Edition (Includes Express Checkout) (UK only)

PayPal Payments Standard

PayPal Payments Standard is the easiest way to accept payments online. You can offer
your customers the convenience of payment by credit card and PayPal by simply adding
a checkout button to your site. During checkout, customers are redirected to PayPal to
complete the payment part of the checkout process. There are no lengthy applications to
complete, or monthly charges to set up in advance. When you make your first sale,
PayPal will guide you through the process of setting up your account.

Payment Gateways
PayPal offers a choice of two payment gateway solutions for your business. You can let
PayPal host your checkout on its secure payment site, or you can take control of the
entire payment experience with a completely customizable solution.

PayPal Payflow Pro

PayPal Payflow Pro is a fully customizable payment gateway that can be used with any
Internet merchant account to process credit card transactions online. Payflow Pro can
also be used to process PayPal Express Checkout transactions.

PayPal Payflow Link

PayPal Payflow Link is a hosted payment gateway with an embedded checkout that
keeps customers on your site. It’s the fast and easy way to add transaction processing to
your site.

PayPal Business Accounts
PayPal payment methods that are integrated with Magento require the merchant to have
a PayPal business account and/or a PayPal Payflow account. The type of PayPal account
that is required is specified in the description of each method.
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Customers who make purchases using Express Checkout and the Express Checkout for
Payflow Pro must have buyer accounts with PayPal to pay for their purchases. PayPal
Payments Standard (and Website Payments Standard) can work either directly or
through a buyer account, if the PayPal Account Optional parameter is enabled in the
Premier or Business account of the merchant. By default, this parameter is enabled and
customers can choose to enter their credit card information and the billing and shipping
addresses and pay the order amount, or to create a buyer account with PayPal and then
pay the order amount. When the parameter is disabled, the customer must create a
buyer account with PayPal before paying for the order.

Website Payments Pro, Website Payments Pro Payflow Edition, Payflow Pro Gateway,
and Payflow Link require the customer to enter credit card information during checkout.

PayPal Payments Advanced
PayPal Payments Advanced lets your customers pay by debit or credit card without
leaving your site, and includes an embedded checkout page that can be customized to
create a seamless and secure checkout experience.

Merchant Requirements
l PayPal Business Account

l If you manage multiple Magento websites, you must have a separate PayPal
merchant account for each.

Configuration
To get started, see Setting Up PayPal Payments Advanced in the Knowledge Base.

Checkout Workflow
With PayPal Payments Advanced, your customer stays on your site during the checkout
process.

The customer selects the PayPal Payments Advanced payment method on the Payment
Information checkout step and clicks Continue.

The Order Review step appears, with the Pay Now button, instead of the Place Order
button. After the customer clicks the Pay Now button, a PayPal-hosted form opens in the
customer’s browser. The customer specifies the card information and clicks Verify Card.
If the transaction is successful, the customer is redirected to the order confirmation
page.

The form also includes the Pay with PayPal button, which redirects the customer to the
PayPal site, where payment can be made with PayPal Express Checkout.

https://www.paypal.com/webapps/mpp/how-to-sell-online
http://www.magentocommerce.com/knowledge-base/entry/setting-up-paypal-payments-advanced-for-magento-community
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If the transaction fails for any reason, an error message appears on the checkout page
and the customer is directed to repeat the checkout process. These issue are managed by
PayPal.

Order Processing Workflow
Processing orders with PayPal Payments Advanced is the same as processing any regular
order with PayPal. An invoice, shipment, and credit memo (online/offline refund) can be
created. Multiple online refunds are not available for the PayPal Payments Advanced
payment method.

With PayPal Payments Advanced, an order is created in the Admin when a customer
clicks the Place Order button. The order status can be any of the following, depending on
the response from PayPal:

Processing The transaction was successful.

Pending Payment The system did not receive any response from PayPal.

Canceled The transaction was not successful for some reason.

Suspected Fraud The transaction did not pass some of the PayPal fraud filters;
the system receives the response from PayPal that the trans-
action is under review by Fraud Service.

You can manage your fraud filters in your PayPal merchant account.

PayPal Payments Pro
PayPal Payments Pro brings you all the benefits of a merchant account and payment
gateway in one, plus the ability to create your own, fully customized checkout
experience. PayPal Express Checkout is automatically enabled with PayPal Payments
Pro, so you can tap into more than 110 million active PayPal users.

Requirements
l PayPal Business Account (with Direct Payments Activated)

Configuration
To get started, see Setting Up PayPal Payments Pro in the Knowledge Base.

Checkout Workflow
After customers add products to their shopping carts, they can go to checkout by
clicking the Proceed to Checkout button. In the Payment Information checkout section,
they select the PayPal Direct Payment option, and enter the credit card information.
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l PayPal Payments Pro lets your customer stay on your site during the checkout
process.

l PayPal Express Checkout redirects your customer to the PayPal site to complete the
transaction.

Order Processing Workflow
If the payment action selected in the configuration is set to “Authorize,” only a sales
order of the Processing status is created in Magento. In this case, the amount of money
to be authorized is pending approval. With PayPal Payments Pro, you can process the
payment online from either the Admin of your store, or from your PayPal merchant
account.

When checking out products from the shopping cart to multiple addresses
simultaneously, customers can choose to pay with Website Payments Pro.

At the customer’s request, the store administrator can also create an order from the
Admin, and place it through the Website Payments Pro payment method.

An order can be voided online at any time until the order amount is fully invoiced. If
required, the order can be online partially invoiced for a specified quantity of products.
For each partial invoice submitted through the PayPal payment system, a separate
transaction record with a unique ID and of the Capture transaction type will become
available on the Transaction tab, and a separate invoice document will be created on the
Invoices tab. The payment transaction of the type “Authorization” is closed only after the
full order amount is captured.

When capturing the payment transaction, PayPal transfers the order amount from the
buyer’s balance, bank account or credit card to the merchant’s account. If for any reason
the customer returns the purchased products and claims a refund, as with order amount
capturing and invoice creation, you can create an online refund either from the Admin or
from your PayPal merchant account.

Make sure that instant payment notifications are enabled in your PayPal merchant
account. An invoice is created in Magento only after an instant payment notification
message is delivered to Magento from PayPal. Based on these notifications, you can
receive detailed payment information on each transaction from PayPal after you click
the Fetch button on the Transaction page of an order.

If the payment method has been set to “Sale,” both a sales order and an invoice are
created in Magento under Sales > Orders.

PayPal Payments Standard
For merchants outside the US, this method is called PayPal Website Payments Standard.
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PayPal Payments Standard is the easiest way to accept payments online. You can offer
your customers the convenience of payment both by credit card and PayPal by simply
adding a checkout button to your store.

With PayPal Payments Standard, you can swipe credit cards on mobile devices. There is
no monthly fee, and you can get paid on eBay. Supported credit cards include Visa,
MasterCard, Discover, and American Express. In addition, customers can pay directly
from their personal PayPal accounts. PayPal Payments Standard is available in all
countries on the PayPal worldwide reference list.

Merchant Requirements
l PayPal Business Account

Configuration
To get started, see Setting Up PayPal Payments Standard in the Knowledge Base.

Checkout Workflow
During checkout, the customer is redirected to the PayPal site to complete the
transaction. PayPal Payments Standard is a one-step process for customers whose credit
card information is up-to-date in their personal PayPal accounts. All the customer needs
to do is click the “Pay Now” button to complete the purchase.

PayPal Express Checkout
PayPal Express Checkout helps boost sales by giving your customers the ability to pay
by credit card or from the security of their personal PayPal accounts. During checkout,
the customer is redirected to the secure PayPal site to complete the payment
information. The customer is then returned to your store to complete the remainder of
the checkout process. Choosing Express Checkout adds the familiar PayPal button to
your store, which has been reported to increase sales.*

Check out with PayPal

Customers with current PayPal accounts can make a purchase in a single step, by
clicking the “Check out with PayPal” button. Express Checkout can be added as a
standalone, or added to an existing PayPal solution. If you already accept credit cards
online, you can offer Express Checkout as an additional option to attract new customers
who prefer to pay with PayPal. PayPal Express Checkout can be used as a standalone, or
in combination with one of PayPal’s All-In-One solutions.
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Requirements

For Merchant: PayPal Business Account

For Customer: Personal PayPal Account

Configuration
To get started, see the following articles in the knowledge base:

Getting Started with PayPal Express Checkout

PayPal Express Checkout Workflow

Setting Up PayPal Express Checkout

Checkout Workflow
With Express Checkout, the customer is redirected to the PayPal site to complete the
transaction. Unlike other payment methods, PayPal Express Checkout allows the
customer to check out at the beginning of the usual checkout flow. With the PayPal
Express Checkout enabled, the “Check out with PayPal” button is available on the
product page, in the shopping cart, and mini shopping cart. Clicking the button
redirects the customer to the PayPal website to review the purchase information.
Customers must log in to their PayPal accounts to complete the transaction. The
payment system uses the customer’s billing and shipping information from the
customer’s PayPal account. The customer is then redirected back to the Magento Review
Order page. After the customer places the order in Magento, the payment information is
submitted to PayPal and the payment transaction is settled.

If the customer uses the one-page checkout and selects the Express Checkout payment
method, the customer is redirected to PayPal during the Payment Review process, just
before the sales order is submitted.

Express Checkout method of payment is unavailable if the customer chooses to check
out the products from the shopping cart to multiple addresses. The store administrator
cannot place an order using the Express Checkout method of payment, because it is also
unavailable from the Admin.

Aside from the configuration details, here are some aspects of PayPal Express Checkout
to be aware of:

l Saving Customer Billing Address

l Managing Order Transactions

l Billing Agreements

l Settlement Reports

https://www.paypal.com/webapps/mpp/how-to-sell-online
https://www.paypal.com/webapps/mpp/buying-online
http://www.magentocommerce.com/knowledge-base/entry/getting-started-with-paypal-express-checkout-for-magento-community
http://www.magentocommerce.com/knowledge-base/entry/paypal-express-checkout-workflow-for-magento-community
http://www.magentocommerce.com/knowledge-base/entry/setting-up-paypal-express-checkout-for-magento-community
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Save Customer Billing Address
The complete billing address of the customer can be saved when the customer pays with
PayPal Express Checkout. The billing address can be received from PayPal, and can be
edited by the customer.

To save the customer billing address:

Make sure that the functionality is enabled in your PayPal merchant account. Contact
PayPal technical support for more information.

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods.

3. Under PayPal Express Checkout, click the Configure link, and do the following:

a. Set Require Customer’s Billing Address to “Yes.”

b. To request the customer’s billing address only for orders with downloadable and/or
virtual products, set Require Customer’s Billing Address to “For Virtual Quotes
Only.”

4. Click the Save Config button.

When customers choose to pay using PayPal Express Checkout, they are redirected to
PayPal. Having logged in to PayPal and reviewed the payment information, they are
redirected back to the Order Review page of your store, where they can choose the
shipping method, edit the billing and shipping addresses, and place the order.

Alternatively, if you have set up your PayPal Express Checkout Advanced settings to
skip the order review step, the customer can pay for the order on the PayPal site by
clicking the Pay Now button.

If a billing address cannot be received from PayPal because of your configuration or
due to any other reasons, the billing address fields on the Order Review page are
prepopulated with the shipping address values. A customer can edit them if necessary.

If a customer leaves the billing and shipping addresses without changes, the Place Order
button is enabled when the customer selects the shipping method in the Shipping
Method field.

If the customer edits the billing or shipping address, the Place Order button is disabled.
The customer needs to click the Update Order Data button first. The system will update
the information, including the available shipping methods, and the Place Order button
will be enabled.

After the customer clicks Place Order, the order is created in Magento, and PayPal
performs the related transaction(s). The complete billing and shipping addresses are
saved in the order record in Magento.
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Manage Order Transactions
Magento includes the option of using the Order payment action for the PayPal Express
Checkout payment method. When a store customer submits an order, having paid using
the PayPal Express Checkout payment method, for which the Order payment action is
set, the funds on the customer’s card are authorized. If the authorization times out
before you capture all payment, the authorization is voided, and a new authorization
and capture are conducted when you create an invoice. Only the amount equal to the
invoice total is authorized and captured. The maximum number of these authorizations
for one order, and the periods for which the first authorization and the order in general
stay valid, depend on your PayPal merchant account settings. These parameters need to
be specified in the Magento Admin Panel as well. Capturing can be done only from the
Magento Admin Panel, by creating one or more invoices.

Situations in which using the Order transaction may be appropriate include the
following:

l Back orders, in which available items are sent immediately, and the remaining part of
the order is sent when available; this may include more than two shipments

l Split orders, in which ordered items are sent in more than one shipment, perhaps to
different addresses, and you want to collect a payment for each shipment

l Drop shipments, which are shipments from other vendors for which you accept the
payment

Using the Order payment action does not influence the checkout process for store
customers.

Payment Action Set to “Order”
When the store customer submits the order, having paid using the PayPal Express
Checkout payment method, for which the Order payment action is set, the order (with
Processing status) is created in the Admin. Two transactions are created for this order:
one with type Order and one with type Authorization.

The funds on the customer’s account are put on hold, and you can capture the payment
only from the Admin. To capture, you need to create an online invoice. When you choose
to create an online invoice, Magento determines whether the number of days passed
from the first authorization exceeds the Order Valid Period value. If more days have
passed, you cannot create an online invoice for this order.

If the order is valid, Magento determines whether the first authorization is valid,
comparing the number of days passed with the Authorization Honor Period value. If the
authorization is valid, the necessary sum is captured; the rest is left on hold, and the
number of captures is not limited. If the authorization is not valid anymore, it is voided.
A new authorization and capture are created, but for the invoice total (not the order
total). From this moment, each time you create an online invoice for this order, a new
authorization and capture will be conducted only for invoice totals.
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Also, Magento will determine whether the number of the conducted captures is equal to
the Number of Child Authorizations value each time. If the number specified there is
already reached, creating online invoices for the order will not be possible.

Bill Me Later
For US merchants, the PayPal service Bill Me Later is now a payment option in
checkout. Bill Me Later offers your customers access to financing, so they can buy now
and pay later, at no additional cost to you. You are not charged when customers choose
Bill Me Later, and only pay your normal PayPal transaction fee.

You can also use free, ready-made banner ads and a prominent Bill Me Later button in
checkout, to tell your customers while they shop that financing is available.

PayPal Bill Me Later Button

We estimate that offering Bill Me Later results in up to 18% more sales, about one-third
of which results from the six months same-as-cash payment option (according to an
August 2013 Forrester Consulting study commissioned by PayPal). You can also visit the
PayPal website for more information about Bill Me Later.

Before you configure Bill Me Later in your store, make sure it is enabled in your PayPal
account .

To enable Bill Me Later:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods.

3. Under PayPal Express Checkout, click the Configure link, and do the following:
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a. Click to expand Required PayPal Settings.

b. Set Enable Bill Me Later to “Yes.”

4. Click the Save Config button.

Bill Me Later Information Link

To enable Bill Me Later banners:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods.

3. Under PayPal Express Checkout, click the Configure link.

4. Click to expand Required PayPal Settings section. Then, click to expand Advertise Bill
Me Later section.

Advertise Bill Me Later
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5. Click the Get Publisher ID from PayPal button and follow the directions to get your
account information. Then, enter your Publisher ID.

6. Click to expand the Home Page section. Then, do the following:

a. To place a banner on the page, set Display to “Yes.”

b. Set Position to one of the following:

l Header (center)

l Sidebar (right)

c. Set Size to one of the following:

l 190 x 100

l 234 x 60

l 300 x 50

l 468 x 60

l 728 x 90

l 800 x 66

7. Repeat the previous step for each of the following sections:

l Catalog Category Page

l Catalog Product Page

l Checkout Cart Page

8. When complete, click the Save Config button.

Bill Me Later Banner Sizes
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Billing Agreements
The Billing Agreement functionality enables customers to sign an agreement with the
payment system and eases the process of checkout because customers do not need to
specify payment information again and again. During the shopping cart checkout, the
customer can simply choose a billing agreement as a payment method and based on its
number; the payment system will charge the customer's account.

To enable billing agreements:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods.

3. Click the Configure button for one of the following PayPal solutions:

l PayPal Express Checkout

l PayPal Payments Advanced (includes Express Checkout)

l PayPal Payments Pro (includes Express Checkout)

4. Scroll down to the PayPal Billing Agreement Settings section, and do the following:

a. Set Enabled to “Yes.”

b. Complete the remaining information according to your business requirements.

For more detailed configuration instructions, see the knowledge base article for your
PayPal solution.

Setting Up PayPal Express Checkout

Setting Up PayPal Payments Pro

Setting Up PayPal Payments Advanced

c. When complete, click the Save Config button.

PayPal Billing Agreement Settings

http://www.magentocommerce.com/knowledge-base/entry/setting-up-paypal-express-checkout-for-magento-community
http://www.magentocommerce.com/knowledge-base/entry/setting-up-paypal-payments-pro-for-magento-community
http://www.magentocommerce.com/knowledge-base/entry/setting-up-paypal-payments-advanced-for-magento-community
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Workflow

Billing agreements make it possible for individual customers to make purchases on a
regular basis through an external payment system without entering their credit card
information again and again. They can simply grant the authorization to the payment
system once. With Billing Agreements, customers do not need to enter credit card
information in Magento and they are not redirected to the external payment system,
although the actual payment is performed there.

After the customer signs a billing agreement with the store on the PayPal side, PayPal
provides the store and the customer with the reference ID for the signed billing
agreement. The reference ID is a unique number assigned to a billing agreement by the
payment system. During subsequent purchases, the customer selects the billing
agreement as the payment method and uses the billing agreement reference ID. No other
payment information is required for placing an order. The payment system verifies
billing agreement information and whether the payment can be fulfilled by the reference
ID specified by the customer. After the payment system performs the payment
transaction, the reference ID is returned to the Magento system and an order is placed.

Currently Magento Community Edition supports only PayPal Express Checkout
payment method for Billing Agreements. Before enabling billing agreements, contact
PayPal Merchant Technical Services to enable billing agreements (reference
transactions) for your PayPal merchant account.

After a billing agreement is signed with PayPal, the store owner can charge the
customer’s PayPal account directly. When billing agreements are enabled, they can be
created in the following ways:

l Creating a billing agreement from the customer account in the frontend: The
customer uses the Billing Agreement wizard which redirects him or her to the PayPal
website, where a billing agreement is signed.

l Submitting a billing agreement with an order: After choosing the corresponding
payment method, the customer is redirected to the PayPal website, where a billing
agreement is signed.

A billing agreement can be created from a customer account only if Allow in Billing
Agreement is enabled in the Admin configuration.

Create Billing Agreement from Customer Account

A customer can create a billing agreement by signing in to her or his customer account
on your website, selecting the billing agreement payment method, and starting the
Billing Agreement wizard located on the Billing Agreements tab. When a billing
agreement is created, it is submitted to the PayPal payment system and is recorded to
the customer account with its reference information. The number of billing agreements
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that a customer can create in the customer account is not limited and depends only on
the customer’s needs. The customer can also cancel some or all of the billing agreements
on the Billing Agreement page of the customer account.

Billing agreements available in the customer account can be either Active or Canceled.
Canceled billing agreements cannot be reactivated. .

When checking out products from the shopping cart, a customer who has already signed
a billing agreement with PayPal can choose the PayPal Billing Agreement payment
method in the Payment Information section of the checkout page and select the
necessary billing agreement reference ID from the list. When the customer clicks the
Place Order button, the billing agreement reference ID and sales order payment details
are transferred to the PayPal payment system. After the payment system confirms the
payment, a sales order is created in Magento.

If the payment action selected for the PayPal Billing Agreement payment method is set
to “Sale,” as soon as the customer places an order, the PayPal payment system transfers
the order amount from the customer’s account to the merchant, and both a sales order
and an invoice are created in Magento. With the Authorization payment action selected,
only a sales order is created.

Create Billing Agreement with Order

If the customer purchasing items from the web store does not yet have a billing
agreement with PayPal, she or he can choose the PayPal Express Checkout method of
payment, select the Sign a billing agreement to streamline further purchases with PayPal
checkbox, and be redirected to the PayPal payment system where the customer payment
information is available and the billing agreement can be signed. After a billing
agreement with the store is signed, the customer is redirected back to the Magento
frontend, where an order is placed. A corresponding record appears in the billing
agreements list.

Additionally, the customer who has no billing agreements in the customer account can
also sign a billing agreement from the mini shopping cart or from a product view page
by clicking the Check out with PayPal button, that is, by using the PayPal Express
Checkout payment method. This opens a dialog box that gives the customer the option
to sign a billing agreement with the PayPal payment system. If the customer cancels
creating a billing agreement, the order is created through the normal PayPal payment
process.

If the customer has one or more billing agreements, the customer can still create a new
billing agreement from the customer's account, but will not be able to sign a new billing
agreement using the PayPal Express Checkout payment method.
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When the customer signs a billing agreement during the order checkout, PayPal creates a
payment transaction through the PayPal Express Checkout payment method selected by
the customer (that is, a sales order is created in Magento), and a billing agreement
reference ID which is sent to the customer and the store. The currently created order is
not related to the billing agreement that is signed. Related billing agreement-order
records are created in Magento the next time that the customer selects this billing
agreement as a payment method and places an order.

Managing Billing Agreements

The store administrator can take a number of actions to manage customer’s billing
agreements both in the Customer and Sales sections.

Sales Management

The list of all billing agreements for all customers is available under Sales > Billing
Agreements. Here, the store administrator can filter the records by the customer or
billing agreement information including billing agreement reference ID, status, and
creation date. A specific record provides general information about the selected billing
agreement and about all sales orders that relate to it. The store administrator can view,
cancel, or delete a customer’s billing agreements in the Sales Management area. Billing
agreements can be canceled or deleted by clicking the corresponding buttons located in
the upper right part of the Billing Agreement page. An already canceled billing
agreement can only be deleted by the store administrator.

Customer Management

Billing agreements created by a single customer can be seen on the Billing Agreements
tab of the customer account page in the Admin (Customers > Manage Customers). From
here, the store administrator can open a required billing agreement to view its general
information and sales orders relating to it, cancel a billing agreement, or delete it.

Create Sales Order with Billing Agreement

On a customer’s request, the store administrator can create a sales order and after filling
in all required information for order currency, items, billing and shipping addresses, she
or he needs to select the PayPal Billing Agreement payment method and specify the
reference number for a specific billing agreement. When the order is submitted, the
billing agreement reference ID is transferred to the PayPal payment system and, if the
payment is authorized, an order is created in Magento.

Settlement Reports
The PayPal Settlement report provides the store administrator with the information
about each transaction that affects the settlement of funds.
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Before generating settlement reports, the store administrator must contact PayPal
Merchant Technical Services to create an SFTP user account, and enable settlement
reports and SFTP for the PayPal business account.

After configuring and enabling settlement reports in the PayPal merchant account,
Magento will start generating reports within twenty-four hours.

To enable settlement reports:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods.

3. Click the Configure button for one of the following PayPal solutions:

l PayPal Express Checkout

l PayPal Payments Advanced (includes Express Checkout)

l PayPal Payments Pro (includes Express Checkout)

4. Scroll down to the Settlement Report Settings section, and do the following:

a. Enter your SFTP Credentials.

b. Complete the remaining information according to your business requirements.

For detailed configuration instructions, see the knowledge base article for your
PayPal solution.

c. When complete, click the Save Config button.

Settlement Report Settings
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View a Settlement Report

The list of available settlement reports can be viewed from the Admin. Each report
contains information as described below.

To view the settlement reports:

On the Admin menu, select Reports > Sales > PayPal Settlement Reports.

Field Descriptions
Field Description

Report Date The date when the settlement report was generated.

Merchant Account The encrypted merchant account number generated by
PayPal.

Transaction ID The identification of a transaction of the money moving event.
Transaction ID is generated by PayPal and cannot be changed
by the merchant.

Invoice ID The identification of an invoice generated within Magento. The
field can be populated with either an invoice ID sent with the
capture request or with the value of the invoice ID (if any)
from the authorizing transaction.

PayPal Reference ID The identification of a related, pre-existing transaction or
event.

Event Code The code assigned to the transaction according to the event
that has initiated it. Among these can be website payments
standard payment, express or direct checkout API, pre-
approved payment, subscription payment, and so on.

Initiation Date The date and time the transaction was initiated.

Completion Date The date and time the transaction was completed.

Gross Amount The amount of the payment between the two parties and
before fees.

Fee Amount The amount of fee associated with the settlement. All trans-
action fees are included in this amount. Fees are never amort-
ized across several transactions.

The store administrator can fetch the most recent settlement reports by clicking the
Fetch Updates button located in the upper right part of the page. After clicking it, a
dialog box appears, stating that the system will connect to the PayPal SFTP server to
fetch the reports. When all recent reports are added to the list, the Infolog message
appears, stating the number of reports fetched. The report includes the following
additional information for each transaction:
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Field Descriptions
Field Description

PayPal Reference ID Type One of the following reference codes:
Order ID
Transaction ID
Subscription ID

Preapproved Payment ID Options include:

Custom The text entered by the merchant on the
transaction in PayPal.

Transaction
Debit or Credit

The direction of money movement of
gross amount.

Fee Debit or
Credit

The direction of money movement for
fee.

PayPal Payflow Pro
PayPal Payflow Pro gateway, formerly known as Verisign, is a payment method available
for customers of the USA, Canada, Australia, and New Zealand. Similar to other PayPal
payment methods that are provided in Magento, PayPal Payflow Pro Gateway requires
that the store owner have a merchant account at PayPal. The PayPal Payflow Pro
gateway links the merchant account at PayPal and the merchant’s website, and acts
both as a gateway and a merchant account. With PayPal Payflow Pro Gateway,
payments are processed directly on the merchant websites and customers are not
redirected to PayPal. Unlike other PayPal payment methods, the pricing for using the
Payflow Pro Gateway method of payment is fixed no matter how many transactions are
submitted. That is, merchants pay a fixed monthly fee plus a fixed fee for each
transaction regardless of their number.

PayPal Payflow Pro does not require customers to have buyer accounts at PayPal; but
depending on the merchant country, customers may use their PayPal buyer accounts for
paying through the gateway.

PayPal Payflow Pro allows customers to enter their credit card information during
checkout, without leaving the store checkout page and without using PayPal hosted
forms. Additionally, payments are accepted through PayPal Payflow Pro at the time an
order is placed.

Customer Workflow
After customers add products to their shopping carts and proceed to the checkout, they
specify their billing and/or shipping addresses and the shipping method. Then, in the
Payment Information section of the Checkout page, they can select the Payflow Pro
payment method, enter the type of credit card, its number, expiration date, and the card
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verification number. Customers are not redirected to the PayPal website when they
choose to pay with Payflow Pro Gateway. Depending on the payment action selected in
the configuration of the payment method, either a sales order or a sales order and an
invoice is created.

Order Processing Workflow
Orders paid with Payflow Pro Gateway can be processed online only from Magento.
Here, you can submit an online invoice and as a result a corresponding transaction and
an invoice will be created. Regarding order amount refunds, you can also submit them
online from the created invoice.

Partial invoices are not available when using the Payflow Pro Gateway payment method.
The Qty to Invoice field is unavailable for editing. The partial refund is unavailable as
well.

You can view all Payflow Pro Gateway transactions in your PayPal business account.

PayPal Payflow Link
PayPal PayFlow Link is available for merchants in the United States and Canada only;
this method requires a Payflow merchant account. PayFlow Link cannot be used for
orders created from the Admin.

PayPal Payflow Link passes the information about the card, entered by the customer,
directly to PayPal; it is never stored in Magento system. A customer does not need to
have a PayPal account to use this method.

Customer Workflow
The store customer selects the PayFlow Link payment method on the Payment
Information checkout step and clicks Continue. The Order Review step appears, where
the Pay Now button is available instead of the usual Place Order button. After the
customer clicks Pay Now, the PayPal-hosted form, where the credit card information can
be entered, loads in the checkout page. The customer specifies the card information and
clicks Pay Now. If the transaction is successful, the customer is redirected to the order
confirmation page.

The form also contains the Cancel Payment link. Clicking it redirects the customer to the
Payment Information step of the checkout, where the payment method is selected. If the
transaction fails on any reason, an error message appears on the checkout page and the
customer is directed to repeat the checkout process. These situations are handled on the
PayPal side.
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Order Workflow
When a customer clicks the Pay Now button on the last checkout step, the order is
created in the Panel with a “Pending Payment” status. After the customer enters the card
information and clicks the Pay Now button in the form, which exists on the PayPal site,
the status of the order changes, depending on the response the system receives from
PayPal:

Processing The transaction was successful.

Pending Payment The system did not receive any response from PayPal.

Canceled The transaction was not successful for some reason.

Suspected Fraud The transaction did not pass some of the PayPal fraud filters;
the system receives the response from PayPal that the trans-
action is under review by Fraud Service.

You can manage your fraud filters in your PayPal merchant account.

If the customer clicks the Cancel Payment link in the form, the order status changes to
Canceled. The new order is created when a customer proceeds with the checkout.

In general, processing of orders that are paid using the PayFlow Link payment method
is the same as regular processing of orders that are paid with PayPal. An invoice,
shipment, and credit memo (online/offline refund) can be created. Multiple online
refunds are not available for the PayFlow Link payment method.

https://manager.paypal.com/
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PayPal Payment Solutions by Country
Country PayPal Payment Solution

United States PayPal Payments Advanced (Includes Express Checkout)
PayPal Payments Pro (Includes Express Checkout)
PayPal Payments Standard+
PayPal Payflow Pro (Includes Express Checkout)
PayPal Payflow Link (Includes Express Checkout)
PayPal Express Checkout

Canada PayPal Payments Pro (Includes Express Checkout)
PayPal Payments Standard
PayPal Payflow Pro
PayPal Payflow Link (Includes Express Checkout)
PayPal Express Checkout

Australia PayPal Payments Standard
PayPal Payflow Pro
PayPal Payments Pro Hosted Solution
PayPal Express Checkout

United Kingdom PayPal Express Checkout
PayPal Payments Standard
PayPal Payments Pro Payflow Edition (Includes Express Check-
out)
PayPal Payments Pro Hosted Solution

Japan PayPal Express Checkout
PayPal Payments Standard
PayPal Website Payments Plus (PayPal Payments Pro Hosted
Solution)

France PayPal Express Checkout
PayPal Payments Standard
PayPal Integral Evolution (PayPal Payments Pro Hosted Solu-
tion)

Italy PayPal Express Checkout
PayPal Payments Standard
PayPal Pro (PayPal Payments Pro Hosted Solution)

Spain PayPal Express Checkout
PayPal Payments Standard
PayPal Pasarela integral (PayPal Payments Pro Hosted Solu-
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Country PayPal Payment Solution

tion)

Hong Kong PayPal Express Checkout
PayPal Payments Standard
PayPal Payments Pro Hosted Solution

New Zealand PayPal Express Checkout
PayPal Payments Standard
PayPal Payflow Pro

Others PayPal Express Checkout
PayPal Payments Standard
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Chapter 46:

Payment Solutions & Gateways
Magento Community Edition supports a wide range of payment solutions and
gateways that offer merchant services in all parts of the world. Unlike some payment
solutions that transfer control to complete the transaction on another site, a
payment gateway makes it possible for you to accept credit card payments directly
from your store.

Worldwide
Amazon Simple Pay

Amazon offers easy payment and checkout solutions for physical goods retailers that
allow customers to use their Amazon.com accounts as a payment method. Magento
Community Edition supports the following payment solutions from Amazon:

l Amazon Simple Pay

l Checkout by Amazon

PayPal

With PayPal’s deep integration with Magento, you can easily accept credit cards and
PayPal payments using PayPal, all while keeping customers on your site. Already
have a merchant account? Add PayPal Express checkout to increase conversion.

Authorize.Net

Authorize.Net includes free fraud tools, free customer support, a free website seal,
and the ability to accept multi-channel payments: online, mail order/telephone
order, retail and mobile. Trusted by 300,000 customers.

ChronoPay

Established in Amsterdam in 2003, ChronoPay offers payment solutions for the
global market. The company has a large presence in the Russian market. Magento
Community Edition supports the following ChronoPay payment solutions:

l ChronoPay Standard

l ChronoPay Gateway
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CyberSource

CyberSource, a wholly-owned subsidiary of Visa Inc., is a payment management
company. Over 330,000 businesses worldwide use CyberSource to process online
payments, streamline fraud management, and simplify payment security.

First Data

Fast, convenient, and secure. With over forty years of industry leading experience
Express Merchant Processing Solutions (EMPS) powered by First Data helps millions of
businesses like yours bring safe, easy, cost-effective payments to their customers with
affordable support, regardless of size.

Europe
CyberMut Payment

CyberMut is a secure payment service operated by the French Bank, Crédit Mutuel. To
use CyberMut, you must open a business account with the bank.

iDEAL

iDEAL is a collection of technical agreements between banks and transaction processors
(a protocol) and not a centralized electronic payment system. The iDEAL protocol
provides an immediate online transfer from the buyer’s bank account to the bank
account of the online store. Magento Community Edition support the following iDEAL
payment solutions:

l iDEAL Basic

l iDEAL Advanced

Ogone

Ogone Payment Services delivers non-face-to-face businesses the payment solutions
platform, added value opportunities and technology advancements that become
essential for the way payments are performed, managed and secured today.

Paybox

Paybox Services provides merchant accounts and eCommerce payment services for
merchants in Europe. Magento Community Edition supports the following Paybox
payment methods:

l Paybox Direct

l Paybox System

Protx Standard

Protx is one of the largest payment processors in the United Kingdom. In 2006, Protx
was aquired by Sage Pay.
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Oceania
eWAY Direct

Focusing on high-level standards in technology, innovations and customer care, eWay
has become Australia’s award-winning payment gateway. eWAY specializes in delivering
successful eCommerce payment gateway services to thousands of merchants. Magento
Community Edition supports the following eWAY payment methods:

l eWAY Direct

l eWAY Shared

l eWAY 3D Secure

Flo2Cash Payment Web Service

New Zealand-based Flo2Cash provides and approves Credit Card and Direct Debit
facilities and is a leading provider of payment processing services and solutions, which
enables businesses of all sizes to streamline their payment processes; this in turn
improves cash flow and reduces operating expense.

Authorize.Net
Authorize.Net gives merchants the ability to accept credit card and payments through
the Authorize.Net payment gateway. It processes the credit card information entered
during checkout, and creates a transaction either for the payment authorization or for
the payment authorization and a capture of the funds, depending on the configuration.

Authorize.Net can be used to pay for purchases made from the storefront or for orders
placed from the Admin. Orders that use the Authorize.Net payment method can be
processed from your store's Admin and also from the Authorize.Net merchant
account.Based on the response that Magento receives from Authorize.Net, an order is
created in Magento with an assigned Authorize.Net transaction number.

To find an order:

1. On the Admin menu, select Sales > Orders.

2. In the list, click to open the order.

3. On the order detail page, click the Invoicebutton.

The Amount field of the order has the following payment actions:

Payment Actions
Payment Action Description

Capture Online When an invoice is submitted, the system captures the
payment amount through the external payment gateway. In
this case, an invoice and a transaction of the “Capture” type
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Payment Action Description

A payment capture transaction can be voided only from
your Authorize.Net merchant account.

Capture Offline When an invoice is submitted using this option, the does not
capture the payment, and only an offline invoice is created in
Magento. It is assumed that the payment will be captured dir-
ectly through the payment gateway, and you do not have the
option to capture the payment online through Magento.

If the invoice is captured online, you cannot create an
online refund from Magento.

Not Capture When an invoice is submitted using this option, Magento does
not capture the payment, and no corresponding transaction
is created in the Authorize.Net merchant account. However, it
is assumed that you will capture the payment online through
Magento at a later date. Therefore, the Capture button is avail-
able in the completed invoice, which has a status temporarily
set to “Pending.”

The order can be canceled at any time before the payment
is captured. After the payment has been captured, a credit
memo must be generated to cancel the order.

Authorize.Net does not allow partial invoices to be created from Magento. The Qty to
Invoice field cannot be edited on the New Invoice for Order page. When an invoice is
captured online, a corresponding document with status of “Paid” is created and appears
in the list of Invoices. In addition, a Capture transaction is added to the list of
Transactions.

You can partially capture the order amount from the Authorize.Net merchant account.
However, Authorize.Net does not allow for the remaining amount to be captured. In the
case of a partial capture from Authorize.Net, no invoice or transaction is created in
Magento for the order.

Direct Post Method
Magento incorporates the Direct Post method for payments made through
Authorize.Net. When payments are made using the Direct Post Method, the
Authorize.Net gateway handles all steps in the transaction process, such as payment
data collection, data submission, and response to the customer, while the customer
remains in your store.
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To enable and configure the Direct Post Method:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods.

3. Set Current Configuration Scope to the website where the configuration is to be applied.
To apply the configuration globally, accept the “Default Config” setting.

4. Click to expand the Authorize.Net Direct Post section.

5. Complete the settings as described in the following field descriptions.

6. When complete, click the Save Config button.

Field Descriptions
Field Scope Description

Enabled Website Activates Authorize Direct Post Method within the
Current Configuration Scope setting. Options
include: Yes / No.

Payment Action Website Determines how payments are authorized in the
Authorize.Net payment system and the entities
that are created after the successful transaction.
Options include:

Authorize
Only

Funds on the customer's card
are only authorized at the side
of the Authorize.Net system and
only an order is created in the
backend of your store. You can
later create an invoice and
conduct the capturing.

Authorize
and Capture

unds on the customer's card are
authorized and captured at
Authorize.Net side, and as a
result an order and an invoice
are created in the backend of
your store.

Title Store View A label that identifies the payment method to cus-
tomers during checkout.

API Login ID Website Your Authorize.Net credentials.

Transaction Key Website Your Authorize.Net credentials.
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Field Scope Description

Merchant MD5 Website The MD5 Hash value enables Magento to verify
that transaction responses are securely received
from Authorize.Net.
The MD5 Hash value is used by the payment
gateway to encrypt responses for transactions,
submitted for your account.You can set your
MD5 Hash Value on the Authorize.Net website at
Account > Settings > Security Settings > MD5-
Hash.

New Order Status Website The status assigned to all new orders that are
created using this payment method.

Test Mode Website Determines if the Direct Post Method is working
in a test environment, or processing live trans-
actions. Options include:

Yes Sends a notification to Author-
ize.Net that orders should be
sent to their test site.

No Orders are sent to Authorize.Net
as live transactions.

After testing transations, don't forget to set Test
Mode to "No," so you can process live trans-
actions.

Gateway URL Website The URL to which order information is sent. the
default URL is:
https://secure.authorize.net/gateway/transact.dll.

If you have a special test URL from
Authorize.Net, you can set Test Mode to “No,”
and specify the testing link in the Gateway
URL field. However, the URL of the live site
must be re-entered before going live.

Accepted Currency Website Make sure that the Accepted Currency field is set
to “US Dollar,” because this is the only currency
that Authorize.Net accepts.

Debug Website Determines if all communication with the
payment system is recorded in a log file.

Email Customer Website Specify whether you want Authorize.Net to send
emails to your customers on the completion of
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Field Scope Description

the checkout.
This is in addition to the order confirmation
email and other transactional email sent from
Magento.

Merchant’s Email Website If you want to receive email notifications of
orders placed with the Direct Post Method, from
Authorize.Net, enter the email address that is
associated with your account. If left blank, no
email will be sent to you by Authorize.Net.

Credit Card Types Website Select the options that will appear in the Credit
Card Type list during checkout. Options include:
American Express
Visa
MasterCard
Discover
Other

Credit Card Verification Website Determines if customers are required to enter
the Credit Card Verification number during check-
out. Options include: Yes / No.

Payment from Applic-
able Countries

Website Determines the countries from which you accept
payment. Options include: All Allowed Countries
/ Specific Countries

Payment from Specific
Countries

Website Determines each country from which you accept
payment. Only customers with a billing address
in one of the selected countries can use this
payment method.

Minimum Order Total Website Determines the minimum order total for orders
processed with the Direct Post Method. The
option appears only for orders that fall within the
minimum and maximum range.

Maximum Order Total Website Determines the maximum order total for orders
processed with the Direct Post Method. The
option only for orders that fall within the
minimum and maximum range.

Sort Order Website Determines the sequence in which the Direct
Post Method is listed with other payment
methods during checkout.
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Admin Workflow
The Authorize.Net Direct Post Method can be used with orders created from the Admin
as well as from the store. When creating an order, you can select it in the Payment
Method section. After selecting the option, the credit card data entry fields appear. If the
transaction fails, an error message appears, and you can select another payment method
or try again with another card.

The order process is similar to the standard order workflow. As with other orders, and
invoice, shipment, and credit memo can be created.

Customer Workflow
If you enable this method, the customer can select it in the Payment Information section
of the checkout process. After the customer clicks the corresponding option button and
clicks Continue, the Order Review section of the checkout appears, with fields to enter
the credit card information. The customer then specifies the card information and clicks
the Place Order button.

If the transaction is successful, the customer is redirected to the order confirmation
page. If the transaction fails on some reason, an error message is displayed in a dialog
box and the customer may then select another payment method or try Authorize.Net
Direct Post with another card.

Checkout Using Authorize.Net Direct Post
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Partial Authorization with Authorize.Net
Authorize.Net gives you the ability to accept multiple credit cards as payment for a
single order. If there isn’t enough remaining balance on a single card to cover the
purchase, the amount can be distributed across multiple cards. Up to five credit cards
can be used to pay for a single order. Partial authorization can be activated in the
Authorize.Net configuration at either the global, or website level.

To enable partial authorization:

1. On the Admin menu, select System > Configuration.

2. In the upper-left, set Current Configuration Scope as needed. To use partial
authorization at the global level, accept the “Default Config” setting.

3. In the panel on the left under Sales, select Payment Methods. Then, click to expand the
Authorize.Net section.

4. Set Allow Partial Authorization to “Yes.”

5. When complete, click the Save Config button.

Customer Workflow

During the checkout process, the customer selects Authorize.Net, enters the card
information, and proceeds to Order Review. When the customer clicks the Place Order
button, the request is sent to Authorize.Net. If the amount available on the card is not
enough to cover the order total, the following message appears:

The amount on your credit card is insufficient to complete your purchase. The available
amount has been put on hold. To complete your purchase, click Continue and specify
additional credit card number. To cancel the purchase and release the amount on hold,
click Cancel.

If the customer chooses to continue, the Payment Information checkout step reappears,
and the customer is prompted to enter another credit card. The information about the
previously used credit cards appears as well.

If the customer clicks the Cancel button, all authorizations are reversed. The customer
can then choose another payment method to complete the purchase. If the customer
closes the browser window, the authorizations remain active until they expire. The term
of each authorization depends on the bank that issued the credit card. An order is
created only after the total amount of the order is captured.
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Partial Authorization During Checkout

If the customer reaches the limit of five cards that can be used for one order, the
following message appears during Order Review:

You have reached the maximum number of credit cards that can be used for the
payment.

When the customer clicks the OK button, the Payment Information checkout step
reappears, with the following message:

You have reached the maximum number of credit cards that can be used for one
payment. The available amounts on all used cards were insufficient to complete
payment. The payment has been canceled and amounts on hold have been released.

The system sends a request to Authorize.Net to void all authorizations of this payment.
The customer can now choose another payment method, or try a different credit card.

During partial authorization, the bank might reject the transaction, For example, the
daily limit for the card might be exceeded. In this case, Authorize.Net sends the
appropriate response to Magento and the following message appears:

Your credit card has been declined. Click Continue to specify another credit card to
complete your purchase. Click Cancel to release the amount on hold and select another
payment method.
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If the customer decides to reverse the payment and clicks Cancel, the payment is
reversed, and a request is sent to Authorize.Net to release the amounts on hold from the
previously entered cards. The customer can then select another payment method. If the
customer chooses to continue, the Payment Information checkout step reappears, and
the customer is prompted to enter another credit card.

Before the order is placed, the customer can click the Cancel button from the Payment
Information step to reverse all authorizations and release all amounts.

If the customer changes any order information after having started the partial
authorization process, an error will occur when the order is submitted. In such a case, all
authorizations are released, and the customer is redirected to the Payment Information
checkout step.

Admin Workflow

Partial authorization can be applied to new orders and recorders from the Admin. After
you choose the Authorize.Net payment method, enter the card information, and click the
Submit Order button, the request is sent to Authorize.Net. If the amount on the card is
not enough to cover the order, the available funds are put on hold, and the partial
authorization is triggered. A message appears on the Create New Order page, asking if
you want to continue. If you choose to continue, the system displays the information
about the previously used credit cards, and prompts you to enter another credit card. If
you click the Cancel button, all authorizations are reversed.

If you close the browser window during the partial authorization process, the
authorizations remain active until they expire. The term of authorization depends on the
bank that issued the credit card.

If payment is not complete, you can click the Cancel button in the upper-right corner.
Magento then sends a request to Authorize.Net to void the authorization for all cards
that were entered during the process, and the amounts on hold are released. If the
payment gateway is not able to void authorization for some transactions, the order is
canceled by the system only.

Do not change any order information after the partial authorization process begins.
Otherwise, an error occur when you submit the order, and all authorizations are released
automatically.

Partial Authorization Refunds
When processing a refund for an order that was paid with partial authorizations,
Magento refunds the correct captured amount to each card. The process is managed by
the system, and requires no action on your part.

When initiating an online invoice or refund, and some authorizations fail, the system
proceeds with the remaining authorizations, but does not generate the invoice or refund.
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After all authorizations have been processed, information about the successful
authorizations, as well as any that failed, appears in the header of the order. The same
information is added to the order comments section of the order.

The administrator is then prompted to process the failed authorizations manually, by
creating an offline invoice or offline refund in Magento.

For a partial refund, the amounts are refunded to the cards from which they originated,
in the order of authorization. The amount captured from the first card is the first to be
refunded. In this order, it is possible for the amount reversed on the last card to be less
than what was captured during the partial authorization process. In this case the
transaction for the card remains open, and can be closed in the next partial refund.

Magento stores only the last four digits of the credit card number. For a period of 120
days after the payment, Authorize.Net allows merchant systems to submit a refund
using the last four digits of the credit card. After 120 days have passed, you cannot
process an online refund for an order that was paid with Authorize.Net.

Because American Express does not support authorization reversals, it is not possible to
create an online refund for any purchases paid for with this method. In such a case, you
can create an offline refund, and settle the situation by releasing the customer’s funds
through the appropriate merchant account, outside of the Magento system.
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Chapter 47:

Payment Services
Your Magento Community Edition includes support for the following service to
provide an additional layer of protection against fraudulent charges and chargebacks
for sales.

3D Secure Credit Card Validation
Magento Community Edition includes the option to use 3D Secure authentication
for payment transactions made with Authorize.Net. Cardinal Centinel® is the
company that provides the 3D Secure Credit Card Validation service.

During checkout, the customer is prompted to enter a secret code that is assigned to
the card, which is then used to confirm the identity of the cardholder. The bank also
provides additional data elements to confirm the cardholder’s identity. The service
provider arranges the communication between the banks and payment systems. 3D
Secure authentication can be used for orders placed from the store, or from the
Admin.

To learn more information about the 3D Secure protocol, search by “Verified by Visa,”
“MasterCard SecureCode,” and “J/Secure.”

Process Overview:
Step 1: Complete the 3D Secure Configuration
Step 2: Enable 3D Secure for Authorize.Net

Step 1: Complete the 3D Secure Configuration

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Services.

3. To apply the configuration at the website level, set Current Configuration Scope in
the upper-left corner, as needed. To apply the configuration at the global level,
accept the “Default Config” setting.
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4. Click to expand the 3D Secure Credit Card Validation section. Then, do the following:

3D Secure Credit Card Validation

a. Enter the following credentials that are required to connect to the Cardinal Centinel
system:

l Processor ID

l Merchant ID

l Pasword

b. To test 3D Secure Validation before going live in the store, set Test Mode to “Yes.”

c. To save a log file of all interactions between your server and the Cardinal Centinel
system, set Debug Mode to “Yes.”

5. When complete, click the Save Config button.

Field Descriptions
Field Scope Description

Processor ID Website Specify the merchant processor identification
code. This value is assigned to you by Cardinal
Centinel.

Merchant ID Website Specify the merchant identification code. This
value is also assigned to you by Cardinal
Centinel.

Password Website Specify the password to connect to the Cardinal
Centinel system.

Test Mode Website Choose whether the connection with the Car-
dinal Centinel system is tested prior to start the
real life 3D Secure validation of payment trans-
actions.

Debug Mode Website Saves a log file of all interaction between your
server and the Cardinal Centinel system.
Options include: Yes / No.
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Step 2: Enable 3D Secure for Authorize.Net

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods.

3. To apply the configuration at the website level, set Current Configuration Scope in the
upper-left corner as needed. To apply the configuration at the global level, accept the
“Default Config” setting.

4. Click to expand the Authorize.Net section. Then, scroll down to the 3D Secure section.
Then, do the following:

Enable 3D Secure Card for Authorize.Net

a. Set Enable 3D Secure Card Validation on Frontend to “Yes.”

If you are use Magento Secure Payment Bridge, you can ignore the additional
settings.

b. In the Severe 3D Secure Card Validation field, specify if you want severe validation
to be applied to credit card purchases made through the Centinel system. Severe
validation removes merchant liability for any chargebacks that may occur.

c. In the Centinel API URL field, enter the URL that was provided by Cardinal Centinel
to establish the connection with their system.

5. When complete, click the Save Config button.

Field Descriptions
Field Scope Description

Enable 3D Secure Card
Validation on Frontend

Website Activates 3D Secure for use with Authorize.Net.
Options Include: Yes / No.

Severe 3D Secure Card
Validation

Website Severe Validation removes chargeback liability
from the merchant. Options include: Yes / No.

Centinel API URL Website Enter the URL provided in your 3D Secure agree-
ment.
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3D Secure Customer Workflow
During the checkout process, the customer selects the Authorize.Net payment method,
enters the credit card information, and clicks the Continue button. During Order Review,
the bank that issued the credit card displays a form to verify the customer’s identity.
Depending on the bank’s requirements, the customer might be required to enter a secret
code, log in to an account, or complete another activity.

3D Secure Authentication for the Customer

After submitting the form, the customer is returned to Order Review. The customer clicks
the Place Order button. If the authentication succeeds, the customer proceeds to the
order confirmation page. If the authentication fails for any reason, an error message
appears and the customer can select another payment method or try again with
Authorize.Net.
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Chapter 48:

Basic Shipping Methods
Magento Community Edition supports a wide range of shipping methods and
carriers. This section shows how to configure the following basic shipping methods:

l Shipping Settings

l Flat Rate

l Free Shipping

l Table Rates

l Online Rates

The setup instructions in this chapter take place in the Configuration section of your
store’s Admin. The Shipping Methods tab manages the configuration for the various
shipping methods and services that are available to your customers during checkout.
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Shipping Settings
The Shipping Settings establish the point of origin for all shipments made from your
store or warehouse, and determine if you support shipments to multiple addresses. The
point of origin also determines the store tax rate for products sold.

Origin

To establish the point of origin:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, click Shipping Settings.

3. Click to expand the Origin section, and complete the following:

l Country

l Region / State

l ZIP / Postal Code

l City

l Street Address (and line 2, if needed)

4. When complete, click the Save Config button.

To support shipments to multiple addresses:

1. Click to expand the Options section, and complete the following:

2. Set Allow Shipping to Multiple Addresses to “Yes.”

3. To limit the number of address you accept per shipment, enter the number in the
Maximum Qty Allowed for Shipping to Multiple Addresses field.

4. When complete, click the Save Config button.

Options
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Flat Rate
Flat rate is a fixed, predefined charge that can be applied per item, or per shipment. Flat
rate is a simple solution, especially when used with the flat-rate packaging that is
available from some carriers.

Flat Rate

To set up flat rate shipping:

1. On the Admin menu, select System > Configuration. In the panel on the left, under
Sales, select Shipping Methods.

2. Click to expand the Flat Rate section. Then, do the following:

a. Set Enabled to “Yes.”

Flat Rate appears as an option in the Estimate Shipping and Tax section of the
shopping cart, and also in the Shipping section during checkout.

b. Enter a descriptive Title for this shipping method. The default is “Flat Rate.”

c. Enter a Method Name that appears next to the calculated rate in the shopping cart.
The default method name is “Fixed.” If you charge a handling fee, you can change
the Method Name to “Plus Handling” or something else that is suitable.

d. To describe how flat rate shipping can be used, set Type to one of the following:

None Disables the payment type. The Flat Rate option is listed
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in the cart, but with a rate of zero—which is the same as
free shipping.

Per Order Charges a single flat rate for the entire order.

Per Item Charges a single flat rate for each item. The rate is
multiplied by the number of items in the cart, regardless
of whether there are multiple quantities of the same, or
of different items.

e. Enter the Price to be charged for the flat rate fee.

f. If charging a handling fee, set Calculate Handling Fee to one of the following:

l Fixed

l Percent

Then, enter the Handling Fee rate according to the method used to calculate the fee.
For example, if the fee is calculating based on a percentage, enter 0.06 for 6 percent.
If using a fixed amount calculation, enter the fee as a decimal.

g. In the Displayed Error Message box, type the message that appears if this method
becomes unavailable.

h. Set Ship to Applicable Countries to one of the following:

All Allowed Countries Customers from all countries specified in your store
configuration can use this shipping method.

Specific Countries After choosing this option, the Ship to Specific Countries
list appears. Select each country in the list where this
shipping method can be used.

i. Enter a Sort Order number to determine the position of Flat Rate in the list of
shipping methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

3. When complete, click the Save Config button.

Free Shipping
Free shipping is one of the most effective promotions you can offer. It can be based on a
minimum purchase, or set up as a shopping cart price rule that applies when a set of
conditions is met. If both apply to the same order, the configuration setting will take
precedence over the shopping cart rule.

Check your shipping carrier configuration for any additional settings that may be
required for free shipping.
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Free Shipping

To set up free shipping:

1. On the Admin menu, select System > Configuration. In the panel on the left, under
Sales, select Shipping Methods.

2. Click to expand the Free Shipping section. Then, do the following:

a. Set Enabled to “Yes.”

b. Enter a Title for this shipping method that will be displayed during checkout.

c. Enter a descriptiveMethod Name to identify this shipping method.

d. Enter theMinimum Order Amount to qualify for free shipping.

To use Free Shipping with Table Rates, you must enter a Minimum Order Amount
so high that it is never met. This prevents Free Shipping from going into effect,
unless triggered by a price rule.

e. In the Displayed Error Message box, type the message to appear if this method
becomes unavailable.

f. Set Ship to Applicable Countries to one of the following:

All Allowed Countries Customers from all countries specified in your store
configuration can use this shipping method.

Specific Countries After choosing this option, the Ship to Specific Countries
list appears.Select each country in the list where this
shipping method can be used.
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g. Set Show Method if Not Applicable to one of the following:

Yes Always shows the Free Shipping method, even when not
applicable.

No Shows the Free Shipping method only when applicable.

h. Enter a Sort Order number to determine the position of Free Shipping in the list of
shipping methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

3. When complete, click the Save Config button.

4. Make sure that you complete any configuration that is required for each carrier you plan
to use with free shipping. For example, assuming that your UPS configuration is
otherwise complete, make the following settings to enable and configure free shipping:

a. From the Shipping Methods configuration, click to expand the UPS section.

b. In the UPS section, set Free Method to “Ground.”

c. To require a minimum order for free shipping, set Free Shipping with Minimum
Order Amount to “Enable.”

d. Enter the required amount in theMinimum Order Amount for Free Shipping field.

5. When complete, click the Save Config button.

Table Rates
The table rate shipping method lets you set up a table to calculate shipping rates for a
combination of conditions. The shipping rate can be based on the following:

l Weight v. Destination

l Price v. Destination

l # of Items v. Destination

For example, if your warehouse is located in Los Angeles, it costs less to ship to San
Diego than to Vermont. You can use table rate shipping to pass the savings on to your
customer.

Only one set of table rate data can be active at a time.

The data that is used to calculate the rate is prepared in a spreadsheet and imported
into your store. When the customer requests a quote, the results appear in the shipping
estimate section of the shopping cart.
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Table Rate in Shopping Cart

Process Overview:
Step 1: Complete the Default Settings
Step 2: Prepare the Table Rate Data
Step 3: Import the Table Rate Data

Step 1: Complete the Default Settings

The first step is to complete the default settings for table rates. You can complete this
step without changing the scope of the configuration.

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, select Shipping Methods.

3. Click to expand the Table Rates section. Then, do the following:

a. Set Enabled to “Yes.”

b. Enter a Title for the section of table rates that appears during checkout. (The default
title is “Best Way.”)

c. Enter theMethod Name that appears next to the calculated rate in the shopping
cart.

d. Set Condition to one of the following calculation methods:

l Weight v. Destination

l Price v. Destination

l # of Items v. Destination
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e. For orders that include virtual products, set Include Virtual Products in Price
Calculation to “Yes” if you want to be able to include the virtual product(s) in the
calculation.

Because virtual products—such as services—have no weight, they cannot change
the result of a calculation that is based on the Weight v. Destination condition.
However, virtual products can change the result of a calculation that is based on
either the Price v. Destination or # of Items vs Destination condition.

f. If charging a handling fee, set Calculate Handling Fee to one of the following:

l Fixed

l Percent

Then, enter the Handling Fee rate according to the method used to calculate the fee.

If the handling fee is based on a percent, enter the whole number without the
percent sign.

g. In the Displayed Error Message box, type the message that appears when this
method is not available.

h. Set Ship to Applicable Countries to one of the following:

All Allowed Countries Customers from any country specified in your store
configuration can use table rate shipping.

Specific Countries After choosing this option, the “Ship to Specific
Countries” list appears. Select each country where
customers can use table rate shipping.

i. Enter a Sort Order number to determine where table rates appear in the list of
shipping methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

4. When complete, click the Save Config button.
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Table Rates

Step 2: Prepare the Table Rate Data

1. In the upper-left corner, set Current Configuration Scope to the “Main Website,” or any
other website where you want the configuration to apply.

Export and Import options appear in the Table Rates section, with “Use Default”
checkboxes to the right of each option.

To change any of the current settings, you must first clear the “Use Default” checkbox
next to the field.

2. If you want to change the Condition, clear the Use Default checkbox. Then, select
another option.

3. Click the Export CSV button. Then, save the tablerates.csv file to your computer.
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Export CSV

4. Open the file in Excel, or any other spreadsheet program.

5. Complete the table with appropriate values for the shipping calculation condition being
used.

l You can use an asterisk (*) as a wildcard to represent all possible values in any
category.

l The Country column must contain a valid three-character code for each row.

Weight vs. Destination

6. When complete, save the tablerates.csv file.

Step 3: Import the Table Rate Data

1. Return to the Table Rates section of your store configuration.

2. In the upper-left corner, set Current Configuration Scope to the website where this
method will be used.
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3. Next to the Import field, click the Choose File button. Select your completed
tablerates.csv file, and import the rates.

Import Table Rates

4. When complete, click the Save Config button. Then, go through the payment process
with different addresses to make sure the shipping and handling rates are correct.

Price v. Destination Example
This example uses the Price v. Destination condition to create a set of three different
shipping rates based on the amount of the order subtotal for the continental United
States, Alaska, and Hawaii. The asterisk (*) is a wildcard that represents all values.

Country Region / State
ZIP / Postal
Code

Order Subtotal
(and above)

Shipping Price

USA * * 0 15

USA * * 50 10

USA * * 100 5

USA AK * 0 20

USA AK * 50 15

USA AK * 100 10

USA HI * 0 20

USA HI * 50 15

USA HI * 100 10
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Online Rates
Magento offers dynamic retrieval of rates from various shipping providers.

Most shipping providers require that you open an account with them. Consult your
shipping provider for details on how to obtain API credentials.

To enable and configure these shipping methods, expand the appropriate tabs (UPS,
USPS, FedEx, or DHL) and configure the settings. The configuration of this method is
similar to the configuration of Flat Rate. Because the options differ for each service,
contact the carrier for more information.
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Chapter 49:

Shipping Carriers
If you have a commercial account with a supported carrier, you can offer your
customers the convenience of choosing that carrier during checkout. The rates are
automatically downloaded, so you do not need to look up the information.

Before you can offer your customers a selection of shipping carriers, you must first
complete the shipping settings to establish the point of origin for your store. Then,
complete the configuration for each carrier service that you want to offer. The
configuration options vary for each carrier. However, all require that you first open a
shipping account with the carrier, and enter your account number or user ID, and
the gateway URL to their system into the configuration of your store.

See Magento Connect for additional shipping services for your Magento Community
Edition installation.

UPS

United Parcel Service offers domestic and international shipping services by land
and air to more than 220 countries.

USPS

The United States Postal Service is the independent postal service of United States
government. USPS offers domestic and international shipping services by land and
air.

FedEx

Offers domestic and international shipping services by land and air to more than
220 countries.

DHL

Offers integrated international services and tailored, customer-focused solutions for
managing and transporting letters, goods and information.
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Package Type by Carrier
The following tables list the shipping methods and supported package types for U.S. and
international shipments, by carrier.

l Custom packaging has been added to each shipping method of each shipping carrier.

l Shipping methods are divided into U.S. and International. Those that are marked as
“U.S.” are for US domestic shipments only. Those that are marked as "International"
can be those shipped from the U.S. to other countries, from other countries to the
U.S. and within countries other than the U.S. FedEx does not offer domestic
shipments for countries other than the U.S. at this time. USPS offers shipments from
the U.S. only for both domestic and international.

l For international shipping, available package types sometimes depend on the country
of origin (U.S. or other). If a shipment originates outside of the U.S., the available
package types are filtered according to the types that are acceptable. For shipments
that originate in countries other than the U.S., the full list of package types available
for the selected shipping carrier is provided.

FedEx

FedEx (U.S.)
Shipping Method Package Type

FedEx First Overnight FedEx Envelope
FedEx Pak
FedEx Box
FedEx Tube
Your Packaging

FedEx Priority Overnight (same as above)

FedEx Standard Overnight (same as above)

FedEx 2Day (same as above)

FedEx Express Saver FedEx Envelope

FedEx Pak

Your Packaging

FedEx Ground
FedEx Home Delivery
FedEx SmartPost

Your Packaging
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FedEx (International)
Shipping Method Package Type

FedEx International First FedEx Envelope
FedEx Pak
FedEx Box
FedEx Tube
Your Packaging

FedEx International Priority FedEx Envelope
FedEx Pak
FedEx Box
FedEx 10 kg Box
FedEx 25 kg Box
FedEx Tube
Your Packaging

FedEx International Ground Your Packaging

FedEx Europe First Priority FedEx Envelope
FedEx Pak
FedEx 10 kg Box
FedEx 25 kg Box
Your Packaging

UPS

UPS (U.S.)
Shipping Method Package Type

UPS Next Day Air Early AM Small Express Box
Medium Express Box
Large Express Box
UPS Express Tube
UPS Pak
UPS Letter
Your Packaging

UPS 2nd Day Air (same as above)

UPS Next Day Air (same as above)

UPS 2nd Day Air AM (same as above)

UPS 3 Day Select Your Packaging
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Shipping Method Package Type

UPS Ground Your Packaging

UPS (International)
Shipping Method Package Type

UPS Worldwide Express Small Express Box
Medium Express Box
Large Express Tube
UPS Express Tube
UPS 10 kg Box
UPS 25 kg Box
UPS Pak
UPS Letter
Customer Packaging

UPS Worldwide Express Plus (same as above)

UPS Worldwide Saver (same as above)

UPS Worldwide Expedited (same as above)

UPS Worldwide Expedited Small Express Box
Medium Express Box
Large Express Tube
UPS Express Tube
UPS 10 kg Box
UPS 25 kg Box
UPS Pak
Customer Packaging

USPS

USPS (International)
Shipping Method Package Type

Express Mail® International Flat Rate Envel-
ope

Express Mail International Flat Rate Envel-
ope

Express Mail Flat Rate Envelop Hold for
Pickup

Express Mail International Flat Rate Envel-
ope

Priority Mail International Large Flat Rate
Box

Priority Mail International Medium Flat Rate
Box

Priority Mail International Small Flat Rate
Box

Priority Mail International Small Flat Rate
Box
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Shipping Method Package Type

Priority Mail International Flat Rate Envel-
ope

Priority Mail International Flat Rate Envel-
ope

Global Express Guaranteed (GXG) Large Package/Non-Rectangular (Regular
and Medium)
Variable

USPS GXG Envelopes Large Package/Rectangular (Regular and
Medium)
Large Package/Non-Rectangular (Regular
and Medium)
Variable

Express Mail International (same as above)

Priority Mail International (same as above)

First-Class Mail International Package (same as above)

DHL

DHL (International)
Shipping Method Package Type

Express Package

Express International Letter
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Chapter 50:

Shipping Labels
Magento Community Edition includes a high level of integration with major
shipping carriers, which gives you access to carrier shipping systems to track orders,
create shipping labels, and more. Shipping labels can be created for regular
shipments and products with return merchandise authorization.

In this chapter, the following terminology used in reference to shipping label
requirements:

International shipments Shipments where the sender and recipient are in different

countries; international borders are crossed.

Domestic shipments Shipments where the sender and recipient are in the same

country; no international borders are crossed.

Shipping labels are supported by the following carriers, with the following
constraints:

USPS Requires a USPS account.

UPS Requires a UPS account. Shipping labels are available
only for shipments that originate in the U.S. Specific
credentials are required for stores outside the US.

FedEx Requires a FedEx account. For stores outside of the U.S.,
shipping labels are supported for international
shipments only. FedEx does not allow domestic
shipments that originate outside of the U.S

DHL Requires a DHL account. Shipping labels are supported only

for shipments that originate in the U.S.

Workflow
When you create a shipping label, Magento prompts you for information about
packaging you want to use (type, size, etc.) and which products go with which
package. When you finish, Magento connects to the shipping carrier web-services,
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creates an order in its system, and receives the shipping label for the shipment. The
tracking number(s) are also received and added in the Admin.

An individual shipment order for each package is created, as a result multiple shipping
labels can be received for one shipment in Magento.

Shipping Label Configuration
The following settings must be made at the product level, as well as in the configuration
of each carrier. It is recommended that you complete the configuration for each carrier
that you intend to use to produce shipping labels.

To configure shipping labels:

1. On the Admin menu, select Catalog > Manage Products.

2. The Country of Manufacture field is required for each product that is shipped
internationally by USPS and FedEx, Update the field for each product record, as needed.

Country of Manufacture

3. When complete, click the Save button.

If you have many products that need to be updated with the same information, do the
following:

a. In the Manage Products list, select the checkbox of each product that needs to be
updated. For example, all products that are manufactured in China.

b. Set the Actions control to “Update Attributes,” and click the Submit button.

c. In the Update Attributes form, find the Country of Manufacture field and select the
Change checkbox. Then, select the country from the list and click the Save button.

4. On the Admin menu, select System > Configuration. Then, do the following:

a. In the panel on the left, under Sales, select Shipping Settings. Click to expand the
Origin section, and verify that the following fields are complete:

Street Address The street address of the place from which shipments are
sent. For example, the location of your company or
warehouse. This field is required for shipping labels.
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Street Address Line 2 Any additional address information, such as the floor,
entrance and so on. We strongly recommend that you
use this field.

Origin

b. In the Configuration panel under Sales, select Shipping Methods. Click to expand
the USPS section, and verify that the following fields are complete:

Secure Gateway URL You do not need to configure this field, it is pre-
populated by Magento.

Password The password is provided by USPS, and gives you access
to their system through Web Services.

Length, Width

Height, Girth

The default dimensions of the package. To make these
fields appear, set Size to “Large,”

c. Click to expand the FedEx section, and verify that the following fields are complete:

l Meter Number

l Key

l Password

This information is provided by the carrier, and is required to gain access to their
system through Web Services.

d. In the Configuration panel under General, select Store Information. Verify that the
fields in this section are complete. If you have multiple stores, and the contact
information differs from the default, set Current Configuration Scope to the store
view and verify that the information is complete. If any of this information is
missing, an error message will appear when you try to print shipping labels.

Store Name The name of the store or store view.

Store Contact
Telephone

The telephone number of the primary contact for the
store or store view.

Country The country where your store is based.
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VAT Number If applicable the Value Added Tax number of your store.
(Not required for stores based in the U.S.)

Store Contact Address The street address of the primary contact for the store or
store view.

Store Information

e. When complete, click the Save Config button.

Generate Shipping Labels
You can decide to create a shipping label while creating the shipment in the Admin, or
later, when the shipment already exists.

To create a shipping label at the shipment creation stage:

1. On the Admin menu, select Sales > Orders.

2. Open the order for editing.

3. Click the Ship button in the upper right corner of the order view.

4. On the New Shipment page, configure the shipment, select the Create Shipping Label
checkbox above the Submit Shipment button, and click the Submit Shipment button.

Create Shipping Label

5. In the Create Packages pop-up, add the packages, distribute all shipped products among
the packages, and click OK.
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Create Package

This is a required step for creating a shipping label. If you click Cancel, the shipping label
will not be created and the Create Shipping Label checkbox will be cleared.

Magento connects to the shipping carrier, creates the order in its system, and receives a
shipping label and tracking number for each package. If a shipping label is successfully
created, the new shipment is saved and the shipping label is available for printing. A
tracking number appears in the Shipping and Tracking Information section. If the
shipping label cannot be created due to problems with connection or any other reason,
the shipment is not created.

To create a shipping label for an existing shipment:

1. Open a shipment for editing.

2. Click the Create Shipping Label button in the Shipping and Tracking Information
section.

3. In the Create Packages pop-up add packages, distribute all shipped products to the
correct package, and click OK.

This is a required step for creating the shipping label. If you click Cancel, the shipping
label is not created.

Magento connects to the shipping carrier, creates the order in its system, and receives a
shipping label and a tracking number. If a shipping label for this shipment already
existed in the system, it is replaced with a new one. Existing tracking numbers are not
replaced. The new received tracking numbers are added to the existing ones. The
information about the packages created and their contents is saved in the system.

4. To view the information, click the Show Packages button located next to the Print
Shipping Label button.

If you create shipping labels multiple times, the Show Packages window reflects the
most recent package configuration.

To print a shipping label:

Shipping labels are stored in PDF format. When you click the Print Shipping Label
button, the PDF file is downloaded. If your browser settings allow it, you can open the
file at once, and print the shipping labels. Each shipping label is placed on a separate
page in the PDF file.
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In addition to the usual information each shipping carrier adds to a shipping label, it
includes the Magento order number, number of the package, and the total quantity of
packages for the Magento shipment.

For all shipping labels created for DHL, FedEx, and UPS shipments, the “Type of Goods”
field of the shipping is “Merchandise.” For USPS, it reflects the value specified in the
Contents field of the Create Packages pop-up window.

1. Open the shipment in edit mode.

2. In the Shipping and Tracking Information section of the shipment, click the Print
Shipping Label button.

If the Print Shipping Label button does not appear, a shipping label has not been
created for this shipment. Click the Create Shipping Label button first. When Magento
receives the shipping label from the carrier, the Print Shipping Label button appears.

Create Packages
The Create Packages pop-up window appears if you choose to create a shipping label.
You can start configuring the first package at once.

Create Package

To configure a package:

1. Complete the fields as described below.

If you select the non-default value in the Type field or choose to require a signature
confirmation, the price of a shipment may differ from the one you charged to the
customer.

2. To view a list of shipped products and add them to the package, click the Add Products
button.

The Qty column is pre-populated with the maximum available quantity to add (for the
Package 1 this number is equal to the total shipped quantity of the product).

3. Specify the products and quantities. To add the products to the package, click the Add
Selected Product(s) to Package button in the header of the grid. The products are added
to the package.
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l To add a new package, click the Add Package button in the window header. You can
add several packages, and edit them simultaneously.

l To delete a package, click the Delete Package button.

Field Descriptions
Field Description

Type The type of a package. Select one of the predefined values.
Available package types are different for each shipping carrier,
and also depend on the shipping method selected during
order creation. To see the complete list of shipping methods
and their supported packages implemented in Magento.
When the Create Packages pop-up window opens, the default
package for the shipping carrier set in system configuration is
selected in the Type field.
If you select a package, which is not designed by a shipping
carrier, you will need to specify the dimensions of the
package.
This field is unavailable for USPS domestic shipments,
because specifying package types is not necessary for these
shipments.

Total Weight The total weight of a package. The field is pre-populated with
the total weight of products in a package, after you add them,
but can be edited manually. The measurement units can be
specified using the drop-down menu next to the field; select
between pounds and kilograms.

Length The length of a package, integer and floating point numbers.
The field is enabled if the custom package type is used. The
measurement units can be specified using the drop-down
menu next to the Height field; select between inches and cen-
timeters.

Width The width of a package, integer and floating point numbers.
The field is enabled if the custom package type is used. The
measurement units can be specified using the drop-down
menu next to the Height field; select between inches and cen-
timeters.

Height The height of a package, integer and floating point numbers.
The field is enabled if the custom package type is used. The
measurement units can be specified using the drop-down
menu next to the Height field; select between inches and cen-
timeters.

Signature Confirmation Defines delivery confirmation. Options include:
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Field Description

Not Required No delivery confirmation letter is sent.

No Signature A delivery confirmation letter without a
recipient’s signature is sent to you.

Signature
Required

The shipping carrier obtains the recip-
ient’s signature and provides you with its
printed copy.

Adult Required The shipping carrier obtains the adult
recipient’s signature and provides you
with its printed copy.

Direct (FedEx
only)

FedEx obtains a signature from someone
at the delivery address and reattempts
delivery if no one is available to sign for
the package.

Indirect (FedEx
only)

FedEx obtains a signature in one of three
ways: (1) from someone at the delivery
address; (2) from a neighbor, building
manager or other person at a neigh-
boring address; or (3) the recipient can
leave a signed FedEx Door Tag author-
izing release of the package without
anyone present. Available for residential
deliveries only.
The field availability and options may vary
slightly for different shipping methods.
For the most up to date information
please refer to shipping carrier’s
resources.

Contents (Available for USPS shipments only) Description of the
package contents. Select from the following:
Gift

Documents
Commercial Sample
Returned Goods
Merchandise
Other

Explanation (Available for USPS shipments only) Detailed description of
the package content.
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Change Product Quantities in Package
After the products are added to the package, their quantity cannot be edited directly. To
increase the quantity of the product in the package, click the Add Selection button, and
specify the additional quantity. This number will be added to the previous quantity of
the product in the package. To decrease the quantity, delete the product from the
package, click Add Selection, and specify the new, smaller value.

After you distribute all products, the total number of the packages you are going to use
is equal to the number of the last package in the list.

The OK button is disabled until all shipped items are distributed between packages and
all necessary information is specified. After you finish creating packages and distributing
the products, click OK. Magento starts the shipping label generation process.

If you click Cancel, your packages are not saved and shipping label creation is canceled.

Print Labels for Multiple Orders
Printing shipping labels is available as mass action on the Orders and the Shipments
pages.

To print shipping labels for the shipments of multiple orders:

1. On the Admin menu, select Sales > Orders.

2. In the list, select the checkhox of each order that needs shipping labels.

3. Set the Actions control to “Print Shipping Labels.”

4. Click the Submit button.

Shipping labels will be printed for all shipments that are related to the selected orders,
for which shipping labels have already been created.

Similarly, multiple shipping labels can be printed on the Shipments. page.

To open the Shipments page:

1. On the Admin menu, select Sales > Shipments.

2. Follow the same process described above.

Tracking Numbers
Together with shipping labels, Magento receives the tracking numbers related to the
shipment. The tracking numbers are inserted in the Shipping and Tracking Information
section of the shipment. When you create shipping labels multiple times, previous
tracking numbers are not deleted.
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Chapter 51:

Managing Taxes
Magento provides a variety of options for defining taxes that can be accessed by
selecting the Sales menu and then the Tax option. Tax classes are used to define “tax
rules.” Tax rules are defined as a combination of a Product Class, a Customer Class
and a Tax Zone and Rate, as described in this chapter.

Each type of customer can be assigned a customer class when you define them, and
each product is assigned a tax class. Magento analyzes the shopping cart of each
customer and calculates the appropriate tax according to the class of the customer,
the class of the products in the shopping cart, and the region (as defined by the
customer’s shipping address, billing address or shipping origin).

Magento also supports the calculation of Value-Added Tax (VAT) for business-to-
business transactions in the European Union.

To learn more, see the Knowledge Base article: Recommended Tax Configurations
and Best Practices.

Important! No guarantee is made regarding any information in this guide. Please
contact an expert before making decisions about tax matters.

Tax Resource Permissions
Admin permissions can be set to restrict access to tax resources, based on the
business “need to know.” To create an Admin role with access to tax settings, select
both the Sales/Tax and System/Tax resources. If setting up a website for a region
that differs from your default shipping point of origin, you must also allow access to
the System/Shipping resources for the role, because the shipping settings determine
the store tax rate used for catalog prices.

General Tax Configuration
Before setting up your taxes, make sure that you are familiar with the tax
requirements of your locale. Then, complete the tax configuration as needed for your
store.

http://www.magentocommerce.com/knowledge-base/entry/magento-ce-18-ee-113-tax-calc
http://www.magentocommerce.com/knowledge-base/entry/magento-ce-18-ee-113-tax-calc
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Process Overview:
Step 1: Set Up Tax Classes
Step 2: Complete the Calculation Settings
Step 3:Set Up the Default Tax Destination
Step 4: Complete the Display Settings
Step 5: Complete the Fixed Product Tax Settings

Step 1: Set Up Tax Classes

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Tax.

3. If you have multiple websites, set Current Configuration Scope to the website where the
tax configuration applies.

4. Click to expand the Tax Classes section.

Tax Classes

5. Set Tax Class for Shipping to the appropriate class. The default classes are:

l Taxable Goods

l Shipping

l Tax Exempt
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Step 2: Complete the Calculation Settings

1. Click to expand the Calculation Settings section. Then, do the following:

Tax Calculation Settings

a. In the Tax Calculation Method Based On field, select whether the tax is based on
the price of each unit, or on the “row total” (that is, the total for a line item in the
order, accounting for any discounts).

b. In the Tax Calculation Based On field, select whether the tax is calculated based on
the customer’s shipping address, billing address, or your store’s shipping origin.

c. In the Catalog Prices field, specify whether the catalog prices of items include tax or
exclude tax.

d. In the Shipping Prices field, select whether the shipping amounts include tax or
exclude tax.

e. In the Apply Customer Tax field, select whether tax is applied to the original or
discounted price.

f. In the Apply Discount on Prices field, select whether any discounts applied include
the tax or exclude it.

g. In the Apply Tax On field, select whether tax is applied to custom prices or to
original prices.

h. In the Enable Cross Border Trade field, select “Yes” to use consistent pricing across
different tax rates, or select “No” to vary the price by tax rate.
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Important! If you enable cross-border trade your profit margin changes by tax
rate. In other words, your profit is determined by the formula (Revenue -
CustomerVAT - CostOfGoodsSold). To enable cross-border trade you must
set prices to display including tax.

Step 3: Set Up the Default Tax Destination

1. Click to expand the Default Tax Destination Calculation section.

2. Select the Default Country to be used for tax calculations.

3. Select the Default State to be used for tax calculations.

4. Select the Default Post Code to be used for tax calculations.

An asterisk can be used as a wildcard to represent all State and Post Code values.

Default Tax Calculation Settings

Step 4: Complete the Price Display Settings

1. Click to expand the Price Display Settings section Then, do the following:

Price Display Settings

a. Set Display Product Prices in Catalog to one of the following:

l Excluding Tax

l Including Tax

l Including and Excluding Tax

If you set the Display Product Prices field to “Including Tax,” the tax appears
only if there is a tax rule that matches the tax origin, or if Magento detects that
the customer address matches the tax rule. This can happen after a customer
creates an account, logs in, or uses the Tax and Shipping estimation tool in the
cart.

b. Set Display Shipping Prices to one of the following:
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l Excluding Tax

l Including Tax

l Including and Excluding Tax

2. Click to expand the Shopping Cart Display Settings section.

For each section listed, chose how you want taxes and prices to be shown for products in
a shopping cart, according to the requirements of your store and locale.

Shopping Cart Display Settings

3. Click to expand the Orders, Invoices, Credit Memos Display Settings section. Then,
select how prices and taxes are displayed in orders, invoices, and credit memos.

Orders, Invoices, Credit Memos Display Settings

Step 5: Complete the Fixed Product Tax Settings

4. Click to expand the Fixed Product Taxes section. Then, specify the behavior of fixed per
product taxes, such as the European DEEE/WEEE (Waste Electrical and Electronic
Equipment) tax, according to the requirements for your store and products.

Fixed Product Taxes



Tax Classes Chapter 51:  Managing Taxes

To assign a fixed tax to a product, create an attribute with the Catalog Input Type for
Store Owner set to “Fixed Product Tax.” Then, add the attribute to the attribute set for
the product.

5. When complete, click the Save Config button.

Tax Classes
Every product and customer is assigned to a tax class. Tax classes, in turn, are used to
define tax rules. Tax rules are a combination of a customer tax class, product tax class,
and tax rates. The two basic types of tax classes are:

l Product Tax Classes

l Customer Tax Classes

Product Tax Classes
Product tax classes can be created and assigned according to the tax requirements of the
product. For example, food might not be taxed (or might be taxed at a different rate). If
your store charges an additional tax on shipping, you should designate a separate
product tax class for shipping.

Product Tax Classes

To define a product tax class:

1. On the Admin menu, select Sales > Tax > Product Tax Class.

2. In the upper-right corner, click the Add New button.

Product Tax Class Information

3. Enter a Class Name for this tax class.

The new tax class now appears as a Tax Class option for product prices.

4. When complete, click the Save Class button.
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Customer Tax Classes
You create customer tax classes and assign customers to them depending on the type of
customer. For example, in some jurisdictions, wholesale transactions are not taxed but
retail transactions are.

Customer Tax Classes

To define a customer tax class:

1. On the Admin menu, select Sales > Tax > Customer Tax Classes.

2. In the upper-right corner, click the Add New button.

Customer Tax Class Information

3. Enter a Class Name for this tax class.

You can link a customer tax class to a customer group by editing the customer group.
You can then assign this customer group when creating or editing a customer.

4. When complete, click the Save Class button.

Tax Zones & Rates
Tax rates generally apply to transactions that take place within a specific geographical
area. The Tax Zones and Rates tool enables you to specify the tax rate for each
geographical area for which you collect and remit taxes. Because you give each tax zone
and rate specification a unique identifier, you can have multiple tax rates for a given
geographic area (for example, for places that do not tax food or medicine but tax other
products).

Store tax is calculated based on the store’s address. The actual customer tax for an order
is calculated after the customer completes the order information. Magento then
calculates the actual tax based upon the tax configuration of the store.



Tax Zones & Rates Chapter 51:  Managing Taxes

Manage Tax Zones & Rates

To define tax zones and rates:

1. On the Admin menu, select Sales > Tax > Manage Tax Zones & Rates.

2. In the upper-right corner, click the Add New Tax Rate button.

Tax Rate Information

3. In the Tax Rate Information section, do the following:

a. In the Tax Identifier field, enter a unique name for this tax. Do not use spaces. This
identifier is not shown in the store if the Tax Titles section is completed, as
described below.

b. Select the location of the Country and State. (Starting in EE 1.13.1, you can use the
wildcard character * for State.)

c. Do one of the following:

l If you want the ZIP or postal code represented as an individual code, set Zip/Post
is Range, to “No.” Then, enter the Zip/Post Code.

l If you want the ZIP or postal code represented as a range, set Zip/Post is Range
to “Yes.” Then, enter the Range From and Range To values.

The wildcard character * can be used to represent all values. For example, 90*
means all ZIP codes from 90000 through 90999.
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d. In the Rate Percent field, enter the percentage of tax.

4. In the Tax Titles section, enter a name of this tax for each store view.

Tax Titles

5. When complete, click the Save Rate button.

Tax Rules
Tax management rules put all the taxation elements together: product tax classes,
customer tax classes, and tax zones and rates. Each tax rule consists of a customer tax
class, a product tax class, and a tax rate.

When numerous taxes must be defined, you can simplify the process by importing
them from a spreadsheet. Select Sales > Tax > Import/Export Tax Rates.

Manage Tax Rules

To define tax rules:

1. On the Admin menu, select Sales > Tax > Manage Tax Rules.

2. In the upper-right corner, click the Add New Tax Rule button. Then, do the following:
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Tax Rule Information

a. Enter a Name for the rule.

b. Select a Customer Tax Class. To select multiple options, hold the Ctrl key down and
click each item.

c. Select a Product Tax Class.

d. Select the Tax Rate.

This rule applies the tax rate to customers in the selected customer tax class and to
products in the selected product tax class.

e. In the Priority field, enter a number to indicate the priority of this tax, when more
than one tax applies. If two tax rules with the same priority apply, then the taxes
are added together. If two taxes with different priority settings apply, then the taxes
are compounded.

3. In the Sort Order field, enter a number to indicate the order in which tax rules are
displayed on the Manage Tax Rules page.

4. If you want taxes to be based on the order subtotal, select the Calculate off Subtotal
Only checkbox.

5. When complete, click the Save Rule button.

Field Descriptions
Field Description

Name Enter a name for this tax rule to make it easy to identify.

Customer Tax Class Select the customer tax class associated with this rule.

Product Tax Class Select the product tax class associated with this rule.

Tax Rate Select the tax rate that applis to this rule.
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Field Description

Priority Enter a number to indicate the priority of this tax, when more
than one tax applies. Lower numbers have higher priority. If
two tax rules with the same priority apply then the taxes are
added together. If two taxes with a different priority apply
then the taxes are compounded. When taxes are com-
pounded, the first priority tax is calculated on the subtotal
amount, and then the second priority tax is calculated on the
subtotal plus the first priority tax amount.

Calculate off Subtotal
Only

Select this checkbox for taxes to be calculated based on the
subtotal of the order. This means that for this tax rule, tax
applies only to the subtotal of the order.

Sort Order Specify the order in which tax rules are displayed on the
Manage Tax Rules page. Lower numbers have higher sort
order in the list.

Cross-Border Price Consistency
Cross-border trade (also referred to as price consistency) supports European Union (EU)
and other merchants who want to maintain consistent prices for customers whose tax
rates are different than the store tax rate.

Merchants operating across regions and geographies can show their customers a single
price. Pricing is clean and uncluttered regardless of tax structures and rates that vary
from country to country.

To use this feature, your store must display prices including tax. (Configure this setting
in the Admin panel at System > Configuration > Sales > Tax > Calculation Settings,
Catalog Prices set to Including Tax.)

To enable cross-border price consistency:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Tax.

3. Click to expand the Calculation Settings section. To enable cross-border price
consistency, set Enable Cross Border Trade to “Yes.”

Important! If you enable cross-border trade your profit margin changes by tax rate.
Profit is determined by the formula: (Revenue - CustomerVAT -
CostOfGoodsSold).

4. When complete, click the Save Config button.
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Enable Cross Border Trade Setting

Fixed Product Tax
Some tax jurisdictions have a fixed tax that must be added to certain types of products.
Magento lets you set up a fixed product tax (FPT) for use in your store's tax
calculations. For example, in some countries FPT can be used to set up a Waste
Electrical and Electronic Equipment Directive (WEEE) tax, also known as "ecological
tax" or "eco tax," that is collected on certain types of electronics to offset the cost of
recycling. This tax is a fixed amount, rather than a percentage of the product price.

Your tax jurisdiction might also have rules about how you display the price of products
to your customers, either with or without tax. Be sure you understand those rules so
that you can set your FPT display options accordingly.

Fixed Product Tax Calculations
Fixed product taxes are applicable at an item level based on the product. In some
jurisdictions this tax is subject to an additional % tax calculation.

FPT Display Setting and Associated Calculation

Not Taxed Excluding FPT Treat FPT as a separate row in the cart and
include the value of FPT in the appropriate tax
calculations.

Including FPT FPT is added to the base price of an item but is
not included in tax- rule-based calculations.

Excluding FPT, FPT
Description, Final
Price

Item prices are shown without FPT, FPT
amount, and with FPT included. FPT is not
included in tax-rule-based calculations.

590 Magento Community Edition: User Guide



Chapter 51:  Managing Taxes Fixed Product Tax

591Magento Community Edition: User Guide

FPT Display Setting and Associated Calculation

Taxed Excluding FPT Treat FPT as a separate row in the cart and
include the value of FPT in the appropriate tax
calculations.

Including FPT FPT is included in the price of an item, and no
change to tax calculations is required.

Excluding FPT, FPT
Description, Final
Price

Item prices are shown without FPT, FPT
amount, and with FPT included. FPT is included
in tax-rule-based calculations.

Fixed Product Tax Setup
The following instructions show how to set up a fixed product tax for your store. An “eco
tax” is an example of how you might used FPT. After setting the scope for the tax and
the countries and states where the tax applies, and depending on the options you
choose, the input fields can change to accommodate the local requirements.

Process Overview:
Step 1: Enable the FPT Tax
Step 2: Create an FPT Attribute
Step 3: Add the FPT to an Attribute Set
Step 4: Apply the FPT to Products

Step 1: Enable the FPT Tax

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Tax.

3. Click to expand the Fixed Product Taxes section. Then, complete the fields as needed,
using the Field Description section at the end of this section for reference.

Fixed Product Tax
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4. When complete, click the Save Config button.

Step 2: Create an FPT Attribute

1. On the Admin menu, select Catalog > Attributes > Manage Attributes.

2. In the upper-right corner, click the Add New Attribute button. Then, do the following:

Fixed Product Tax

a. In the Attribute Code field, specify a unique identifier for this attribute. Do not use
spaces or special characters. However, you can use hyphens or underscores. The
maximum length is 30 characters.

b. Set Scope to indicate where in your Magento installation the attribute will be
available.

c. Set Catalog Input Type for Store Owner to “Fixed Product Tax.”

d. Set Apply To to one of the following:

All Product Types Makes the FPT attribute available for all product types.

Selected Product Types If you select this option, select each product type in the
list that will use the attribute.

3. In the panel on the left, select Manage Label / Options. Then, enter a label to identify
the field. If you enter one label for the Admin, it will be used for the other views.

Manage Label / Options

4. When complete, click the Save Attribute button.

To learn more, see: Creating Attributes.

Step 3: Add the FPT Attribute to an Attribute Set

1. On the Admin menu, select Catalog > Attributes > Manage Attribute Sets.

2. Open the attribute set that needs the FPT attribute.
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3. Drag the FPT attribute from the list of Unassigned Attributes on the right to the Groups
list. The group folders correspond to sections in the Product Information panel. You can
place the attribute wherever you want it to appear.

Edit Attribute Set

4. When complete, click the Save Attribute Set button.

To learn more, see: Creating Attribute Sets.

Step 4: Apply the FPT to Products

1. On the Admin menu, select Catalog > Manage Products.

2. Find the product that needs the FPT and open it in edit mode.

3. In the product information, find the FPT field that you added to the attribute set. Then,
do the following:

Product Information with FPT Field



Fixed Product Tax Chapter 51:  Managing Taxes

4. Click the Add Tax button. Then, do the following:

a. Select the Country/State where the FPT applies.

b. Enter the amount in the Tax field.

c. To add more FPT taxes, click the Add Tax button and repeat the process.

5. When complete, click the Save button.

Field Descriptions
Field Scope Description

Enable FPT Website Determines if FPT is available. Options include:
Yes / No

Display Prices in Product
Lists

Website Controls the display of FPT in product lists.
Options include:
Including FPT only
Including FPT and FPT description
Excluding FPT, FPT description, final price
Excluding FPT

Display Price On Product
view Page

Website Controls the display of FPT on the product page.
Options include:
Including FPT only
Including FPT and FPT description
Excluding FPT, FPT description, final price
Excluding FPT

Display Prices in Sales
Modules

Website Controls the display of FPT in the shopping cart
and during checkout. Options include:
Including FPT only
Including FPT and FPT description
Excluding FPT, FPT description, final price
Excluding FPT

Display Prices in Emails Website Controls the display of FPT in email. Options
include:
Including FPT only
Including FPT and FPT description
Excluding FPT, FPT description, final price
Excluding FPT

Apply Discounts to FPT Website Determines if discounts can be applied to the
FPT amount. Options include: Yes / No

FPT Tax Configuration Website (Available in EE 1.13.1 and later) Determines how
FPT tax is calculated. Options include:
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Field Scope Description

Not Taxed Select this option if your taxing
jurisdiction does not tax FPT.
(For example,California.)

Taxed Select this option if your taxing
jurisdiction does tax FPT. (For
example, Canada.)

Loaded and
Displayed
with Tax

Click this option if FPT is added
to the order total before apply-
ing tax. (For example, EU coun-
tries.)

Include FPT in Subtotal Website Determines if FPT is included in the shopping
cart subtotal. Options include:

Yes Includes FPT in the shopping
cart subtotal.

No FPT is not included in the sub-
total, and is placed after the sub-
total in the shopping cart.

Be Careful Disclosing FPT Prices in Email

The manner in which you set the Display Prices in Sales Modules and Display Prices in
Email options can affect customer confidence in their orders. For example, if you choose
to display Order Review prices without showing FPT, customers who buy items with
associated FPT will see a total that includes the FPT tax amount, but they will not see
an itemized entry for the amount.

This might cause abandoned carts if your customers see an order total that does not
match what they expect, based on an itemized list of products in the order.

Compound Taxes
For compound taxes, the total cost of a product or service is taxed at one rate, and then
the total of that amount, including the first tax amount, is taxed a second time.
Compound tax is also known as stacked tax.

For example, in a regular tax calculation involving two tax rules, each rule is applied
separately to the product subtotal, and the taxes are added together to calculate the
total tax, which is then added to the product subtotal to calculate the grand total:
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$50.00
+   $50.00
$100.00

Product Price
Product Price
Subtotal

$5.00
+    $10.00

$15.00

Subtotal x 1st tax rate 5%
Subtotal x 2nd tax rate 20%
Total Taxes

$100.00
+   $15.00

$115.00

Subtotal
Total Taxes
Grand Total

Regular Two-Tax Calculation

With compound taxes, the first tax is added to the product subtotal, and the second tax
is applied to that total:

$50.00
+   $50.00
$100.00

Product Price
Product Price
Subtotal

$5.00
+    $10.50

$15.50

Subtotal x 1st tax rate 5%
[Subtotal + (Subtotal x 1st rate)] x 2nd tax rate: $105 x 10%
Total Taxes

$100.00
+   $15.50

$115.50

Subtotal
Total Taxes
Grand Total

Compound Tax Calculation

Setting Up Compound Taxes
Price rules with different priorities are used to set up a compound tax. If two tax rules
with the same priority apply then the taxes are added together. If two taxes with a
different priority apply then the taxes are compounded. When taxes are compounded,
the first priority tax is calculated on the subtotal amount, and then the second priority
tax is calculated on the subtotal plus the first priority tax amount. Lower numbers have
higher priority.

Important: In order for compound taxes to work correctly do not select the Calculate off
subtotal only check box when you set up your tax rules that apply to compound taxes.
This check box overrides the compounding calculation and cannot be used in
conjunction with compound taxes.
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To set up compound taxes:

1. Complete the setup of all tax rates to be used in the compound tax rule. See: Tax Zones
& Rates.

2. Set up the first tax rule for compounding. For the first tax rule, be sure that you set a
higher priority than you will set for the next tax rule, which will be compounded on top
of this first tax rule. Lower numbers are used for higher priority. Use 0 for the highest
priority. See: Tax Rules.

3. Set up the second tax rule for compounding. For the second rule, be sure that you set a
lower priority (use a higher number) than you set for the first tax rule.
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Chapter 52:

Value Added Tax (VAT)
Some countries charge a value added tax, or VAT, on goods and services. There can
be different VAT rates depending on which stage you as a merchant are at in the
manufacture or distribution of the products, materials, or services that you sell to
your customers. In this case you may need to use more than one VAT rate in your
store for tax calculation purposes.

This section provides a sample procedure for setting up a 20% VAT in the U.K. for
sales to retail customers. For other tax rates and countries, follow the general
procedure but enter specific information that corresponds to your country, VAT rate,
customer types, and so on.

Before proceeding, make sure to find out which rules and regulations apply to VAT
in your area.

In certain business-to-business transactions, VAT is not assessed. Magento can
validate a customer’s VAT ID to ensure that VAT is assessed (or not assessed)
properly. To learn more, see: VAT Validation.

Process Overview:
Step 1: Set Up Customer Tax Classes
Step 2: Set Up Product Tax Classes
Step 3: Set Up Tax Zones and Rates
Step 4: Set Up Tax Rules
Step 5: Apply Tax Classes to Products

Step 1: Set Up Customer Tax Classes

1. On the Admin menu, select Sales > Tax > Customer Tax Classes.

2. Ensure that there is a customer tax class that is appropriate to use with the VAT.
For this example, ensure that there is a customer tax class named Retail Customer.
If Retail Customer does not exist, click the Add New button and add it.
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Step 2: Set Up Product Tax Classes

1. On the Admin menu, select Sales > Tax > Product Tax Classes.

2. Click the Add New button and create three new classes:

l VAT Standard

l VAT Reduced

l VAT Zero

3. Click the Save Class button for each new class that you add.

Step 3: Set Up Tax Zones and Rates

1. On the Admin menu, select Sales > Tax > Manage Tax Zones & Rates.

For this example you can remove the U.S. tax rates, or leave them as they are.

2. Click the Add New Tax Rate button. Add new rates as follows:

New Tax Rate Settings

VAT Standard Tax Identifier: VAT Standard

Country and State: United Kingdom

Rate Percent: 20.00

VAT Reduced Tax Identifier: VAT Reduced

Country and State: United Kingdom

Rate Percent: 5.00

3. Click the Save Rate button for each rate.

Step 4: Set Up Tax Rules

A tax rule is a combination of a customer tax class, a product tax class, and a tax rate.

1. On the Admin menu, select Sales > Tax > Manage Tax Rules.

2. Add new tax rules as follows:

New Tax Rule Settings

VAT Standard Name: VAT Standard
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New Tax Rule Settings

Customer Tax Class: Retail Customer

Product Tax Class: VAT Standard

Tax Rate: VAT Standard Rate

VAT Reduced Name: VAT Reduced

Customer Tax Class: Retail Customer

Product Tax Class: VAT Reduced

Tax Rate: VAT Reduced Rate

3. Click the Save Rule button for each rate.

Step 5: Apply Tax Classes to Products

1. On the Admin menu, select Catalog > Manage Products.

2. Open a product from your catalog in edit mode.

3. On the General page, find the Tax Class field. Then, select the VAT Class that applies to
the product.

4. When complete, click the Save button.

VAT ID Validation
All editions of Magento include value-added tax (VAT) ID validation. VAT ID Validation
is intended for B2B merchants from the European Union (EU), where VAT is charged if a
merchant and a customer are in the same country, and VAT is not charged if a merchant
and a customer are in different countries within EU and both parties are EU-registered
business entities. If enabled, you can override it for a certain customer by selecting the
correspondent checkbox on the Customer Information page.

VAT identification number (VAT ID) Validation enables store administrators to create
more than one default customer group, which will be automatically assigned to each
customer during account creation, address creation or update, and checkout according
to the customer’s VAT ID, and the customer’s and merchant’s location countries. This
feature enables merchants to create different tax rules for intra-country (domestic) and
intra-EU sales, and to apply the corresponding VAT amount automatically.

VAT-related tax rules do not influence other tax rules and do not prevent applying other
tax rules where applicable. Only one tax rule can be applied at a given time.
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Magento performs VAT ID validation using the web-services of the European
Commission server.

Setting Up VAT ID Validation

Process Overview:
Step 1: Create the VAT-Related Customer Groups
Step 2: Create the VAT-Related Classes, Rates and Rules
Step 3: Enable and Configure VAT ID Validation
Step 4: Set your VAT ID and Location Country
Step 5: Verify the List of EU Member Countries

Step 1: Create the VAT-Related Customer Groups

VAT ID Validation automatically assigns one of the four default customer groups to
customers according to VAT ID validation results:

l Domestic

l Intra-EU

l Invalid VAT ID

l Validation error.

You can create new customer groups to be used in the VAT ID Validation functionality
or use existing groups, if they comply with your business logic. Customer groups are
created under Customers > Customer Groups.

When configuring the VAT ID Validation functionality, you will need to assign each of
the created customer groups as a default for customers with appropriate VAT ID
validation results. For details see the Enabling and Configuring the VAT ID Validation
Functionality section further.

Step 2: Create the VAT-Related Classes, Rates, and Rules

The VAT ID Validation functionality was implemented to facilitate the VAT applying for
EU B2B merchants. In Magento, taxes are applied using the tax rules mechanism. Each
tax rule is defined be three entities:

l Customer Tax Classes

l Product Tax Classes

l Tax Rates

To use the VAT ID Validation functionality effectively, you need to create the
appropriate tax rules.
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l All tax rule related entities, including tax rules, tax rates, product tax classes and
customer tax classes, are managed under Sales > Tax.

l Tax classes are assigned to customer groups under Customers > Customer Groups >
%customer group%.

Important! According to the EU taxation policy, the supply of services between
businesses (B2B services) is in principle taxed at the customer’s place of establishment.
If you sell downloadable or virtual products, which do not require shipping, the VAT
rate of a customer’s location country should be applied for both, intra-union and
domestic sales. This means that you additionally must create individual tax rules for a
product tax class that corresponds to the downloadable and virtual product types.

Minimal Tax Rules Required for VAT ID Validation
Tax Rule #1

Customer Tax Class n A class for domestic customers

n A class for customers with invalid VAT ID

n A class for customers, for whom VAT ID validation failed

Product Tax Class A class for products of all types, except bundle and virtual.

Tax Rate VAT rate of the merchant’s country.

Tax Rule #2

Customer Tax Class A class for intra-union customers.

Product Tax Class A class for products of all types, except downloadable and
virtual.

Tax Rate VAT rates for all EU countries, except merchant’s country. Cur-
rently this rate is 0%.

Tax Rule #3

(Required only if you sell bundle or virtual products.)

Customer Tax Class n A class for domestic customers

n A class for customers with invalid VAT ID

n A class for customers, for whom VAT ID validation failed

Product Tax Class A class for downloadable and virtual products.

Tax Rate VAT rate of the merchant’s country.

http://ec.europa.eu/taxation_customs/taxation/vat/how_vat_works/vat_on_services/index_en.htm
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Tax Rule #4

(Required only if you sell bundle or virtual products.)

Customer Tax Class A class for intra-union customers.

Product Tax Class A class for downloadable and virtual products.

Tax Rate VAT rates for all EU countries, except merchant’s country. Cur-
rently this rate is 0%.

It is recommended that you apply the merchant’s VAT rate for customers with invalid
VAT IDs, and those for whom validation fails. You can create other tax rules and apply
other tax rates according to your business logic.

Step 3: Enable and Configure VAT ID Validation

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Customers, select Customer Configuration.

3. Set Current Configuration Scope to “Default Config,” or the applicable store view.

4. Click to expand the Create New Account Options section.

5. Set Enable Automatic Assignment to Customer Group to “Yes.” Then complete the
fields as described below.

6. When complete, click the Save Config button.

Create New Account Options
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Field Descriptions
Field Scope Description

Enable Automatic Assign-
ment to Customer Group

Store View Determines if customers are automatically
assigned to the default customer group. To
show VAT number in the store, set Show VAT
Number in the storefront, select “Yes.” Options
include:

Yes The system does not auto-
matically validate customer VAT
IDs nor does it change cus-
tomer groups.

No The system behavior is as
usual, and the default customer
group can be set in the Default
Group field.

Tax Calculation Based
On

Store View Choose whether VAT calculation will be based
on customer's shipping or billing address. If the
customer does not have a shipping address
(that is, the customer has only now registered
and the system does not yet take into account
the customer's shipping address), the Default
Tax Destination Calculation address is used for
tax calculations that appear to the customer.
Options include:

Billing
Address

Calculates VAT based on the
customer billing address.

Shipping
Address

Calculates VAT based on the
cusotmer shipping address.

Important! If the Tax Calculation Based On
shipping address, and a customer
purchases only downloadable or virtual
products, Magento will use the billing
address for VAT calculation.

Default Group Store View Identifies the default customer group.

Group for Valid VAT ID -
Domestic

Store View Determines the customer group that is auto-
matically assigned to customers from your
country who have a valid VAT ID.

Group for Valid VAT ID -
Intra-Union

Store View Determines the customer group that is auto-
matically assigned to customers from other
EU countries who have a valid VAT ID.
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Field Scope Description

Group for Invalid VAT ID Store View Determines the customer group that is auto-
matically assigned to customers who have an
invalid VAT ID.

Validation Error Group Store View Determines the customer group that is auto-
matically assigned to customers who failed VAT
ID validation.

Validate on Each Trans-
action

Store View Choose whether VAT ID validation will be per-
formed each time during order creation even if
a previously saved customer address with val-
idated VAT ID is used. The option applies to one-
page checkout in the storefront, only. If a new
customer address is used (including guest check-
out or if a customer has no address assigned to
their account), then the validation is performed
irrespective of this setting. During order creation
in the Admin, no automatic validations are per-
formed. Options include: Yes / No

Default Value for Disable
Automatic Group
Changes Based on
VAT ID

Global (Available only if Current Configuration Scope is
set to “Default Group.”) Choose whether the
automatic change of customer group based on
VAT ID will be enabled or disabled by default.
The setting can be overridden on the product
level. The setting influences the system behavior
in the following situations:

n The VAT ID of the customer’s default
address or the whole default address
changes.

n Customer group change was emulated
during the checkout for a registered
customer who had no previously saved
address or for a customer, who registered
during the checkout.

If the automatic group change is enabled, then
in the first case the customer group changes
automatically, and in the second case the tem-
porarily emulated customer group is assigned
to customer.
If the automatic group change is disabled, the
customer group that is assigned never changes,
unless an administrator changes it manually.

Show VAT Number on Website Determines if the VAT number is visible to cus-
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Field Scope Description

Frontend tomers in the store. Options include: Yes / No

Default Email Domain Store View Identifies the default email domain.

Default Welcome Email Store View Identifies the email template used for the
default Welcome email.

Email Sender Store View Identifies the store identity that appears as the
sender of the Welcome email.

Require Emails Con-
firmation

Website Determines if email messages require con-
firmation. Options include: Yes / No

Confirmation Link Email Store View Identifies the email template used for the con-
firmation email.

Welcome Email Store View Identifies the template used for the Welcome
email that is sent after the account is confirmed.

Generate Human-
Friendly Customer ID

Global Choose whether the field for entering and
storing the VAT ID number will be visible in the
frontend. Options include: Yes / No

Step 4: Set Your VAT ID and Location Country

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under General, select General.

3. Set Current Configuration Scope to the applicable store view.

4. Click to expand the Store Information section. Then, do the following:

Store Information
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a. Select your Country.

b. Enter your VAT Number. Then, click the Validate VAT Number button. The result
appears immediately.

If your VAT number is valid, then apart from validation result for each customer’s
VAT ID validation, the validation server will send to Magento the following additional
information: VAT request identifier and VAT request date. If a customer’s VAT
validation is performed during checkout, then the VAT request identifier and VAT
request date are saved in the Comments History section of the Order View page
under Sales > Orders > (select appropriate order).

5. When complete, click the Save Config button.

Step 5: Verify the List of EU Member Countries

1. On the Admin menu, select System > Configuration.

2. Set Current Configuration Scope to the applicable store view.

3. Click to expand the Countries Options section.

Countries Options

4. In the European Union Countries list, verify that each member country of the EU is
selected.

5. When complete, click the Save Config button.
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VAT Validation Customer Workflow

During Registration

If VAT ID Validation is enabled, after registration each customer is proposed to enter the
VAT ID number. However only those who are registered VAT customers are expected to
fill this field.

After a customer specifies the VAT number and other address fields, and chooses to save,
the system saves the address and sends the VAT ID validation request to the European
Commission server. According to the results of the validation, one of the default groups
is assigned to a customer. This group can be changed if a customer or an administrator
changes the VAT ID of the default address or changes the whole default address. And
the group can be temporarily changed (group change will be emulated) in some cases
during one-page checkout.

During Checkout

The system behavior concerned with the VAT ID validation and the customer group
change during the checkout depends on how the Validate on Each Transaction and the
Disable Automatic Group Change settings are configured. This section describes the
implementation of the VAT ID Validation functionality for the checkout on the frontend.

In case a customer uses Google Express Checkout, PayPal Express Checkout or another
external checkout method, when the checkout is performed completely on the side of the
external payment gateway, the Validate on Each Transaction setting cannot be applied.
Thus the customer group cannot change during checkout. The following inllustration
shows the flow of VAT ID validation and customer group change during one-page
checkout.
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One-Page Checkout with VAT ID Validation

Managing VAT Validation

VAT Number Customer Address Attribute

Customer VAT ID value is stored in the vat_id customer address attribute. The default
label of this attribute is VAT number. Customer address attributes are managed under
Customers > Attributes > Manage Customer Address Attributes.

The VAT number field is always present in all shipping and billing customer addresses
in the backend. It is not mandatory. Displaying the field in the frontend is configured in
the Show VAT Number in Frontend field under System > Configuration > Customers >
Customer Configuration > Create New Account Options.
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For customers not from the EU countries, consider storing the VAT number (if any), in
the existing Tax/VAT Number customer attribute to avoid any possibility of customer
group change (whether persistent or emulation during checkout). It is recommended
that you rename the Tax/VAT Number customer attribute to avoid confusion with the
new VAT Number customer address attribute that is used for the VAT ID Validation
functionality.

Disable Automatic Customer Group Change

When the VAT ID Validation functionality is enabled, the group of a customer can only
be changed manually in the Admin Panel, no automatic changes of customer group can
take place.

When the VAT ID Validation functionality is enabled, the system will automatically,
permanently change a customer group in the following situations:

l The VAT ID of the customer’s default address or the whole default address changes.

l The customer group change was emulated during the checkout for a registered
customer who had no previously saved address, or a customer who registered during
the checkout.

The automatic customer group change can be disabled by selecting the Disable
automatic group change checkbox on the customer’s page under Customers > Manage
Customers > %customer% > Account Information.

Disabling Automatic Group Change on Customer Level

Important! The setting does not influence the emulation of the customer group
change during checkout.

The default value of the Disable automatic group change checkbox is set in the Default
Value for Disable Automatic Group Changes Based on VAT ID field under System >
Configuration > CUSTOMERS > Customer Configuration > Create New Account
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Options. The configuration setting is made on the global level. The default value applies
to new customers and to customers whose records are available in the system when the
VAT ID Validation functionality is enabled for the first time.

VAT ID Validation in Customer Accounts

When an administrator adds a new default address with a VAT ID to the account of a
new or existing customer or changes the VAT ID of the existing default address, the
system validates the VAT ID and assigns the appropriate customer group to the
customer. The validation is performed after the Save or Save and Continue button is
clicked.

The system behavior is as described when the VAT ID Validation functionality is enabled
and configured.

If you want to disable the automatic change of a customer group, select the Disable
automatic group change check box on the Account Information tab of the Customer
Information page.

VAT ID Validation When Creating an Order

During order creation in the Admin Panel no VAT ID validation is performed
automatically. To validate the VAT ID of the customer address, an administrator needs
to click the Validate VAT Number button in the Billing Address or Shipping Address
section of the Create New Order page.

Validating Customer VAT ID at Order Creation

After the validation, the administrator receives a notification about the validation results
in the form of a pop-up message.

A customer group, which should be assigned to a customer according to the validation
results, can differ from the customer group that is currently assigned to the customer. In
this case the system displays a dialog box suggesting that the administrator confirm or
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reject the group change emulation for the customer’s current order. If the administrator
confirms, then the group change is emulated for the current order and the corresponding
VAT rate is applied (if the corresponding tax rule is configured in the system). The
actual customer group of a customer is not changed.

If a new customer account is added when an order is created, and an administrator
confirms the customer group that corresponds to the VAT ID validation results, after the
order is created, the customer account is saved in the system, and the customer group
that was used to create the order is assigned to the customer.
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Chapter 53:

Managing Email Templates
Magento includes a set of default email templates that are associated with a variety
of events that take place during the operation of your store, such as:

l Invoiced order

l Account change

l Newsletter subscription

l Abandoned shopping cart

l Product back in stock

These messages are referred to as “transactional emails” because they are triggered by
an event and sent automatically. Each message is based on an HTML template that
can be edited as needed, using the Transactional Emails tool.

Transactional Emails

Uploading Your Email Logo
The email logo appears at the top of automated email messages that are sent to
customers. These are referred to as “transactional emails” and are based on
templates that can be customized to suit your needs.

Transactional Emails
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To upload your email logo:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Design, select Transactional Emails.

3. Click the Choose File button and select the Logo Image from your computer.

The size of the logo image file cannot exceed 2 MB.

4. In the Logo Image Alt field, type the alt text you want to use for the image.

5. When complete, click the Save Config button to upload the image. Any previous logo
image file is overwritten.

Field Descriptions
Field Description

Logo Image Choose a file to use as the logo. Allowed file types are jpg, gif,
png. File size cannot exceed 2 MB.

Logo Image Alt Enter alternative text to appear if the logo image is not avail-
able.

Customizing Email Templates
Email templates are formatted with HTML and CSS, and can be easily edited. In
addition, you can further customize the template by adding variables and widgets.

Many of the default email templates contain placeholder information that should be
changed before any transactional email messages are sent to customers. When the
template is ready to be used, make sure to update your system configuration, so the
updated template will be used instead of the previous version.

Step 1: Choose a Default Template

1. On the Admin menu, select System > Transactional Emails.

2. Click the Add New Template button.

3. In the Template list, select a default template from the list of predefined templates.

Load Default Template

4. If necessary, set the Locale to the store language.
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5. Click the Load Template button.

Template Information

The path to the configuration settings for each default template appears at the
top of the Template Information section. Make note of this “Used as Default for”
path, because you will later need to update the configuration with the name of
the new template.

Step 2: Customize the Content

1. In the Template Information section, do the following:

a. Enter a Template Name for the new email template.

b. In the Template Subject field, type the text to appear in the Subject header of the
message.

c. Complete the Template Content as needed.

2. (Optional) To insert a variable, do the following:

a. Position the cursor in the text where you want the variable to appear.

b. Click the Insert Variable button.

c. In the list of available predefined variables, click the variable you want to insert into
the template.
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Insert Variable

3. When complete, click the Save Template button.

4. Make sure to Preview the template before associating it with a transactional email
message that is sent to customers.

Step 3: Update Your Configuration

Before the template can be used, the configuration must be updated with the name of
the new template. Refer to the path that you recorded in Step 1 when updating your
configuration with the name of the new template.

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Sales Emails.

To learn more, see: Configuring Email Templates.

Email Template Variables
Predefined Variables

Store Contact Information
Base Unsecure URL
Base Secure URL
General Contact Name
General Contact Email
Sales Representative Contact Name
Sale Representative Contact Email
Custom 1 Contact Name
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Predefined Variables

Custom 1 Contact Email
Custom 2 Contact Name
Custom 2 Contact Email
Store Name
Store Contact Telephone
Store Contact Address

Template Variables
Store Url
Emali Logo Image Url
Customer Name
Customer Account Url
Customer Email
Customer Password

Email Template Configuration
Email templates contain the content and formatting for automated messages that area
sent from your store. These messages are called transactional emails because each one is
associated with a specific type of transaction or event.

Your store has a set of default templates that you can customize. After creating a
customized version of a template, remember to update your system configuration so the
correct template is used for the message.

Sales Email Configuration

To configure sales email templates:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Sales Emails. Then, select the appropriate
templates for each of the following sections:
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l Order and Order Comments

l Invoice and Invoice Comments

l Shipment and Shipment Comments

l Credit Memo and Credit Memo Comments

Order Email Configuration

3. When complete, click the Save Config button.

To configure customer email templates:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Customer, select Customer Configuration. Then, select
the appropriate templates for the following sections:

l Create New Account Options

l Password Options

Password Options

3. When complete, click the Save Config button.
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Chapter 54:

Managing Data Transfer
The Import/Export tool gives you the ability to manage multiple customer and
product records in a single operation. If you have a large catalog of products, you
will find it much easier to export the data, edit the data in a spreadsheet, and then
import the data back into your store.

The CSV file format separates each data element by a comma, and is used as the
standard for data exchange operations. All spreadsheet and database applications
support the CSV file format. If you are working with a Mac, you should save the
data in the CSV (Windows) format.

Working with CSV Files
In order to import a CSV file into Magento, it must have certain characteristics.
Specifically, each column heading must exactly match the Attribute Code for the
attribute in that column.

To ensure that a CSV file’s column headings can be read by Magento, first export a
product CSV file. You can then edit the file (by adding or updating rows) and re-
import it.

For the Category column, specify product category as text, based on a category’s
path, with a slash (/) between each category level. For example: Furniture/Living
Room. Do not include the Root Category in the path.

Product CSV Structure
The imported or exported catalog products CSV file contains information about
products and relations between them. The table has the following structure:
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Exported Product CSV in Excel

The first row of the table contains the names of the columns, there are two types of the
names, as shown in the following table. Other rows contain attributes values, service
data, and complex data. If a row contains the value in the SKU column, then this row
the rows below it describe the product. Each new SKU value begins the description of the
next product.

In the import procedure, if a row that contains the SKU value is invalid, then this row,
and all other rows with data for that product cannot be imported.

The minimal valid table contains only the SKU column. It can be used to delete entries
from the database. There is no limit to the number of the columns in the table. Columns
that do not contain data will be ignored.

Exported Product CSV in Notepad

CSV Product Structure
Column Name Description

_<name> The names of the service columns and complex data
columns. Service columns contain entity properties, which are
not attributes. For example, columns with website or product
type information are service columns. The underscore as first
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Column Name Description

character is used to distinguish these columns from the attrib-
ute column names.

<attribute name> The names of the columns with values of both system-created
attributes and attributes created by the store administrator.

Customer CSV Structure
The imported or exported customers CSV file contains the table with information about
customers. The table has the following structure:

Exported Customer CSV in Excel

The first row of the table contains the names of the attribute columns (which are the
same as attribute codes). There are two types of column names, as shown in the
following table. Other rows contain attribute values, service data, and complex data.
Each row with non-empty values in the “email” and “_website” columns starts the
description of the subsequent customer. Each row can represent customer data with or
without address data, or the address data only. In case a row contains only the address
data, values in the columns, related to the customer profile, will be ignored and may be
empty.

To add or replace more than one address for a customer, in the import file add a row for
each new address with empty customer data and the new or updated address data below
the customer data row.

Exported Customer CSV in Notepad

CSV Customer Structure
Column Name Description

_<name> The names of the service columns, and complex data
columns. Service columns contain entity properties, which are
not attributes. For example, columns with website or store
information are service columns. The underscore as first char-
acter is used to distinguish these columns from the other
attributes names.
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Column Name Description

The “_address_default_billing” and the “_address_default_ship-
ping” columns are the default billing and shipping addresses
flags. If the address in the row is the default billing and/or ship-
ping address of the client, the “_address_default_billing”
and/or “_address_default_shipping” columns in this row will
have the “1” value.

<attribute name> The names of the columns with values of both system-created
attributes, and attributes created by the store administrator.

Importing Data
Importing is available for all product types, except bundle and downloadable products.
You can import customer data, product data, and product images.

To import customer or product data:

1. On the Admin menu, select System > Import/Export > Import. Then, do the following:

Import Settings

a. Set Entity Type to one of the following:

l Products

l Customers

b. Set Import Behavior to the way you want complex data to be managed if imported
records already exist in the database.

l Complex data for products includes categories, websites, custom options, tier
prices, related products, up-sells, cross-sells, and associated products data.

l Complex data for customers includes addresses.

Choose one of the following options:

Append Complex Data The new complex data will be added to the existing
complex data for the existing entries in the database.

Replace Existing
Complex Data

The existing complex data for the existing entities will be
replaced.

Delete Entities If entities that are imported already exist in the
database, they will be deleted from the database.
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c. At the Select File to Import field, click the Choose File button. Then, select the CSV
file that you have prepared for import.

2. Click the Check Data button in the upper-right corner of the page. The system validates
the file. If the file is valid, the corresponding message and the Import button appear. If
some of the rows in the imported file are not valid and cannot be imported, the
corresponding information is included to the message, but you can proceed with
importing. The invalid rows will be skipped.

3. If needed, make corrections to the CSV file.

4. Click the Import button to import the data into the database.

File Validation
File validation includes the following:

1. All attribute values are checked for conformance with the required data type (decimal,
integer, varchar, text, datetime).

2. The complex data, service data. and attributes whose values must be from a defined set
(such as a drop-down or multiple select input type), are checked to ensure their values
exist in the defined sets.

3. For new entities, the presence of the required attributes values in the file is checked. For
existing entities, the presence of the required attributes values is not checked, but if a
required value is specified, it is validated by the attribute type.

The “Required” option of the attributes is set in the Magento Admin Panel. To access the
attribute management section, select Catalog > Attributes > Manage Attributes.

Importing Product Images
Multiple product images of each type can be imported into Magento, and associated
with the correct product. Review the steps below, and run through the process with a
few products. After you understand how it works, you’ll feel confident to import large
quantities of images.

To import product images:

1. Place the image files that you need to import in the subfolders in the %path_to_your
Magento_instance%/media/import folder. Subfolders for the files should be created
according to the following logic: Name the first folder using the first symbol of the file
name, and then create a subfolder and name it using the second symbol of the file name.

For example: for importing filename.jpg the path to the file will be the following:
%path_to_your_Magento_instance%/media/import/f/i/filename.jpg
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Set the RE0777 permissions for the folders, and at least 0666 permissions for the image
files.

2. In the import CSV file, specify the relative path to the image file (For example,
/f/i/filename.jpg). The following columns correspond to product images:

l image

l small_image

l media_image

3. Perform the import in the same manner as you would import product data.

Important! Do not use upper-case characters in the file names of image files to be
imported.

Import Guidelines
For entities that are new and do not exist in the database:

l The entities are added with the attribute values specified in the CSV file.

l If there is no value, or there is a non-valid value, for a required attribute with no
default value set, then the entity (the corresponding row or rows) cannot be imported.

l If there is no value, or there is a non-valid value, for a required attribute with the
default value set, then the entity (the corresponding row or rows) is imported, and
the default value is set for the attribute.

l If the complex data is not valid, then the entity (the corresponding row or rows)
cannot be imported.

For entities that already exist in the database:

l For attributes that are not complex data, the values from the import file, including
the empty values for the non-required attributes, replace the existing values.

l If there is no value, or there is a non-valid value, for a required attribute, then the
existing value is not replaced.

l If the complex data for the entity is invalid, the entity (the corresponding row or
rows) cannot be imported, except the case, when Delete Entities was selected in the
Import Behavior drop-down menu.

The way complex data is handled depends on the Import Behavior.

l For both new and existing entities, if an attribute, specified in the import file, exists
in the system, and its values are taken from the defined set of values, but the value,
specified in the import file does not exist in the defined set, the row is imported and
the default value, if it is defined, is set for this attribute. Otherwise the corresponding
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row cannot be imported.

l If an attribute name is specified in the import file but has not been defined in the
system, it is not created in the system, and its values are not imported.

The file is invalid and cannot be imported if:

l All rows in the file are invalid

l A non-existing service data or complex data name is specified in the import file (that
is, there is a column with a “_<non-existing name>” heading)

Exporting Data
The best way to become familiar with the structure of your database is to export the data
and open it in a spreadsheet. Once you become familiar with the process, you’ll find that
it is an efficient way to manage large amounts of information.

All product types can be exported except gift cards.

To export customer or product data:

1. On the Admin menu, select System > Import/Export > Export.

2. In the Export Settings section, specify the following:

Export Settings

a. Set Entity Type to one of the following:

l Customers

l Products

b. Accept the default Export File Format of “CSV.”

3. In the Entity Attributes section, you can include or exclude data to be exported
according to the entity attribute values.

l To include records with specific attribute values, set the required values of the
attributes in the Filter column.

l To omit an attribute from the export, select the Skip checkbox at the beginning of the
row.
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Export Customers Based on Attribute Value

4. Scroll down and click the Continue button in the lower-right corner of the page. Look for
the download prompt in the lower-right corner of your browser.

The CSV file that is generated can be edited and imported back into your store. Or, it can
be used for mailing or other application.
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Chapter 55:

Reports
Magento Community Edition provides a wide selection of reports to keep you
current on everything from the contents of your customers’ shopping carts to the
tags they use. Report data can be viewed online or downloaded as a CSV or XML
data file. The main types of reports are:

l Sales

l Shopping Cart

l Products

l Customers

l Tags

l Reviews

l Search Terms

Dashboard
The dashboard is usually the first page that appears when you log in to the Admin,
and gives an overview of sales and customer activity.

The blocks on the left provide a snapshot of lifetime sales, average order amount, the
last five orders, and search terms. The graph depicts the orders and amounts for the
selected date range. You can use the tabs above the graph to toggle between the two
views.
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Dashboard

Snapshot Reports
The tabs at the bottom provide quick reports about your best-selling and most viewed
products, new customers and those who have purchased the most.

Bestsellers

Lists your best-selling products, showing the price and quantity ordered.

Most Viewed Products

Lists the most recently viewed products and the number of times viewed.

New Customers

Lists recently registered customers.

Customers

Lists the customers who have ordered the most during the specified range of time.

To set the date range:

Set Select Range to one of the following:

l Last 24 Hours

l Last 7 Days
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l Current Month

l YTD

l 2YTD

Dashboard Configuration
By default, the dashboard is the startup page for the Admin. However, if you prefer, you
can change the configuration to display a different page when you log in. You can also
set the starting dates used in dashboard reports, and disable the display of the charts
section.

To set the starting dates:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under General, select Reports.

3. Click to expand the Dashboard section, do the following:

a. Set Year-To-Date Starts to the month and year that the current year began.

b. Set Current Month Starts to the current month.

Dashboard

To change the Admin startup page:

1. On the Admin menu, select System > Configuration. Then in the panel on the left,
under Advanced, select Admin.

2. In the Admin UI section, set Startup Page to the page you want to first appear when
you log in to the Admin.

3. Click the Save Config button to save the setting.

Startup Page
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To turn off real-time data:

If you have a lot of data to process, the performance of the Dashboard can be improved
by turning off the display of real time data.

1. On the Admin menu, select System > Configuration. Then in the Configuration panel on
the left, under Sales, select Sales.

2. Click to expand the Dashboard section. Then, set Use Aggregated Data (beta) to “Yes.”

To disable charts:

1. On the Admin menu, select System > Configuration. Then in the Configuration panel on
the left, under Advanced, select Admin.

Turn Off Dashboard Charts

2. In the Dashboard section, set Enable Charts to “No.”

3. When complete, click the Save Config button.

A message on the Dashboard indicates that the chart is now disabled.

Running Reports
Magento provides a variety of reports that you can access at any time. To see the reports
that you can generate in Magento, from the Reports menu, select a type of report and
then select a specific report of that type. Some report pages have filter controls that
enable you to narrow the scope of the report.

When you are finished making filter selections, click Show Report (or Refresh, in some
reports) to generate the report.

Reports Menu

Orders Report
The Orders report includes real-time data, and can include orders of any status during a
specific period of time.

634 Magento Community Edition: User Guide



Chapter 55:  Reports Running Reports

635Magento Community Edition: User Guide

To run the Orders report:

1. On the Admin menu, select Reports > Sales > Orders. Then, do the following:

a. A message indicates the last time the report statistics were refreshed. If necessary,
click the link to refresh the statistics.

b. Set Show Report for to the website, store, or store view that you want to include in
the report.

c. Set Match Period To to one of the following:

l Order Created Date

l Order Updated Date

d. To determine how the report data is aggregated by row, set Period to one of the
following:

l Day

l Month

l Year

e. To include activity during a specfic period, click the calendar icon and select the
From and To dates.

f. Do one of the following:

l To include all orders, set Order Status to “Any.”

l To include only orders with a specific status, set Order Status to “Specified.”
Then, select each order status that you want to include in the report.

g. To omit any empty rows from the report, set Empty Rows to “No.”

h. To show actual, rather than projected values, set Show Actual Values to “Yes.”

2. When ready to run the report, click the Show Report button.
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Orders Report by Month

To export report data:

1. Set the Export to control to one of the following:

l CSV

l Excel XML

2. Click the Export button. Then, look for the download file in the lower-left corner of your
browser window.

Field Descriptions
Filter Control Description

Show Report For The Show Report For drop-down menu enables you to select
the store view or website (or all websites) to report on.

Match Period To The Match Period To drop-down menu enables you to select
which records to report on, based on either the order cre-
ation date or the order modified date.

Period The Period drop-down menu enables you to aggregate the
report data into rows for each day, month, or year within your
report From and To dates.

From and To Use the From and To calendar controls to determine the start
and end dates that will be covered by the report.

Order Status For Order Status, select Any to include all orders, or select Spe-
cified to select one or more order status values from a list.

Empty Rows The Empty Rows drop-down menu enables you to select
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Filter Control Description

whether to include date period rows that have no data.

Show Actual Values The Show Actual Values drop-down menu enables you to
select whether to display actual (Yes) or projected (No) values.
Projected values are based on estimates of amounts to be
paid.

Refreshing Sales Report Statistics
To reduce the performance impact of generating sales reports, Magento calculates and
stores the required statistics for each report. When you generate a report, the report uses
the stored statistics, rather than recalculating the statistics each time you generate a
report.

To include the most recent data, the sales report statistics must be refreshed. Refreshing
the sales report statistics is a manual process.

Report Statistics

To refresh sales report statistics:

1. On the Admin menu, select Reports > Refresh Statistics.

2. In the list, select the checkbox of each report that needs to be refreshed.

3. Set the Actions control to one of the following:

l Refresh Lifetime Statistics

l Refresh Statistics for the Last Day

4. When complete, click the Submit button.
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Available Reports
Report Description

Sales Reports

Total Ordered Reports > Sales > Orders
Shows orders for the specified time period.

Order Taxes Reports > Sales > Tax
Shows taxes charged for orders in the specified time period;
grouped by tax rate.

Total Invoiced vs. Paid Reports > Sales > Invoiced
Shows amounts paid and unpaid for invoiced orders in the
specified time period.

Total Shipped Reports > Sales > Shipping
Shows orders shipped in the specified time period, grouped
by carrier/method; includes shipping charge amounts.

Total Refunded Reports > Sales > Refunds
Shows refunds applied to orders in the specified time period.

Coupons Usage Reports > Sales > Coupons
Shows coupons used for orders in the specified time period,
grouped by coupon code.

PayPal Settlement Reports > Sales > PayPal Settlement Reports
Shows PayPal settlements for the specified time period. Click
Fetch Updates to retrieve data from PayPal.

Shopping Cart Reports

Products in Carts Reports > Shopping Cart > Products in carts
Shows products that are currently in shopping carts.

Abandoned Carts Reports > Shopping Cart > Abandoned Carts
Shows shopping carts that were started but then abandoned.
Enables you to contact customers to offer incentives to turn
an abandoned cart into a conversion.

Product Reports

Products Bestsellers Reports > Products > Bestsellers
Shows the products that were sold in the highest quantity in
the specified time period.

Products Ordered Reports > Products > Products Ordered
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Report Description

Shows all products that were ordered in the specified time
period.

Most Viewed Reports > Products > Most Viewed
Shows the products that were viewed the most times in the
specified time period.

Low Stock Reports > Products > Low Stock
Shows the products whose stock levels are low.

Downloads Reports > Products > Downloads
Shows the number of purchases and downloads for each
downloadable product.

Customer Reports

New Accounts Reports > Customers > New Accounts
Shows the new accounts that were created during the spe-
cified time period.

Customers by Orders
Total

Reports > Customers > Customers by orders total
Shows the customers listed in descending order of total order
amount.

Customers by Number
of Orders

Reports > Customers > Customers by number of orders
Shows the customers listed in descending order of number of
orders placed.

Tag Reports

Customers Tags Reports > Tags > Customers
Shows the customers listed with the number of tags each one
has created.

Products Tags Reports > Tags > Products
Shows the number of unique tags and total number of tags
created for each product.

Popular Tags Reports > Tags > Popular
Shows the number of times each tag has been applied.

Review Reports

Customers Reviews Reports > Reviews > Customers Reviews
Shows the customers listed in descending order of number of
reviews contributed.

Products Reviews Reports > Reviews > Products Reviews
Shows the products listed in descending order of number of
reviews.
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Report Description

Search Term Report

Search Terms Reports > Search Terms
Shows terms submitted with the search tool.If Hits are high,
but the Results are low, you should review product names
and descriptions so you can promote products related to the
term.
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Chapter 56:

Admin Permissions
Magento uses roles and permissions to create different levels of access to the Admin.
When your store is first set up, you receive a set of login credentials for the
Administrator role, with full permissions. However, you can restrict the level of
permissions on a “need to know” basis for other people who work on your site. For
example, a designer can be given access to only the Design tools, but not to areas
with customer and order information.

Creating New Users
When your store is first installed, your login credentials have with full
administrative access. As a best practice, one of the first things you should do is to
create another user account with full Administrator permissions. That way, you can
use one account for your everyday Administrative activities, and reserve the other as
a “Super Admin” account in case you forget your regular credentials or they
somehow become otherwise unusable.

If there are others on your team, or service providers who need access, you can create
a separate user account for each, and assign a restricted role. To limit the websites or
stores that admin users can access when they log in, you must first create a role
with limited scope and resources. Then, you can assign the role to a specific user
account. Admin users assigned to a restricted role can see and change data only for
websites or stores that are associated with the role. They cannot change any global
settings or data.

Step 1: Create a New User

1. On the Admin menu, select System > Permissions > Users.

2. Click the Add New User button.

3. In the Account Information section, do the following:
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Account Information

a. Enter the User Name for account.

The User Name should be easy to remember. It is not case-sensitive. For example, if
your user name is “John,” you can also log in as “john.”

b. Complete the following information:

l First Name

l Last Name

l Email address

This email address must be different from the one that is associated with your
original Admin account.

c. Assign a Password to the account.

The password should be seven or more characters long, and include both letters and
numbers.

d. In the Password Confirmation box, repeat the password to make sure it was
entered correctly.

4. Set This Account is to “Active.”

Step 2: Define the Role

1. In the User Information panel on the left, click User Role. Then, in the list of Roles,
select Administrators. (Initially, it will be the only role available.)

Add New User Role

2. When complete, click the Save User button.

You now have two accounts with Administrator access.
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Creating Custom Roles
To give someone restricted access, the first step is to create a role with the appropriate
level of permissions. After the role is created, you will add the new user, set up the login
credentials, and assign the role to the user account. After the role is established, you can
create new Administrator users at any time, and assign the restricted role to grant
limited access to the user.

Role Resources

Step 1: Define the Role

1. On the Admin menu, select System > Permissions > Roles. Then in the upper-left
corner, click the Add New Role button.

2. In the Role Information section, enter a descriptive Role Name.

Role Name

3. In the panel on the left, select Role Resources.

4. In the Roles Resources section, select the checkbox of each Admin Resource that you
want to grant those with the role permission to access.
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Important! Be sure to disable access to the Permissions tool if you are limiting
access for a given role. Otherwise, users with this role will be able to modify their
own restrictions.

Role Resources, Collapsed View

5. (Optional) In the panel on the left, select Role Users. Then, assign additional
Administrator user accounts to the new role.

6. When complete, click the Save Role button. The role now appears in the list of available
roles

Step 2: Add the New User

1. On the Admin menu, select System > Permissions > Users.

2. Click the Add New User button.

3. In the Account Information section, do the following:

Account Information

a. Assign a User Name to the account.

The User Name should be easy to remember. It is not case-sensitive. For example, if
your user name is “john,” you can also log in as “John.”

b. Complete the following information:

l First Name

l Last Name

l Email address
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c. Assign a Password to the account.

The password should be at least seven characters long, and include letters and
numbers.

d. In the Password Confirmation field, type the password again to make sure it was
entered correctly.

e. Set This Account is to “Active.”

4. In the User Information panel on the left, click User Role. Then, in the list of Roles,
select the option for the role you want to assign to the new user.

New User Role

5. When complete, click the Save User button.
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Chapter 57:

Security
In this chapter, you will learn how to manage Admin sessions and credentials,
implement CAPTCHA, and manage website restrictions.

Security Configuration
The security settings give you the ability to control the lifetime of user sessions, and
whether to allow your Magento store to run in a frame. (This setting can prevent
clickjacking.) In addition you can add a secret key to URLs, and determine the case
sensitivity of login credentials.

For security reasons Magento strongly recommends against running your store in a
frame.

Security

To configure Admin security:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Advanced, select Admin.

3. Click to expand the Security section, and complete the settings as needed.

4. When complete, click the Save Config button.

https://www.owasp.org/index.php/Clickjacking
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Field Descriptions
Field Scope Description

Login Is Case Sensitive Global Options include: Yes / No

Add Secret Key to URLs Global Options include: Yes / No

Session Lifetime
(seconds)

Global Determines the length of a user session in
seconds.

Allow Magento Backend
to run in frame

Global This option prevents “clickjacking” if you run
your store in an iframe. Enabling the option
causes the X-Frame-Options response
header to be sent. Options
include: Enabled/Only from same domain.

For security reasons, it is recommended that
this setting not be enabled.

Allow Magento Frontend
to run in frame

Global This option prevents “clickjacking” if you run
your store in an iframe. Enabling the option
causes the X-Frame-Options response
header to be sent. Options
include: Enabled/Only from same domain.

For security reasons, it is recommended that
this setting not be enabled.

CAPTCHA
CAPTCHA is an acronym for “Completely Automated Public Turing test to tell
Computers and Humans Apart.” A CAPTCHA is a visual device that ensures that a
human being, rather than a computer, is interacting with the site. CAPTCHA can be
used for both the Admin and customers.

l Admin CAPTCHA

l Customer CAPTCHA

Users can reload the displayed CAPTCHA by clicking the Reload icon in the upper right
corner of the image. The number of reloads is not limited.

The Magento CAPTCHA was implemented using a Zend Framework module, and is fully
configurable.
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CAPTCHA in Customer Login

Admin CAPTCHA Configuration
For an extra level of security, you can add a CAPTCHA to the Admin Login page.
Administrator users can reload the displayed CAPTCHA by clicking the Reload icon in
the upper- right corner of the image. The number of reloads is not limited.

Admin CAPTCHA

To configure CAPTCHA for the Admin:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Advanced, select Admin.

3. In the upper-right corner, set Current Configuration Scope to “Default.”

4. Click to expand the CAPTCHA section, and complete the settings as described below.

5. When complete, click the Save Config button.
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CAPTCHA Configuration

Field Descriptions
Field Scope Description

Enable CAPTCHA in
Admin

Global Enables CAPTCHA for the Admin login page.
Options include: Yes / No

Font Global Determines the font used to dipslay the
CAPTCHA. To add your own font, put the font
file in the same directory as your Magento
instance and specify it in the config.xml file at:
app/code/core/Mage/Captcha/etc/

Forms Global Determines the form where the CAPTCHA is
used. Available options: Admin Login / Admin
Forgot Password.

Displaying Mode Global Defines preconditions for displaying CAPTCHA.
Available options:

Always CAPTCHA is always
required to log in the
Admin.

After number of
attempts to login

When selected displays the
Number of Unsuccessful
Attempts to Login field.
Enter the number of login
attempts allowed. A value
of 0 (zero) is similar to
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Field Scope Description

setting Displaying Mode to
Always. This option does
not cover the Forgot Pass-
word form. If CAPTCHA is
enabled and set to be
appear on this form, then
it is always included on the
form.

To track the number of unsuccessful login
attempts, the attempts to log in under one
email address from one IP address are
counted. The maximum allowed number of
attempts to log in from one IP address is
1,000. This limitation is applied only when
the CAPTCHA functionality is enabled.

CAPTCHA Timeout
(minutes)

Global Determines the lifetime of the current CAPTCHA.
After the CAPTCHA expires, the user must reload
the page.

Number of Symbols Global Determines the number of symbols that are
used for creating CAPTCHA. Maximum allowed
value is 8. You can also specify a range, for
example, 5-8; each generated CAPTCHA can
contain different number of symbols.

Symbols Used in
CAPTCHA

Global Determines the symbols used in the CAPTCHA.
Only letters (a-z and A-Z) and numbers (0-9) are
allowed. The default set of symbols suggested in
the field excludes similar looking symbols like “i”,
“l”, “1”. Displaying these symbols in CAPTCHA
decreases the chances that a user will recognize
CAPTCHA correctly.

Case Sensitive Global Detremines if the letters used in the CAPTCHA
are case sensitive.

Customer CAPTCHA Configuration
CAPTCHA can be required to log in to a customer account, or be configured to appear
after several unsuccessful attempts.. It can also be used for other forms in the
storefront.
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Customer CAPTCHA Configuration

To configure CAPTCHA for customers:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Customers, select Customer Configuration.

3. Set Current Configuration Scope to the website where you want the configuration to
apply.

4. Click to expand the CAPTCHA section, and complete the fields as described below.

5. When complete, click the Save Config button.

Field Descriptions
Field Scope Description

Enable CAPTCHA on
Frontend

Website Enables the CAPTCHA in the storefront. Options
include: Yes / No

Font Website Determines the font that is used to display the
CAPTCHA. To add your own font, put the font
file in the same directory as your Magento
instance and specify it in the config.xml stored
at: app/code/core/Mage/Captcha/etc/

Forms Website Determines the form(s) where CAPTCHA is used.
Options include:
Create User
Login
Forgot Password
Checkout as Guest
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Field Scope Description

Register during Checkout.

Displaying Mode Website Determines when the CAPTCHA appears.
Options include:

Always CAPTCHA is always
required to log in.

After number of
attempts to login

When selected displays the
Number of Unsuccessful
Attempts to Login field.
Enter the number of login
attempts allowed. A value
of 0 (zero) is similar to
setting Displaying Mode to
Always. This option does
not cover the Forgot Pass-
word and Create User
forms. If CAPTCHA is
enabled and set to be
appear, then it is always
included on these form.

To track the number of unsuccessful
attempts to log in, the attempts to log in
under one email address from one IP-
address are counted. The maximum
allowed number of attempts to log in from
one IP-address is 1,000. This limitation is
only applied when the CAPTCHA
functionality is enabled.

CAPTCHA Timeout
(minutes)

Website Determines the lifetime of the current CAPTCHA.
When the CAPTCHA expires, the user must
reload the page.

Number of Symbols Website Determines the number of symbols that are
used in the CAPTCHA. Maximum allowed value
is 8. You can also specify a range, for example, 5-
8.

Symbols Used in
CAPTCHA

Website Determines which symbols are used in the
CAPTCHA. Only letters (a-z and A-Z) and
numbers (0-9) are allowed. The default set of
symbols suggested in the field excludes similar
looking symbols like i, l, or 1. Displaying these
symbols in CAPTCHA decreases the chances that
a user will recognize CAPTCHA correctly.
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Field Scope Description

Case Sensitive Website Determines if the characters used in the
CAPTCHA are case sensitive. Options include:
Yes / No
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Chapter 58:

Index Management
Indexing is how Magento transforms data such as products, categories, and so on,
to improve the performance of your web store. As data changes, the transformed
data must be updated—or reindexed. Magento has very sophisticated architecture
that stores merchant data (including catalog data, prices, users, stores, and so on)
in many database tables. To optimize storefront performance, Magento accumulates
data into special tables using indexers.

For example, suppose you change the price of an item from $4.99 to $3.99. Magento
must reindex the price change to display it on your store. Without indexing,
Magento would have to calculate the price of every product on the fly—taking into
account shopping cart price rules, bundle pricing, discounts, tier pricing, and so on.
Loading the price for a product would take a long time, possibly resulting in cart
abandonment.

Index Management

To access Index Management:

1. On the Admin menu, select System > Index Management.

2. Any indexer with a checkbox next to its name can be managed manually. The other
indexers update automatically according to your Magento cron job. The default
mode for each indexer is set in the system configuration.

Column Descriptions
Column Description

Index The name of the indexer.
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Column Description

Description A description of the indexer.

Mode Applies only to the indicated indexers. Most of the indic-
ated indexers are set to Update on Save, which means a
reindex is required when a change is saved. See: Manual
Reindexing.

Status Displays one of the following:

Reindex Required A change has been made
that requires reindexing. If
a checkbox and Reindex
Required link appears, can
be reindexed manually.

Ready The index is up-to-date.

Scheduled

Running

The following options apply only to the automatic indexers:

Scheduled Reindexing is required but
hasn't run yet according to
your Magento cron job.

Running Rreindexing is required
and is either running or in
the queue.

Outdated Indicates reindexing is
required but there is an
issue preventing it from
running. If this state per-
sists, submit a bug report.

Update Required Applies only to the indicated indexers. Indicates whether or
not you must manually reindex. (The value in the Mode
column indicates whether the indexer must be manually
updated.)

Updated At Displays the date and time an index was last manually
updated, or Never if the index has never been manually
updated.

Action Indexers that require manual updating display a Reindex
Data link. Click the link to reindex that option only.
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Manual Reindexing
When reindexing is required, a message appears at the top of the workspace with a link
to Index Management.

l If the Status column indicates “Reindex Required,” and the Update Required column
indicates “No,” only a partial index is produced when you index manually.

l If the Status column indicates “Reindex Required,” and the Update Required column
indicates “Yes,” a full index is produced when you index manually.

Index States

To reindex manually:

1. On the Admin menu, select System > Index Management.

2. Select the checkbox of each item to be reindexed.

3. Set Actions to “Reindex Data.”

4. Click the Submit button.

Index Modes
Magento reindexes automatically whenever one or more items are changed (for example,
price changes, catalog or shopping cart price rules are created, new categories added,
and so on). Reindexing is performed as a background process; your store is accessible
during all reindexing processes.

To change the index mode:

1. On the Admin menu, select System > Index Management.

2. Select the checkbox of each indexer you want to change.

3. Set Actions to “Change Index Mode.” Then, set Index Mode to one of the following:

l Update on Save

l Manual Update
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Change Index Mode

4. Click the Submit button to apply the change to each selected indexer.

Events that Trigger Reindexing
Index Type Reindexing Event

Product Prices Add customer group
Change configuration settings

Flat catalog1 product
data

Add store
Add store group
Add, edit, or delete attribute (for searching and filtering)

Flat catalog category data Add store
Add store group
Add, edit, or delete attribute (for searching and filtering)

Catalog cat-
egory/product index

Add, edit, or delete products (single, mass, and import)
Change product-to-category relations
Add, edit, or delete categories
Add or delete stores
Delete store groups
Delete websites

Catalog search index Add, edit, or delete products (single, mass, and import)
Add or delete stores
Delete store groups
Delete websites

Stock status index Change inventory configuration settings.

Category permissions
index

Add store, add store group, add or delete or update attribute
(for searching and filtering)

1The flat product and category indexers also influence how catalog and shopping cart price rules are
indexed. If you have a large number of SKUs (about 500,000 or more), you will notice a dramatic
improvement in indexing time for price rules. To take advantage of this improvement, you must
enable Use Flat Catalog Product.
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Index Actions and Controls
Action Result To Control

Creating a new store,
new customer group, or
any action listed in
“Actions that Cause a Full
Reindex.”

Full reindex
.

Full reindexing is performed on the sched-
ule determined by your Magento cron job.
In a few cases, full reindexing must be per-
formed manually.

Bulk loading of items in
the following ways:

n Magento
import/export

n Direct SQL query

n Any other method
that directly adds,
changes, or deletes
data.

Partial reindex
(only changed
items are rein-
dexed)

At the frequency determined by your
Magento cron job.

Changing scope (for
example, from global to
website)

Partial reindex
(only changed
items are rein-
dexed)

At the frequency determined by your
Magento cron job.

Events that Trigger a Full Reindex
Indexer Event

Catalog Category Flat
Indexer

Create a new web store
Create a new web store view
Create, or delete an attribute that is any of the following:

n Searchable or visible in advanced search

n Filterable

n Filterable in search

n Used for sorting

Change an existing attribute to be any of the preceding.
Enable flat category frontend options

Catalog Product Flat
Indexer

Create a new web store
Create a new web store view
Create, or delete an attribute that is any of the following:
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Indexer Event

n Searchable or visible in advanced search

n Filterable

n Filterable in search

n Used for sorting

Change an existing attribute to be any of the preceding.
Enable flat category frontend options

Stock status indexer When the following Catalog Inventory options changes in the
system configuration:

Stock Options: Display Out of Stock Products

Product Stock
Options:

Manage Stock

Price Indexer Adding a new customer group.
When any of the following Catalog Inventory options changes
in the system configuration:

Stock Options: Display Out of Stock Products

Product Stock
Options:

Manage Stock

Price: Catalog Price Scope

Category or Product
Indexer

Create or delete a store view
Delete a store
Delete a website
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Chapter 59:

Cache Storage Management
Using Magento’s cache management system is an easy way to improve the
performance of your site. The Cache Storage Management page shows the status of
each primary cache and its associated tag. Whenever one of the caches needs to be
refreshed, a notice appears at the top of the workspace to guide you through the
process.

Cache Storage Management

There are separate command buttons to flush the Magento-specific cache, and the
more all-inclusive cache storage. In addition, there are command buttons to flush
the catalog product images cache and JavaScript/CSS cache.

On the server, the default location for the primary Magento cache is var/cache. As an
alternative to using the Cache Management tool, the contents of each cache can be
manually deleted from the server.

Clearing Caches
After clearing a cache, always refresh your browser to make sure that it uses the
most recent files.
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Cache Storage Management

To refresh specific caches:

1. Do one of the following:

l Click the Cache Management link in the message at above the workspace.

l On the Admin menu, select System > Cache Management.

The status of each cache that needs to be refreshed appears in yellow and marked,
“Invalidated.”

2. Do one of the following:

l For each cache that needs to be refreshed, click the checkbox at the beginning of the
row.

l To select a group, click one of the selection options above the list.

3. Set Actions to “Refresh,” and click the Submit button.

To flush the product image cache:

1. From the Cache Storage Management page, under Additional Cache Management, click
the Flush Catalog Images Cache button.

The message, “Image cache was cleaned” appears at the top of the workspace.

2. Make sure to also clear the cache of your browser.

To flush the JavaScript/CSS cache:

1. From the Cache Storage Management page, under Additional Cache Management, click
the Flush JavaScript/CSS Cache button.

The message, “The JavaScript/CSS cache has been cleaned” appears at the top of the
workspace.

2. Make sure to also clear the cache of your browser.
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Button Descriptions
Command Buttons Description

Flush Magento Cache Removes all items in the default Magento cache (var/cache),
according to its associated Magento tag.

Flush Cache Storage Removes all items from the cache, regardless of Magento tag.
If your system uses an alternate cache location, any cached
files used by other applications is removed in the process.

Flush Catalog Images
Cache

Removes all automatically resized and watermarked catalog
images that are stored at: media/catalog/product/cache.
If recently uploaded images aren't reflected in the catalog, try
flushing the catalog and refreshing your browser.

Flush JavaScript/CSS
Cache

Removes the merged copy of JavaScript and CSS files from the
cache. If recent changes to the stylesheet or JavaScript aren't
reflected in the store, try flushing the JavaScript/CSS cache and
refreshing your browser.

Cache Types
Type Description

Configuration System and module configuration files.
Associated tag: CONFIG

System: config.xml
local.xml

Module: config.xml

Layouts Page layout building instructions.
Associated tag: LAYOUT_GENERAL_CACHE_TAG

Blocks HTML Output The HTML that is associated with page blocks.
Associated tag: BLOCK_HTML

Translations Language translation files.
Associated tag: TRANSLATE

Collections Data Files that contain data that is the result of a query.
Associated tag: COLLECTION_DATA

EAV Types and Attributes Attribute entities, types, and values.
Associated tag: EAV

Web Services Con-
figuration

Web Services definition files (api.xml)
Associated tag: CONFIG_API

Web Services Con-
figuration

Web Services definition files (api2.xml)
Associated tag: CONFIG_API2
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External Full-Page Cache
Full-page caching can improve response time and reduce the load on the server.
Magento Community Edition supports the external Send Full Page Cache. To learn
more, see Content Caching (Dynamic) on the Zend website.

To enable external caching:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Advanced, select System.

3. Click to expand the External Full Page Cache Settings section. Then, do the following:

a. Set Enable External Cache to “Yes.”

b. Set External Cache Control to “Zend Full Page Cache.”

External Full-Page Cache Settings

4. When complete, click the Save Config button.
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Chapter 60:

Alternate Media Storage
Magento Community Edition gives you the option to store media files in a database
on a database server, or on a Content Delivery Network (CDN), as opposed to storing
them on the file system of the web server. The advantage of using alternate storage is
that it minimizes the effort required to synchronize media when multiple instances
of the system that are deployed on different servers that need access to the same
images, CSS files, and other media files.

CDN as alternate media storage is implemented as a support option only, not as a
full integration with a specific CDN. You must choose and configure a CDN on your
own.

Using a Database for Media Storage
By default, all images, compiled CSS files, and compiled JavaScript files of the
Magento instance are stored in the file system on the web server. You can choose to
store these files in a database on a database server. One advantage of this approach
is the option of automatic synchronization and reverse synchronization between the
web server file system and the database. You can use the default database to store
media or create a new one. To be able to use a newly created database as media
storage, you must add information about it and its access credentials to the
local.xml file.

To use a database for media storage:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Advanced, select System.

3. This configuration takes place at the global level, so set Current Configuration
Scope to “Default Config.”

4. Click to expand the Storage Configuration for Media section. Then, do the
following:
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Storage Configuration for Media

a. Set Media Storage to “Database.”

b. Set Select Media Database to the database you want to use.

c. Click the Synchronize button to transfer the existing media to the newly selected
database.

d. Enter the Environment Update Time in seconds.

5. When complete, click the Save Config button.

Accessing Media from a Database
When the customer opens the store page, its browser requests the HTML code and the
media specified in the HTML code from the Magento system. The system searches the
requested media in the file system and passes it to the browser, if it is found. If the
system does not find the media in the file system, it requests the media from the
database specified in the settings, places the media to the file system, and sends it to
the customer’s web browser.

To get the files from the database to the file system on the web server a PHP script is
used. When the browser requests media from the web server, there are two alternatives
for when a PHP script is run:

l If web server rewrites are enabled in the Magento system and supported by the server,
the PHP script is run only when the requested media is not found in the web server
file system.

l If web server rewrites are disabled in the Magento system or not supported by the
server, the PHP script is run in any case, even when the required media exists in the
file system of the web server.

You can configure web server rewrites in System > GENERAL > Web > Search Engine
Optimization > Use Web Server Rewrites.

Using a Content Delivery Network
Storing media files in a CDN is another alternative supported in Magento. There is no
full integration with a specific CDN, and you are responsible for choosing and
configuring a CDN on your own. After configuring the CDN, you must complete the
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configuration from the Admin. The changes can be made at either the global or website
level.

To configure a content delivery network:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under General, select Web.

3. Set the Current Configuration Scope as needed.

4. Click to expand the Unsecure section. Then, do the following:

Unsecure

a. Change the value of the Base Media URL.

b. Change the value of the Base JavaScript URL.

5. Click to expand the Secure section.

Secure

a. Change the value of the Base Media URL.

b. Change the value of the Base JavaScript URL.

6. When complete, click the Save Config button.
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Accessing Media from a CDN
When a CDN is selected as media storage, all paths to media on the web store pages are
changed to paths to the CDN. Retrieving media that is stored in a CDN works as
follows:

l When a customer opens a page in the store, the browser addresses the CDN with the
request to acquire some media files, such as images.

l If the CDN does not yet have these images in its storage, it requests them from the
server, and provides images to the customer’s browser.

l If the CDN already has the required images in storage, it simply serves the requested
images to the customer's browser.

Important! When a CDN is used as media storage, JavaScript may not function
properly if the CDN is not in your subdomain. This is a browser security feature.

670 Magento Community Edition: User Guide



671Magento Community Edition: User Guide

Chapter 61:

Server Backups & Rollback
Magento enables you to perform different types of backups (backup of database, file
system, or both) and to perform rollbacks automatically. Files are compressed using
the .gz and .tgz formats. Backup files are stored in the var/backups directory in your
Magento file system. The content of the /var/cache, /var/log, /var/session and
/var/report folders is excluded from the backup.

Backups

Creating a Backup

To create a backup:

1. On the Admin menu, select System > Tools > Backups.

2. Click one of the following buttons, depending on the backup type you need to create:

System Backup Creates a complete backup of the database and the file
system. On the next step you will have the possibility to
choose whether to include the media folder to the
backup.

Database and Media
Backup

Creates a backup of the database and the media folder.

Database Backup Creates a backup of the database.

3. To put the store into maintenance mode during the backup, select the checkbox.
After the backup is created, maintenance mode is turned off automatically.
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4. If you are creating a system backup, select the Include Media folder to System Backup
checkbox if you want to include the media folder. When prompted, confirm the action.

Database backup files are compressed using the .gz format. For the system backups and
database and media backups, the .tgz format is used. Backup files are stored in the
var/backups directory in your Magento file system. The files that are stored in the
/var/cache, /var/log, /var/session and /var/report folders are excluded from the backup.

Records of all created backups are listed on the Backups page. Deleting a record deletes
the archive file as well.

Roll Back Changes

To roll back the whole system or the database:

1. On the Admin menu, select System > Tools > Backups.

2. On the Backups page, find the backup you want. Then in the Action column, click the
Rollback link.

All changes made since the backup was created will be lost after the rollback.

3. Confirm the roll back. When prompted, enter your Admin Password. Then, choose
whether you want to put your store into the maintenance mode during the roll back.
When restoring file system or database and media files you can choose to use the FTP
connection.

After the rollback, you are redirected to the Admin login page.

4. Refresh cache types and rebuild required indexes. This can be done under System >
Cache Management and System > Index Management, respectively.

Important! Use the Rollback with caution. Customers who are in the process of
checking out when you start the rollback may not be able to complete checkout.

Limiting Access to Backup and Rollback
Access to the Backups and Rollback management tool can be restricted by configuring
user permissions for backup and rollback resources. To restrict access, leave the
corresponding checkbox unselected. If you need to grant access to the Rollback resources,
you must grant access to backup resources as well.

Create a Backup from Magento Connect Manager
Before installing an extension, you should always perform a backup. In the Magento
Connect Manager (MCM), you can choose to create a backup before installing an
extension or upgrading Magento.
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To create a backup fromMCM:

1. On the Admin menu, select System > Magento Connect > Magento Connect Manager.

2. Select the Create Backup checkbox and select the backup type.

Proceed with installing extension or updating Magento. The backup is created
automatically, and is listed under System > Tools > Backups.
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Chapter 62:

Magento Connect
Magento Connect is the marketplace for Magento extensions. There are hundreds of
extensions available from all over the world. Magento out-of-the-box supports a few
of the most popular ones. However, community members are developing and
publishing new extensions in order to extend Magento with various new features.

Magento Connect

Updating Magento
Magento Community Editionis constantly evolving. New features are added and
problems resolved on an ongoing basis. From time to time you will be notified that a
new Magento CE version is available. This notice will be published in the Magento
blog, and in your Admin InBox.

Consider the following before updating your store:

http://www.magentocommerce.com/magento-connect/


Updating Magento Chapter 62:  Magento Connect

l If the update is critical, contains mandatory updates, or resolves issues that you have
encountered, you should update your store.

l If your store has a custom theme, you will benefit from the bug fixes in the update,
but new the functionality might not be implemented in your theme.

l Upgrading between major versions, such as between version 1.1 and 1.2, might require
minor configuration changes. See the update release notes for more information.

l We strongly recommend that you test all updates in a staging environment before
upgrading a live store.

To update your store to a new version:

1. On the Admin menu, select System > Magento Connect > Magento Connect Manager.

2. Enter your Admin username and password, and click the Log In button.

3. Click the Check for Upgrades button. Any upgrades available for Magento CE modules
are marked in yellow.

4. In the Actions column, select the upgrades to be installed. Then, click the Commit
Changes button.

5. When the installation is complete, click the Return to Admin link in the header.

Congratulations! You have just upgraded your Magento CE. Now check your site to
make sure everything works as expected.
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Installing Extensions
Many extensions are available on Magento Connect, and the installation process varies
for each. Some extensions require additional configuration after the installation. Please
read the documentation provided by the extension developer for specific instructions.
The following instructions outline the general process. Before installing any extension,
always back up your store.

To back up your store:

1. On the Admin menu, select System > Magento Connect > Magento Connect Manager.

2. Select the Create Backup checkbox and select the backup type.

The backup is created automatically, and is listed under System > Tools > Backups.

To install an extension:

1. Go to Magento Connect.

2. Use the filters to browse through the available extensions.

3. On the page of the extension you want to install, do the following:

a. If the extension is available for sale, click the Get Extension button. Then, follow the
prompts to purchase the extension.

b. Click the Get Extension Key key button.

c. Click the link to read the license agreement, and if you agree to the terms, select the
checkbox.

An extension key similar to this appears: magento-core/Mage_xxxx. The key is a
special link that Magento needs to install the extension to your store.

d. Click Select to select the key, and press Ctrl + C to copy it to the clipboard.

4. Log in to your store Admin, and do the following:

a. On the Admin menu, select System > Magento Connect > Magento Connect
Manager.

b. When prompted, enter your Admin User Name and Password. Then, click the Log
In button.

http://www.magentocommerce.com/magento-connect/
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Log In to Magento Connect Manager

c. In the Install New Extensions section, paste the Extension Key.

d. Click the Install button and wait for the installation to complete.

5. You can now return to your store Admin and use the extension.

Look for new options in the related section of the Admin. For example, a payment
extension will appear in System > Configuration > Sales > Payment Methods.
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Chapter 63:

Web Services
Web services share information across networks using standards-based technologies.
Information from your store can be shared with other Web-based services to help
create a more integrated set of tools for your business.

Web services retrieve information from your store using an application programming
interface, the Magento Core API. The Magento Core API includes all the parameters
for data requests that other web services need to access information from your store.

Magento Core API Settings
The Magento Core API supports both SOAP and XML RPC protocols. The API is
permission-based, and allows access to the Customer, Catalog, and Order modules
of your store.

The WSDL (Web Services Description Language) definition that you create for your
Magento Community Edition API solution ism by default, WS-I compliant. This
makes it possible to use tools that require a WS-I complaint WSDL definition for API
integration. No additional settings are required.

WS-I Endpoint URL
Use the following endpoint URL for all WSI-I APIs, and replace {site_url} with the
store domain.

http://{site_url}/api/wsi_soap/?wsdl

General Settings
By default, the API default character set is UTF-8, and the timeout for client
sessions is 3600 seconds. You can change the default settings through the system
configuration of the store.

http://www.ws-i.org/
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To change the general settings:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Services, select Magento Core API. Then,
click to expand the General Settings section. Then, do the following:

Magento Core API General Settings

a. Enter the name of the Default Response Charset that you want to use.

b. Enter the length of the Client Session Timeout in seconds.

c. To enableWS-I Compliance, select “Yes.”

d. To enable theWSDL Cache, select “Yes.”

3. When complete, click the Save Config button.

Activating Web Services
Web Services give you the ability to grant permission to third-party applications to
access your store data for the purpose of integration. Magento Community Edition
supports both SOAP and REST services.

Step 1: Create a Web Service Role

1. On the Admin menu, select System > Web Services > SOAP/XML-RPC Roles.

2. Click the Add New Role button.

3. In the Role Information section, enter a Role Name such as “API.”

4. In the panel on the left, select Role Resources. Then do one of the following:

l To enable full access, set Resource Access to “All.”

l To provide limited access to data, set Resource Access to “Custom.” Then, select the
checkbox of each resource that is available to this role.

l By default, when a area is selected, full access is granted. However, you can specify
the actions that a person is allowed to take. Specific types of access are listed under
many of the resource links, so it is easy to determine exactly what a user is allowed
to do with the resource.

5. When complete, click the Save Role button.
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Step 2: Create a Web Service User

1. On the Admin menu, select Web Services > SOAP/XML-RPC-Users.

2. Click the Add New User button.

3. Complete the following fields:

l User Name

l First Name

l Last Name

l Email

4. In the API Key field, type in a verification key, or password. This is the access credentials
that third-party web services will use to access your Magento store.

Web Service User

5. To confirm, re-enter the key in the API Key Confirmation field.

6. In the panel on the left, select User Role. Then, select a role for the user.

7. When complete, click the Save User button.

Step 3: Add Custom Scripts to Your Store

Some third-party web services rely on snippets of JavaScript code to gather data. Some
web services require you to insert code in the HTML <head> section, while others require
the code to be in the HTML footer, below the closing </body> tag.

REST Roles
The REST API defines a set of functions that developers can use to perform requests and
receive responses. To learn more about REST permissions, see: Web Services.



Activating Web Services Chapter 63:  Web Services

682 Magento Community Edition: User Guide

Notes
________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________

________________________________________________________________



683Magento Community Edition: User Guide

Appendix A:

Glossary

A

above the fold
The web page content that is immediately visible in the browser window;
section of a page that is displayed without the need to scroll.

Admin
The password-protected back office of your store where orders, catalog,
content, and configurations are managed.

alt text
The text that is displayed in place of an image when the user is unable to
view the image.

anchor text
The visible text that is anchored to another page or page section; the literal
text of a hyperlink.

API
Application Program Interface: A software interface that lets third-party
applications read and write to a system using programming language
constructs or statements.

aspect ratio
The proportional relationship between the width and height of an image.

attribute
A characteristic or property of a product; anything that describes a product.
Examples of product attributes include color, size, weight, and price.

authorization
To give a service permission to perform certain actions or to access
resources.
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average inventory cost
Product price, less coupons or discounts, plus freight and applicable taxes. The
average is determined by adding the beginning cost of inventory each month,
plus the ending cost of inventory for the last month of the period.

B

B2B
Business to Business: A type of business transaction between two business
entities that are not the final consumers of the goods or services.

B2C
Business to Consumer: Business transactions between a business entity and a
consumer.

banner
Promotional graphics displayed either horizontally on the top of a web page or
vertically on the left or right margins. Website advertisements are often
displayed as banners.

base currency
The primary form of currency used in store transactions.

base currency rate
The base currency rate is the default for your store.

batch processing
To perform a task or make a change to multiple items all at once, without manual
repetition.

bounce rate
The percentage of visitors to your site that leave without viewing any other
pages.

brand
A unique identity that defines a particular product or group of products.

breadcrumb
A navigation aid that helps the user to keep track of their location within your
store.

brick and mortar
A retail business with a permanent physical location, as opposed to being entirely
virtual.

broken link
A hyperlink that fails to send the user to its intended web page.
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C

callout
A term that is sometimes used to describe a block that is defined as a layout
update using XML code.

canonical URL
The canonical meta tag redirects search engines to the correct URL, when
seemingly duplicate content is encountered on the server.

capture
The process of converting the authorized amount into a billable transaction.
Transactions cannot be captured until authorized, and authorizations cannot be
captured until the goods or services have been shipped.

cardholder
A person who opens a credit card account and is authorized to make purchases.

cascading style sheet
The markup standard used to apply styles to HTML elements on the page.

category
A set of products that share particular characteristics or attributes.

CCV
Credit Card Verification code. (See CVV)

checkout process
The process of gathering the payment and shipping information that is
necessary to complete the purchase of items in the shopping cart. In the final
step, the customer reviews and places the order.

CMS
Content Management System: A software system that is used to create, edit, and
maintain content on a website.

composite product
Any product type that offers customers a choice of options.

composite products

Content Delivery Network
A large distributed network of servers that specializes in the high performance
delivery of multi-media content.
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content marketing
The art of promoting products or services by providing valuable information at
no charge.

conversion
A marketing term that indicates a goal has been reached. If the goal is to sell a
product, conversion is reached when a visitor to your site becomes a buyer.

conversion rate
The percentage of visitors who are converted into buyers.

credit memo
A document issued by the merchant to a customer to write off an outstanding
balance because of overcharge, rebate, or return of goods.

CSS
Cascading Style Sheets: A style sheet language that controls the appearance of
HTML documents; a way to control the appearance of text, graphics, lists, links,
and all other elements on a web page.

CSV
Comma Separated Values: A type of file used to store data values which are
separated from each other by commas.

CVM
Card Verification Method: A way to verify the identity of the customer by
confirming a 3-digit or 4-digit credit card security code with the payment
processor.

CVV
The Card Verification Value, also known as the Card Security Code, provides an
additional level of security for online transactions.

D

domain
The address of a website on the web; what the customer types in their browser
address bar to access the store.

double opt-in
The process for subscribing email recipients by requiring them to take a
secondary step to confirm that they want to receive emails.

dynamic content
A web page that displays different content depending on the user request.
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Dynamic Media URL
A link to an image that contains a relative reference to the file location in media
storage.

E

EAV
Entity Attribute Value

evergreen content
Content that has a long shelf life.

F

FAQ
Frequently Asked Questions.

favicon
Short for favorites icon; a 16x16 or 32x32 pixel icon associated with a website; is
displayed in the browser address bar and next to the site name in a bookmark
list.

feed reader
Software that is used to read syndicated content from RSS feeds.

FOB
Freight On Board: A shipping term indicating who is responsible for paying
transportation charges.

frontend properties
Properties that determine the presentation and behavior of an attribute from
the standpoint of the customer in your store.

fulfillment
The process of managing customer shipments.

G

gateway
A transaction bridge between a customer and a payment processing service that
is used to transfer money between the customer and the merchant.

gross margin
The difference between the cost and price of a product.
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H

handle
In programming, a name used to reference an object.

home page
The first home page a visitor sees when they access your website URL.
Considered the most important page on your website according to search engine
indexing.

HTML
HyperText Markup Language: A standard for tagging and structuring text,
images, videos, and other media on a web page.

I

invoice
A document that provides a detailed description of a purchase, including
products purchased, quantity, price, shipping cost, sales tax, and total.

J

JavaScript
A scripting language used with HTML to produce dynamic effects and
interactions on web pages.

K

keyword
A term or phrase used in a search to filter for content that is of significant
importance to that term or phrase.

L

LAMP
Linux / Apache / MySQL / PHP

landing page
A page on your site where a visitor arrives after clicking a link or advertisement.

layout
The visual and structural composition of a page.

layout update
A specific set of XML instructions that determines how the page is constructed.
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link juice
The value and authority transferred from one web page to another via
hyperlinks (or links). Link juice affects a website’s page rank, a factor used to rank
a search engine results page.

liquid layout
A flexible approach to web design that specifies the size and position of elements
as percentages rather than as exact measurements in pixels.

load sequence
The order in which scripts are loaded into memory. To work correctly, some
scripts must be loaded before others.

locale
A set of configurations that defines the user’s language, country, tax rate, and
other settings.

login
The process of signing into an online account.

M

markdown
The amount subtracted from the original price of a product.

markup
A percentage added to the cost of an item to determine the retail price.

media storage
A dedicated space on the content delivery network for your store's assets.

merchant account
An account with a bank or financial institution that makes it possible to accept
credit card transactions.

meta tags
Information in a web page that is not displayed on the page itself, but is used by
search engines to determine the page title, description, and page keywords.

N

navigation
The primary group of web page links that a customer uses to navigate around
the website; the navigation links to the most important categories or pages on
an online store.
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O

opt-in
The process by which a user consents to receiving emails from an online store.

P

packing slip
A document that is usually included in a shipped package that describes the
contents. Packing slips do not include financial or account information.

path to purchase
The path a prospect follows that leads to a sale.

payment bridge
An application that helps merchants meet PCI- DSS requirements.

payment gateway
A service that charges your customers’ credit cards and sends the funds to your
merchant account, for deposit into your business bank account.

PCI
Payment Card Industry: Refers to debit and credit cards and their associated
businesses.

privacy policy
A document that explains the merchant’s policies for handling customer
information.

purchase order (PO)
A written sales contract between a buyer and seller that describes the
merchandise or service to be purchased from a vendor.

R

redirect
A method used to alert browsers and search engines that a page has been
moved. 301 Redirect: Permanent change 302 Redirect: Temporary change

relative link
A hyperlink that includes only the address of the linked page that is relative to
the linking page, rather than the full URL.

return policy
A document that explains the merchant’s rules regarding the return of products
by customers.
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robots.txt
A file placed on a website that tells search engine crawlers which pages not to
index.

RSS feed
Really Simple Syndication: A technology that creates web content syndication
and allows web users to subscribe to product feeds, websites, and blogs.

S

SaaS
Software as a Service: A software delivery model where the vendor provides the
software and hosting environment, and customers pay for the service by
subscription or per use.

security certificate
Information that is used by the SSL protocol to establish a secure connection.

SEO
Search Engine Optimization: The process of improving a website’s search engine
rankings in order to increase valued visitors.

SERP
Search Engine Results Page

settlement
Settlement occurs when the acquiring bank and the issuer exchange funds and
the proceeds are deposited into the merchant account.

shipping carrier
A company that transports packages. Common carriers include UPS, FedEx, DHL,
and USPS.

shopping cart
A grouping of products that the customer wishes to purchase at the end of their
shopping session.

sidebar
The right or left column of a two-column page layout.

sitemap
A page that provides search engines with an efficient, alternate route through
your site.

SKU
Stock Keeping Unit: A number or code assigned to a product to identify the
product, options, price, and manufacturer.
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splash page
A promotional page with a product or advertisement; normally displayed before
the home page.

SSL certificate
A validation and security mechanism that identifies the merchant and encrypts
credit card and other sensitive information.

static block
A fixed content block that can be displayed on various content pages in a store.

static content
Content that does not change frequently. See also dynamic content.

T

theme
A package that contains graphics and appearance information, and customizes
the look and feel of the store.

transactional email
A notification email sent to the customer when a transaction is processed.

transactional emails
An automated email message that is sent in response to a specific event or
transaction.

U

URL
Uniform Resource Locator: The unique address of a page on the internet.

usability
Refers to the degree to which a product or service is easy to use by its customers.

W

widget
A prepared snippet of code that adds functionality and/or dynamic effects to
your store.

WYSIWYG
What You See Is What You Get: An editor that displays formatted text as it will
appear in its final published form.
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X

XML
Extensible Markup Language: A markup format derived from SGML that it used
to format information for publication and distribution.
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Editor Toolbar

Editor Toolbar

Editing Tools

Editing Tools

Button Description

Undo

Redo

Cut

Copy

Paste
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Button Description

Paste as Plain Text

Paste from Word

Find

Find and Replace

Spellchecker (not installed)

Mark as Deletion

Mark as Insertion

Citation

Abbreviation

Acronym

Styles and Fonts

Styles and Fonts
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List Description

Styles

Format

Font Family

Font Size

Character Format

Character Format

Button Description

Bold

Italic

Underline

Strikeout

Subscript



Appendix B:  Editor Toolbar

Button Description

Superscript

Special Characters

Special Characters

Button Description

Insert Symbol

Insert Non-Breaking Space

Insert Page Break

Color

Color

Button Description

Select Text Color

Select Background Color

698 Magento Community Edition: User Guide



Appendix B:  Editor Toolbar

699Magento Community Edition: User Guide

Paragraph Format

Paragraph Format

Button Description

Left Justify

Center

Right Justify

Full Justify

Outdent

Indent

Blockquote

Coding Tools

Coding Tools
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Button Description

Remove Formatting

Cleanup Messy Code

Lists

Lists

Button Description

Bulleted (Unordered) List

Numbered (Ordered) List

Rules

Rules

Button Description

Insert Simple Horizontal Rule

Insert Formatted Horizontal Rule
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Links and Anchors

Links and Anchors

Button Description

Insert/Edit Link

Remove Link

Insert/Edit Anchor

Images and Media

Images and Media

Button Description

Insert/Edit Image

Insert Media
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Tables

Tables

Button Description

Insert/Modify Table

Table Row Properties

Table Cell Properties

Insert Row Above

Insert Row Below

Remove Column

Remove Row

Split Merged Table Cells

Merge Table Cells

702 Magento Community Edition: User Guide



Appendix B:  Editor Toolbar

703Magento Community Edition: User Guide

Layers

Layers

Button Description

Insert New Layer

Move Layer Forward

Move Layer Backward

Toggle Absolute Positioning

Variables, Attributes and Widgets

Variables, Attributes and Widgets

Button Description

Insert Variable

Insert/Edit Attributes

Insert Widget
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Workspace Preferences

Workspace Preferences

Button Description

Toggle Fullscreen Mode

Display Visual Control Characters (On/Off)

Toggle Guidelines / Invisible Elements

Set Typing Direction Left-to-Right

Set Typing Direction Right-to-Left

Help
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1

1 Column Layout 106, 411, 413

2

2 Columns

with Left Bar 107, 412, 414

with Right Bar 107, 412

3

3 Column Layout 413, 415

3D Secure Credit Card Validation 543

4

404 Page Not Found 356

A

Abandoned carts 455

report 638

About Us page 356

Account

customer information 434

Magento 25

share 26

Actions

control 52, 56

Add

Exception, theme 428

New User 644

Root Category 101

to Wishlist 295

Address

Book, customer 434

Address format 482

Address templates 482

Admin 43, 48, 56

CAPTCHA 648

login 44

menu 49

permissions 641

role 641

role, create 642

role, custom 643

security 647

Startup Page 633

user 641

user, create 641

Adobe Reader 475

Advanced Search 117, 221

Advocacy Tools 38

AirMail, mobile 332

Allow

cookies 455

Countries 70

Gift Message 172

HTML tags 117, 122

HTML Tags on Frontend 122

Printed Card 310
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Allowed Currencies 72

American Express 542

Analytics 32, 38

Anchor category 90, 100-101

Antivirus software 80

Any, checkbox 56

AOV 34

API 39, 349, 679

Core 679

Key 681

Append Complex Data 626

Approve product review 301

As Low As, bundle product 150

Associated Product 136, 141

Attribute 109

advanced search 117

code 118

create 111

delete 114

entities 628

filterable 93

Google Shopping 349

group 116

information 113

input types 110

layered navigation 117

predefined 385

price 215

product 117

properties 111

quick search 116

system 116

Attribute set 109, 114, 138-139, 161

Australia, PayPal solutions 528

Authorize.Net 531, 533, 539

capture 533

Direct Post Method 534

refund 542

Auto Bill, recurring payment 167

Autogenerate

Site Map 235

Automatic

redirect 246

Average Order Value 34

Average Orders 48

B

BackendSee also 

Admin 44

Backorders 181-182, 185

PayPal Express Checkout 515

Backup

create 677

delete 672

permissions 672

Bank Transfer 496

Base

currency 71

image 197-198, 200

JavaScript URL 669

media URL 669

Best practice

industry 79

SEO 233

Bestsellers 48, 632

Bill Me Later, PayPal 516
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Index

Billing

agreement 434, 519, 521

recurring payment 168-169

Block 367, 385

category 104, 106

create 368

ID, markup tag 401

Block reference 390-392

category 369

CMS pages 369

product page 370

Blocks HTML Output, cache 665

Blog, Magento 5

Breadcrumb trail 91

Bundle Product 129, 148

group price 213

Items 150

Business location 70

Buy X, Get Y Free 286

C

Cache 663

CSS files 665

JavaScript 664

module 665

Storage Management 663

system 665

types 665

Callout 390

Canada, PayPal solutions 528

Cancel

order 450

Canceled, order status 465

Canonical meta tag 238, 240, 242

CAPTCHA 648

configuration, Admin 649

configuration, store 651

Capture

Offline 470, 534

Online 468, 533

Cardholder data 80

Cardinal Centinel 543

Cart contents, retrieve 455

Cash On Delivery 498

Catalog 39

Categories Link 363

Category Link 373

flat 123

images 197

indexing 123

Input Type for Store Owner 112

menu 49

New Products List 374

Price Rules 259, 261

Product Link 374

Products Link 363

Search 163

Category 174

create 96

Description 104

Display Settings 104

General Information 103

grayed out 96

ID 98

image 104

landing page 99, 106

levels 90



Index

link 363

modify 100

name 103

page 104

path, in URL 238-239, 243

Products 107

rewrite 250

root 100

tree 96

URL key 98

Category hidden 102

CDN 667, 669

JavaScript use 670

media retrieval 670

Certification 5

Channels 317

Check / Money Order 499

Checkbox 52

states 56

Terms and Conditions 462

Checkout process 36, 433

Terms and Conditions 460

Checkout with PayPal 512

Child authorizations, PayPal Express
Checkout 516

Clear cache 663

Click for price 213

Closed, order status 465

CMS 33, 353

Block, category 105

menu 51

Page Link 363, 373

page rewrite 252

page, breadcrumbs 91

Pages 355, 357

Static Block 367, 373

Widget 374

COD 498

Collections Data, cache 665

Color

message importance 47

Column 411

layout 106, 390

sort 54

Combine, Search Type 228

Comma-separated values 623

Community 38

Poll 294

Compare Products 117, 121, 293, 296

Comparison operator 263

Comparison properties 117

Complete, order status 465, 473

Compliance, industry 79

Composite product 130

Compound tax 595

Conditions, price rule 270

config.xml 665

Configurable Product 128

create 138

image 144

inventory 192

Manage Stock 192

Configuration

cache 665

email addresses 75

search, default 227

security 647

Consent, cookies 82
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Index

Consistent prices 589

Consulting 5

Contact Us 77

form 402

Contacts 77

Content 353, 355

Delivery Network 667, 669

management system 33

mobile app 327

page 357

Cookie

domain 83

law 82

lifetime 83

persistent 455

Restriction Mode 81-82

Restriction Notice 83

session 455

use, Magento 85

Copy from Configurable 143

Copyright notice 422

Countries Options 70

Coupon 34, 37, 278, 321, 449

Usage, report 638

Coupon Usage, report 283

Create

New Attribute 164

order 445

Packages, shipping labels 572

Simple Associated Products 142

Store 62

Store View 63

Website 61

Credit 485

card 531

cards, multiple 539

memo 441, 487

Credit Memo

Return to Stock 181, 183

Critical, message 47

Cron job 123

Cross-border trade 589

Cross-sells 177, 260

CSS

cache 665

email 618

CSV file 558, 623, 628, 631, 636

category path 623

customer structure 625

structure 623

Currency

rates 71

Setup 71

symbols 71

Current Configuration Scope 63-64

Custom

Design

Category 106

layout 107

Layout Update

product 171

Layout Update, category 107

Options 130, 178

rewrite 252

scripts 681

Theme 107, 171

URL 32
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variable 385

Custom Order Status 466

Customer

account 38, 433, 451

dashboard 433

VAT Validation 612

address template 482

billing address, PayPal Express
Checkout 514

CSV structure 625

engagement 33

group 452

create 437-438

edit 438

VAT 602

import 626

journey 30-31

Order Status, RSS feed 322

retention 37

Reviews, report 639

segment 34

Service page 356

Support 75

Tags, report 639

Customers 632

by Number of Orders, report 639

by Orders Total, report 639

menu 50

reports 631

Customers online 444

CyberSource 532

D

Dashboard 38, 48, 631

charts 634

configuration 633

customer 433

menu 49

Database

and Media Backup 671

backup 671

compression, backup 672

media storage 667

Date, input type 110

Days of week 68

Default

Config 63

Country 70

Display Currency 71

email template 618

Robots 421

Title, page 420

Value 116

Default theme 424

Delete Entries, Import 626

Demo

login 44

Design 33, 39, 407

custom, category 106

product 171

Development environment 124

DHL 561

shipping labels 567

shipping packages 565

Direct Post Method, Authorize.Net 534

710 Magento Community Edition User Guide



711Magento Community Edition User Guide

Index

Discount 261, 502

quantity 206

Display

Actual Price 204, 213

in Suggested Terms 229

Mode, category 105

not required State 69

Settings

Category 104

Store Demo Notice 409, 420

Distributing newsletters 316

Documentation 4

Double opt-in 314

Download

links 156

samples 157

Downloadable Product 129

configure 159

create 153

Downloader 12

Downloads, report 639

Drill-down, price 95

Drop shipments, PayPal Express
Checkout 515

Dropdown

attribute 139

input type 110

Duplicate

content 242

Dynamic

media URL 226, 240

URL 236

values, bundle product 148

E

EAV 123

Types and Attributes, cache 665

eBook download 153

ECG 6

Eco tax 590

Ecommerce Tracking, Google Analytics 347

Ecosystem, Magento 6

Editor, WYSIWYG 360

Email

a Friend 294, 309

addresses, configuration 75

addresses, domain 75

addresses, store 75

campaign 37

logo 617

Options 77

template 617-618

template, configure 621

template, default 618

Email template 77

variables 385

Empty, page layout 107, 413

Enable

Cookies 357

Qty Increments 192

WYSIWYG Editor 117

Encryption 80

Encryption key 24

Entity Attributes 629

Equalize

Price Ranges, layered navigation 95

Product Counts, layered navigation 95
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EU Member Countries 608

Evergreen content 353

eWAY Direct 533

Excel

XML 636

Export 629

product data 629

product types 629

Settings 629

to, report 636

Expressed consent, cookies 82

Extension

install 24, 677

social media 317

external cache 666

F

Facebook 6

extensions 317

Open Graph 317

Favicon 416, 420

FedEx 561

shipping labels 567

shipping packages 562

Fee failure, recurring payment 168

Feed reader 321

File

compression, backup 671

validation, import 627

File permissions 13

Filter

by Attribute 99

controls 55

Filterable

attribute 93, 121

Filters 52

Firewall 80

First Data Global Gateway 532

Fixed Product Tax 590

input type 110

Flat

catalog 123, 226

setup 124

Rate Shipping 551

Flurry

Analytics 329

API Code 329

Flush

Cache Storage 665

Catalog Cache 665

JavaScript cache 664

JavaScript/CSS Cache 665

Magento Cache 665

product image cache 664

Footer 419, 422

Forum, Magento 5

FPT 590

attribute 592

configuration 591

in attribute set 592

in product 593

setup 594

Frame, running your store in 648

France, PayPal solutions 528

Free

shipping 552

shipping, price rule 283
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Index

Frontend Properties 112

FTP calculations 590

Fulfillment 473

Full

reindex 661

Full Page Cache, external 666

Fulltext, Search Type 228

G

[GLOBAL] 64

Gateway, payment 531

General

Contact 75-76

Product Information 162

Get Extension Key 677

Gift Options

configure 310

product 172, 310

Global

attribute scope 139

search 52-53

Google 337

Analytics 85, 337, 346

API for Shopping 349

Merchant Center 337, 349

Product Listing Ads 337

Reader 321

Shopping 337, 349

Sitemap 337, 342

Webmaster Tools 344

Google API

Google Analytics 348

Google Merchant Center 346

Grid

filter 55

Only 225

sort 54

View As 223

Group price 213

group_price attribute 213

Grouped Product 128

create 135

Guest

retrieve cart contents 455

H

Handle 399

Header 419, 421

welcome message 408

Help 4

Hidden category 96, 102

Hold, order 450

Home page 355

New Products list 378

Hong Kong, PayPal solutions 529

HTML

address template 484

editor 360

email 618

head 345

Head 419

in product description 122

product descriptions 110

suffix 237
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I

Iframe, running your store in 648

Image

cache, flush 664

catalog, add 198

import 627

placeholder 134, 157, 200

size 197

sort order 199

URL 362

watermarks 201

zoom 196

Implementation 39

Implied consent, cookies 82

Import 626

Behavior 628

file validation 627

guidelines 628

images 627

table rates, shipping 559

In Anchor, category 105

In Stock 186

Inbox, Admin 44

Include in

Advanced Search 221

Navigation Menu 102, 104

Incoming Messages 45

Index 657

actions 661

modes 659

Indexing speed 123

Initial Fees, recurring payment 170

Input type

Bundle product 150

Date 110

Dropdown 110

Fixed Product Tax 110

Media Image 110

Multiple Select 110

Price 110

Text Area 110

Text Field 110

Yes/No 110

Input Validation 116

Insert image 362

Install

extension 677

Magento 44

Update 675

Installation

Part I 11

Part II 20

Integration 679

Inventory 181, 183

configurable product 192

Configuration 181, 183

Manage Stock 186

Invoice 58, 441-442, 468, 472

Comments 473

Invoiced

order, download product 158

IP Anonymization, Google Analytics 348

Is Active 103

Is Anchor 99, 101

Italy, PayPal solutions 528

Iterative splitting, price navigation 94
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Index

iTunes icon, mobile app 332

J

Japan, PayPal solutions 528

JavaScript

address template 484

cache 664

K
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thumbnails 195

type

export 629

Virtual 145

Product Alerts

configuration 191

run settings 191

Product Bestsellers, report 638

Product Stock Options 181

Product tag

by Admin 304

720 Magento Community Edition User Guide



721Magento Community Edition User Guide

Index

Product View Page, visible on 122

Products

in Carts, report 638

Ordered, report 639

per page 225

reports 631

Tags, report 639

Promotions 259

menu 50

Price Rules 286

Publish
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Q
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import 554
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multiple orders 575
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create 130
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dynamic, bundle product 149

in price rules 266

multiple 266

use of 138

Slider 195

Small Image 197, 199
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shopping 295
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Sort 52
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product list 105

Sort By 223
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Spam 314

Special Price 203, 205

Special Products, RSS feed 322
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SSL 22
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Admin 633
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Static URL 236
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code, in URL 237

URL 44

Store Demo Notice 409
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CAPTCHA 648
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purchase by 166
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T
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customer group 437
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VAT 602
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tag 402
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Field, input type 110

Theme 33

change 423, 427
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Update Attributes 57
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UPS 561
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rewrite 100
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USPS 561

shipping labels 567

shipping packages 564

V

Value Added Tax 579, 599

Values Required 116

var/backups 671
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